Автор Тема: Черный экран после установке драйверов на видеокарту  (Прочитано 5572 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн agentik007

  • Новичок форума
  • Сообщений: 2
Ноутбук MSI GX70, карточки Radeon R9 M290X  и Radeon HD 8650G. Делаю чистую установку, устанавливаю fglrx и после черный экран при входе в систему, но в консоль выйти могу. Также пробовал ставить дистрибутивы, основанные на дебиане (ubuntu,elementaryOS,linux mint, etc..) все виснут при установке, если не указать флаг nomodeset. Весь гугл перерыл, ответа так и не нашел.
 

Оффлайн ihammers

Какое графическое окружение используется? Если Gnome (если ничего не изменилось), то том всё ещё есть проблемы с работой.

Установлены ли пакеты firmware-linux-free и firmware-linux-nonfree?
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290
 

Оффлайн agentik007

  • Новичок форума
  • Сообщений: 2
Какое графическое окружение используется? Если Gnome (если ничего не изменилось), то том всё ещё есть проблемы с работой.

Установлены ли пакеты firmware-linux-free и firmware-linux-nonfree?
Пробовал Gnome, KDE и XFCE, пакеты устанавливал - реакция та же. От знакомых узнал: "Видеокарта довольно новая - поэтому жди еще года два", НО R9 M290X - всего лишь переделка какой-то видяхи (точно не помню). На gentoo все прекрасно работает
 

Оффлайн ihammers

От знакомых узнал: "Видеокарта довольно новая - поэтому жди еще года два"
Это если вы захотите использовать только свободные драйвера. Вам нужно установить драйвер fglrx 15.7, а лучше 15.9, к сожалению пока не все пакеты есть в jessie-backports (32x битных либ нету).

Попробуйте поставить LightDM или KDE, плюс нужны логи /var/log/Xorg.0.log, чтобы посмотреть какие проблемы возникаю при запуске X-ов. По какой инструкции устанавливали драйвера?

Как вариант грузите систему, заходите в консоль подключаете флешку и перебрасываете на неё вывод команд:
~$ sudo mount /dev/sdb1 /mnt
~$ cp /var/log/Xorg.0.log{,.old} /mnt/
~$ lspci > /mnt/lspci.txt
~$ dpkg -l \*fglrx\* > /mnt/dpkg.txt
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290
 

Оффлайн mrgoodvin

Всё верно, проблема в новой карточке. Для debian, на сайте - http://www.amd.com/ru-ru/products/graphics/notebook/r9-m200# пока драйверов нету.
Поддерживаются следующие ОС на ядре linux:
Spoiler: ShowHide
Red Hat Enterprise Linux Suite 7.1, 7.0, 6.6, 6.5
Ubuntu 12.04.4 LTS, 14.04.2, 15.04
SUSE® Linux Enterprise 11 SP3, 12
OpenSuSE 13.1
 

Оффлайн ihammers

Поддерживаются следующие ОС на ядре linux:
И? В данном списке debian мне никогда не встречался. Вам нужно смотреть "Supported Products", а там данная серия карточек есть.

Теперь смотрим на наличие пакета в репозитарии debian: packages.debian.org, как можно заметить версия драйвера v15.9 есть либо в backports либо в testing.
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290
 

Оффлайн CyberSnake

Столкнулся с той же проблемой что и автор темы. Radeon R7 260X. Устанавливал драйвера по этому гайду https://wiki.debian.org/ATIProprietary#Debian_8_.22Jessie.22 . После загрузки черный экран. Выход в Ctrl+Alt+F1 работает.
dpkg http://pastebin.com/50hwXDPb
lspci http://pastebin.com/09W3jFwQ
Xorg.0.log http://pastebin.com/p09NUW9j
Xorg.0.log.old http://pastebin.com/wKmpx2kW

Что посоветуете?
 

Оффлайн ihammers

Какую графическую систему используете? Если GNOME, то там пока ещё проблемы с AMD видеокартами. Производили конфигурацию xorg после установки системы?
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290
 

Оффлайн CyberSnake

Среда GNOME.
Производили конфигурацию xorg после установки системы?
Нет. Если я правильно понимаю надо либо менять среду, либо ставить свободные драйвера. Или со свободными драйверами тоже проблема?
 

Оффлайн ihammers

Нет. Если я правильно понимаю надо либо менять среду, либо ставить свободные драйвера. Или со свободными драйверами тоже проблема?
На данный момент с GNOME пока ещё не работает с fglrx. Попробуйте доставить firmware-linux и удалить fglrx, чтобы проверить работу свободного драйвера с GNOME.

PS: я не пользователь GNOME, поэтому точной информации не знаю, когда данная проблема будет исправлена.
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290
 

Оффлайн CyberSnake

Проблема решилась интересным образом. Удалил fglrx через #apt-get remove --purge fglrx*Перезагрузил. Тот же черный экран. Потом решил поставить XFCE. Среда установилась, но в конце пожаловалась на файл /etc/X11/xorg.conf.d/20-fglrx.conf. Удалил в ручную, перезагрузился и увидел гномовский экран приветствия. Все заработало причем с анимациями, чего сначала не было. Посмотрел информацию о драйверах
dmitry@debian-pc:~$ glxinfo | grep -i opengl
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD BONAIRE
OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.3.2
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 10.3.2
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 10.3.2
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.0
OpenGL ES profile extensions:
Я так понял вместе с XFCE подтянулись свободные драйвера Mesa 10.3.2, но из-за 20-fglrx.conf FXCE не запустилась. Т.е. надо сразу было ставить свободные драйвера.
 

Теги:
     

    Чёрный экран после установки драйвера nvidia (РЕШЕНО)

    Автор Veritas Vestas

    Ответов: 5
    Просмотров: 6205
    Последний ответ 10 Февраля 2019, 19:34:53
    от ferum
    Черный экран после установки Nvidia драйвера

    Автор Bojokot

    Ответов: 7
    Просмотров: 4001
    Последний ответ 24 Января 2017, 15:23:43
    от Bojokot