Автор Тема: package 'gee-1.0 >= 0.5.0' not found  (Прочитано 1884 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн longstreet

package 'gee-1.0 >= 0.5.0' not found
« : 19 Октября 2015, 07:56:51 »
пробую поставить клиент твиттера Pino
в процессе установки не нашёлся пакет gee-1.0

поиск по "gee" и подобным в Synaptic Packet Manager ничего не дал

откуда мне поставить этот пакет?
 

Онлайн endru

Re: package 'gee-1.0 >= 0.5.0' not found
« Ответ #1 : 19 Октября 2015, 08:06:47 »
есть пакет gir1.2-gee-1.0
если ничего не находит показывай /etc/apt/sources.list

Оффлайн longstreet

Re: package 'gee-1.0 >= 0.5.0' not found
« Ответ #2 : 19 Октября 2015, 08:15:09 »
ой, есть похожий с girl, но версия другая: girl1.2-gee-0.8
а нужен gee-1.0 как я понял...

sources.list у меня такой:

Цитировать
deb http://ftp.us.debian.org/debian/ testing main
deb-src http://ftp.us.debian.org/debian/ testing main

deb http://security.debian.org/ testing/updates main
deb-src http://security.debian.org/ testing/updates main

deb http://ftp.us.debian.org/debian/ testing-updates main
deb-src http://ftp.us.debian.org/debian/ testing-updates main
 

Онлайн endru

Re: package 'gee-1.0 >= 0.5.0' not found
« Ответ #3 : 19 Октября 2015, 09:01:19 »
в testing данного пакета нет. как вариант можно добавить в список источников реп jessie
echo "deb http://ftp.us.debian.org/debian/ jessie main" >>/etc/apt/sources.listобновить список:
apt-get updateпоставить нужный пакет и удалить добавленную строку из sources.list
 
Пользователи, которые поблагодарили этот пост: longstreet

Оффлайн longstreet

Re: package 'gee-1.0 >= 0.5.0' not found
« Ответ #4 : 19 Октября 2015, 20:46:12 »
а что значит, если sudo apt-get update выдаёт

Цитировать
W: Failed to fetch http://ppa.launchpad.net/hotot-team/ppa/ubuntu/dists/wily/main/binary-amd64/Packages  404  Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.

 

Оффлайн ferum

Re: package 'gee-1.0 >= 0.5.0' not found
« Ответ #5 : 19 Октября 2015, 21:27:05 »
Что бы это значило ? Пытаемся поставить pino но последние пакеты для бунты кармик  пятилетней давности, приходим к выводу что ну его на фиг давай ка вкорячим  hotot  из другого бунтовского архива но и его бросили в 13 году, тогда ubuntu wily ещё и в проекте не было.
Осталось выяснить на каком дистрибутиве сидим и как компильнуть pino3 из исходников
Spoiler: ShowHide

For unstable versions (3.x):

hg clone https://troorl@bitbucket.org/troorl/pino3

Installation from sources

With Cmake build system:

mkdir build
cd build
cmake ../ -DCMAKE_INSTALL_PREFIX=/usr -DUBUNTU_ICONS=OFF -DENABLE_DEBUG=OFF
make
sudo make install

For uninstalling:

sudo make uninstall

 надо гуглить по сборке и пробовать.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн longstreet

Re: package 'gee-1.0 >= 0.5.0' not found
« Ответ #6 : 19 Октября 2015, 22:15:11 »
так я и пытаюсь из исходников, но он ругается при попытке компилирования что не находит пакета gee-1.0
 

Оффлайн ferum

Re: package 'gee-1.0 >= 0.5.0' not found
« Ответ #7 : 20 Октября 2015, 08:34:44 »
Дистрибутив то какой у вас ?  По чему в sources.list  http://ppa.launchpad.net/hotot-team/ppa/ubuntu/dists/wily/main ?
По любому нужен заголовок libgee-dev.
Даже интересно стало...
Русские дебианщики против цифрового слабоумия !
 

Онлайн endru

Re: package 'gee-1.0 >= 0.5.0' not found
« Ответ #8 : 20 Октября 2015, 08:48:50 »
ferum, скорее всего поможет команда:
cat /etc/apt/sources.list.d/*

Оффлайн ferum

Re: package \'gee-1.0 >= 0.5.0\' not found
« Ответ #9 : 20 Октября 2015, 09:36:35 »
ferum, скорее всего поможет команда:
Пытаюсь добиться от человека, на каком дистрибутиве он сидит, то что у него прописан источник к которому потерян доступ это и так понятно.
Из любопытства пытаюсь собрать свежую версию программы для jessie зависимостей тянет япона мама.

Cообщение объединено 20 Октября 2015, 11:48:01
В общем провёл эксперимент по установке из исходников в среде pbuilder
Что бы разрешить сборочные зависимости нам потребуются
Spoiler: ShowHide

apt-utils libgee-dev  libxml2-dev libglib2.0-dev  libnotify-dev libsoup2.4-dev libwebkit-dev valac libgtk2.0-dev python intltool gettext libunique-dev libgtkspell-dev librest-dev git-core mercurial опционально libindicate-dev но толку от неё нет

Скачиваем последние исходники pino3
hg clone https://troorl@bitbucket.org/troorl/pino3
Установку из них можем произвести только с использованием системы сборки waf https://github.com/waf-project/waf
скачиваем исходники waf
git clone https://github.com/waf-project/waf.git
переходим в каталог с исходниками waf  и делаем что написано https://github.com/waf-project/waf/blob/master/README
моё внимание привлекли строки 15, 21, 26 , 37, 38, 39
Переходим в каталог с исходниками pino3
mkdir -p build
cd build
с помощью mc я скопировал в ~/pino3/build содержимое ~/waf/demos/c
 Как написано в исходниках  pino3 файл INSTALLвыполнил команды
Spoiler: ShowHide

 ./waf configure --prefix=/usr
    ./waf build
    sudo ./waf install


 Что то куда то без ошибок установилось....но я ставил всё это на pbuilder  где нет иксов, по этому проверить результат не могу  да и работать это должно только с гномом, если у вас его нет он неизбежно появится вместе с зависимостями.
Вот как то так...
« Последнее редактирование: 20 Октября 2015, 11:48:01 от ferum »
Русские дебианщики против цифрового слабоумия !
 

Оффлайн longstreet

Re: package \\\'gee-1.0 >= 0.5.0\\\' not found
« Ответ #10 : 20 Октября 2015, 20:19:06 »
Дистрибутив то какой у вас ?
дистрибутив Дебиана какой?
команда uname -a даёт

Цитировать
Linux swirl 4.2.0-1-amd64 #1 SMP Debian 4.2.1-2 (2015-09-27) x86_64 GNU/Linux

просветите меня, что из этого есть указание на дистрибутив?

Cообщение объединено 20 Октября 2015, 20:22:03
работать это должно только с гномом
у меня Xfce, я так понял что много зависимостей из Gnome установка Pino потянет, но не весь же...

Cообщение объединено 20 Октября 2015, 20:26:02
ferum, вообще мне примерно всё равно какой клиент твиттера ставить, но у меня два требования:
*чтобы это была программа именно, а не окно в браузере
**чтобы интерфейс был схож с другими моими окнами

и блин я такого пока и не нашёл, а уже штуки 4 перебрал этих твиттер-клиентов  :-\
у них какие-то собственные кнопочки закрыть-открыть-свернуть
« Последнее редактирование: 20 Октября 2015, 20:26:02 от longstreet »
 

Оффлайн longstreet

Re: package 'gee-1.0 >= 0.5.0' not found
« Ответ #11 : 22 Октября 2015, 01:44:49 »
ferum, у меня Ваш путь обламывается в самом начале:

Цитировать
apt-utils: command not found

 ???
 

Оффлайн ferum

Re: package 'gee-1.0 >= 0.5.0' not found
« Ответ #12 : 22 Октября 2015, 09:25:11 »
Это пакет а не команда вовсе. у вас testing думаю пакетная база мало пригодна что бы что то собирать, на данном этапе тестирования возможно много конфликтов а вы ещё пытаетесь прицепить сторонние источники от ubuntu.
Может проще подобрать что нибудь из репозитория  http://myubuntu.ru/programmy/pyat-udobnykh-twitter-klientov-dlya-ubuntu  http://webtun.com/webservices/1164-twitter-klienty-dlya-linux.html
Русские дебианщики против цифрового слабоумия !
 

Теги:
     

    Проблема с установкой пакетов (Unable to locate package)

    Автор vasaiziza

    Ответов: 6
    Просмотров: 371
    Последний ответ 26 Июля 2021, 21:41:04
    от dzhoser
    dpkg: error processing package <packege name> (--purge):

    Автор incognito15

    Ответов: 2
    Просмотров: 2540
    Последний ответ 27 Июля 2015, 11:07:15
    от incognito15
    Недоступен kernel-package и бардак с репозиториями

    Автор Ethanol

    Ответов: 10
    Просмотров: 4215
    Последний ответ 09 Октября 2017, 21:54:44
    от Ethanol