Автор Тема: После смены видеокарты черный экран при загрузке  (Прочитано 3615 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн maxspb

Сменил видеокарту с nVidia GF550Ti на nVidia GF970. Windows грузит нормально, т.е. вопрос не в железе.
При загрузке Debian 8 - черный экран. Терминал не вызывается (Ctrl+Alt+F1). Нашел много тем с переустановкой драйвера
nVidia и черным экраном, но там хотя бы можно через терминал похимичить. Какие варианты все восстановить?
С уважением, maxspb
 
 

Оффлайн ferum

Полагаю используется проприаретарный драйвер тогда
Ctrl+Alt+F2 = вторая виртуальная консоль логинимся root или пользователем который с sudo
# nvidia-xconfig
# reboot
Русские дебианщики против цифрового слабоумия !
 

Оффлайн maxspb

Драйвер стоит не проприетарный. Ни одна из консолей не запускается.
 

Оффлайн ihammers

Драйвер стоит не проприетарный. Ни одна из консолей не запускается.
А вот это странно, такое поведение системы характерно для проблем с драйвером, проприетарным. Если возможность запустить систему в recovery mode? Если есть, то попробуйте выложить на форум данные следующих команд:
~$ lspci
~$ dpkg -l firmware\*
~$ dpkg -l \*nvidia\*

PS: Каждый вывод можно перенаправить в файл команда > файл (создаст или перезапишет файл), если >>, допишет.
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290
 

Оффлайн _Semen1991_

Сменил видеокарту с nVidia GF550Ti на nVidia GF970. Windows грузит нормально, т.е. вопрос не в железе.
При загрузке Debian 8 - черный экран. Терминал не вызывается (Ctrl+Alt+F1). Нашел много тем с переустановкой драйвера
nVidia и черным экраном, но там хотя бы можно через терминал похимичить. Какие варианты все восстановить?
С уважением, maxspb
 
При загрузке, если стоит гроб (а раз есть форточка, то скорее всего стоит гроб), надо выбрать что-то типо save mode.
Если такового нету, то включаем командною строку гроб (нажать "C" при отображении окна выбора системы) и пишем что-то вида:

Spoiler: ShowHide
Для справки по командам гроб - http://help.ubuntu.ru/wiki/grub, там целый раздел есть по командам именно гробовской консоли


set root=(hd*(что там у Вас),5)
linux /boot/vmlinuz-2.6.*(что там у Вас) root=/dev/sda*(что там у Вас) single
initrd /boot/initrd.img*(что там у Вас)
boot

Кажется именно параметр single запускает режим администрирования, без всяких иксов и прочего.
Если нет - курите мануал параметров запуска ядра, например, здесь http://ipmnet.ru/~sadilina/Fedora/303.html.

Ну а дальше у Вас будет консоль)))
Я бы снес проприетарный драйвер, откатил все на какую-нибудь месу и попробовал запустить иксы вручную. Но вообще Вы сами сказали - вариантов много, главное консоль =)
« Последнее редактирование: 14 Сентября 2016, 10:30:45 от _Semen1991_ »
 

Оффлайн ferum

А вот это странно, такое поведение системы характерно для проблем с драйвером, проприетарным. Если возможность запустить систему в recovery mode?
ihammers, Напротив Nouveau display driver не всегда справляется с новой навороченной карточкой ( если правильно нагуглилось 4х гиговая фильдиперсовая железка ) и драйвер из репозитория ещё не факт. Скорее и проще всего надо вставить старую карточку, поставить последний драйвер с официального сайта и уже потом вставлять новую, а то все эти маникуляции с nomodeset могут и не проканать.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн ihammers

ihammers, Напротив Nouveau display driver не всегда справляется с новой навороченной карточкой ( если правильно нагуглилось 4х гиговая фильдиперсовая железка ) и драйвер из репозитория ещё не факт.
Ясно, буду знать, что проблемы могут возникнуть из-за Nouveau.

PS: С Nouveau я не работал, так как использую видеокарты от AMD, а на работе где есть Nvidia, то проприетарный драйвер.
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290
 

Оффлайн maxspb

Пробовал химичить с grub. Ничего не помогает (nomodeset и т.п.) Психанул, переустановил OS, проблема с noveau - он почему-то
не работает с видюхой, хотя она заявлена в списке. Буду пробовать ставить старую видюху, накатить проприетарный драйвер и
поменять обратно на новую.
 

Теги:
     

    Пропадает звук после загрузки системы Debian 8

    Автор oobook

    Ответов: 0
    Просмотров: 583
    Последний ответ 26 Сентября 2019, 12:07:57
    от oobook
    [РЕШЕНО] После обновления пропал звук

    Автор su16

    Ответов: 13
    Просмотров: 14078
    Последний ответ 22 Мая 2012, 18:07:31
    от su16
    Проблемы со звуком после апгрейда до Wheezy

    Автор Sergei_Alekseev

    Ответов: 2
    Просмотров: 1981
    Последний ответ 08 Мая 2013, 19:04:59
    от Sergei_Alekseev
    Пропал профиль HSP/HFP для bluetooth гарнитуры после обновления до Jessie

    Автор mikyman388

    Ответов: 0
    Просмотров: 5472
    Последний ответ 23 Мая 2015, 08:57:38
    от mikyman388
    alsa после апгрейда

    Автор Sergei_Alekseev

    Ответов: 3
    Просмотров: 1231
    Последний ответ 12 Июля 2017, 20:52:21
    от bob1704