Автор Тема: Steam и драйвера nvidia,да и вообще установка дров nvidia  (Прочитано 4039 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн artfok

Здравствуйте,начну из далека:-) Поставил debian 8.5,поставил быстро,раньше другие убунты,минты и т д были...И вот решил я поставить проприетарные дрова на nvidia gtx 960(видюха моя)мучался дня 3,и так и эдак,шаманил,плясал,в барабаны стучал,ибо не опытен был,раз 10 ось переустанавливал,потому что после установки драйверов и перезагрузки ПК всегда был чёрный экран и мигающий курсор слева в верхнем углу.И тут о чудо,как то они встали и иксы запустились(помог способ толи fgrlx,или run запускал,уже не помню)через полгодика решил STEAM поставить,поиграться решил:-) ,включил поддержку мультиархитекруры,дрова для i386 скачал(вобщем все как в wiki написано)при установке дров i386,в консоли выскачила табличка,мол у вас в системе остался от предыдущей установки nvidia installer,и его удалить нужно,ну нужно так нужно,нажал ОК,все встало,но steam не запускается,перезагрузился,и тут опять чёрный экран и мигающий курсор!Че я только не делал,сносил систему и дрова так ставил-apt-get install nvidia-driver
#apt-get install nvidia-xconfig
#nvidia-xconfig
$nvidia-setting-----чернота с мигающим курсором,все способы перепробывал,перекрыл много инфы,как то нужно xorg.conf править,че то нужно в блэклист заносить,не пойму как да что,был бы очень признателен,если бы кто нибудь пошагово описал действия( представим что я снес ОС и начинаю все с нуля)Систему поставил.........(щас на работе,пишу с планшета,будте добры,распишите пошагово как все сделать).
 

Оффлайн qupl


Оффлайн artfok

Вычитал вот что Но в Backports никогда не прилетят, скажем, новые версии графических окружений.....

Cообщение объединено 09 Февраля 2017, 12:46:56
А дрова то обновляться будут?
 

Оффлайн Aalexeey

раз 10 ось переустанавливал,потому что
https://debianforum.ru/index.php?topic=6879 чтоб не переустанавливать раз 10,  ;D
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
 

Оффлайн artfok

раз 10 ось переустанавливал,потому что
https://debianforum.ru/index.php?topic=6879 чтоб не переустанавливать раз 10,  ;D
] Хорошо вам говорить,тырнет то у вас уважаемый безлимитный,да шустрый наверно,а в тех еб...ях где я живу 1 мегабайт трафика 3 рубля стоит,и играться в виртуалке или в liveCD со скачиванием дров и софта-разоришся,вот и сношу и ставлю,в надежде что какой то способ да сработает:-) .
 

Оффлайн amd_amd

драйвера nvidia - сущее дерьмо, использую связку luakit + flashplugin, при попытке воиспроизведения видео на весь экран - заметны лаги\тормоза, оно и понятно - иксы не тянут, ставлю nvidia-driver - после чего при попытке просмотра видео luakit крашится спустя несколько секунд после начала воиспроизведения, можно конечно с пеной у рта доказывать что luakit говно и надо поставить лисицу или хромого, но ведь до установки nvidia-driver все работало, сея манипуляция была проверена на 8-и компьютерах с абсолютно разным железом и везде получился одинаковый результат - после установки nvidia-driver браузер luakit крашится, более того проверял на jessie и на stretch использовал разные архитектуры - везде одно и тоже, в топку все эти драйвера - еду на иксах...
 

Оффлайн artfok

Я после той вот удачной попытке установки драйверов nvidia,от тиринга не мог избавится,дня три,и это на gtx 960!!!! И тройная буферизация и vsync,день промучался,ну щас вот приду попробую ещё раз дровишки поставить,посмотрим

Cообщение объединено [time]10 Февраля 2017, 02:08:28[/time]
Встало все,спасибо,но вот выскакивает проблема,при установке 32 битных библиотек openGL,при установке они напрочь удаляют драйвера nvidia,че делать то?
Нажимать no,так они не становятся(библиотеки 32 openGl)?

Cообщение объединено [time]10 Февраля 2017, 07:26:20[/time]
вот ставлю STEAM по wiki ,в конце когда нужно установить 32 битные для openGL вот че появляется

Spoiler: ShowHide
aptitude install libgl1-nvidia-glx:i386
Следующие НОВЫЕ пакеты будут установлены:       
  glx-alternative-nvidia:i386{ab} glx-diversions:i386{ab}
  libatk1.0-0:i386{a} libaudit1:i386{a} libavahi-client3:i386{a}
  libavahi-common-data:i386{a} libavahi-common3:i386{a} libbz2-1.0:i386{a}
  libcairo2:i386{a} libcomerr2:i386{a} libcups2:i386{a} libdatrie1:i386{a}
  libdbus-1-3:i386{a} libegl1-mesa:i386{a} libegl1-mesa-drivers:i386{a}
  libegl1-nvidia:i386{a} libepoxy0:i386{ab} libfontconfig1:i386{a}
  libfontenc1:i386{a} libfreetype6:i386{a} libgbm1:i386{a}
  libgcrypt20:i386{a} libgdk-pixbuf2.0-0:i386{a} libgl1-nvidia-glx:i386
  libgles1-nvidia:i386{a} libgles2-nvidia:i386{a} libglib2.0-0:i386{a}
  libgmp10:i386{a} libgnutls-deb0-28:i386{a} libgpg-error0:i386{a}
  libgraphite2-3:i386{a} libgssapi-krb5-2:i386{a} libgtk2.0-0:i386{a}
  libharfbuzz0b:i386{a} libhogweed2:i386{a} libjansson4:i386{a}
  libjasper1:i386{a} libjbig0:i386{a} libjpeg62-turbo:i386{a}
  libk5crypto3:i386{a} libkeyutils1:i386{a} libkrb5-3:i386{a}
  libkrb5support0:i386{a} liblzma5:i386{a} libnettle4:i386{a}
  libnvidia-eglcore:i386{ab} libnvidia-ml1:i386{ab} libopenvg1-mesa:i386{a}
  libp11-kit0:i386{a} libpango-1.0-0:i386{a} libpangocairo-1.0-0:i386{a}
  libpangoft2-1.0-0:i386{a} libpcre3:i386{a} libpixman-1-0:i386{a}
  libpng12-0:i386{a} libselinux1:i386{a} libtasn1-6:i386{a}
  libthai0:i386{a} libtiff5:i386{a} libvdpau1:i386{ab}
  libwayland-client0:i386{a} libwayland-egl1-mesa:i386{a}
  libwayland-server0:i386{a} libxcb-render0:i386{a} libxcb-shape0:i386{a}
  libxcb-shm0:i386{a} libxcb-xfixes0:i386{a} libxcomposite1:i386{a}
  libxcursor1:i386{a} libxfont1:i386{a} libxi6:i386{a} libxnvctrl0:i386{ab}
  libxrandr2:i386{a} libxrender1:i386{a} nvidia-alternative:i386{ab}
  nvidia-driver:i386{ab} nvidia-driver-bin:i386{ab}
  nvidia-kernel-common:i386{ab} nvidia-kernel-dkms:i386{ab}
  nvidia-modprobe:i386{ab} nvidia-settings:i386{ab}
  nvidia-vdpau-driver:i386{ab} pkg-config{a} xserver-xorg-core:i386{ab}
  xserver-xorg-video-nvidia:i386{ab}
Следующие пакеты будут обновлены:
  fontconfig-config libcairo2 libcomerr2 libdbus-1-3 libfontconfig1
  libgcrypt20 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common libgnutls-deb0-28
  libhogweed2 libjasper1 libnettle4 libpng12-0 libtiff5
14 пакетов обновлено, 85 установлено новых, 0 пакетов отмечено для удаления, и 175 пакетов не обновлено.
Необходимо получить 53,4 MB архивов. После распаковки 183 MB будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
 nvidia-alternative : Ломает: nvidia-driver:i386 (< 343.22-2~) но устанавливается 340.101-1.
                      Конфликтует: nvidia-alternative:i386 но устанавливается 340.101-1.
 nvidia-alternative:i386 : Конфликтует: nvidia-alternative но установлен 375.26-1~bpo8+1
 libgnutls-openssl27 : Зависит: libgnutls-deb0-28 (= 3.3.8-6+deb8u3) но устанавливается 3.3.8-6+deb8u4.
 libnvidia-cfg1 : Ломает: libgl1-nvidia-glx:i386 (< 355.11-5) но устанавливается 340.101-1.
 nvidia-driver : Конфликтует: nvidia-driver:i386 но устанавливается 340.101-1.
 nvidia-driver:i386 : Конфликтует: nvidia-driver но установлен 375.26-1~bpo8+1
 libepoxy0 : Конфликтует: libepoxy0:i386 но устанавливается 1.2-1.
 libepoxy0:i386 : Конфликтует: libepoxy0 но установлен 1.2-1
 libegl1-glvnd-nvidia : Конфликтует: libegl1-nvidia:i386 но устанавливается 340.101-1.
 xserver-xorg-video-nvidia : Ломает: glx-alternative-nvidia (< 0.6.91) но установлен 0.7.3~bpo8+1
                             Ломает: glx-alternative-nvidia:i386 (< 0.6.91) но устанавливается 0.5.1.
                             Конфликтует: xserver-xorg-video-nvidia:i386 но устанавливается 340.101-1.
 xserver-xorg-video-nvidia:i386 : Конфликтует: xserver-xorg-video-nvidia но установлен 375.26-1~bpo8+1
 nvidia-settings : Конфликтует: nvidia-settings:i386 но устанавливается 340.46-2.
 nvidia-settings:i386 : Конфликтует: nvidia-settings но установлен 375.26-3~bpo8+1
 libnvidia-glcore : Ломает: libgl1-nvidia-glx:i386 (< 355.11-5) но устанавливается 340.101-1.
 nvidia-modprobe : Конфликтует: nvidia-modprobe:i386 но устанавливается 340.46-1.
 nvidia-modprobe:i386 : Конфликтует: nvidia-modprobe но установлен 358.09-1~bpo8+1
 xserver-xorg-core : Конфликтует: xserver-xorg-core:i386 но устанавливается 2:1.16.4-1.
 xserver-xorg-core:i386 : Конфликтует: xserver-xorg-core но установлен 2:1.16.4-1
 libgles1-glvnd-nvidia : Ломает: libgles1-nvidia:i386 (< 361) но устанавливается 340.101-1.
 nvidia-kernel-support : Ломает: glx-alternative-nvidia (< 0.6.91) но установлен 0.7.3~bpo8+1
                         Ломает: glx-alternative-nvidia:i386 (< 0.6.91) но устанавливается 0.5.1.
 libgles2-glvnd-nvidia : Ломает: libgles2-nvidia:i386 (< 361) но устанавливается 340.101-1.
 glx-diversions : Конфликтует: glx-diversions:i386 но устанавливается 0.5.1.
 glx-diversions:i386 : Конфликтует: glx-diversions но установлен 0.7.3~bpo8+1
 nvidia-kernel-dkms : Конфликтует: nvidia-kernel-dkms:i386 но устанавливается 340.101-1.
 nvidia-kernel-dkms:i386 : Конфликтует: nvidia-kernel-dkms но установлен 375.26-1~bpo8+1
 libnvidia-ml1 : Ломает: libnvidia-ml1:i386 (!= 375.26-1~bpo8+1) но устанавливается 340.101-1.
 libnvidia-ml1:i386 : Ломает: libnvidia-ml1 (!= 340.101-1) но установлен 375.26-1~bpo8+1
 glx-alternative-nvidia : Ломает: nvidia-alternative (< 341) но установлен 375.26-1~bpo8+1
                          Ломает: nvidia-alternative:i386 (< 341) но устанавливается 340.101-1.
                          Конфликтует: glx-alternative-nvidia:i386 но устанавливается 0.5.1.
 glx-alternative-nvidia:i386 : Конфликтует: glx-alternative-nvidia но установлен 0.7.3~bpo8+1
 nvidia-vdpau-driver : Ломает: nvidia-vdpau-driver:i386 (!= 375.26-1~bpo8+1) но устанавливается 340.101-1.
 nvidia-vdpau-driver:i386 : Ломает: nvidia-vdpau-driver (!= 340.101-1) но установлен 375.26-1~bpo8+1
 nvidia-driver-bin : Ломает: nvidia-driver:i386 (< 343.22-2~) но устанавливается 340.101-1.
                     Конфликтует: nvidia-driver-bin:i386 но устанавливается 340.101-1.
 nvidia-driver-bin:i386 : Конфликтует: nvidia-driver-bin но установлен 375.26-1~bpo8+1
 nvidia-kernel-common : Конфликтует: nvidia-kernel-common:i386 но устанавливается 20141201+1.
 nvidia-kernel-common:i386 : Конфликтует: nvidia-kernel-common но установлен 20151021+1~bpo8+1
 libvdpau1 : Ломает: libvdpau1:i386 (!= 1.1.1-1~bpo8+1) но устанавливается 0.8-3+deb8u2.
 libvdpau1:i386 : Ломает: libvdpau1 (!= 0.8-3+deb8u2) но установлен 1.1.1-1~bpo8+1
 libgl1-glvnd-nvidia-glx : Конфликтует: libgl1-nvidia-glx:i386 но устанавливается 340.101-1.
 libnvidia-eglcore : Ломает: libnvidia-eglcore:i386 (!= 375.26-1~bpo8+1) но устанавливается 340.101-1.
 libnvidia-eglcore:i386 : Ломает: libnvidia-eglcore (!= 340.101-1) но установлен 375.26-1~bpo8+1
 libxnvctrl0 : Ломает: libxnvctrl0:i386 (!= 375.26-3~bpo8+1) но устанавливается 340.46-2.
 libxnvctrl0:i386 : Конфликтует: libxnvctrl0 но установлен 375.26-3~bpo8+1
Следующие действия разрешат зависимости:

       Удалить следующие пакеты:                                               
1)       cinnamon                                                               
2)       cinnamon-core                                                         
3)       cinnamon-desktop-environment                                           
4)       glx-alternative-mesa                                                   
5)       glx-alternative-nvidia                                                 
6)       glx-diversions                                                         
7)       gnome-session-bin                                                     
8)       iputils-ping                                                           
9)       libegl-nvidia0                                                         
10)      libegl1-glvnd-nvidia                                                   
11)      libepoxy0                                                             
12)      libgl1-glvnd-nvidia-glx                                               
13)      libgl1-nvidia-glvnd-glx                                               
14)      libgles-nvidia1                                                       
15)      libgles-nvidia2                                                       
16)      libgles1-glvnd-nvidia                                                 
17)      libgles2-glvnd-nvidia                                                 
18)      libglx-nvidia0                                                         
19)      libglx0-glvnd-nvidia                                                   
20)      libgnutls-openssl27                                                   
21)      libnvidia-cfg1                                                         
22)      libnvidia-ml1                                                         
23)      libvdpau1                                                             
24)      nvidia-alternative                                                     
25)      nvidia-driver                                                         
26)      nvidia-driver-bin                                                     
27)      nvidia-driver-libs                                                     
28)      nvidia-egl-icd                                                         
29)      nvidia-kernel-common                                                   
30)      nvidia-kernel-dkms                                                     
31)      nvidia-kernel-support                                                 
32)      nvidia-modprobe                                                       
33)      nvidia-settings                                                       
34)      nvidia-vdpau-driver                                                   
35)      nvidia-vulkan-icd                                                     
36)      task-cinnamon-desktop                                                 
37)      task-desktop                                                           
38)      update-glx                                                             
39)      va-driver-all                                                         
40)      vdpau-va-driver                                                       
41)      xorg                                                                   
42)      xserver-xorg                                                           
43)      xserver-xorg-core                                                     
44)      xserver-xorg-input-all                                                 
45)      xserver-xorg-input-evdev                                               
46)      xserver-xorg-input-mouse                                               
47)      xserver-xorg-input-synaptics                                           
48)      xserver-xorg-input-vmmouse                                             
49)      xserver-xorg-input-wacom                                               
50)      xserver-xorg-video-all                                                 
51)      xserver-xorg-video-ati                                                 
52)      xserver-xorg-video-cirrus                                             
53)      xserver-xorg-video-fbdev                                               
54)      xserver-xorg-video-intel                                               
55)      xserver-xorg-video-mach64                                             
56)      xserver-xorg-video-mga                                                 
57)      xserver-xorg-video-modesetting                                         
58)      xserver-xorg-video-neomagic                                           
59)      xserver-xorg-video-nouveau                                             
60)      xserver-xorg-video-nvidia                                             
61)      xserver-xorg-video-openchrome                                         
62)      xserver-xorg-video-qxl                                                 
63)      xserver-xorg-video-r128                                               
64)      xserver-xorg-video-radeon                                             
65)      xserver-xorg-video-savage                                             
66)      xserver-xorg-video-siliconmotion                                       
67)      xserver-xorg-video-sisusb                                             
68)      xserver-xorg-video-tdfx                                               
69)      xserver-xorg-video-trident                                             
70)      xserver-xorg-video-vesa                                               
71)      xserver-xorg-video-vmware                                             
72)      xwayland                                                               

       Сохранить для следующих пакетов их текущие версии:                       
73)      glx-alternative-nvidia:i386 [Не установлен]                           
74)      libegl1-nvidia:i386 [Не установлен]                                   
75)      libgl1-nvidia-glx:i386 [Не установлен]                                 
76)      libgles1-nvidia:i386 [Не установлен]                                   
77)      libgles2-nvidia:i386 [Не установлен]                                   
78)      libnvidia-eglcore:i386 [Не установлен]                                 
79)      libnvidia-ml1:i386 [Не установлен]                                     
80)      libxnvctrl0:i386 [Не установлен]                                       
81)      nvidia-alternative:i386 [Не установлен]                               
82)      nvidia-driver:i386 [Не установлен]                                     
83)      nvidia-driver-bin:i386 [Не установлен]                                 
84)      nvidia-kernel-common:i386 [Не установлен]                             
85)      nvidia-kernel-dkms:i386 [Не установлен]                               
86)      nvidia-settings:i386 [Не установлен]                                   
87)      nvidia-vdpau-driver:i386 [Не установлен]                               
88)      xserver-xorg-video-nvidia:i386 [Не установлен]                         

       Оставить следующие зависимости неразрешёнными:                           
89)      libnotify4 рекомендует notification-daemon                             
90)      lightdm рекомендует xserver-xorg                                       
91)      network-manager-gnome рекомендует notification-daemon                 
92)      rhythmbox рекомендует notification-daemon                             
93)      xinit рекомендует xserver-xorg | xserver                               
94)      xserver-xorg-input-all рекомендует xserver-xorg-input-wacom           
95)      glx-diversions:i386 рекомендует glx-alternative-mesa:i386             
96)      nvidia-settings:i386 рекомендует libgl1-nvidia-glx:i386               
97)      nvidia-driver-bin:i386 рекомендует nvidia-driver:i386                 
98)      nvidia-kernel-dkms:i386 рекомендует nvidia-driver:i386 (>= 340.101) | l
99)      nvidia-vdpau-driver:i386 рекомендует nvidia-kernel-dkms:i386 (= 340.101
100)     xserver-xorg-video-nvidia:i386 рекомендует nvidia-driver:i386 (>= 340.1
101)     nvidia-settings рекомендует libgl1-nvidia-glvnd-glx | libgl1-nvidia-glx
102)     nvidia-driver-bin рекомендует nvidia-driver                           
103)     nvidia-driver-libs рекомендует libglx-nvidia0 (= 375.26-1~bpo8+1)     
104)     nvidia-driver-libs рекомендует libgles-nvidia1 (= 375.26-1~bpo8+1)     
105)     nvidia-driver-libs рекомендует libgles-nvidia2 (= 375.26-1~bpo8+1)     
106)     nvidia-driver-libs рекомендует libnvidia-cfg1 (= 375.26-1~bpo8+1)     
107)     nvidia-driver-libs рекомендует nvidia-vulkan-icd (= 375.26-1~bpo8+1)   
108)     nvidia-egl-common рекомендует libegl-nvidia0                           
109)     nvidia-kernel-dkms рекомендует nvidia-driver (>= 375.26) | libcuda1 (>=
110)     nvidia-vulkan-common рекомендует nvidia-vulkan-icd                     


Принять данное решение? [Y/n/q/?]

Нажимаю Y и все дрова нвидиа удаляются,и опять черный экран с курсором.Как исправить?

* используйте теги! endru

Cообщение объединено [time]10 Февраля 2017, 07:50:10[/time]
Че делать то,куда дальше рыть?


Cообщение объединено [time]10 Февраля 2017, 09:24:53[/time]
Steam стоит уже,осталось библиотеке эти 32 bit установить,решение кто знает то?или дохлое дело?

Cообщение объединено [time]10 Февраля 2017, 11:12:53[/time]
Поможет кто нибудь?

Cообщение объединено 10 Февраля 2017, 11:56:13
Ткните носом хотя бы где искать решение проблемы:-) .
« Последнее редактирование: 10 Февраля 2017, 11:56:13 от artfok »
 

Оффлайн Aalexeey

вот и сношу и ставлю,в надежде что какой то способ да сработает:-)
Вы точно поняли что там написано (https://debianforum.ru/index.php?topic=6879), вы до линукса что никогда акрониса ни нюхали? Повторюсь наверное, но не надо навязчиво непрерывно переустанавливать систему, надо делать копии системных разделов на разные моменты например когда она только установлена и ещё не трогана рукой ... нехорошего пользователя.
Да и интернет у меня сейчас медленный спутниковый.
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
 

Оффлайн VKH

О самой системе информации нет. Если возникли проблемы с установкой драйверов, то укажите ссылку на инструкцию и опишите процес установки.
Перед установкой проприетарных драйверов попробуйте следующим образом:
sudo dpkg --add-architecture i386 && apt-get update && apt-get ugrade // только для 64bit
sudo apt-get install build-essential && sudo apt-get install linux-source && sudo apt-get install linux-headers-generic // если используете ядро из jessie-backports то устанавливать эти пакеты из backports
sudo apt-get install -fЗатем установить драйвера согласно инструкции.

А ваша проблема вроде в том что поставили ядро и драйвера с backpotrs, а для стима ставите из стабильной версии...! 


 

Оффлайн amd_amd

aptitude install libgl1-nvidia-glx:i386
что это?
 

Оффлайн Aalexeey

Ткните носом хотя бы где искать решение проблемы:-)
SteamOS (SteamOS2 Brewmaster - она же Jessie - та версия что на Jessie - полностью совместима и использует также репы Jessie):
deb http://repo.steampowered.com/steamos/ brewmaster main contrib non-freeТрадиционно там всё допилено под гэээээймеров, то есть упор на продвинутую поддержку видео.
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
 

Оффлайн artfok

вот и сношу и ставлю,в надежде что какой то способ да сработает:-)
Вы точно поняли что там написано (https://debianforum.ru/index.php?topic=6879), вы до линукса что никогда акрониса ни нюхали? Повторюсь наверное, но не надо навязчиво непрерывно переустанавливать систему, надо делать копии системных разделов на разные моменты например когда она только установлена и ещё не трогана рукой ... нехорошего пользователя.
Да и интернет у меня сейчас медленный спутниковый.
Ну вообще то я Clonezilla использую,но все равно,восстановил систему clonezilloй:-) ,а дрова то нужно скачивать.

Cообщение объединено [time]10 Февраля 2017, 23:10:09[/time]
aptitude install libgl1-nvidia-glx:i386
что это?
Это в wiki написано,инструкция по установке steam для debian jessi 8,пошаговая

Cообщение объединено [time]10 Февраля 2017, 23:22:35[/time]
О самой системе информации нет. Если возникли проблемы с установкой драйверов, то укажите ссылку на инструкцию и опишите процес установки.
Перед установкой проприетарных драйверов попробуйте следующим образом:
sudo dpkg --add-architecture i386 && apt-get update && apt-get ugrade // только для 64bit
sudo apt-get install build-essential && sudo apt-get install linux-source && sudo apt-get install linux-headers-generic // если используете ядро из jessie-backports то устанавливать эти пакеты из backports
sudo apt-get install -fЗатем установить драйвера согласно инструкции.

А ваша проблема вроде в том что поставили ядро и драйвера с backpotrs, а для стима ставите из стабильной версии...!
Дрова я ставил вот по этой ссылке https://wiki.debian.org/ru/NvidiaGraphicsDrivers Система моя Debian Jessi 8.5 x64 ядро 3.16.0.4,дрова для моей видеокарты(nvidia gtx 960) цитирую-Обратите внимание, что версия 367.44 доступна только в нестабильной версии Debian и через репозиторий Backports,тоесть работают только бэкпортовские.

Cообщение объединено [time]10 Февраля 2017, 23:41:40[/time]
Вот походу в чем проблема то,дрова для моей видеокарты есть только в бэкпортовской ветке,это что,значит мне 32 bit ные библиотеки для Стима тоже нужно из бэкпортовской ветки ставить?Если да то как?

Cообщение объединено [time]11 Февраля 2017, 00:01:22[/time]
Ткните носом хотя бы где искать решение проблемы:-)
SteamOS (SteamOS2 Brewmaster - она же Jessie - та версия что на Jessie - полностью совместима и использует также репы Jessie):
deb http://repo.steampowered.com/steamos/ brewmaster main contrib non-freeТрадиционно там всё допилено под гэээээймеров, то есть упор на продвинутую поддержку видео.
Попробу сейчас.

Cообщение объединено [time]11 Февраля 2017, 01:31:30[/time]
не робит,ключ не удается проверить.Гайды из интернета тоже не помогают

Cообщение объединено [time]11 Февраля 2017, 07:32:06[/time]
Написал в тех поддержку стима,мож они подскажут как установить 32 битные библиотки,чтобы они не удаляли дрова мои и DE
« Последнее редактирование: 11 Февраля 2017, 07:34:32 от artfok »
 

Оффлайн VKH

В данной инструкции https://wiki.debian.org/ru/Steam так и написано. Если устанавливаете драйвера из бэкпорта, то и пакет libgl1-nvidia-glx:i386 надо устанавливать из бэкпорта. Установка пакетов из бэкпорта https://wiki.debian.org/ru/Backports или из синаптика или подобной командой apt-get -t jessie-backports install libgl1-nvidia-glx:i386. Почистите систему и начните все сначала. Добавить необходимые репозитории и поддержку 32bit архитектуры, обновить пакеты, обновить систему, установить драйвера и поставить пакеты из бэкпорта для стим согласно инструкции, остальное подтянется из бэкпорта.
 

Оффлайн artfok

Спасибо,попробую,кажется мне что это как раз то что нужно,через 2 дня отпишусь,и можно будет закрывать тему(если пойдёт асе ок)
 

Оффлайн artfok

ура все заработало!!!
сделал для себя инструкцию
Инструкция по установке Steam для stable версии дебиан(если драйвера для вашей видеокарты имеются  только в Backports ветке)

добавляем Backports репозиторий в source list
deb http://httpredir.debian.org/debian jessie-backports main contrib non-free
 далее в терминале
sudo dpkg --add-architecture i386
apt-get update
apt-get upgrade
apt-get install build-essential
sudo apt-get install linux-source
apt-get install -f
 установка драйверов для видеокарты
apt-get install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,')
apt-get update
 apt-get install -t jessie-backports nvidia-driver
перезагрузка
далее в терминале
apt-get -t jessie-backports install libgl1-nvidia-glx:i386
установка steam
apt-get install steam
бинго!по этой инструкции у меня все заработало

Cообщение объединено 13 Февраля 2017, 05:56:32
Большое спасибо VKH
Очень помог.
Закрыто
« Последнее редактирование: 13 Февраля 2017, 05:56:32 от artfok »
 

Теги: