неудовлетворённые зависимости

Автор debi, 19 ноября 2021, 14:50:04

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

debi

Пытаюсь скомпилировать код с помощью g++ на debian, но выводит ошибку "g++ команда не найдена", хотя после ввода команды whereis gcc пишет "/usr/lib/gcc /usr/share/gcс". Пыталась установить g++, но пишет, что все уже установлено и последней версии. Как запустить компилятор?
Уже делала:

sudo apt-get install -y build-essential И sudo apt-get --reinstall build-essential

Выдает: Следующие пакеты имеют неудовлетворённые зависимости:
dpkg-dev : Зависит: libdpkg-perl (= 1.18.25) но 1.20.9 должен быть установлен
            Рекомендует: fakeroot
            Рекомендует: libalgorithm-merge-perl но он не будет установлен
libc6-dev : Зависит: libc6 (= 2.24-11+deb9u4) но 2.31-13+deb11u2 должен быть установлен
             Зависит: libc-dev-bin (= 2.24-11+deb9u4) но он не будет установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.


sudo apt-get update

Выдает:
Не удалось соединиться с www.tataranovich.com:80 (159.69.2.125). - connect (111: В соединении отказано) Невозможно инициализировать соединение с www.tataranovich.com:80 (2a01:4f8:1c0c:61da::1). - connect (101: Сеть недоступна). *при этом сеть есть


sudo apt-get install libgcc1 - ошибок не выдал

sudo apt-get --fix-broken install

Выдал: Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено

P.S. Sources во вложении

Пользуемся тегами, ogost

ogost


ls /etc/apt/sources.list.d
sudo apt update
sudo apt install build-essentials

а что мешает запустить gcc?

debi


ogost, прописала, вот что выводит после sudo apt update:

Ошб:1 http://www.tataranovich.com/debian xenial InRelease
  Не удалось соединиться с www.tataranovich.com:80 (159.69.2.125). - connect (111: В соединении отказано) Невозможно инициализировать соединение с www.tataranovich.com:80 (2a01:4f8:1c0c:61da::1). - connect (101: Сеть недоступна)
Игн:2 http://deb.debian.org/debian stretch InRelease
Сущ:3 http://security.debian.org/debian-security stretch/updates InRelease
Сущ:4 http://deb.debian.org/debian stretch-updates InRelease
Сущ:5 http://deb.debian.org/debian stretch-backports InRelease
Сущ:6 http://deb.debian.org/debian stretch Release
Чтение списков пакетов... Готово           
Построение дерева зависимостей... Готово
Чтение информации о состоянии... Готово         
Все пакеты имеют последние версии.
W: Не удалось получить http://www.tataranovich.com/debian/dists/xenial/InRelease  Не удалось соединиться с www.tataranovich.com:80 (159.69.2.125). - connect (111: В соединении отказано) Невозможно инициализировать соединение с www.tataranovich.com:80 (2a01:4f8:1c0c:61da::1). - connect (101: Сеть недоступна)
W: Некоторые индексные файлы скачать не удалось. Они были проигнорированы, или вместо них были использованы старые версии.
root@debi:/etc/apt/sources.list.d# sudo apt install build-essentials
Чтение списков пакетов... Готово
Построение дерева зависимостей... Готово
Чтение информации о состоянии... Готово         
E: Невозможно найти пакет build-essentials


qupl

debi, приведите список источников к нормальному виду. Смотрите здесь. Нестандартные репозитории, если без них никак, на время закомментируйте (#).

k.kirill

Здравствуйте!
Нужна помощь. При установке Wine по инструкции https://wiki.winehq.org/Debian
получаю:
sudo apt install wine-stable
Чтение списков пакетов... Готово
Построение дерева зависимостей... Готово
Чтение информации о состоянии... Готово         
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
libcurl3-gnutls : Зависит: librtmp1 (>= 2.4+20131018.git79459a2-3~) но он не может быть установлен
libcurl4 : Зависит: librtmp1 (>= 2.4+20131018.git79459a2-3~) но он не может быть установлен
wine-stable-amd64 : Зависит: libgstreamer-plugins-base1.0-0 (>= 1.0.0) но он не может быть установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.


Далее при попытке установить пакеты
sudo apt install librtmp1 libgstreamer-plugins-base1.0-0
Чтение списков пакетов... Готово
Построение дерева зависимостей... Готово
Чтение информации о состоянии... Готово         
Уже установлен пакет libgstreamer-plugins-base1.0-0 самой новой версии (1.18.4-dmo1).
Уже установлен пакет librtmp1 самой новой версии (2:2.4~20160119.gitfa8646dae-dmo7).
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.


Репозитории:
sudo apt update
Сущ:1 http://deb.debian.org/debian bullseye InRelease
Сущ:2 http://security.debian.org/debian-security bullseye-security InRelease
Сущ:3 http://deb.debian.org/debian bullseye-updates InRelease
Сущ:4 https://dl.winehq.org/wine-builds/debian bullseye InRelease
Сущ:5 https://download.virtualbox.org/virtualbox/debian bullseye InRelease


Подскажите пожалуйста, как решить такую проблему?
Debian 11 Cinamon

Aalexeey

Цитата: k.kirill от 23 января 2022, 20:27:10Уже установлен пакет libgstreamer-plugins-base1.0-0 самой новой версии (1.18.4-dmo1).
Уже установлен пакет librtmp1 самой новой версии (2:2.4~20160119.gitfa8646dae-dmo7)
dmo означает что эти пакеты из debian-multimedia - репозитарий с отвратительной выпендрёжной нумерацией пакетов (например у вас 2:2.4), что вызывает поломку зависимостей при различных обновлениях. Из за них была большая перепалка у проекта MX где после выхода нового GIMP он у некоторых пользователей отказывался работать, из за более старых пакетов из debian-multimedia которые были пронумерованы с большим приоритетом. Я debian-multimedia с тех пор не пользуюсь или при крайней необходимости пересобираю их пакеты с правильным указанием версии, соответственно дистрибутиву. Заменил их на MX и Antix репозитарии где всё есть и версии нумеруются правильно.
Ваша задача для начала заменить эти два пакета оригинальными.
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"

k.kirill

Спасибо за ответ!
Да похоже дело в этом. Один раз подключал реп. multimedia и, вероятно оттуда пакеты и поставились.
Как только раскомментировал в /etc/apt/sources.list закомментированный, но ранее использовавшийся multimedia, Wine установился.
Поскольку я новичок, прошу чуть более подробно описать процесс замены пакетов из другого репозитория. 
Debian 11 Cinamon

Aalexeey

Цитата: k.kirill от 23 января 2022, 22:07:02Как только раскомментировал в /etc/apt/sources.list закомментированный, но ранее использовавшийся multimedia, Wine установился.
Установился и ладно, просто будьте осторожны с пакетами из debian-multimedia, почему написал выше.
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"

ek-nfn

Цитата: k.kirill от 23 января 2022, 22:07:02Поскольку я новичок, прошу чуть более подробно описать процесс замены пакетов из другого репозитория.
Вам в первую очередь необходимо почитать про apt-pinning, затем правильно расставить приоритеты репозитариев. debian-multimedia удалять необязательно, некоторый софт из него лучше, чем в штатном репе, просто присвоите ему низший приоритет и установка из него будет возможна лишь силовым способом.
Затем можно провести даунгрейт в stable (замена всех пакетов на версии из стэйбл). далее уже по своему вкусу вручную обновите выборочно из debian-multimedia. Автоматом все будет ставится и обновляться согласно выставленным приоритетам. Вручную установленные из  debian-multimedia будут обновлятся из него
Debian 11 xfce

dzhoser

Цитата: ek-nfn от 26 января 2022, 07:38:20Затем можно провести даунгрейт в stable (замена всех пакетов на версии из стэйбл).
Можно по подробнее очень интересует эта тема, так как насколько мне известно apt не предполагает даунгрэйд. Или имелась в виду замена в /etc/apt/sources.list?
Ubuntu->Linux mint->Astra Linux SE->Debian 11
Для новичков

ek-nfn

Цитата: dzhoser от 26 января 2022, 08:06:19так как насколько мне известно apt не предполагает даунгрэйд. Или имелась в виду замена в /etc/apt/sources.list?

даунгрейд и делается через апт, но сначала необходимо правильно расставить приоритеты репозитариев (можно и отдельных пакетов) в /etc/apt/preferences.  Я сам так избавлялся от пакетов dmo из мультимедиа, когда начались проблемы с зависимостями в ffmpeg
Открыть содержимое (спойлер)
• P >= 1000 - пакет будет установлен, даже если это приведет к понижению версии уже установленного пакета
• 990 <= P < 1000 - пакет будет установлен, если не установлена более новая версия
• 500 <= P < 990 - пакет будет установлен, если нет пакета принадлежащего к целевому выпуску или не установлена более новая версия
• 100 <= P < 500 - пакет будет установлен, если нет кандидатов из других источников или установленного пакета более новой версии
• 0 < P < 100 - пакет будет установлен, если нет других кандидатов и установленных пакетов любой версии
• P < 0 - пакет не будет установлен ни при каких условиях
• P = 0 - неопределенное состояние, не используется
[свернуть]
Debian 11 xfce

k.kirill

ek-nfn, спасибо за разъяснение! Изучу тонкости работы с apt
Debian 11 Cinamon

ferum

Цитата: ek-nfn от 26 января 2022, 08:19:36даунгрейд и делается через апт,
Ой ли, сомневаюсь что вы пробовали это делать. Если понижаемая версия пакета имеет хоть пяток зависимостей , то ни какие приоритеты вам не помогут. Куда проще отключить или заменить ненужные источники, обновить кэш пакетов, скачать хоть через apt хоть через браузер интересующий пакет и силовым способом поставить интересующий пакет через dpkg, естественно он останется не настроенным. За тем просто выполнить apt -f install, зависимости подтянутся даже с понижением версий, всё установится и настроится.
Русские дебианщики против цифрового слабоумия !

ek-nfn

Цитата: ferum от 26 января 2022, 16:18:46Ой ли, сомневаюсь что вы пробовали это делать.
смешно. Я же писал, что делал это, а не пробовал. В 9-й или 10 -й версии, не помню точно.
Это многие делают. Вбейте в гугл даунгрейт дебиан и вникайте
Debian 11 xfce