Автор Тема: Установка свежих версий Libreoffice и Mozilla из репозитория  (Прочитано 49952 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн calambus

  • Почетный пользователь форума
  • Старожил
  • ****
  • Сообщений: 554
  • Ушел из жизни 14.07.2013
John , это из того-же места :
 
   
 
и не надо путать Божий Дар - с яишницей , речь идёт о тестовой версии а не о стабильной ...

Оффлайн kivalrd

  • Пользователь
  • *
  • Сообщений: 26
Друзья, помогите с обновлением iceweasel!
Захожу в Синаптик, обновил источники и отфильтровав по доступным обновлениям, выбираю iceweasel для обновления, но обновляться категорически не хочет. Появляется предупреждение о неких неразрешённых зависимостях.
Картинка
Репозиторий iceweasel в sources.list добавлен, ключ установлен. Всё как бы и правильно, но обновиться не могу, при этом все те указанные зависимости не устанавливаются.
Собственно, вот мой сорс.лист:
# deb cdrom:[Debian GNU/Linux 6.0.7 _Squeeze_ - Official amd64 CD Binary-1 20130223-14:06]/ squeeze main

# deb cdrom:[Debian GNU/Linux 6.0.7 _Squeeze_ - Official amd64 CD Binary-1 20130223-14:06]/ squeeze main

deb http://ftp.ua.debian.org/debian/ squeeze main
deb-src http://ftp.ua.debian.org/debian/ squeeze main

deb http://security.debian.org/ squeeze/updates main
deb-src http://security.debian.org/ squeeze/updates main

# squeeze-updates, previously known as 'volatile'
deb http://ftp.ua.debian.org/debian/ squeeze-updates main
deb-src http://ftp.ua.debian.org/debian/ squeeze-updates main
#
deb http://backports.debian.org/debian-backports squeeze-backports main
deb http://backports.debian.org/debian-backports squeeze-backports main contrib non-free
#
deb http://mozilla.debian.net/ squeeze-backports iceweasel-release

При этом, что ещё хочу добавить, после внесения источника iceweasel в sources.list, в трее появилась иконка о доступных обновлениях, но и они устанавливаться никак не хотят.
Картинка
По умолчанию там отключены галочки во многих чекбоксах, т.е. дополнения, которые конфликтуют или имеют некоторые зависимости. Там где стоят галочки, жму апдейт и ничего не устанавливается, пишет, что применено 0 обновлений...
Я новичок в линуксе, помогите решить эту головоломку...
Добавлю, что ядро обновил до 3.2, может что-то из-за этого не получается?
« Последнее редактирование: 28 Февраль 2013, 20:38:48 от kivalrd »
 

Оффлайн Brainey

  • Ветеран
  • *****
  • Сообщений: 1943
  • Jabber: brainey@jabber.cz
kivalrd,
1) Приведите в порядок sources.list.
2) Поставьте iceweasel командой # aptitude -t squeeze-backports install iceweasel iceweasel-l10n-ru
Конференция форума в jabber: debianforum@conference.jabber.ru | Клуб кедоводов: kde@conference.jabber.ru
 


Оффлайн kivalrd

  • Пользователь
  • *
  • Сообщений: 26
Brainey, вот, изменил. deb-src закомментировал, я так понял, что исходники мне необязательны для моих начинаний, тем самым ускорится обновление источников.
# deb cdrom:[Debian GNU/Linux 6.0.7 _Squeeze_ - Official amd64 CD Binary-1 20130223-14:06]/ squeeze main
# deb cdrom:[Debian GNU/Linux 6.0.7 _Squeeze_ - Official amd64 CD Binary-1 20130223-14:06]/ squeeze main

# Debian repository
deb http://ftp.ru.debian.org/debian/ squeeze main non-free contrib
# deb-src http://ftp.ru.debian.org/debian/ squeeze main non-free conrib

# Security fixes
deb http://security.debian.org/ squeeze/updates main contrib non-free
# deb-src http://security.debian.org/ squeeze/updates main contrib non-free

# squeeze-updates, previously known as 'volatile'
deb http://ftp.debian.org/debian squeeze-updates main contrib non-free
# deb-src http://ftp.debian.org/debian squeeze-updates main contrib non-free

# Debian Backports
deb http://backports.debian.org/debian-backports squeeze-backports main contrib non-free
# deb-src http://backports.debian.org/debian-backports squeeze-backports main contrib non-free

# Iceweasel
deb http://mozilla.debian.net/ squeeze-backports iceweasel-release

Iceweasel пока ещё не устанавливал. Если с sources.list  всё правильно, то сразу же установлю.

Сообщение объединено: 28 Февраль 2013, 22:05:53
В общем, попробовал обновить Iceweasel, а оно мне столько изменений предлагает...
root@robco:/home/vadim# aptitude -t squeeze-backports install iceweasel iceweasel-l10n-ru
Следующие НОВЫЕ пакеты будут установлены:       
  libmozjs19d{a} libnspr4{ab} libnss3{ab} libvpx1{a} libxcb-shm0{a} xulrunner-19.0{a}
Следующие пакеты будут УДАЛЕНЫ:
  libxcb-render-util0{u} xulrunner-1.9.1{u}
Следующие пакеты будут обновлены:
  iceweasel iceweasel-l10n-ru libcairo2 libpixman-1-0 libsqlite3-0
5 пакетов обновлено, 6 установлено новых, 2 пакетов отмечено для удаления, и 62 пакетов не обновлено.
Необходимо получить 20,1 MB/20,4 MB архивов. После распаковки 25,3 MB будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
  libnss3: Конфликтует: libnss3-1d (< 2:3.13.4-2) но установлен 3.12.8-1+squeeze6 и удерживается.
  libnspr4: Конфликтует: libnspr4-0d (< 2:4.9-2~) но установлен 4.8.6-1 и удерживается.
Следующие действия разрешат зависимости:

      Удалить следующие пакеты:                                                                                 
1)      ca-certificates-java                                                                                   
2)      default-jre                                                                                             
3)      default-jre-headless                                                                                   
4)      deskbar-applet                                                                                         
5)      ekiga                                                                                                   
6)      empathy                                                                                                 
7)      epiphany-browser                                                                                       
8)      epiphany-extensions                                                                                     
9)      evolution                                                                                               
10)     evolution-data-server                                                                                   
11)     evolution-exchange                                                                                     
12)     evolution-plugins                                                                                       
13)     evolution-webcal                                                                                       
14)     gnome                                                                                                   
15)     gnome-accessibility                                                                                     
16)     gnome-applets                                                                                           
17)     gnome-control-center                                                                                   
18)     gnome-core                                                                                             
19)     gnome-desktop-environment                                                                               
20)     gnome-office                                                                                           
21)     gnome-panel                                                                                             
22)     gnome-session                                                                                           
23)     hamster-applet                                                                                         
24)     libaccess-bridge-java                                                                                   
25)     libaccess-bridge-java-jni                                                                               
26)     libcamel1.2-14                                                                                         
27)     libebackend1.2-0                                                                                       
28)     libebook1.2-9                                                                                           
29)     libecal1.2-7                                                                                           
30)     libedata-book1.2-2                                                                                     
31)     libedata-cal1.2-7                                                                                       
32)     libedataserver1.2-13                                                                                   
33)     libedataserverui1.2-8                                                                                   
34)     libegroupwise1.2-13                                                                                     
35)     libevolution                                                                                           
36)     libmozjs2d                                                                                             
37)     libnspr4-0d                                                                                             
38)     libnss3-1d                                                                                             
39)     librpm1                                                                                                 
40)     librpmio1                                                                                               
41)     openjdk-6-jre                                                                                           
42)     openjdk-6-jre-headless                                                                                 
43)     openjdk-6-jre-lib                                                                                       
44)     openoffice.org                                                                                         
45)     openoffice.org-base                                                                                     
46)     openoffice.org-base-core                                                                               
47)     openoffice.org-calc                                                                                     
48)     openoffice.org-common                                                                                   
49)     openoffice.org-core                                                                                     
50)     openoffice.org-draw                                                                                     
51)     openoffice.org-emailmerge                                                                               
52)     openoffice.org-evolution                                                                               
53)     openoffice.org-filter-binfilter                                                                         
54)     openoffice.org-filter-mobiledev                                                                         
55)     openoffice.org-gcj                                                                                     
56)     openoffice.org-gnome                                                                                   
57)     openoffice.org-gtk                                                                                     
58)     openoffice.org-help-en-us                                                                               
59)     openoffice.org-help-ru                                                                                 
60)     openoffice.org-impress                                                                                 
61)     openoffice.org-java-common                                                                             
62)     openoffice.org-math                                                                                     
63)     openoffice.org-officebean                                                                               
64)     openoffice.org-report-builder-bin                                                                       
65)     openoffice.org-style-galaxy                                                                             
66)     openoffice.org-style-tango                                                                             
67)     openoffice.org-thesaurus-en-us                                                                         
68)     openoffice.org-thesaurus-ru                                                                             
69)     openoffice.org-writer                                                                                   
70)     python-evolution                                                                                       
71)     python-uno                                                                                             
72)     rpm2cpio                                                                                               

      Оставить следующие зависимости неразрешёнными:                                                           
73)     alacarte рекомендует gnome-panel                                                                       
74)     ca-certificates-java рекомендует libnss3-1d                                                             
75)     capplets-data рекомендует gnome-control-center (>= 1:2.30.1-2)                                         
76)     epiphany-browser-data рекомендует epiphany-browser                                                     
77)     evolution-common рекомендует evolution                                                                 
78)     evolution рекомендует evolution-plugins                                                                 
79)     evolution рекомендует evolution-webcal                                                                 
80)     file-roller рекомендует rpm2cpio                                                                       
81)     gnome-applets рекомендует deskbar-applet                                                               
82)     gnome-panel-data рекомендует gnome-panel                                                               
83)     gnome-panel рекомендует gnome-control-center                                                           
84)     gnome-panel рекомендует evolution-data-server                                                           
85)     gnome-system-tools рекомендует gnome-control-center (>= 1:2.10.1-1)                                     
86)     gnome-desktop-environment рекомендует gnome-accessibility                                               
87)     metacity рекомендует gnome-session | x-session-manager                                                 
88)     mousetweaks рекомендует gnome-control-center                                                           
89)     openoffice.org-evolution рекомендует evolution                                                         
90)     openoffice.org-help-en-us рекомендует openoffice.org-core (> 1:3.2.1) | language-support-translations-en
91)     openoffice.org-help-ru рекомендует openoffice.org-core (> 1:3.2.1) | language-support-translations-ru   
92)     openoffice.org-l10n-be-by рекомендует openoffice.org-core (> 1:3.2.1) | language-support-translations-be
93)     openoffice.org-l10n-bg рекомендует openoffice.org-core (> 1:3.2.1) | language-support-translations-bg   
94)     openoffice.org-l10n-ru рекомендует openoffice.org-core (> 1:3.2.1) | language-support-translations-ru   
95)     openoffice.org-writer рекомендует openoffice.org-filter-binfilter                                       
96)     openoffice.org-writer рекомендует openoffice.org-math                                                   
97)     openoffice.org рекомендует openoffice.org-filter-binfilter                                             


Принять данное решение? [Y/n/q/?]
Я в замешательстве... пока вышел с установки.
« Последнее редактирование: 28 Февраль 2013, 22:05:53 от kivalrd »
 

Оффлайн vladimir_ar

  • Ветеран
  • *****
  • Сообщений: 1624
пока вышел с установки.
А попробовать вариант ответа <n> и посмотреть варианты?
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
 

Оффлайн kivalrd

  • Пользователь
  • *
  • Сообщений: 26
 :) Ну вроде как получше стало:
Принять данное решение? [Y/n/q/?] n
Следующие действия разрешат зависимости:

     Удалить следующие пакеты:                         
1)     iceweasel                                       
2)     iceweasel-l10n-ru                               

     Сохранить для следующих пакетов их текущие версии:
3)     libmozjs19d [Не установлен]                     
4)     libnspr4 [Не установлен]                       
5)     libnss3 [Не установлен]                         
6)     xulrunner-19.0 [Не установлен]   

Принимать решение "уеs"?

А что мне делать с этими обновлениями, которые тоже не устанавливаются? Или попробовать их установить после установки свежей версии iceweasel?
« Последнее редактирование: 28 Февраль 2013, 23:56:51 от kivalrd »
 

Оффлайн vladimir_ar

  • Ветеран
  • *****
  • Сообщений: 1624
Там еще могут быть варианты по <n>. А можно и принять и потом установить то, что нужно.
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
 

Оффлайн kivalrd

  • Пользователь
  • *
  • Сообщений: 26
Если нажать вариант <n>, то опять появляется длинющий список, который сносит всё и вся. Ну, как в первом моём посте.
Попробую всё же установить, а потом доустановить те недостающих 4 компонента.
 

Оффлайн vladimir_ar

  • Ветеран
  • *****
  • Сообщений: 1624
Тогда принимаем этот вариант и далее пробуем ставить то, что нужно. Можно куда-то в текстовик копировать то, что удаляется, чтобы потом вернуться.
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
 

Оффлайн kivalrd

  • Пользователь
  • *
  • Сообщений: 26
Даже не знаю, опять какие-то варианты появились:
     Удалить следующие пакеты:                         
1)     iceweasel                                       
2)     iceweasel-l10n-ru                               

     Сохранить для следующих пакетов их текущие версии:
3)     libmozjs19d [Не установлен]                     
4)     libnspr4 [Не установлен]                       
5)     libnss3 [Не установлен]                         
6)     xulrunner-19.0 [Не установлен]                 



Принять данное решение? [Y/n/q/?] y
Следующие НОВЫЕ пакеты будут установлены:
  libxcb-shm0{a}
Следующие пакеты будут УДАЛЕНЫ:
  iceweasel{a} iceweasel-l10n-ru{a} libxcb-render-util0{u}
Следующие пакеты будут обновлены:
  libcairo2 libpixman-1-0 libsqlite3-0
3 пакетов обновлено, 1 установлено новых, 3 пакетов отмечено для удаления, и 62 пакетов не обновлено.
Необходимо получить 1.814 kB архивов. После распаковки освободится 3.883 k байт.
Хотите продолжить? [Y/n/?]

Жать <y>?


Сообщение объединено: 01 Март 2013, 00:18:43
В общем, нажал yes, iceweasel удалился. Пробую опять выполнить команду на установку, и снова появляется тот длинющий список удаления пакетов. При варианте <n>, появляется вот это:
Принять данное решение? [Y/n/q/?] n
Следующие действия разрешат зависимости:

     Сохранить для следующих пакетов их текущие версии:
1)     iceweasel [Не установлен]                       
2)     iceweasel-l10n-ru [Не установлен]               
3)     libmozjs19d [Не установлен]                     
4)     libnspr4 [Не установлен]                       
5)     libnss3 [Не установлен]                         
6)     xulrunner-19.0 [Не установлен]

Сообщение объединено: 01 Март 2013, 01:15:23
Всё, установил новую версию Iceweasel.
Установил через Синаптик. Все эти компоненты установились вместе с Icewеasel автоматом:
3)     libmozjs19d [Не установлен]                     
4)     libnspr4 [Не установлен]                       
5)     libnss3 [Не установлен]                         
6)     xulrunner-19.0 [Не установлен]

Вопрос решён. Всем спасибо!

Единственное ещё что, кто-нибудь подскажет, есть ли для Iceweasel такая менюшная кнопка, что располагается на панеле вкладок, подобно как в Firefox? Чтобы скрыть панель меню.
Хм, в айсвизел почему-то не работает необходимое Ctrl+Shift+T, как в фоксе. Создаёт новую вкладку, а не восстанавливает закрытую.
« Последнее редактирование: 01 Март 2013, 02:53:21 от kivalrd »
 

Оффлайн Brainey

  • Ветеран
  • *****
  • Сообщений: 1943
  • Jabber: brainey@jabber.cz
Единственное ещё что, кто-нибудь подскажет, есть ли для Iceweasel такая менюшная кнопка, что располагается на панеле вкладок, подобно как в Firefox? Чтобы скрыть панель меню.
Галочку снять надо:
Конференция форума в jabber: debianforum@conference.jabber.ru | Клуб кедоводов: kde@conference.jabber.ru
 

Оффлайн F Nikolaev

  • Активный пользователь
  • **
  • Сообщений: 63
Пытаюсь поставить iceweasel release из http://mozilla.debian.net/ на testing amd64.

Spoiler: ShowHide
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 iceweasel : Зависит: xulrunner-19.0 (>= 19.0-1) но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.


А то у меня в squeeze Iceweasel из бэкпортов свежее, чем в wheezy :)
 

Оффлайн vladimir_ar

  • Ветеран
  • *****
  • Сообщений: 1624
sudo aptitude install -t experimental iceweasel
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
 

Оффлайн F Nikolaev

  • Активный пользователь
  • **
  • Сообщений: 63
В итоге iceweasel удаляет себя полностью. Если попытаться поставить снова, то ругается про неудовлетворенные зависимости  xulrunner и libnss3. Гемор короче...в смысле головная боль.
Да и одно дело ставить из бэкпортов, другое из experimental. Боюсь, как бы это не сказалось на системе целиком в будущем.
Может подскажете, как скоро iceweasel в стандартных репах обновиться до релизной версии? Только после разморозки?
« Последнее редактирование: 01 Март 2013, 19:57:34 от F Nikolaev »
 

Оффлайн easy

  • Активный пользователь
  • **
  • Сообщений: 95
  • Мурманск
libnss3 и libnss3-1d (емнип) надо из sid взять, тогда установится
 

Теги:
 

[РЕШЕНО] Установка пакетов из списка

Автор SuperGeek256

Ответов: 2
Просмотров: 1198
Последний ответ 14 Июль 2014, 15:37:58
от SuperGeek256
Установка windows 10 с ОС Linux Debian10

Автор sergey_klcv

Ответов: 1
Просмотров: 361
Последний ответ 24 Август 2019, 21:57:57
от G_r_i_g_a
Установка debian. Модули ядра не найдены.

Автор valikst

Ответов: 3
Просмотров: 2478
Последний ответ 20 Март 2013, 09:06:06
от fry
Установка ограниченных прав на нового пользователя

Автор madwayz1337

Ответов: 3
Просмотров: 820
Последний ответ 18 Сентябрь 2016, 18:08:19
от alsoijw
Установка 32-битных библиотек для запуска игр

Автор fureimu

Ответов: 10
Просмотров: 15079
Последний ответ 08 Июль 2013, 22:27:33
от ferum