Автор Тема: Звук запускается не с первого раза  (Прочитано 3111 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Изжог

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 120
Чтобы загрузился звук,приходится запускать систему несколько раз подряд,иногда запускается с первого раза,но очень редко. ALSA загружается всегда.
 

Оффлайн Brainey

  • Ветеран
  • *****
  • Сообщений: 1943
  • Jabber: brainey@jabber.cz
Re: Звук запускается не с первого раза
« Ответ #1 : 09 Апрель 2012, 16:59:17 »
Ждем выхлопы dmesg | grep -i fail dmesg | grep -i error и lspci при неработающем звуке.
Конференция форума в jabber: debianforum@conference.jabber.ru | Клуб кедоводов: kde@conference.jabber.ru
 

Оффлайн Изжог

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 120
Re: Звук запускается не с первого раза
« Ответ #2 : 09 Апрель 2012, 17:37:43 »
Spoiler: ShowHide
root@59-63-202-109:/home/izzhog# dmesg | grep -i fail
[    0.625842] PM: Resume from disk failed.
[    2.937362] PM: Resume from disk failed.
[    4.911433] amd64_edac: probe of 0000:00:18.2 failed with error -22
[    5.664393] [drm] nouveau 0000:01:00.0: failed to evaluate _DSM: 5
root@59-63-202-109:/home/izzhog# dmesg | grep -i error
[    2.937360] PM: Error -22 checking image file
[    4.911433] amd64_edac: probe of 0000:00:18.2 failed with error -22
root@59-63-202-109:/home/izzhog# lspci
00:00.0 Host bridge: nVidia Corporation nForce3 250Gb Host Bridge (rev a1)
00:01.0 ISA bridge: nVidia Corporation nForce3 250Gb LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation nForce 250Gb PCI System Management (rev a1)
00:02.0 USB Controller: nVidia Corporation CK8S USB Controller (rev a1)
00:02.1 USB Controller: nVidia Corporation CK8S USB Controller (rev a1)
00:02.2 USB Controller: nVidia Corporation nForce3 EHCI USB 2.0 Controller (rev a2)
00:05.0 Bridge: nVidia Corporation CK8S Ethernet Controller (rev a2)
00:06.0 Multimedia audio controller: nVidia Corporation nForce3 250Gb AC'97 Audio Controller (rev a1)
00:08.0 IDE interface: nVidia Corporation CK8S Parallel ATA Controller (v2.5) (rev a2)
00:0a.0 IDE interface: nVidia Corporation nForce3 Serial ATA Controller (rev a2)
00:0b.0 PCI bridge: nVidia Corporation nForce3 250Gb AGP Host to PCI Bridge (rev a2)
00:0e.0 PCI bridge: nVidia Corporation nForce3 250Gb PCI-to-PCI Bridge (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1)
02:09.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
root@59-63-202-109:/home/izzhog#
 

Оффлайн vladimir_ar

  • Ветеран
  • *****
  • Сообщений: 1624
Re: Звук запускается не с первого раза
« Ответ #3 : 12 Октябрь 2012, 22:13:48 »
Не буду начинать новую тему, потому как проблема такая же. Не всегда с первого раза стартует звук ASUS Xonar DS (PCI) при включении компьютера (при выходе из ждущего / спящего проблемы не наблюдается). Аlsa стартует всегда. На экране при "нестарте" ошибка очень похожа на строку
[    4.911433] amd64_edac: probe of 0000:00:18.2 failed with error -22
Логи выложу завтра, сегодня на работе. Проблема наблюдалась и на squeezy, и, сейчас, на wheezy. Система и там и там AMD64.

При включении при появлении меню GRUB со списком вариантов загрузки, если сразу нажать энтер (не дожидаясь отсчета таймаута) звуковая не стартует практически никогда. При ожидании 5с (время по умолчанию) стартует практически всегда. У себя заметил, что если драйвера на видео (ATI) стоят свободные, то этой проблемы нет. Проблема появляется при установке проприеритарного видео. Как это связано и почему так происходит - не пойму. Может кто подскажет, куда копать? Мои догадки - старт видео (я так понимаю, именно модулей проприеритарного драйвера) какимто образом мешает инициализации звуковой. Почему так думаю - у меня звуковая при инициализации щелкает реле (там они есть) и этот щелчек слышно. И этот момент совпадает визуально с изменением отрисовки экрана (старт драйвера ATI). Может, возможно задержать инициализацию видеодрайвера? И как єто сделать?


Сообщение объединено: 13 Октябрь 2012, 09:27:01
Вот, в логах нашел ситуацию по звуку, когда карта не поднялась (snd-virtuoso)
Spoiler: ShowHide
[spoiler][    4.591460] snd_hda_intel 0000:00:01.1: >irq 53 for MSI/MSI-X
[spoiler][    4.593126] Linux video capture interface: v2.00
[spoiler][    4.614612] uvcvideo: Found UVC 1.00 device <unnamed> (046d:0825)
[spoiler][    4.629396] input: UVC Camera (046d:0825) as /devices/pci0000:00/0000:00:12.2/usb5/5-2/5-2:1.0/input/input7
[spoiler][    4.629538] usbcore: registered new interface driver uvcvideo
[spoiler][    4.629541] USB Video Class driver (1.1.1)
[spoiler][    4.708416] input: HD-Audio Generic HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.1/sound/card2/input8
[spoiler][    4.708902] hda-intel: 0000:01:00.1: Handle VGA-switcheroo audio client
[spoiler][    4.709058] snd_hda_intel 0000:01:00.1: >irq 54 for MSI/MSI-X
[spoiler][    4.723500] input: HDA ATI HDMI HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:02.0/0000:01:00.1/sound/card0/input9
[spoiler][    4.744334] cannot find the slot for index 0 (range 0-3), error: -16
[spoiler][    4.744386] snd_virtuoso: probe of 0000:02:06.0 failed with error -16
[spoiler][    5.698602] 2:3:2: cannot set freq 24000 to ep 0x86
[spoiler][    5.837794] usbcore: registered new interface driver snd-usb-audio


Сообщение объединено: 13 Октябрь 2012, 10:05:13
В общем, кгм, сам по ходу лопухнулся. И знал об этом. По ошбкам из лога полез в нет и нашел то, о чем раньше знал, но забыл. Все банально просто (у меня решилось) - в файл /etc/modprobe.d/alsa.conf вписываем строку (ее не было, а, по хорошему, должна быть):
options snd-virtuoso index=-2Все. Хоть мгновенно грузиться с grud меню, хоть с задержкой - инициализация устойчива. По поводу связи с видео и драйверами АТИ - давно было (обычно на свободных не сижу) - может и попутал уже чего, а специально проверять не хочется (может, буду с тестовой системой какой играться - тогда и понаблюдаю еще).
 :) Сам с собой немного поговорил. Может кому пригодится.
« Последнее редактирование: 13 Октябрь 2012, 10:06:22 от vladimir_ar »
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
 

Оффлайн vladimir_ar

  • Ветеран
  • *****
  • Сообщений: 1624
Re: Звук запускается не с первого раза
« Ответ #4 : 24 Октябрь 2012, 21:04:30 »
Рано написал. Оказалось - случайно повезло. Со временем проблема та-же. Причем, зарыто это ниже уровня старта драйверов (удалил полностью alsa, pulse и так не было) - проблема не исчезла и не изменила своего характера. Звуковая может инициализироваться, а может и нет. Куда копать дальше - пока не пойму. По нету внятных решений по этой проблеме тоже пока не нашел.  :(
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
 

Оффлайн vladimir_ar

  • Ветеран
  • *****
  • Сообщений: 1624
Re: Звук запускается не с первого раза
« Ответ #5 : 27 Октябрь 2012, 09:26:12 »
Перерыл нет по сходным проблемам - получается, проблема в железе. Скорее всего - недостаточная ширина окна инициализации карты в прошивке. Решение - у всех по разному - от игры с прерываниями (в биос - если есть возможность - у меня нет), отключения в биос неиспользуемых устройств (мне не помогло), перепрошивка биос (мне не помогла - зато проверил, как мой биос шьется из под линукса - :) ), до (наиболее часто) замены материнской платы.

Мать менять не хочется, на данный момент помогло снижение частоты процессора (с 3 ГГц до 2,5 ГГц). Пришел к такому выводу потому, что неделю назад стоял проц с 2,9 - проблема случалась намного реже. Сейчас (после снижения частоты проца) инициализируется стабильно (на 3 можно было офигеть с перезагрузками - в лучшем случае 1 из 10).
Находил вариант с успешным решением с правкой исходников прошивки и перекомпиляции - но это для меня темный лес пока.

Все варианты с перестановкой ПО (alsa, pulse) ни к чему не привели, кроме того, что потерял многопоточность по звуку - но это в другой теме.
А здесь, я считаю, все. И у ТС, похоже, та же проблема с железом.
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
 

Оффлайн vladimir_ar

  • Ветеран
  • *****
  • Сообщений: 1624
Re: Звук запускается не с первого раза
« Ответ #6 : 31 Октябрь 2012, 11:29:54 »
Последний штрих. Помог переход на real-time ядро (3.2.0-3-rt-amd64 - The Linux kernel 3.2 and modules for use on PCs with AMD64 or Intel 64 processors. This kernel includes the PREEMPT_RT realtime patch set.). Частоты по процессору вернул штатные (3ГГц), со звуковой проблем более нет. Если ТС еще читает этот топик - может попробовать.
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
 

Теги:
 

В видеопроигрователе звук есть, а в Firefox на youtube нет

Автор IlyaLinux

Ответов: 0
Просмотров: 166
Последний ответ 24 Сентябрь 2020, 12:29:01
от IlyaLinux
[Решено!] Очень тихий звук в KDE. Возможно ли побороть?

Автор Sferg

Ответов: 6
Просмотров: 5102
Последний ответ 19 Сентябрь 2013, 19:32:27
от Sferg
Не работает звук в браузере

Автор Babss88

Ответов: 4
Просмотров: 2415
Последний ответ 13 Март 2011, 19:19:13
от Ghostdmn
как снять звук с колонок?

Автор starlayt

Ответов: 6
Просмотров: 2134
Последний ответ 24 Октябрь 2014, 21:03:55
от starlayt
Очень громкий звук.

Автор proninyaroslav

Ответов: 1
Просмотров: 1488
Последний ответ 29 Апрель 2014, 12:34:44
от qupl