Автор Тема: [РЕШЕНО] Аварийное отключение питания. "Потерял" PS/2 клаву и USB мышь.  (Прочитано 3193 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Nik

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 10
Привет.

Проблема возникла после аварийного выключения питания. Компьютер был в "Suspend mode", когда вырубило электричество в доме... После восстановления питания, загружаю систему, а PS/2 клава не работает. Не работает так же и мышка, подключаемая к USB порту. Подключил USB-шную клавиатуру, работает, отключил и включил мышку, работает... Перезагрузился, снова ничего не работает... Но если "перевключить" USB клаву или мышь когда система уже загружена, то они подхватываются. После "аварии" при первой загрузке произошло сканирование диска на наличие ошибок (файловая система ext4 на LVM) были найдены и удалены какие-то поврежденные ноды... Пока в сети решения не нашел. Хотелось бы понять, что вообще произошло. На линуксе я наверное уже как год, но с такой проблемой не сталкивался и даже не знаю откуда начать.

Заранее благодарен всем, кто откликнется.
« Последнее редактирование: 09 Июля 2012, 10:52:46 от Nik »
ASUS P5W DH Deluxe+Intel Core 2 Duo E6420+4x2048MB DDR2+NVidia GeForce 7100.
Linux 2.6.32-5-amd64 x86_64 GNU/Linux, Debian 6.0.2, Gnome...
 

Оффлайн rayanAyar

В dmesg, syslog какие-нить подозрительные сообщения?

В качестве бреда могу порекомендовать заново установить ядро. Может он модули какие-то потерял. Хотя все равно не понятно где он их потом находит.
Может ещё с udev что-то стряслось.

Бекапа системы не было? Сейчас как раз тот случай когда бы он пригодился.  ;D
 

Оффлайн Nik

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 10
Да, да, да...
есть и в dmesg сообщения типа "failed", syslog не смотрел, а вот udev точно не в порядке, потому как последнее сообщение при загрузке что-то там про него и снова  "failed". Хотел в предыдущем сообщении под спойлером опубликовать вывод dmesg, но почему-то он не полностью публикуется... когда просматриваю сообщение перед публикацией,  всё нормально, но когда нажимаю кнопку "отправить", и смотрю результат, то почему-то обрезано... могу прикрепить файлик, может так... (аттач Boot.txt это он)
а syslog сейчас тоже посмотрю...
А по поводу "бреда", так ничего.. я как раз об этом тоже подумал  :D
спасибо за ответ..

Сообщение объединено: 07 Июля 2012, 09:52:33
Почитал syslog, увидел, что сообщения об ошбках начинаются с момента:

Jul  7 11:21:50 gdm-simple-greeter[2145]: Gtk-WARNING: /scratch/build-area/gtk+2.0-2.20.1/gtk/gtkwidget.c:5628: widget not within a GtkWindow
потом еще парочка...

Jul  7 11:21:50 gdm-simple-greeter[2145]: WARNING: Unable to parse history: (null)   8#012
. . . . . . .
Jul  7 11:27:07 fx-deb gdm-simple-greeter[2145]: WARNING: Failed to send buffer

Переключился на первую консоль, и "О чудо!!"  клава то работает, тогда не всё так страшно, что-то в иксах не так.
Но не могу понять, что делать дальше...

Сообщение объединено: 07 Июля 2012, 12:51:16
Ну вот, уже лучше... в файле Xorg.0.log нашел следующие строчки:
(==) ModulePath set to "/usr/lib/xorg/modules"
(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
(WW) Disabling Keyboard0
(WW) Disabling Mouse0

дальше что пока не знаю, посмотрю /usr/lib/xorg/modules   ...

Сообщение объединено: 07 Июля 2012, 13:19:53
Запустил поиск фразы "AllowEmptyInput" по всей фс  :( жду... ведь это же где-то устанавливается.

Сообщение объединено: 07 Июля 2012, 14:19:18
попробовал при загрузке выбрать режим востановления и запустил иксы от рута, иксы запустились сразу без gdm3 и клава с мышью работают... идем искать туда :)
« Последнее редактирование: 07 Июля 2012, 14:19:18 от Nik »
ASUS P5W DH Deluxe+Intel Core 2 Duo E6420+4x2048MB DDR2+NVidia GeForce 7100.
Linux 2.6.32-5-amd64 x86_64 GNU/Linux, Debian 6.0.2, Gnome...
 

Оффлайн Alexey_F

  • Местный житель
  • ***
  • Сообщений: 153
AllowEmptyInput  - это параметр иксов, поиск не поможет  :)

man xorg.conf
Spoiler: ShowHide

Option "AllowEmptyInput" "boolean"
              If enabled, don't add the standard keyboard and  mouse  drivers,
              if  there  are  no input devices in the config file.  Enabled by
              default if AutoAddDevices and AutoEnableDevices is enabled, oth?
              erwise  disabled.   If  AllowEmptyInput is on, devices using the
              kbd, mouse or vmmouse driver are ignored.


Проверь содержимое xorg.conf
 

Оффлайн Nik

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 10
xorg.conf был у меня сохранен, скопировал старый не помогло...
Решил проблему переустановкой ядра. Теперь надо UPS починить  :)
И научиться бэкапы делать  :)
Спасибо всем, кто откликнулся.
« Последнее редактирование: 09 Июля 2012, 10:55:38 от Nik »
ASUS P5W DH Deluxe+Intel Core 2 Duo E6420+4x2048MB DDR2+NVidia GeForce 7100.
Linux 2.6.32-5-amd64 x86_64 GNU/Linux, Debian 6.0.2, Gnome...
 

Оффлайн rayanAyar

вырубило электричество
Пока гром не грянет...
Теперь надо UPS починить  :)
И научиться бэкапы делать  :)
...бекапы делать не научатся.
 

Теги:
 

[Решено]Не могу настроить Tablet Hardware Buttons на ThinkPad X61 tablet

Автор svl

Ответов: 1
Просмотров: 3205
Последний ответ 07 Февраля 2015, 20:21:53
от svl
Debian 10. Подключение hdd после установки системы [РЕШЕНО - проблема с ОЗУ]

Автор cleaner83

Ответов: 6
Просмотров: 1144
Последний ответ 09 Ноября 2019, 13:45:16
от cleaner83
не запускается power.sh при подключении и отключении блока питания ноутбука

Автор vavun

Ответов: 2
Просмотров: 1939
Последний ответ 18 Октября 2011, 00:25:54
от vavun
[Решено] (EE) No devices detected. NVIDIA GeForce 710M Linux Debian

Автор Wanderer

Ответов: 26
Просмотров: 19760
Последний ответ 13 Ноября 2013, 12:57:56
от Wanderer
[Решено] iMX6. Debian 7. Помогите оживить тачскрин

Автор qqqqq2

Ответов: 1
Просмотров: 1634
Последний ответ 17 Января 2017, 09:57:31
от qqqqq2