Автор Тема: [Решено] Не работают "fn" keys на ASUS Q400A, с ядрами wheezy-backports  (Прочитано 3791 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Aalexeey

По этой https://debianforum.ru/index.php?topic=2209.15 причине очень ждал новых ядер от Debian. После установки 3.10-0.bpo.3-amd64 и 3.9-0.bpo.1-amd64 проблему с сетевой картой Atheros AR8151 решил но теперь в "Управлении питанием" не регулируется яркость экрана, не работает включение или выключение по "fn" bluetooth, яркости экрана и яркость подсветки клавиятуры. В /etc/modules добавлял asus-nb-wmi по совету найденному где-то в сети, не помогло. Вот это:
asus-kbd-backlight_0.1~ppa5_amd64.deb
asus-wmi-dkms_0.2_all.deb
asus-wmi-dkms_999.01_all.deb
тоже не помогает.
« Последнее редактирование: 14 Июль 2015, 22:33:11 от Aalexeey »
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
 

Оффлайн vladimir_ar

Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
 

Оффлайн Aalexeey

А работало?
С оффициальным ядром работает всё кроме "fn" клавиш подсветки клавиатуры, и графически по нажатию на экран регулировка выскакивает, но регулирую её файлом /sys/class/leds/asus::kbd_backlight/brightness. К остальному особых претензий не было, старые драйвера сетевух в текущем ядре только работают не правильно (они там всё ещё Atheros, а дожны быть Qualcomm Atheros). Непонимаю зачем держать с стабильном ядре глючные старые драйвера?
« Последнее редактирование: 16 Октябрь 2013, 10:09:18 от Aalexeey »
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
 

Оффлайн Aalexeey

Ядро 3.2.46-1+deb7u1 (stable)
root@asus-q400a:/home/xxxxxx# modprobe asus-nb-wmi
root@asus-q400a:/home/xxxxxx#

Ядра 3.9.6-1~bro70+1, 3.10.5-1~bro70+1, 3.11.10-1~bpo70+1, 3.12.6-2~bpo70+1 (wheezy-backports)
root@asus-q400a:/home/xxxxxx# modprobe asus-nb-wmi
ERROR: could not insert 'asus_nb_wmi': Invalid argument
root@asus-q400a:/home/xxxxxx#
« Последнее редактирование: 02 Февраль 2014, 23:53:35 от Aalexeey »
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
 

Оффлайн Aalexeey

С ядрами 3.11..../3.12....~bpo70+1 не работает всё кроме яркости экрана и громкости. Кроме того на всех ядрах из бэкпортов на всех компах недоступен режим conservative для CPU, а это очень важно для ноутбука например (cpufreq-info выдаёт что доступны только powersave и performance), решается только блокированием загрузки драйвера intel-pstate (GRUB_CMDLINE_LINUX_DEFAULT="quiet intel_pstate=disable").
« Последнее редактирование: 02 Февраль 2014, 23:49:56 от Aalexeey »
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
 

Оффлайн Aalexeey

Не прошло и два года как проблему удалось побороть :D. Был случайно найден и скачен весь "набор" ядра 3.14.15-2~bpo70+1_amd64, отсюда:
http://snapshot.debian.org/ (в поисковиках не обнаруживается!)
После установки из папки /lib/modules/3.14-0.bpo.2-amd64/kernel/drivers/platform/x86 был копирован файл asus-wmi.ko в папку /lib/modules/3.14-0.bpo.2-amd64/updates/dkms. После перезагрузки asus-nb-wmi.ko начал подхватываться. На ноутбуке и на ASRock Z77Extreme6 это единственное ядро которое грузится без error'ов, единственное определяющее всё в /dev/ во время загрузки, так что от себя его рекомендую.
На машинах 32bit уже не всё так гладко (на старых машинах иногда необходимо блокировать загрузку каких то модулей, например у меня на ASUS P4P800E-Delux в "blacklist" отключенный в BIOS гейм порт snd_mpu401_uart и snd_mpu401), решён и этот bug: https://debianforum.ru/index.php?topic=6968.
Осталась одна несущественная проблема, во время нажатия на fn клавиши на некоторые действия на экран вместо иконок выскакивают гдето 5x5mm пустые квадраты. Может кто подскажет как это исправить, где и как это GUI берётся.

P.S. Судя по тому что у меня ни одна машина не работает нормально с ядром 3.16, пилить его будут долго и нудно и не факт что оно вообще сможет претендовать на stable.
Про GUI от fn клавиш всё ещё актуально если кто знает где оно лежит отпишитесь пожалуйста.
« Последнее редактирование: 22 Май 2016, 21:08:28 от Aalexeey »
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
 

Теги:
 

Wheezy и Epson Perfection V600

Автор Paul

Ответов: 6
Просмотров: 2336
Последний ответ 07 Апрель 2013, 22:08:55
от Paul
[РЕШЕНО] debian 7.7 hp1018

Автор pa_

Ответов: 6
Просмотров: 3069
Последний ответ 09 Ноябрь 2014, 19:13:18
от pa_
[Решено] не работает wifi плата DWA-510

Автор Екатерина

Ответов: 5
Просмотров: 1658
Последний ответ 10 Июль 2018, 15:59:14
от ogost
[Решено] Принтер Brother HL-2275DW не печатает

Автор vicmic

Ответов: 9
Просмотров: 2703
Последний ответ 20 Февраль 2016, 07:07:53
от vicmic
Presario 2100 wifi driver [РЕШЕНО]

Автор extrafant

Ответов: 11
Просмотров: 2492
Последний ответ 17 Декабрь 2013, 07:15:12
от qupl