Автор Тема: [Решено] Не работает встроенная звуковая карта на плате Gigabyte H81M-S2PV  (Прочитано 9612 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ivor

  • Новичок форума
  • Topic Author
  • Сообщений: 8
  • Jabber: ivor@jabber.ru
Здравствуйте, прошу помочь настроить звук в Debian 7.2 (в других ОС на этой материнке звук работает)
Материнская плата:                Gigabyte H81M-S2PV
Интерфейс звуковой карты:  Realtec ALC887

uname -a
Spoiler: ShowHide
Linux debian 3.2.0-4-amd64 #1 SMP Debian 3.2.51-1 x86_64 GNU/Linux

lspci -v
Spoiler: ShowHide
00:03.0 Audio device: Intel Corporation Haswell HD Audio Controller (rev 06)
   Subsystem: Intel Corporation Device 2010
   Flags: bus master, fast devsel, latency 0, IRQ 16
   Memory at f0514000 (64-bit, non-prefetchable) [size=16K]
   Capabilities: <access denied>
   Kernel driver in use: snd_hda_intel
00:1b.0 Audio device: Intel Corporation Lynx Point High Definition Audio Controller (rev 05)
   Subsystem: Giga-byte Technology Device a002
   Flags: bus master, fast devsel, latency 0, IRQ 45
   Memory at f0510000 (64-bit, non-prefetchable) [size=16K]
   Capabilities: <access denied>
   Kernel driver in use: snd_hda_intel

aplay -l
Spoiler: ShowHide
**** List of PLAYBACK Hardware Devices ****
card 1: PCH [HDA Intel PCH], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 1: ALC887-VD Digital [ALC887-VD Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

sudo alsactl init
Spoiler: ShowHide
Found hardware: "HDA-Intel" "Intel ID 2807" "HDA:80862807,80860101,00100000" "0x8086" "0x2010"
Hardware is initialized using a generic method

cat /proc/asound/card0/codec#0 | grep Codec
Spoiler: ShowHide
Codec: Intel ID 2807


В журнале имеются ошибки:
sudo less /var/log/syslog | grep sound
Spoiler: ShowHide
Dec 17 00:55:01 debian kernel: [    2.666445] snd_hda_intel 0000:00:03.0: irq 45 for MSI/MSI-X
Dec 17 00:55:01 debian kernel: [    2.666455] snd_hda_intel 0000:00:03.0: setting latency timer to 64
Dec 17 00:55:01 debian kernel: [    5.683838] hda-intel: azx_get_response timeout, switching to polling mode: last cmd=0x000f0000
Dec 17 00:55:01 debian kernel: [    6.685531] hda-intel: No response from codec, disabling MSI: last cmd=0x000f0000
Dec 17 00:55:01 debian kernel: [    7.687199] hda-intel: Codec #0 probe error; disabling it...
Dec 17 00:55:01 debian kernel: [    8.704848] hda_intel: azx_get_response timeout, switching to single_cmd mode: last cmd=0x000f0001
Dec 17 00:55:01 debian kernel: [    8.709566] snd_hda_intel 0000:00:1b.0: irq 45 for MSI/MSI-X
Dec 17 00:55:01 debian kernel: [    8.709604] snd_hda_intel 0000:00:1b.0: setting latency timer to 64
Dec 17 00:55:01 debian kernel: [    8.815930] hda_codec: num_steps = 0 for NID=0xc (ctl = Front Playback Volume)

sudo less /var/log/syslog | grep audio
Spoiler: ShowHide
Dec 17 00:54:21 debian pulseaudio[3489]: [pulseaudio] module-alsa-card.c: Failed to find a working profile.
Dec 17 00:54:21 debian pulseaudio[3489]: [pulseaudio] module.c: Failed to load module "module-alsa-card" (argument: "device_id="0" name="pci-0000_00_03.0" card_name="alsa_card.pci-0000_00_03.0" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes card_properties="module-udev-detect.discovered=1""): initialization failed.
Dec 17 00:55:02 debian pulseaudio[3391]: [pulseaudio] module-alsa-card.c: Failed to find a working profile.
Dec 17 00:55:02 debian pulseaudio[3391]: [pulseaudio] module.c: Failed to load module "module-alsa-card" (argument: "device_id="0" name="pci-0000_00_03.0" card_name="alsa_card.pci-0000_00_03.0" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes card_properties="module-udev-detect.discovered=1""): initialization failed.
Dec 17 00:55:02 debian pulseaudio[3391]: [pulseaudio] alsa-util.c: Unable to load mixer: Недопустимый аргумент
« Последнее редактирование: 23 Декабрь 2013, 00:15:59 от ivor »
 


Оффлайн gardarea51

  • Старожил
  • ****
  • Сообщений: 764
  • Jabber: gard.area51@jabber.ru
А банально в alsamixer все нужные каналы включены?

Можете еще посмотреть здесь: http://www.alsa-project.org/main/index.php/Matrix:Module-hda-intel
И здесь: https://help.ubuntu.com/community/HdaIntelSoundHowto
Возможно что-то получится. На крайний случай можно попробовать скачать последнюю альсу и скомпилировать ее.
« Последнее редактирование: 17 Декабрь 2013, 22:10:03 от gardarea51 »
 

Оффлайн ferum

  • Ветеран
  • *****
  • Сообщений: 3627
  • Buster TDE & KDE
/etc/modprobe.d/alsa-base.conf
options snd-hda-intel model=auto
Русские дебианщики против цифрового слабоумия !
 

Оффлайн ivor

  • Новичок форума
  • Topic Author
  • Сообщений: 8
  • Jabber: ivor@jabber.ru
Спасибо за отклики!

to gardarea51:
 в alsamixer всего один канал - Master - включен. На экране F6 выбор такой:
- (default)
0 HDA Intel
1 HDA Intel PCH

при выборе 0 пишет "This sound device does not have any controls."
при выборе 1 выходит из микшера.

По поводу ссылки http://www.alsa-project.org/main/index.php/Matrix:Module-hda-intel
команда sudo modinfo snd выводит следующий текст:
Spoiler: ShowHide
filename:       /lib/modules/3.2.0-4-amd64/kernel/sound/core/snd.ko
alias:          char-major-116-*
license:        GPL
description:    Advanced Linux Sound Architecture driver for soundcards.
author:         Jaroslav Kysela <perex@perex.cz>
license:        GPL
description:    Jack detection support for ALSA
author:         Mark Brown <broonie@opensource.wolfsonmicro.com>
depends:        soundcore
intree:         Y
vermagic:       3.2.0-4-amd64 SMP mod_unload modversions
parm:           slots:Module names assigned to the slots. (array of charp)
parm:           major:Major # for sound driver. (int)
parm:           cards_limit:Count of auto-loadable soundcards. (int)
, что, как я понял, означает, что модуль звука в системе присутствует и не нужно пересобирать ядро с нужным драйвером
Попробую что-то сделать по второй ссылке.

to ferum:
Пробовал, причем не только с model=auto, но и с model=generic, model=ALC887. Эффект не наблюдался. Может, надо было все остальные опции комментарить? Или как-то по-особому применить настройки, помимо alsa restart и перезагрузки.
 

Оффлайн ferum

  • Ветеран
  • *****
  • Сообщений: 3627
  • Buster TDE & KDE
Мы пока гадаем конечно
Русские дебианщики против цифрового слабоумия !
 

Оффлайн ivor

  • Новичок форума
  • Topic Author
  • Сообщений: 8
  • Jabber: ivor@jabber.ru
десктоп - Gnome3
В параметрах системы вкладка "Звук" показывает только одно устройство:
 

Оффлайн ivor

  • Новичок форума
  • Topic Author
  • Сообщений: 8
  • Jabber: ivor@jabber.ru
Проблема решена так:
- сборка alsa-driver, alsa-firmware, alsa-lib, alsa-utils из исходников;
- подключение к ядру модуля snd-hda-intel.

Теперь звук есть. Были хрипы, но прекратились после удаления pulseaudio и выбора в качестве устройства вывода карты HDA Intel.

Спасибо откликнувшимся, тему можно закрывать.
« Последнее редактирование: 20 Декабрь 2013, 17:18:14 от ivor »
 

Оффлайн gardarea51

  • Старожил
  • ****
  • Сообщений: 764
  • Jabber: gard.area51@jabber.ru
Рад за вас, что все получилось. :)
 

Оффлайн qupl

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 4943
  • memento mori
  • Jabber: qupl@jabber.ru
ivor, пометьте тему решенной, исправив заголовок первого сообщения.

Оффлайн Danvol

  • Новичок форума
  • Сообщений: 2
Проблема решена так:
- сборка alsa-driver, alsa-firmware, alsa-lib, alsa-utils из исходников;
- подключение к ядру модуля snd-hda-intel.

Теперь звук есть. Были хрипы, но прекратились после удаления pulseaudio и выбора в качестве устройства вывода карты HDA Intel.

Здравствуйте! У меня та же проблема со звуком. Материнка Gigabyte GA-P85-D3.  Можно как-то подробней описать ваше решение проблемы?
« Последнее редактирование: 03 Январь 2014, 01:53:23 от Danvol »
 

Оффлайн ivor

  • Новичок форума
  • Topic Author
  • Сообщений: 8
  • Jabber: ivor@jabber.ru
Danvol, попробуй не так, как я а в другой последовательности:
1. Сразу стоит удалить pulseaudio:
"sudo apt-get remove pulseaudio"

2. Зайди в "Приложения"->"Системные"->"Параметры"->"Параметры системы"->"Звук" и установи в качестве устройства вывода вместо pulseaudio твою звуковую карту HDA Intel.

3.Если для аудио/видео используется vlc, так что в нём также нужно установить воспроизведение через ALSA, а не через pulseaudio.

4. Пробуй. Если не заработает - напиши.

 

Теги:
 

Установка xbmc 11 на debian stable[РЕШЕНО]

Автор olegod

Ответов: 12
Просмотров: 5086
Последний ответ 21 Март 2012, 20:58:11
от olegod
[Решено] pulseaudio+alsa: слышно поток с микрофона в наушниках

Автор Defman

Ответов: 4
Просмотров: 2003
Последний ответ 24 Август 2014, 22:48:05
от Defman
[Решено] Установка драйвера ATI на Debian 7

Автор Ituriel

Ответов: 0
Просмотров: 13235
Последний ответ 04 Август 2013, 16:48:16
от Ituriel
[РЕШЕНО] Alsa + гудение при включении Headphone Mic

Автор Krishnoved

Ответов: 1
Просмотров: 851
Последний ответ 10 Январь 2017, 15:59:53
от Krishnoved
[РЕШЕНО] Установка nvidia-driver на Debian Stretch (340.x.) 9800GT

Автор midnight_walker

Ответов: 4
Просмотров: 5986
Последний ответ 26 Сентябрь 2017, 10:40:16
от polzovatel