Автор Тема: optirun не работает  (Прочитано 2963 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн barnaul

optirun не работает
« : 03 Июля 2014, 14:22:29 »
Ситуация такая, как только зайду в систему загружу искы. запускаю optirun , работает..
после подключение к сети,долгодумая optirun выдает :
[ 1310.493943] [WARN]Received Interrupt signal.
[ 1310.494026] [WARN]Could not read data! Error: Bad file descriptor

и

^C[ 1314.923710] [WARN]Received Interrupt signal.
[ 1314.923846] [WARN]Could not read data! Error: Bad file descriptor
[ 1314.923870] [ERROR]Failed to retrieve LibraryPath setting.
в чем проблема подскажите , второй день не могу настроить нормально

ставил по - https://wiki.debian.org/ru/Bumblebee

ядро 3.2 . linix-headers установлены. во время установки bumblebee-nvidia установились 319 дрова....
« Последнее редактирование: 03 Июля 2014, 15:52:29 от barnaul »
 

Оффлайн barnaul

как правильно сконфигурировать Xorg.conf
« Ответ #1 : 03 Июля 2014, 14:26:49 »
установил базовую систему, wheezy.
Поставил xorg, bumblebee.
пытаюсь скопировать сконфигурированный Xorg.conf.new в /etc/X11/xorg.conf..
после этого иксы не запускаются..
если точнее они запускаются, попереключавшись между консолями и иксами можно заметить как иксы "мелькают"..
но в основе получается черный экран((((((
подскажите кто знает что и как сделать, какие логи нужно скинуть) куда копать?
 


Оффлайн barnaul

Re: как правильно сконфигурировать Xorg.conf
« Ответ #3 : 03 Июля 2014, 15:18:24 »
да openbox.
иксы замечательно запускаются, если не создавать /etx/X11/xorg.conf.
интересно почему с xorg.conf не рабоатет...
думаю, может если настроить xorg.conf то и bumblebee будет работать)
« Последнее редактирование: 03 Июля 2014, 15:22:54 от barnaul »
 

Оффлайн barnaul

Re: optirun не работает
« Ответ #4 : 03 Июля 2014, 18:03:07 »
что никто не знает?
 

Оффлайн vladimir_ar

Re: как правильно сконфигурировать Xorg.conf
« Ответ #5 : 03 Июля 2014, 22:24:56 »
/etx/X11/xorg.conf уже давно свободными дровами не используется.
Его создают проприеритарные драйвера (например, АТИ).
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
 

Оффлайн Defman

Re: как правильно сконфигурировать Xorg.conf
« Ответ #6 : 03 Июля 2014, 23:20:18 »
Или проприетарные дрова нвидии.
:)
 

Оффлайн ihammers

Re: как правильно сконфигурировать Xorg.conf
« Ответ #7 : 04 Июля 2014, 04:52:59 »
Поставил xorg, bumblebee.
...
А bumblebee настроили? Какие используете драйвера?
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290
 

Оффлайн ihammers

Re: optirun не работает
« Ответ #8 : 04 Июля 2014, 04:57:15 »
Какая у вас видеокарта? Правильно ли настроили bumblebee?
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290
 

Оффлайн barnaul

Re: optirun не работает
« Ответ #9 : 06 Июля 2014, 15:11:33 »
Какая у вас видеокарта? Правильно ли настроили bumblebee?
Geforce GT 630M
 

Оффлайн barnaul

Re: как правильно сконфигурировать Xorg.conf
« Ответ #10 : 06 Июля 2014, 15:13:11 »
ставил xorg.
bumblebee,bumblebee-nvidia,primus, с ними автоматом поставились 319 дровишки..
пытался 304 ставить там с зависимости "геморой"
 

Оффлайн ihammers

Re: optirun не работает
« Ответ #11 : 07 Июля 2014, 05:33:33 »
В настройках bumblebee используется KernelDriver=Nvidia или Nvidia-current?

PS: недавно настраивали ноут с GT 630M, никаких проблем с bumblebee замечено не было. Сегодня попытаюсь спросить о работе системы.
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290
 

Оффлайн dvano

Re: optirun не работает
« Ответ #12 : 08 Июля 2014, 19:00:56 »
Цитировать
ядро 3.2 . linix-headers установлены. во время установки bumblebee-nvidia установились 319 дрова....
???
У меня автоматом ставятся драйвера 304. Как так?
Устанавливаю так:
apt-get install bumblebee-nvidia primus primus-libs:i386
 

Оффлайн ihammers

Re: optirun не работает
« Ответ #13 : 08 Июля 2014, 19:24:37 »
У меня автоматом ставятся драйвера 304. Как так?
Подключите репозиторий backports и выполните следующую команду:
apt-get install -t wheezy-backports bumblebee-nvidia primus primus-libs:i386
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290
 

Теги:
     

    Optirun totem- воспроизводит видео рывками.

    Автор Serko

    Ответов: 1
    Просмотров: 1148
    Последний ответ 26 Марта 2018, 07:37:32
    от qupl