Автор Тема: [Решено] packages kept back  (Прочитано 6018 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Sergei_Alekseev

[Решено] packages kept back
« : 17 Января 2015, 17:48:57 »
root@debian:~# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  gstreamer1.0-libav gstreamer1.0-plugins-base gstreamer1.0-plugins-good
  gstreamer1.0-plugins-ugly gstreamer1.0-x libgstreamer-plugins-base1.0-0
  libtevent0
0 upgraded, 0 newly installed, 0 to remove and 7 not upgraded.
root@debian:~#
Как посмотреть из-за чего они kept back?
Итд.
« Последнее редактирование: 18 Января 2015, 17:34:05 от qupl »
 

Оффлайн qupl

Re: packages kept back
« Ответ #1 : 17 Января 2015, 18:10:48 »
Sergei_Alekseev, apt how-to пункт 3.5.

Оффлайн Sergei_Alekseev

Re: packages kept back
« Ответ #2 : 17 Января 2015, 19:13:39 »
qupl,
root@debian:~# apt-get -u install gstreamer1.0-libav
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gstreamer1.0-libav : Depends: libgstreamer-plugins-base1.0-0 (>= 1.2.2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
root@debian:~# apt-get -u install gstreamer1.0-libav libgstreamer-plugins-base1.0-0
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgstreamer-plugins-base1.0-0 : Depends: liborc-0.4-0 (>= 1:0.4.18) but 1:0.4.16-2 is to be installed
E: Unable to correct problems, you have held broken packages.
root@debian:~#
 

Оффлайн qupl

Re: packages kept back
« Ответ #3 : 17 Января 2015, 19:31:19 »
Sergei_Alekseev, покажите sources.list. И update до всего этого делали?

Оффлайн Sergei_Alekseev

Re: packages kept back
« Ответ #4 : 17 Января 2015, 21:12:28 »
qupl,
deb-src http://ftp.fi.debian.org/debian/ wheezy contrib non-free main
deb http://ftp.fi.debian.org/debian/ wheezy main contrib non-free
deb http://ftp.fi.debian.org/debian/ wheezy-updates contrib non-free main
deb-src http://ftp.fi.debian.org/debian/ wheezy-updates contrib non-free main
deb http://security.debian.org/ wheezy/updates main contrib non-free
deb-src http://security.debian.org/ wheezy/updates main contrib non-free
deb http://ftp.fi.debian.org/debian/ wheezy-proposed-updates non-free contrib main
deb-src http://ftp.fi.debian.org/debian/ wheezy-proposed-updates non-free contrib main
deb http://www.deb-multimedia.org wheezy main non-free
deb http://mirrors.kernel.org/debian wheezy-backports main contrib
deb http://ftp.fi.debian.org/debian wheezy-backports main contrib non-free
update делал, конечно.
 

Оффлайн qupl

Re: packages kept back
« Ответ #5 : 17 Января 2015, 22:29:07 »
Sergei_Alekseev, я бы попробовал оставить первые две строчки, остальные временно закомментировать и обновиться.

Оффлайн Sergei_Alekseev

Re: packages kept back
« Ответ #6 : 18 Января 2015, 01:29:31 »
qupl,
эээ, kept back пакеты из backports.
 

Оффлайн qupl

Re: packages kept back
« Ответ #7 : 18 Января 2015, 12:20:39 »
Sergei_Alekseev, тогда все логично, их версии более новые чем есть в стабильных ветках.

Оффлайн toZen

Re: packages kept back
« Ответ #8 : 18 Января 2015, 12:39:15 »
Может есть смысл посмотреть в сторону:
sudo aptitude upgrade --full-resolve??
| Arch Linux Openbox | Crunchbang ++ |
 

Оффлайн Sergei_Alekseev

Re: packages kept back
« Ответ #9 : 18 Января 2015, 13:19:54 »
qupl, не совсем понял.
kept back пакеты из бэкпортс и обновлённые версии из бэкпортс, почему не обновляются?

Сообщение объединено: 18 Января 2015, 13:23:37
toZen,
root@debian:~# aptitude upgrade --full-resolve
The following packages will be REMOVED: 
  eom-common{u} libexempi3{u} libgadu3{u} libgnutls28{u} libmatedesktop{u}
  libmatewnck{u} libmatewnck-common{u} libmozjs24d{u} xulrunner-24.0{u}
The following packages will be upgraded:
  gstreamer1.0-libav gstreamer1.0-plugins-base{b}
  gstreamer1.0-plugins-good{b} gstreamer1.0-plugins-ugly{b} gstreamer1.0-x
  libgstreamer-plugins-base1.0-0{b} libtevent0{b}
7 packages upgraded, 0 newly installed, 9 to remove and 0 not upgraded.
Need to get 5,958 kB of archives. After unpacking 61.1 MB will be freed.
The following packages have unmet dependencies:
 gstreamer1.0-plugins-ugly : Depends: liborc-0.4-0 (>= 1:0.4.18) but 1:0.4.16-2 is installed.
 gstreamer1.0-plugins-good : Depends: liborc-0.4-0 (>= 1:0.4.18) but 1:0.4.16-2 is installed.
 libgstreamer-plugins-base1.0-0 : Depends: liborc-0.4-0 (>= 1:0.4.18) but 1:0.4.16-2 is installed.
 libtevent0 : Depends: libtalloc2 (>= 2.1.0) but 2.0.7+git20120207-1 is installed.
 gstreamer1.0-plugins-base : Depends: liborc-0.4-0 (>= 1:0.4.18) but 1:0.4.16-2 is installed.
The following actions will resolve these dependencies:

      Remove the following packages:                       
1)      bluefish                                           
2)      gecko-mediaplayer                                 
3)      gnome-mplayer                                     
4)      gstreamer1.0-libav                                 
5)      gstreamer1.0-plugins-base                         
6)      gstreamer1.0-plugins-good                         
7)      gstreamer1.0-plugins-ugly                         
8)      gstreamer1.0-pulseaudio                           
9)      gstreamer1.0-x                                     
10)     gvfs-backends                                     
11)     libgnomevfs2-extra                                 
12)     libgstreamer-plugins-base1.0-0                     
13)     libldb1                                           
14)     libsmbclient                                       
15)     libsmbclient-dev                                   
16)     libtevent0                                         
17)     mencoder                                           
18)     mplayer                                           
19)     mplayer2                                           
20)     samba-dsdb-modules                                 
21)     samba-libs                                         
22)     smplayer                                           
23)     smplayer-themes                                   
24)     smplayer-translations                             
25)     smplayer2                                         
26)     smtube                                             
27)     vlc                                               
28)     vlc-nox                                           
29)     vlc-plugin-notify                                 
30)     vlc-plugin-pulse                                   
31)     vlc-plugin-sdl                                     

      Leave the following dependencies unresolved:         
32)     libgnomevfs2-0 recommends libgnomevfs2-extra       
33)     libgnome2-vfs-perl recommends libgnomevfs2-extra   
34)     pcmanfm recommends gvfs-backends                   
35)     gstreamer1.0-plugins-good recommends gstreamer1.0-x
36)     mate-bluetooth recommends gvfs-backends           


Accept this solution? [Y/n/q/?]
« Последнее редактирование: 18 Января 2015, 13:23:37 от Sergei_Alekseev »
 

Оффлайн qupl

Re: packages kept back
« Ответ #10 : 18 Января 2015, 14:58:06 »
Sergei_Alekseev, так и ставьте их тогда с параметром -t=wheezy-backports.

Оффлайн toZen

Re: packages kept back
« Ответ #11 : 18 Января 2015, 15:43:26 »
root@debian:~# aptitude upgrade --full-resolve
The following packages will be REMOVED:
....
Ясно, в данном случае - это только усугубит ситуацию удалением большого числа пакетов.
| Arch Linux Openbox | Crunchbang ++ |
 

Оффлайн Sergei_Alekseev

Re: packages kept back
« Ответ #12 : 18 Января 2015, 16:23:06 »
qupl,
сэнкс, решено
root@debian:~# apt-get install --reinstall -t=wheezy-backports gstreamer1.0-libav gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-ugly gstreamer1.0-x libgstreamer-plugins-base1.0-0 libtevent0
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  liborc-0.4-0 liborc-0.4-0:i386 liborc-0.4-dev libtalloc2
Suggested packages:
  gstreamer-codec-install gnome-codec-install liborc-0.4-doc
The following packages will be upgraded:
  gstreamer1.0-libav gstreamer1.0-plugins-base gstreamer1.0-plugins-good
  gstreamer1.0-plugins-ugly gstreamer1.0-x libgstreamer-plugins-base1.0-0
  liborc-0.4-0 liborc-0.4-0:i386 liborc-0.4-dev libtalloc2 libtevent0
11 upgraded, 0 newly installed, 0 to remove and 279 not upgraded.
Need to get 6,669 kB of archives.
After this operation, 938 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://mirrors.kernel.org/debian/ wheezy-backports/main liborc-0.4-dev amd64 1:0.4.19-1~bpo70+1 [287 kB]
Get:2 http://mirrors.kernel.org/debian/ wheezy-backports/main liborc-0.4-0 i386 1:0.4.19-1~bpo70+1 [200 kB]
Get:3 http://mirrors.kernel.org/debian/ wheezy-backports/main liborc-0.4-0 amd64 1:0.4.19-1~bpo70+1 [192 kB]
Get:4 http://mirrors.kernel.org/debian/ wheezy-backports/main libgstreamer-plugins-base1.0-0 amd64 1.2.4-1~bpo70+1 [1,224 kB]
Get:5 http://mirrors.kernel.org/debian/ wheezy-backports/main libtalloc2 amd64 2.1.1-1~bpo70+1 [32.2 kB]
Get:6 http://mirrors.kernel.org/debian/ wheezy-backports/main libtevent0 amd64 0.9.21-1~bpo70+1 [30.4 kB]
Get:7 http://mirrors.kernel.org/debian/ wheezy-backports/main gstreamer1.0-libav amd64 1.2.4-1~bpo70+1 [166 kB]
Get:8 http://mirrors.kernel.org/debian/ wheezy-backports/main gstreamer1.0-plugins-base amd64 1.2.4-1~bpo70+1 [1,219 kB]
Get:9 http://mirrors.kernel.org/debian/ wheezy-backports/main gstreamer1.0-plugins-good amd64 1.2.4-1~bpo70+1 [2,170 kB]
Get:10 http://mirrors.kernel.org/debian/ wheezy-backports/main gstreamer1.0-plugins-ugly amd64 1.2.4-1~bpo70+1 [360 kB]
Get:11 http://mirrors.kernel.org/debian/ wheezy-backports/main gstreamer1.0-x amd64 1.2.4-1~bpo70+1 [789 kB]
Fetched 6,669 kB in 17s (374 kB/s)                                             
Reading changelogs... Done
(Reading database ... 305338 files and directories currently installed.)
Preparing to replace liborc-0.4-dev 1:0.4.16-2 (using .../liborc-0.4-dev_1%3a0.4.19-1~bpo70+1_amd64.deb) ...
Unpacking replacement liborc-0.4-dev ...
Preparing to replace liborc-0.4-0:amd64 1:0.4.16-2 (using .../liborc-0.4-0_1%3a0.4.19-1~bpo70+1_amd64.deb) ...
De-configuring liborc-0.4-0:i386 ...
Unpacking replacement liborc-0.4-0:amd64 ...
Preparing to replace liborc-0.4-0:i386 1:0.4.16-2 (using .../liborc-0.4-0_1%3a0.4.19-1~bpo70+1_i386.deb) ...
Unpacking replacement liborc-0.4-0:i386 ...
Setting up liborc-0.4-0:amd64 (1:0.4.19-1~bpo70+1) ...
Setting up liborc-0.4-0:i386 (1:0.4.19-1~bpo70+1) ...
(Reading database ... 305352 files and directories currently installed.)
Preparing to replace libgstreamer-plugins-base1.0-0:amd64 1.0.8-1~bpo70+1 (using .../libgstreamer-plugins-base1.0-0_1.2.4-1~bpo70+1_amd64.deb) ...
Unpacking replacement libgstreamer-plugins-base1.0-0:amd64 ...
Preparing to replace libtalloc2:amd64 2.0.7+git20120207-1 (using .../libtalloc2_2.1.1-1~bpo70+1_amd64.deb) ...
Unpacking replacement libtalloc2:amd64 ...
Preparing to replace libtevent0:amd64 0.9.19-1~bpo70+1 (using .../libtevent0_0.9.21-1~bpo70+1_amd64.deb) ...
Unpacking replacement libtevent0:amd64 ...
Preparing to replace gstreamer1.0-libav:amd64 1.0.8-1~bpo70+1 (using .../gstreamer1.0-libav_1.2.4-1~bpo70+1_amd64.deb) ...
Unpacking replacement gstreamer1.0-libav:amd64 ...
Preparing to replace gstreamer1.0-plugins-base:amd64 1.0.8-1~bpo70+1 (using .../gstreamer1.0-plugins-base_1.2.4-1~bpo70+1_amd64.deb) ...
Unpacking replacement gstreamer1.0-plugins-base:amd64 ...
Preparing to replace gstreamer1.0-plugins-good:amd64 1.0.8-1~bpo70+1 (using .../gstreamer1.0-plugins-good_1.2.4-1~bpo70+1_amd64.deb) ...
Unpacking replacement gstreamer1.0-plugins-good:amd64 ...
Preparing to replace gstreamer1.0-plugins-ugly:amd64 1.0.8-1~bpo70+1 (using .../gstreamer1.0-plugins-ugly_1.2.4-1~bpo70+1_amd64.deb) ...
Unpacking replacement gstreamer1.0-plugins-ugly:amd64 ...
Preparing to replace gstreamer1.0-x:amd64 1.0.8-1~bpo70+1 (using .../gstreamer1.0-x_1.2.4-1~bpo70+1_amd64.deb) ...
Unpacking replacement gstreamer1.0-x:amd64 ...
Setting up liborc-0.4-dev (1:0.4.19-1~bpo70+1) ...
Setting up libgstreamer-plugins-base1.0-0:amd64 (1.2.4-1~bpo70+1) ...
Setting up libtalloc2:amd64 (2.1.1-1~bpo70+1) ...
Setting up libtevent0:amd64 (0.9.21-1~bpo70+1) ...
Setting up gstreamer1.0-libav:amd64 (1.2.4-1~bpo70+1) ...
Setting up gstreamer1.0-plugins-base:amd64 (1.2.4-1~bpo70+1) ...
Setting up gstreamer1.0-plugins-good:amd64 (1.2.4-1~bpo70+1) ...
Setting up gstreamer1.0-plugins-ugly:amd64 (1.2.4-1~bpo70+1) ...
Setting up gstreamer1.0-x:amd64 (1.2.4-1~bpo70+1) ...
root@debian:~# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@debian:~#
 

Теги:
     

    [Решено] Права доступа после к папке того, как пользователь удален.

    Автор sx88

    Ответов: 1
    Просмотров: 1508
    Последний ответ 02 Сентября 2013, 19:04:46
    от qupl
    [Решено] Установка драйверов с диска

    Автор vasiliy_b

    Ответов: 6
    Просмотров: 4117
    Последний ответ 08 Января 2014, 01:00:54
    от vasiliy_b
    (РЕШЕНО) проблема обновлений debian ( apt-get update )

    Автор sergej.biz

    Ответов: 2
    Просмотров: 5594
    Последний ответ 03 Июня 2015, 18:08:01
    от sergej.biz
    [РЕШЕНО] apparmor.service loaded failed LSB: AppArmor initializat

    Автор hathory

    Ответов: 1
    Просмотров: 2117
    Последний ответ 19 Декабря 2016, 16:17:20
    от hathory
    (Решено)Не могу создать нового пользователя с зашифрованной домашней папкой

    Автор Максимыч

    Ответов: 5
    Просмотров: 2728
    Последний ответ 22 Декабря 2011, 10:00:45
    от Максимыч