Установка ffmpeg на debian

Автор ilyha123, 15 марта 2015, 12:32:24

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

ilyha123

Привет форумчане, нужна помощь установка ffmpeg php на VPS с debian 7.2

Прописываю команду :
apt-get install ffmpeg
после :
apt-get install php5-ffmpeg

Ни первая,не вторая не работают, получаю : E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Буду благодарен за помощь по данному вопросу.

  •  

qupl


ilyha123

Вот что выдало :

root@ilyharoot:~# cat /etc/apt/sources.list
deb http://ftp.debian.org/debian wheezy main contrib non-free
deb http://security.debian.org wheezy/updates main contrib non-free

deb http://www.debian-multimedia.org squeeze main non-free

deb http://www.deb-multimedia.org wheezy main non-free
deb-src http://www.deb-multimedia.org wheezy main non-free
deb http://packages.dotdeb.org squeeze all

root@ilyharoot:~# uname -a
  •  

Leo

#3
Где вывод команды uname -a ?

Сообщение объединено: 15 Март 2015, 14:37:04

Используйте, пожалуйста, теги для оформления вывода команд.

ogost

1. смешаны ветки squeeze и wheezy
2. указаны сторонние репозитории

ilyha123

#5
Leo,  Вот вывод команды  uname -a :  Linux ilyharoot 2.6.32-042stab104.1 #1 SMP Thu Jan 29 12:58:41 MSK 2015 x86_64 GNU/Linux


ogost, как мне это можно исправить ? можете написать рабочий вариант пожалуйста.
  •  

qupl

ilyha123, не совпадает информация в первом сообщении и в последнем.Ядро от squeeze. И система что-то среднее между 6и 7 Debian.  Я бы обновился до wheezy.
Источники сделать такими.

deb http://ftp.debian.org/debian wheezy main contrib non-free
deb http://security.debian.org wheezy/updates main contrib non-free

#deb http://www.deb-multimedia.org wheezy main non-free
#deb-src http://www.deb-multimedia.org wheezy main non-free

aptitude update && aptitude dist-upgrade

ilyha123

qupl, источники сменил.
При выполнении : aptitude update && aptitude dist-upgrade  выдает : -bash: aptitude: command not found
  •  

yoric

  •  

qupl

ilyha123, от root или через sudo нужно запускать.

ilyha123

yoric, так сработало,но с ошибкой.
qupl, да,я от root заходил.

Вот логи выполнения этой команды :
root@ilyharoot:~# apt-get update && apt-get dist-upgrade
Hit http://ftp.debian.org wheezy Release.gpg
Hit http://ftp.debian.org wheezy Release
Hit http://ftp.debian.org wheezy/main amd64 Packages
Hit http://ftp.debian.org wheezy/contrib amd64 Packages
Hit http://download.ispsystem.com stable-wheezy Release.gpg
Hit http://ftp.debian.org wheezy/non-free amd64 Packages
Hit http://ftp.debian.org wheezy/main i386 Packages
Hit http://download.ispsystem.com stable-wheezy Release
Hit http://ftp.debian.org wheezy/contrib i386 Packages
Hit http://ftp.debian.org wheezy/non-free i386 Packages
Hit http://ftp.debian.org wheezy/contrib Translation-en
Hit http://download.ispsystem.com stable-wheezy/main amd64 Packages
Hit http://ftp.debian.org wheezy/main Translation-en
Hit http://ftp.debian.org wheezy/non-free Translation-en
Hit http://download.ispsystem.com stable-wheezy/main i386 Packages
Hit http://security.debian.org wheezy/updates Release.gpg
Ign http://download.ispsystem.com stable-wheezy/main Translation-en
Hit http://security.debian.org wheezy/updates Release
Hit http://security.debian.org wheezy/updates/main amd64 Packages
Hit http://security.debian.org wheezy/updates/contrib amd64 Packages
Hit http://security.debian.org wheezy/updates/non-free amd64 Packages
Hit http://security.debian.org wheezy/updates/main i386 Packages
Hit http://security.debian.org wheezy/updates/contrib i386 Packages
Hit http://security.debian.org wheezy/updates/non-free i386 Packages
Hit http://security.debian.org wheezy/updates/contrib Translation-en
Hit http://security.debian.org wheezy/updates/main Translation-en
Hit http://security.debian.org wheezy/updates/non-free Translation-en
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
libpulse-dev : Depends: libpulse0 (= 2.0-6.1) but it is not installed
libpulse-mainloop-glib0 : Depends: libpulse0 (= 2.0-6.1) but it is not installed
libsdl1.2debian : Depends: libpulse0 (>= 0.99.1) but it is not installed
E: Unmet dependencies. Try using -f.
  •  

yoric

Сначала:
apt-get install libpulse0
Потом
apt-get dist-upgrade
  •  

ilyha123

yoric, вот что получилось при apt-get install libpulse0

root@ilyharoot:~# apt-get install libpulse0
Reading package lists... Done
Building dependency tree
Reading state information... Done
Suggested packages:
  pulseaudio
The following NEW packages will be installed:
  libpulse0
0 upgraded, 1 newly installed, 0 to remove and 92 not upgraded.
193 not fully installed or removed.
Need to get 0 B/232 kB of archives.
After this operation, 777 kB of additional disk space will be used.
(Reading database ... 47536 files and directories currently installed.)
Unpacking libpulse0:amd64 (from .../libpulse0_2.0-6.1_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libpulse0_2.0-6.1_amd64.deb (--unpack):
trying to overwrite shared '/etc/pulse/client.conf', which is different from other instances of package libpulse0:amd64
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/libpulse0_2.0-6.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
  •  

yoric

Я б для начала раскомментировал-таки в sources.list
deb http://www.deb-multimedia.org wheezy main non-free
А то может установленные оттуда пакеты мешают обновиться.

Потом
apt-get update
apt-get upgrade


Если благополучно, то
reboot
apt-get dist-upgrade


Если не получится, тогда уж Try using -f.
apt-get -f dist-upgrade

Главное не забывать после изменения sources.list делать
apt-get update

ilyha123

Благодарю всех кто помогал )
В общем мне помогло удаление из каталога  /var/lib/dpkg/info файлов на которых ругается при установке.
Вопрос решен, всем спасибо.

  •