Автор Тема: Debian периодически зависает и не реагирует на перезагрузку  (Прочитано 3010 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн BRONNER

  • Новичок форума
  • Topic Author
  • Сообщений: 4
Проблема появилась не сразу, т.е некоторое время назад после первой установки дебиан(больше года), всё работало стабильно, но потом начались проблемы(несколько месяцев назад). На протяжении всего этого времени никакого нового оборудования не подключалось, компьютер стоял в уголке без монитора и иксов, с одним лишь доступом по ssh и выполнял роль тестовой площадки для веб php и java se приложений.

Зависать система стала с разной периодичностью от нескольких часов до нескольких дней при одних и тех же условиях и в основном без нагрузки, т.е ничего нового в этот момент не запускалось. После нажатия на кнопку ресет порой ПК перезагружается нормально, а бывает что ничего не происходит. Иногда после этого бывало и так, что даже если выключить из сети, а потом запустить, ничего не происходило, только после N включений система запускалась и работала дальше, как ни в чем ни бывало.


За период проведения тестов было
1. Поменян БП дабы исключить вариант с проседанием напряжения
2. Подключалась дискретная видеокарта (мало ли)
3. Был заменён HDD и всё установлено с нуля и дебиан 8 (stable)
4. Была установлена другая сетевая карта
5. Вместо стандартного, собиралось последнее стабильное ядро с kernel.org на момент Debian 7.6 (вроде 3.16) а после обновления до Jessie было установлено 4.1 из репы
6. Загрузка с acpi=off
7. Несколько раз были отчаянные попытки погонять memtest, как выборочно(3-5,7), так и целиком, но это ничего не дало, хотя я продолжаю периодически его запускать и на момент написания этого текста он работает уже около суток.

В результате всех этих действий система продолжает падать вот с таким вот сообщением. Вроде оно даже перестало меняться.

Проблема в том, что я не пойму в чем проблема. Может здесь знает кто?

Spoiler: ShowHide

[32236.979874] perf interrupt took too long (2504 > 2500), lowering kernel.perf_event_max_sample_rate to 50000
[33073.353897] Process accounting resumed
[33710.436091] general protection fault: 0000 [#1] SMP
[33710.436275] Modules linked in: nfsd auth_rpcgss oid_registry nfs_acl nfs lockd grace fscache sunrpc powernow_k8 radeon ppdev kvm ttm pcspkr drm_kms_helper serio_raw evdev drm sp5100_tco edac_mce_amd k8temp edac_core acpi_cpufreq parport_pc i2c_algo_bit shpchp processor thermal_sys 8250_fintek parport i2c_piix4 asus_atk0110 wmi button netconsole configfs autofs4 ext4 crc16 mbcache jbd2 sg sd_mod ata_generic ohci_pci via_rhine mii pata_atiixp ahci libahci ohci_hcd ehci_pci ehci_hcd usbcore usb_common libata scsi_mod
[33710.438148] CPU: 0 PID: 3344 Comm: java Not tainted 4.1.0-0.bpo.1-amd64 #1 Debian 4.1.3-1~bpo8+1
[33710.438336] Hardware name: System manufacturer System Product Name/M4A785-M, BIOS 1101    11/20/2012
[33710.438528] task: ffff8800cb0f73f0 ti: ffff8800ca7ac000 task.ti: ffff8800ca7ac000
[33710.438685] RIP: 0010:[<ffffffff810d6f06>]  [<ffffffff810d6f06>] run_timer_softirq+0xd6/0x330
[33710.438886] RSP: 0000:ffff88019fc03ec8  EFLAGS: 00010002
[33710.439004] RAX: ffffffff81abf9f0 RBX: 0000000000000570 RCX: fffeffff81abfa28
[33710.439161] RDX: ffffffff81abfa28 RSI: ffff88019fc03ee8 RDI: ffffffff81abf480
[33710.439310] RBP: ffffffff8180c0c8 R08: 0000000000006850 R09: 0000000000000000
[33710.439459] R10: 0000000000000003 R11: 0000000000000020 R12: 0000000000000000
[33710.439608] R13: ffffffff81abf480 R14: 0000000000000082 R15: 0000000000000001
[33710.439773] FS:  00007f41072e8700(0000) GS:ffff88019fc00000(0000) knlGS:0000000000000000
[33710.439945] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[33710.440030] Stack:
[33710.440030]  ffffffff81ac04b8 ffffffff81ac08b8 ffffffff81ac0cb8 ffffffff81ac10b8
[33710.440030]  ffff88019fc03ee8 ffff88019fc03ee8 0000000000000096 0000000000000001
[33710.440030]  ffffffff8180c0c8 0000000000000000 0000000000000001 0000000000000082
[33710.440030] Call Trace:
[33710.440030]  <IRQ>
[33710.440030]  [<ffffffff810772da>] ? __do_softirq+0x11a/0x290
[33710.440030]  [<ffffffff810775c5>] ? irq_exit+0x95/0xa0
[33710.440030]  [<ffffffff8157c16e>] ? smp_apic_timer_interrupt+0x3e/0x50
[33710.440030]  [<ffffffff8157a23e>] ? apic_timer_interrupt+0x6e/0x80
[33710.440030]  <EOI>
[33710.440030] Code: 0f 1f 44 00 00 0f b6 d8 85 db 0f 84 f8 01 00 00 48 c1 e3 04 49 83 45 10 01 48 8d 74 24 20 49 8d 44 1d 00 48 8b 48 38 48 8d 50 38 <48> 89 71 08 48 89 4c 24 20 48 8b 48 40 48 89 4c 24 28 48 89 31 [33710.440030] RIP  [<ffffffff810d6f06>] run_timer_softirq+0xd6/0x330
[33710.440030]  RSP <ffff88019fc03ec8>
« Последнее редактирование: 31 Август 2015, 17:11:39 от BRONNER »
 

Оффлайн ferum

  • Ветеран
  • *****
  • Сообщений: 3595
  • Buster TDE & KDE
Проверьте состояние конденсаторов на материнской плате, приходилось ремонтировать компьютер под виндой но проблемы были идентичные загрузка -висяк -ребут по кругу. Даже визуальным осмотром были выявлены три припухших конденсатора, после их замены проблема ушла окончательно и бесповоротно.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн ogost

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 3088
  • Linux Registered User #547151
солидарен с ferum, проблема похоже что "железная".


Оффлайн BRONNER

  • Новичок форума
  • Topic Author
  • Сообщений: 4
Проверьте состояние конденсаторов на материнской плате, приходилось ремонтировать компьютер под виндой но проблемы были идентичные загрузка -висяк -ребут по кругу. Даже визуальным осмотром были выявлены три припухших конденсатора, после их замены проблема ушла окончательно и бесповоротно.

На вид они, как новенькие. Да и плата вроде не такая старая для таких проблем. Она же работает какое-то время (от суток до недель) разве такое может быть при неисправных конденсаторах?

В любом случае, погоняю еще сутки Memtest, а завтра тогда попробую ёмкости замерять, мало ли.
 

Оффлайн Упрямый

  • Пользователь
  • *
  • Сообщений: 43
  • ~$ Linux forever!
Проблема однозначно в оборудовании, и конденсаторы могут быть и не причём, и на внешний вид всё бывает чисто и красиво. Вероятнее всего конечно материнка, и малый срок эксплуатации не чего не значит. Возможна и другая причина: память,видео, и малая программная нагрузка то же не чего не значит.
 

Оффлайн BRONNER

  • Новичок форума
  • Topic Author
  • Сообщений: 4
Проблема однозначно в оборудовании, и конденсаторы могут быть и не причём, и на внешний вид всё бывает чисто и красиво. Вероятнее всего конечно материнка, и малый срок эксплуатации не чего не значит. Возможна и другая причина: память,видео, и малая программная нагрузка то же не чего не значит.

В общем не знаю, как это объясняется, после всех этих бессмысленных тестов я просто включил всё как было и оно до сих пор работает, как ни в чем ни бывало.
 

Оффлайн ferum

  • Ветеран
  • *****
  • Сообщений: 3595
  • Buster TDE & KDE
Не далее чем вчера была та же история, ни с тог ни с сего мой debian 7 завис наглухо После выключения кнопкой компьютер не захотел запускаться совсем, то есть как бы вечный ребут не доходя даже до загрузчика. Уже думал нести в ремонт но по скольку у нас только на днях включили отопление а до этого дома было немного сыро решил сделать компьютеру продувку пылесосом ( хотя пыли там было совсем чуть чуть) и частичную расборку сборку видюшка, оперативка, DVB карта. Помогло.
Русские дебианщики против цифрового слабоумия !
 

Теги:
 

Debian 8.3 i386, SAMBA

Автор Spirit412

Ответов: 0
Просмотров: 1232
Последний ответ 19 Март 2016, 14:57:26
от Spirit412
[Решено] Установка Debian

Автор ZanO

Ответов: 17
Просмотров: 3637
Последний ответ 18 Февраль 2012, 12:03:14
от ZanO
Переход на Debian: вопросы

Автор Owenel

Ответов: 3
Просмотров: 949
Последний ответ 13 Март 2017, 19:14:36
от amd_amd
Как установить MonoDevelop 3.0.3.2 в Debian

Автор Mixim

Ответов: 1
Просмотров: 2034
Последний ответ 12 Декабрь 2012, 23:36:10
от Alexey_F
rc.local не работает на Debian 9.3 после смены systemd to sysvinit

Автор lenin

Ответов: 1
Просмотров: 926
Последний ответ 21 Март 2018, 20:10:57
от ZEN