debian.org / О Debian Где взять Debian Поддержка Уголок разработчика Новости Wiki

Автор Тема: Нет модема в /dev  (Прочитано 265 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ethanol

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 130
Нет модема в /dev
« : 02 Апрель 2019, 22:58:54 »
Здравствуйте.
Хотел повторить эксперимент описанный в статье.
Конкретно сейчас хочу подключить модем ZTE MF652, чтобы в последующем он принимал SMS-сообщения. Подключил модем к компу, который выполняет роль сервера с Debian 9.8. 32-бита i386.

Не устанавливал как в вышеназванной статье usb-redirector, т.к. в статье описывается создание всей системы на виртуальной машине. У меня же всё на отдельном компьютере. Правильно ли я сделал, что не установил usb-redirector?

Установил usb-modeswitch usb-modeswitch-data wvdial
Вывод ls /dev:
Spoiler: ShowHide
employee@debian-wifi:/tmp/usb-redirector-linux-i386$ ls /dev
agpgart          full          memory_bandwidth    sda1      tty11  tty26  tty40  tty55    ttyS2    vcsa4
autofs           fuse          mqueue              sda2      tty12  tty27  tty41  tty56    ttyS3    vcsa5
block            hidraw0       net                 sda5      tty13  tty28  tty42  tty57    uhid     vcsa6
bsg              hidraw1       network_latency     sda6      tty14  tty29  tty43  tty58    uinput   vga_arbiter
btrfs-control    hidraw2       network_throughput  serial    tty15  tty3   tty44  tty59    urandom  vhci
bus              hpet          null                sg0       tty16  tty30  tty45  tty6     vcs      vhost-net
char             hugepages     parport0            shm       tty17  tty31  tty46  tty60    vcs1     watchdog
console          hwrng         port                snapshot  tty18  tty32  tty47  tty61    vcs2     watchdog0
core             initctl       ppp                 snd       tty19  tty33  tty48  tty62    vcs3     zero
cpu              input         psaux               stderr    tty2   tty34  tty49  tty63    vcs4
cpu_dma_latency  kmsg          ptmx                stdin     tty20  tty35  tty5   tty7     vcs5
cuse             log           pts                 stdout    tty21  tty36  tty50  tty8     vcs6
disk             loop-control  random              tty       tty22  tty37  tty51  tty9     vcsa
dri              mapper        rtc                 tty0      tty23  tty38  tty52  ttyACM0  vcsa1
fb0              mcelog        rtc0                tty1      tty24  tty39  tty53  ttyS0    vcsa2
fd               mem           sda                 tty10     tty25  tty4   tty54  ttyS1    vcsa3


Вывод lsusb:
Spoiler: ShowHide
employee@debian-wifi:/tmp/usb-redirector-linux-i386$ lsusb
Bus 002 Device 006: ID 19d2:1217 ZTE WCDMA Technologies MSM MF652
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 0000:0538 
Bus 001 Device 002: ID 2a7a:938f 
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub



То есть во многих статьях модем переводится в режим модема с помощью minicom, где указывается устройство /dev/ttyUSB0. Почему у меня нет /dev/ttyUSB0?
Заметил также, что при подключении модема появляется ttyACM0, но почему-то в настройках minicom его указать не получается из-за последующих ошибок.
 

Оффлайн moreplavatel

  • Местный житель
  • ***
  • Сообщений: 215
  • Jabber: moreplavatel@404.city
Re: Нет модема в /dev
« Ответ #1 : 02 Апрель 2019, 23:07:09 »
Скорее всего этот ttyACM0
 

Оффлайн Ethanol

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 130
Re: Нет модема в /dev
« Ответ #2 : 02 Апрель 2019, 23:13:35 »
Скорее всего этот ttyACM0
Я пробовал указывать его в minicom. То есть в "Настройка последовательного порта" указал /dev/ttyACM0. Затем вышел и ввёл ati0. Я так понимаю, он должен был какую-то информацию по устройству вывести, как в статье, но мне выдал ERROR.

Может я чего то не понимаю. Прошу тогда объяснить)
 

Оффлайн Ethanol

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 130
Re: Нет модема в /dev
« Ответ #3 : 02 Апрель 2019, 23:15:52 »
Скорее всего этот ttyACM0
Я пробовал указывать его в minicom. То есть в "Настройка последовательного порта" указал /dev/ttyACM0. Затем вышел и ввёл ati0. Я так понимаю, он должен был какую-то информацию по устройству вывести, как в статье, но мне выдал ERROR.

Может я чего то не понимаю. Прошу тогда объяснить)
p.s. Но огонёк на модеме зелёненький)
 

Оффлайн moreplavatel

  • Местный житель
  • ***
  • Сообщений: 215
  • Jabber: moreplavatel@404.city
Re: Нет модема в /dev
« Ответ #4 : 02 Апрель 2019, 23:16:53 »
Цитировать
ati0
просто введи AT, должен ответить OK.
 

Оффлайн Ethanol

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 130
Re: Нет модема в /dev
« Ответ #5 : 02 Апрель 2019, 23:32:34 »
Цитировать
ati0
просто введи AT, должен ответить OK.

Да, действительно. Выводит ОК.
То есть я и команды могу отправлять на модем на ttyACM0? А команды отправляются в консоли minicom?
 

Оффлайн moreplavatel

  • Местный житель
  • ***
  • Сообщений: 215
  • Jabber: moreplavatel@404.city
Re: Нет модема в /dev
« Ответ #6 : 02 Апрель 2019, 23:38:24 »
Да. Ищи в сети AT команды ZTE MF652.
Большинство команд начинаются с AT^. AT^команда.
« Последнее редактирование: 02 Апрель 2019, 23:40:02 от moreplavatel »
 
Пользователи, которые поблагодарили этот пост: Ethanol

Оффлайн Ethanol

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 130
Re: Нет модема в /dev
« Ответ #7 : 02 Апрель 2019, 23:43:46 »
Большое вам спасибо!

p.s. Если что, команда AT%USBMODEM=0 переводит в режим только модем.
 

Оффлайн moreplavatel

  • Местный житель
  • ***
  • Сообщений: 215
  • Jabber: moreplavatel@404.city
Re: Нет модема в /dev
« Ответ #8 : 02 Апрель 2019, 23:44:35 »
Цитировать
Затем вышел и ввёл ati0. Я так понимаю, он должен был какую-то информацию по устройству вывести, как в статье, но мне выдал ERROR.
ERROR  неправильная AT команда.
 
Пользователи, которые поблагодарили этот пост: Ethanol

Оффлайн moreplavatel

  • Местный житель
  • ***
  • Сообщений: 215
  • Jabber: moreplavatel@404.city
Re: Нет модема в /dev
« Ответ #9 : 02 Апрель 2019, 23:50:40 »
Если что, команда AT%USBMODEM=0 переводит в режим только модем
Ну вроде как да.
 

Русскоязычное сообщество Debian GNU/Linux

Re: Нет модема в /dev
« Ответ #9 : 02 Апрель 2019, 23:50:40 »


 

Подключение модема от МТС

Автор Xboxgame

Ответов: 18
Просмотров: 2642
Последний ответ 22 Октябрь 2015, 19:01:55
от priemhik