debian.org / О Debian Где взять Debian Поддержка Уголок разработчика Новости Wiki

Автор Тема: Debian + Quake II (QuDos)  (Прочитано 2037 раз)

0 Пользователей и 1 Гость просматривают эту тему.

cinyflo

  • Гость
Debian + Quake II (QuDos)
« : 29 Ноябрь 2012, 23:27:00 »
Перешёл с Убунты на Дебиан, из всего что мне нужно не могу запустить лишь одну игру - Quake 2.
Тема на форуме - http://forum.ubuntu.ru/index.php?topic=146763.0
От современных игр тошнит, но без старых дума и кваки не могу.
Посоветовали ставить не deb из репозитория, а собрать из исходников.
Но ведь как я понял дело в зависимостях, а зависимости такими же и останутся при ручной сборке.
Вот что (не) получилось. make:
cc -c -I/usr/include -I/usr/include -DGAME_NAME='"gamei386.so"' -DQUDOS_VERSION='"QuDos v0.40.3.3"' -O3 -ffast-math -funroll-loops -fomit-frame-pointer -fexpensive-optimizations -falign-loops=2 -falign-jumps=2 -falign-functions=2 -fno-strict-aliasing -DWITH_ACEBOT -DDATADIR='"/usr/share/games/quake2"' -DGAME_MOD -DJoystick -DLIBDIR='"/usr/lib/qudos"' -DQMAX -DREDBLUE -DRETEX -fPIC -DREF_GL -o QuDos-build/ref_glx/gl_blooms.o src/ref_gl/gl_blooms.c
In file included from src/ref_gl/gl_blooms.c:22:0:
src/ref_gl/gl_local.h:28:20: fatal error: GL/glx.h: Нет такого файла или каталога
compilation terminated.
make: *** [QuDos-build/ref_glx/gl_blooms.o] Ошибка 1
Не получается. Наверное из-за того, что не установился пакет libsdl1.2-dev.
arcturus@debian:~/downloads/qudos-master$ sudo aptitude install libjpeg62-dev libvorbis-dev libxxf86dga-dev libxxf86vm-dev
Ни одного пакета не будет установлено, обновлено или удалено.
0 пакетов обновлено, 0 установлено новых, 0 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 0 B архивов. После распаковки 0 B будет занято.
                                                 
arcturus@debian:~/downloads/qudos-master$ sudo aptitude install libsdl1.2-dev
Следующие НОВЫЕ пакеты будут установлены:       
  libasound2-dev{a} libavahi-client-dev{a} libavahi-common-dev{a}
  libcaca-dev{a} libdirectfb-dev{a} libdirectfb-extra{a} libgl1-mesa-dev{a}
  libglu1-mesa-dev{a} libjpeg8-dev{ab} libpulse-dev{a}
  libpulse-mainloop-glib0{a} libsdl1.2-dev libslang2-dev{a} libts-dev{a}
  mesa-common-dev{a}
0 пакетов обновлено, 15 установлено новых, 0 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 4 429 kB/4 452 kB архивов. После распаковки 14,3 MB будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
 libjpeg8-dev : Конфликтует: libjpeg62-dev но установлен 6b1-3
Следующие действия разрешат зависимости:

     Удалить следующие пакеты:
1)     libjpeg62-dev         



Принять данное решение? [Y/n/q/?]
Следующие НОВЫЕ пакеты будут установлены:
  libasound2-dev{a} libavahi-client-dev{a} libavahi-common-dev{a}
  libcaca-dev{a} libdirectfb-dev{a} libdirectfb-extra{a} libgl1-mesa-dev{a}
  libglu1-mesa-dev{a} libjpeg8-dev{a} libpulse-dev{a}
  libpulse-mainloop-glib0{a} libsdl1.2-dev libslang2-dev{a} libts-dev{a}
  mesa-common-dev{a}
Следующие пакеты будут УДАЛЕНЫ:
  libjpeg62-dev{a}
0 пакетов обновлено, 15 установлено новых, 1 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 4 429 kB/4 452 kB архивов. После распаковки 13,9 MB будет занято.
Хотите продолжить? [Y/n/?] n
Прервать.
arcturus@debian:~/downloads/qudos-master$
 

Оффлайн Malaheenee

  • Ветеран
  • *****
  • Сообщений: 2565
  • Учтите, мы можем дать и вредный совет.
Re: Debian + Quake II (QuDos)
« Ответ #1 : 30 Ноябрь 2012, 07:03:24 »
Нет, это из-за libgl1-mesa-glx (вероятно, т.к. dev-версии все равно нет).
И да, какой дистрибутив-то? Stable, testing? Или намешали всего, а теперь не устанавливается?
Debian Sid: XFCE x 1, openbox x 2.
Все мы где-то, когда-то и в чем-то были новичками.
 

cinyflo

  • Гость
Re: Debian + Quake II (QuDos)
« Ответ #2 : 30 Ноябрь 2012, 09:38:47 »
Wheezy. Ничего я не мешал.
 

Оффлайн Malaheenee

  • Ветеран
  • *****
  • Сообщений: 2565
  • Учтите, мы можем дать и вредный совет.
Re: Debian + Quake II (QuDos)
« Ответ #3 : 30 Ноябрь 2012, 10:48:19 »
Так в чем проблема-то? Удалите libjpeg62 и поставьте libjpeg8.
А еще лучше сбэкпортируйте пакты из ппа, там будет попроще

Сообщение объединено: 30 Ноябрь 2012, 17:19:55
libgl1-mesa-dev еще установите на всякий случай.
« Последнее редактирование: 30 Ноябрь 2012, 17:19:55 от Malaheenee »
Debian Sid: XFCE x 1, openbox x 2.
Все мы где-то, когда-то и в чем-то были новичками.
 

Русскоязычное сообщество Debian GNU/Linux

Re: Debian + Quake II (QuDos)
« Ответ #3 : 30 Ноябрь 2012, 10:48:19 »


Теги:
 

Debian Jessie (Dota 2)

Автор Mystique

Ответов: 7
Просмотров: 4373
Последний ответ 16 Январь 2016, 18:05:50
от Roma-san
(РЕШЕНО) Не могу установть Wine 3-0 на Debian 9.3 x 64bit.

Автор Zerg

Ответов: 11
Просмотров: 7471
Последний ответ 27 Январь 2018, 18:09:17
от ogost
GameOnLinux (Debian 7) NEED HELP ;)

Автор FreonX

Ответов: 7
Просмотров: 1921
Последний ответ 08 Март 2016, 10:44:16
от ferum
Pillars of Eternity Debian 8 x64

Автор serke7771

Ответов: 3
Просмотров: 885
Последний ответ 03 Март 2017, 09:37:07
от ihammers
Steam debian wheezy

Автор iron22

Ответов: 22
Просмотров: 5322
Последний ответ 16 Январь 2015, 14:23:01
от qupl