Автор Тема: [решено] что не так с моим sources.list файлом? Failed to fetch debian.org  (Прочитано 1939 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн longstreet

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 110
Пытаюсь поставить программу-клиент твиттера Corebird версии 1.0
При установке выдаётся такая ошибка в терминале:
Цитировать
warning: macro 'AM_GLIB_GNU_GETTEXT' not found in library

Я погуглил, говорят такая ошибка возникает если не установлен пакет libglib2.0-dev
Пошёл в Synaptic Packet Manager, нашёл там этот пакет, но при попытке установки выдаёт такую ошибку:
Цитировать
Failed to fetch http://ftp.us.debian.org/debian/pool/main/g/glib2.0/libglib2.0-dev_2.44.1-1.1_amd64.deb

Я опять погуглил, и нашёл что этому может быть причиной неправильный sources.list файлик, он такой у меня:
Цитировать
# deb cdrom:[Debian GNU/Linux 8.1.0 _Jessie_ - Official amd64 xfce-CD Binary-1 20150606-14:19]/ testing main

deb http://ftp.us.debian.org/debian/ testing main
deb-src http://ftp.us.debian.org/debian/ testing main

deb http://security.debian.org/ testing/updates main
deb-src http://security.debian.org/ testing/updates main

# testing-updates, previously known as 'volatile'
deb http://ftp.us.debian.org/debian/ testing-updates main
deb-src http://ftp.us.debian.org/debian/ testing-updates main

Я его взял из интернетта, когда обновлялся со стабильной версии Debian Jessie до тестовой.



Что с ним у меня не так? Запутался совсем :-[
« Последнее редактирование: 13 Октябрь 2015, 15:57:14 от longstreet »
 


Оффлайн neon1ks

  • Активный пользователь
  • **
  • Сообщений: 79
Выполниsudo apt-get update
 

Оффлайн longstreet

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 110
neon1ks, выполнил в терминале, там промелькали 39 строк с адресами, а две последние такие:
Цитировать
Fetched 634 kB in 20s (31.1 kB/s)                                                   
Reading package lists... Done

Потом зашёл в Synaptic Packet Manager, он мне сразу выдал "You have 5 broken packages on your system!".
Отсортировал пакеты по Broken dependencies, оказались такие:
Цитировать
libcairo2-dev
libgdk-pixbuf2.0-dev
libgtk2.0-dev
libpango1.0-dev
valac-0.28

Пометил их для как Mark for Reinstallation, пробую применить, но выдаёт ошибку:
Цитировать
E: Internal Error, No file name for libcairo2-dev:amd64

Подскажите, пожалуйста, как мне быть...
 

Оффлайн neon1ks

  • Активный пользователь
  • **
  • Сообщений: 79
longstreet,
Могу тебе посоветовать
sudo apt-get install -f
 
Пользователи, которые поблагодарили этот пост: longstreet

Оффлайн longstreet

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 110
neon1ks, большое спасибо! Сделал, чего-то там на 11Мб поставилось.
Потом ещё раз запустил sudo apt-get update, и на 11 кБ чего-то fletched.
Синаптик при открытии ошибок не выдал.

Но при установке программы я видимо не все пакеты поставил, и мне выдаётся вот что:


Их все можно поставить в моей системе? А то я читал, что gtk+-3.0 не встанет в Debian, почему-то.


Cообщение объединено 08 Октябрь 2015, 01:42:29
У меня Synaptic Packet Manager при поиске пакета "gtk+-3.0" выдаёт только gtk3-engines-xfce3.2.0-2 (GTK+-3.0 theme engine for Xfce).
И я этот пакет уже ставил, а именно "gtk+-3.0" мне говорится что нет при установке программы которую я хочу.
« Последнее редактирование: 08 Октябрь 2015, 01:42:29 от longstreet »
 

Оффлайн neon1ks

  • Активный пользователь
  • **
  • Сообщений: 79
Что за программу ставишь?
Вместо gtk+-3.0 надо установить libgtk-3-dev
Для остальных пакетов надо искать нужные.

Cообщение объединено 08 Октябрь 2015, 02:07:53
Если для программы Corebird,
то посмотрел какие нужны пакеты для сборки в репозитории для Ubuntu:
sudo apt-get install debhelper automake libtool autoconf autopoint libgtk-3-dev libglib2.0-dev librest-dev libjson-glib-dev libsqlite3-dev libsoup2.4-dev intltool libgee-0.8-dev valac libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev
« Последнее редактирование: 08 Октябрь 2015, 02:07:53 от neon1ks »
 
Пользователи, которые поблагодарили этот пост: longstreet

Оффлайн longstreet

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 110
neon1ks, здорово, всё получилось теперь!  :)
 

Теги:
 

Ошибки при установке Samba.Решено.

Автор Александр_ru

Ответов: 42
Просмотров: 9830
Последний ответ 03 Февраль 2015, 08:30:57
от Александр_ru
[Решено] Ищу программу для черчения

Автор Artuom

Ответов: 20
Просмотров: 3447
Последний ответ 16 Июнь 2013, 20:11:02
от Udachnik
Ошибки при запуске Debian 9.8.0 Mate

Автор maahzur_ph

Ответов: 7
Просмотров: 487
Последний ответ 23 Апрель 2019, 14:36:35
от maahzur_ph
Debian 8 - запуск скрипта из Gnome

Автор abrasum

Ответов: 3
Просмотров: 1290
Последний ответ 15 Июль 2015, 17:09:29
от alsoijw
[Решено] Момент с Root Terminal

Автор Damiano

Ответов: 7
Просмотров: 2058
Последний ответ 20 Ноябрь 2011, 13:37:53
от Damiano