debian.org / О Debian Где взять Debian Поддержка Уголок разработчика Новости Wiki

Автор Тема: Сразу после установки не работает chromium  (Прочитано 1032 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dmitry1903

  • Topic Author
  • Сообщений: 124
Здравствуйте!

Сразу после установки из репозитория не работает chromium
chromium_37.0.2062.120-1~deb7u1_i386.deb
Не открываются ни сайты, ни настройки.

При попытке запустить в терминале:

chromium
[7910:7910:1208/011913:ERROR:desktop_window_tree_host_x11.cc(766)] Not implemented reached in virtual void views::DesktopWindowTreeHostX11::InitModalType(ui::ModalType)
ATTENTION: default value of option force_s3tc_enable overridden by environment.

Debian 7.11
Gnome
GIGABYTE GA-D425TUD 4 Gb RAM
« Последнее редактирование: 08 Декабрь 2016, 02:10:36 от dmitry1903 »
 

red_rain

  • Гость
Re: Сразу после установки не работает chromium
« Ответ #1 : 08 Декабрь 2016, 17:26:48 »
А действительно, а что это хромиум 37 не работает на debian 7.11?
А как такое может быть?
А может debian 8 поставить надо?
Да не, бред какой то.
 

Оффлайн dmitry1903

  • Topic Author
  • Сообщений: 124
Re: Сразу после установки не работает chromium
« Ответ #2 : 09 Декабрь 2016, 00:41:39 »
Установил SRWare Iron — браузер, разрабатываемый немецкой компанией SRWare на основе исходного кода проекта Chromium:
http://www.srware.net/forum/viewtopic.php?f=27&t=11259
https://ru.wikipedia.org/wiki/SRWare_Iron
Вроде работает нормально, даже быстрее, чем Chromium (когда тот работал).

Но все же интересно узнать, почему сломался Chromium.
 

Оффлайн ihammers

  • Сообщений: 1666
  • Debian GNU/Linux Stretch
    • Алтайская Группа Пользователей Linux
  • Jabber: ihammers@jabber.ru
Re: Сразу после установки не работает chromium
« Ответ #3 : 10 Декабрь 2016, 04:10:16 »
Попробуйте перед запуском chromium запустить dmesg, после чего ещё раз dmesg. Что-то типа такого:
~$ tail dmesg
~$ chromium
~$ tail dmesg

И вывод под спойлер.
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290
 

Оффлайн dmitry1903

  • Topic Author
  • Сообщений: 124
Re: Сразу после установки не работает chromium
« Ответ #4 : 10 Декабрь 2016, 17:56:58 »
Попробуйте перед запуском chromium запустить dmesg, после чего ещё раз dmesg.
Перед запуском chromium:
tail dmesg
tail: невозможно открыть «dmesg» для чтения: Нет такого файла или каталога

После запуска chromium:
chromium
[5426:5426:1210/174553:ERROR:desktop_window_tree_host_x11.cc(766)] Not implemented reached in virtual void views::DesktopWindowTreeHostX11::InitModalType(ui::ModalType)
ATTENTION: default value of option force_s3tc_enable overridden by environment.

И опять с тем же результатом:
tail dmesg
tail: невозможно открыть «dmesg» для чтения: Нет такого файла или каталога
 

Оффлайн yoric

  • Сообщений: 508
  • gentoo
  • Jabber: yoric@jabber.ru
Re: Сразу после установки не работает chromium
« Ответ #5 : 10 Декабрь 2016, 18:27:20 »
dmesg|tail
 

Оффлайн dmitry1903

  • Topic Author
  • Сообщений: 124
Re: Сразу после установки не работает chromium
« Ответ #6 : 10 Декабрь 2016, 18:56:26 »
Код: [Выделить]
dmesg|tail
dmesg|tail
[ 7016.109607] sd 6:0:0:0: [sdb] Asking for cache data failed
[ 7016.109616] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[ 7016.218326]  sdb: sdb1
[ 7016.224737] sd 6:0:0:0: [sdb] Asking for cache data failed
[ 7016.224746] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[ 7016.224753] sd 6:0:0:0: [sdb] Attached SCSI removable disk
[ 7016.777893] FAT-fs (sdb1): utf8 is not a recommended IO charset for FAT filesystems, filesystem will be case sensitive!
[12749.273116] nautilus: sending ioctl 2285 to a partition!
[12754.218063] WARNING! power/level is deprecated; use power/control instead
[12754.296387] usb 1-5: USB disconnect, device number 2
 

Оффлайн dmitry1903

  • Topic Author
  • Сообщений: 124
Re: Сразу после установки не работает chromium
« Ответ #7 : 12 Декабрь 2016, 11:07:18 »
Попробовал из репозитория установить Chromium на другой компьютер с Debian 7.

Перед запуском chromium:
tail dmesg
tail: невозможно открыть «dmesg» для чтения: Нет такого файла или каталога

После запуска chromium:
chromium
[6500:6500:1212/104822:ERROR:desktop_window_tree_host_x11.cc(766)] Not implemented reached in virtual void views::DesktopWindowTreeHostX11::InitModalType(ui::ModalType)

И опять с тем же результатом:
tail dmesg
tail: невозможно открыть «dmesg» для чтения: Нет такого файла или каталога
 

Оффлайн alsoijw

  • Fedora 25 GNOME 3 amd64
  • Сообщений: 1232
Re: Сразу после установки не работает chromium
« Ответ #8 : 12 Декабрь 2016, 13:54:17 »
dmitry1903, не правильно набираешь команду. Нужно так
dmesg|tail
Мало видеть нам начало - надо видеть и конец. Если видишь ты создание - значит где-то есть ТВОРЕЦ
Многие жалуются: геометрия в жизни не пригодилась. Ямб от хорея им приходится отличать ежедневно?
 

Оффлайн ihammers

  • Сообщений: 1666
  • Debian GNU/Linux Stretch
    • Алтайская Группа Пользователей Linux
  • Jabber: ihammers@jabber.ru
Re: Сразу после установки не работает chromium
« Ответ #9 : 12 Декабрь 2016, 14:47:42 »
Я допустил ошибку при наборе команды, tail должен идти после dmesg:
~$ dmesg | tail
~$ chromium
~$ dmesg | tail
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290
 

Оффлайн dmitry1903

  • Topic Author
  • Сообщений: 124
Re: Сразу после установки не работает chromium
« Ответ #10 : 12 Декабрь 2016, 17:08:46 »
На первом компьютере:

dmesg | tail
[   27.374604] Bluetooth: L2CAP socket layer initialized
[   27.383197] Bluetooth: SCO socket layer initialized
[   27.456518] Bluetooth: RFCOMM TTY layer initialized
[   27.464713] Bluetooth: RFCOMM socket layer initialized
[   27.472569] Bluetooth: RFCOMM ver 1.11
[   27.710072] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   27.717878] Bluetooth: BNEP filters: protocol multicast
[   28.752024] eth0: no IPv6 routers present
[   29.000843] lp0: using parport0 (interrupt-driven).
[   29.378867] ppdev: user-space parallel port driver


chromium
ATTENTION: default value of option force_s3tc_enable overridden by environment.
[3654:3654:1212/170701:ERROR:desktop_window_tree_host_x11.cc(766)] Not implemented reached in virtual void views::DesktopWindowTreeHostX11::InitModalType(ui::ModalType)


dmesg | tail
[   27.374604] Bluetooth: L2CAP socket layer initialized
[   27.383197] Bluetooth: SCO socket layer initialized
[   27.456518] Bluetooth: RFCOMM TTY layer initialized
[   27.464713] Bluetooth: RFCOMM socket layer initialized
[   27.472569] Bluetooth: RFCOMM ver 1.11
[   27.710072] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   27.717878] Bluetooth: BNEP filters: protocol multicast
[   28.752024] eth0: no IPv6 routers present
[   29.000843] lp0: using parport0 (interrupt-driven).
[   29.378867] ppdev: user-space parallel port driver


На втором компьютере:

dmesg | tail
[   22.521382] Bluetooth: L2CAP socket layer initialized
[   22.522507] Bluetooth: SCO socket layer initialized
[   22.575754] Bluetooth: RFCOMM TTY layer initialized
[   22.575771] Bluetooth: RFCOMM socket layer initialized
[   22.575776] Bluetooth: RFCOMM ver 1.11
[   22.833931] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   22.833941] Bluetooth: BNEP filters: protocol multicast
[   23.687391] lp0: using parport0 (interrupt-driven).
[   23.801259] ppdev: user-space parallel port driver
[   24.864049] eth0: no IPv6 routers present


chromium
[3770:3770:1212/173049:ERROR:desktop_window_tree_host_x11.cc(766)] Not implemented reached in virtual void views::DesktopWindowTreeHostX11::InitModalType(ui::ModalType)


dmesg | tail
[   22.521382] Bluetooth: L2CAP socket layer initialized
[   22.522507] Bluetooth: SCO socket layer initialized
[   22.575754] Bluetooth: RFCOMM TTY layer initialized
[   22.575771] Bluetooth: RFCOMM socket layer initialized
[   22.575776] Bluetooth: RFCOMM ver 1.11
[   22.833931] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   22.833941] Bluetooth: BNEP filters: protocol multicast
[   23.687391] lp0: using parport0 (interrupt-driven).
[   23.801259] ppdev: user-space parallel port driver
[   24.864049] eth0: no IPv6 routers present


(На первом компе я этот Chromium уберу и верну Iron, дальнейшие исследования будут на втором.)
« Последнее редактирование: 12 Декабрь 2016, 17:34:00 от dmitry1903 »
 

Оффлайн 0d1n

  • Сообщений: 34
Re: Сразу после установки не работает chromium
« Ответ #11 : 08 Январь 2017, 16:22:37 »
$uname -a
Linux 3.2.0-4-686-pae #1 SMP Debian 3.2.84-1 i686 GNU/Linux

$ chromium
ATTENTION: default value of option force_s3tc_enable overridden by environment.
[12869:12891:0108/161456:ERROR:object_proxy.cc(566)] Failed to call method: org.kde.KWallet.isEnabled: object_path= /modules/kwalletd: org.freedesktop.DBus.Error.ServiceUnknown: The name org.kde.kwalletd was not provided by any .service files
[12869:12891:0108/161456:ERROR:native_backend_kwallet_x.cc(230)] Error contacting kwalletd (isEnabled)
[12869:12891:0108/161457:ERROR:object_proxy.cc(566)] Failed to call method: org.kde.KWallet.isEnabled: object_path= /modules/kwalletd: org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
[12869:12891:0108/161457:ERROR:native_backend_kwallet_x.cc(230)] Error contacting kwalletd (isEnabled)
[5:5:0108/161457:ERROR:nss_util.cc(211)] Error initializing NSS without a persistent database: NSS error code: -8023
[5:5:0108/161457:FATAL:nss_util.cc(213)] nss_error=-8023, os_error=0



включил kwallet
$ chromium
ATTENTION: default value of option force_s3tc_enable overridden by environment.
[5:5:0108/161724:ERROR:nss_util.cc(211)] Error initializing NSS without a persistent database: NSS error code: -8023
[5:5:0108/161724:FATAL:nss_util.cc(213)] nss_error=-8023, os_error=0
[7:7:0108/161726:ERROR:nss_util.cc(211)] Error initializing NSS without a persistent database: NSS error code: -8023
[7:7:0108/161726:FATAL:nss_util.cc(213)] nss_error=-8023, os_error=0


запускается только так:
chromium %U --no-sandbox

[13045:13045:0108/162011:ERROR:browser_main_loop.cc(161)] Running without the SUID sandbox! See https://code.google.com/p/chromium/wiki/LinuxSUIDSandboxDevelopment for more information on developing with the sandbox on.
ATTENTION: default value of option force_s3tc_enable overridden by environment.
[13080:13080:0108/162011:ERROR:renderer_main.cc(227)] Running without renderer sandbox

но так не работает https

проблема решилась даунгрейдом библиотеки
apt-get install libnss3=2:3.14.5-1+deb7u5
« Последнее редактирование: 08 Январь 2017, 16:42:09 от 0d1n »
 

Теги: