debian.org / О Debian Где взять Debian Поддержка Уголок разработчика Новости Wiki

Автор Тема: Wheezy 7.5 + Mate ошибка segfault in libXv.so  (Прочитано 468 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Arhat109

  • Topic Author
  • Сообщений: 16
Wheezy 7.5 + Mate ошибка segfault in libXv.so
« : 21 Январь 2017, 18:36:15 »
Установил Debian Wheezy 7.5 amd64 с имеющегося под рукой дистрибутива. Свежее под руками нет, а надо было переставить систему срочно. Третий гном, входящий в поставку встал как-то не так с сообщением "перешел в альтернативный режим". Видеокарта - Radeon .. не помню какая, комп старый, 2-х ядерный интел с 2 гигами оперативы.

1. Сначала доустановил wine, ИС ДРАКОН затребовал wine 32 поставил dpkg --add-configure i386 и доставил wine-bin:i386. Не помогло, но ладно. Сейчас "не горит".Eclipse, Idea работают, они нужнее, но кривой гном не понравился и,

2. Согласно этой темы: https://debianforum.ru/index.php?topic=1913.msg18676#msg18676 поставил Mate, все вроде как встало ровно. Но при проверке просмотра видео как через firefox, так и через "видеопроигрыватель" в /var/log/syslog обнаруживаю такую ошибку:

totem[4459] segfault at 31 ip:... sp:... error 4 in libXv.so.1.0.0 [...+5000]

Как понимаю это ошибка сегментации в библиотеке видеовывода .. гуглем ничего вразумительного не нашел, кроме того что есть свежие версии.

Кто-то может помочь поднять просмотр видео на такой конфигурации? Видео нужно ребенку .. выкачивать новый дистрибутив или ставить его по сети "прямо сейчас" нет ни времени ни возможности (1Мбит интернет по IDSL модему, иной связи тут нет "в принципе", да и срочная работа есть)

Спасибо.
 

Оффлайн VKH

  • Сообщений: 137
Re: Wheezy 7.5 + Mate ошибка segfault in libXv.so
« Ответ #1 : 21 Январь 2017, 22:45:58 »
Mate для Debian https://wiki.debian.org/Mate.
Все ли рекомендуемые пакеты установили?
 
« Последнее редактирование: 23 Январь 2017, 03:52:06 от ogost »
 

Оффлайн Arhat109

  • Topic Author
  • Сообщений: 16
Re: Wheezy 7.5 + Mate ошибка segfault in libXv.so
« Ответ #2 : 22 Январь 2017, 06:47:30 »
Устанавливал по ссылке. Сначала добавил бэкпорт в список репозиториев, а потом делал установку mate-desktop-enviroment как там указано. Выкачалось вроде как все без ошибок (или я не заметил), установлено поверх гнома3, и теперь при входе есть выбор какой стол использовать. Проверил, кстати при загрузке гнома в альтернативном режиме (это он сам так пишет), видео не работает точно так же и с той же ошибкой.
 

Оффлайн VKH

  • Сообщений: 137
Re: Wheezy 7.5 + Mate ошибка segfault in libXv.so
« Ответ #3 : 22 Январь 2017, 10:45:09 »
Проверить зависимости sudo apt-get -f installУстановить драйвера для видео firmware-linux-nonfree.
Тотем использует gstreamer, то можно проверить на другом плеере, например sudo apt-get install mplayer2 smplayer, или другое что еще.
 

Оффлайн Aalexeey

  • Сообщений: 417
  • ASUS_Q400A, Winmate_I771 GTK2/Qt4_MATE
Re: Wheezy 7.5 + Mate ошибка segfault in libXv.so
« Ответ #4 : 22 Январь 2017, 14:42:52 »
Arhat109, попробуйте VLC в нём практически все необходимые компоненты автономны. Попробуйте установить кодеки из debian-multimedia. Я когда-то чтоб долго не заморачиваться с так называемой чистотой системы установил все возможные кодеки которые не ломали зависимости друг-друга, это дало результат. Мультимедиа должно работать на 100% иначе на кой такая система.
Какие у меня в Wheezy кодеки и другие мульти можете сравнить из прикрепления отсюда: https://debianforum.ru/index.php?topic=3834.msg85673#msg85673
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"
 

Оффлайн Arhat109

  • Topic Author
  • Сообщений: 16
Re: Wheezy 7.5 + Mate ошибка segfault in libXv.so
« Ответ #5 : 22 Январь 2017, 17:04:57 »
#apt-get -f install

Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.

.. вроде бы ничего "такого" не видит.

Установил smplayer, при попытке посмотреть видео с цифромыльницы, из домашнего каталога сказал, что он "рухнул" и дал посмотреть диагностику. Привожу вложенным файлом, ибо там - многа..

P.S.
.. есть большое подозрение что "что-то встало не так", или моя попытка поставить wine-bin:i386 на 64-х битный дебиан (см. п.1. в мервом сообщении) привела к какому-то залипу с библиотеками. Пока не разберусь "чё за фигня" творится или не докачаю свежий дистр. - ничего нового ставить больше не буду.
« Последнее редактирование: 22 Январь 2017, 17:08:17 от Arhat109 »
 

Оффлайн Arhat109

  • Topic Author
  • Сообщений: 16
Re: Wheezy 7.5 + Mate ошибка segfault in libXv.so
« Ответ #6 : 23 Январь 2017, 04:57:28 »
Всем спасибо, вопрос уже не актуален. Пришлось дитенка тащить к соседям, дабы он посмотрел свои кины для подготовки сегодняшней презентации. Вопрос так и не решился, но уже выкачал свежий дистр, ухожу на него и видимо на какой-то иной рабочий стол.

kde, gnom3 - не предлагать. Что ещё есть легкое, желательное в стиле Гном2, кроме mate?
 

Оффлайн CoolAller

  • Сообщений: 789
Re: Wheezy 7.5 + Mate ошибка segfault in libXv.so
« Ответ #7 : 23 Январь 2017, 08:25:14 »
Arhat109, Debian 8 Jessie + MATE + VLC хавает практически все, за исключением некоторых HDTV записанных с feed трансляций. Никаких сторонних кодеков не нужно.
Что ещё есть легкое, желательное в стиле Гном2, кроме mate?
Нет такого в природе, XFCE и LXDE лично я не считаю за альтернативу Gnome2, слишком многое на мой взгляд там недоделано, мало настроек через GUI, больше ковырянья в конфигах, но с большой натяжкой можно сказать, что оно отдаленно похожее, имеет интерфейс GTK+, Qt, можете попробовать.

PS. Можно записать образ с Debian на DVD диск или на флешку не требующий интернета и подключения репозиторий MATE во время установки, там все нужные пакеты для установки DE MATE находятся на этом образе диска.
« Последнее редактирование: 23 Январь 2017, 22:15:28 от CoolAller »
 

Оффлайн Arhat109

  • Topic Author
  • Сообщений: 16
Re: Wheezy 7.5 + Mate ошибка segfault in libXv.so
« Ответ #8 : 24 Январь 2017, 07:28:33 »
Вообще все как-то странно. Вчера так и не удалось выкачать дистрибутив из-за падения сети и связи (оценка времени 5часов, 2 падения с интервалом по 4 часа .. *опа). Но, сегодня обнаружил что "оно работает" .. видео кажет, не вываливается. Ничего не делал. Как так?

До выходных остаюсь на 7.5 версии + MATE, что уже поставил. Работать надо.
 

Теги: