debian.org / О Debian Где взять Debian Поддержка Уголок разработчика Новости Wiki

Автор Тема: Подскажите , какое ядро на данный момент самое стабильное под squeeze ?  (Прочитано 2015 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Lexs

  • Topic Author
  • Сообщений: 4
Подскажите , какое ядро на данный момент самое стабильное под squeeze , нужно поставить на боевой сервер, чтобы не нарушилась совместимость.

Версия ядра обязательно должна быть выше 2.6.35 под amd64  , ибо в этом релизе есть необходимый мне функционал.

Еще подскажите, ну не лежит у меня душа к компилции ядра, можно ли откуда-то скачать готовый .deb пакет с headers ?
Сейчас ядро 2.6.32-5 , в репах linux-kernel-2.6.35 я не вижу, а хочется собрать банально, как-то так apt-get install linux-image-2.6.35-5-amd64 && grub-update
« Последнее редактирование: 21 Сентябрь 2011, 14:08:51 от Lexs »
 

Оффлайн Brainey

  • Сообщений: 1943
  • Jabber: brainey@jabber.cz
Цитировать
sqeeze
Позвольте полюбопытствовать, о чем вы?
Конференция форума в jabber: debianforum@conference.jabber.ru | Клуб кедоводов: kde@conference.jabber.ru
 

paulcarroty

  • Гость
Самое стабильное сейчас 32. Если тебе не подходит, ставь с бекпортов и не парся.
 

Оффлайн Lexs

  • Topic Author
  • Сообщений: 4
Цитировать
sqeeze
Позвольте полюбопытствовать, о чем вы?
Ну вы же поняли о чем речь, зачем передергивать. Отпечатался в 4 утра.

Самое стабильное сейчас 32. Если тебе не подходит, ставь с бекпортов и не парся.
Хм, я что-то думал , что .35 уже стабильное

в бакпортах есть:
linux-image-2.6.38-bpo.2-amd64 - Linux 2.6.38 for 64-bit PCs
linux-image-2.6.39-bpo.2-amd64 - Linux 2.6.39 for 64-bit PCs

что поставить? стоит ли на боевом сервере обновится, не вылезет ли мне боком нигде?

 

Оффлайн gardarea51

  • Сообщений: 633
  • Jabber: gard.area51@jabber.ru
А в стабильной ветке, если не считать бэкпортов, несколько ядер? Если так, то логично предположить, что все они стабильные. Нет?
 

paulcarroty

  • Гость
39-е конечно. С бэкпортами никогда не имел проблем.
 

Оффлайн Lexs

  • Topic Author
  • Сообщений: 4
пробовал и 38 и 39 , ни в какую не хочет собираться ипсет (((

Делаю так
apt-get install xtables-addons-source xtables-addons-common && m-a -v -t auto-install xtables-addons

выдает выдает ошибку:

LD      /usr/src/modules/xtables-addons/built-in.o
  CC [M]  /usr/src/modules/xtables-addons/compat_xtables.o
In file included from /usr/src/modules/xtables-addons/compat_xtables.c:21:
/usr/src/modules/xtables-addons/compat_xtnu.h:87: warning: ‘struct xt_match_param’ declared inside parameter list
/usr/src/modules/xtables-addons/compat_xtnu.h:87: warning: its scope is only this definition or declaration, which is probably not what you want
/usr/src/modules/xtables-addons/compat_xtnu.h:103: warning: ‘struct xt_target_param’ declared inside parameter list
/usr/src/modules/xtables-addons/compat_xtables.c:212: warning: ‘struct xt_target_param’ declared inside parameter list
/usr/src/modules/xtables-addons/compat_xtables.c: In function ‘xtnu_target_run’:
/usr/src/modules/xtables-addons/compat_xtables.c:226: error: dereferencing pointer to incomplete type
/usr/src/modules/xtables-addons/compat_xtables.c:235: warning: passing argument 2 of ‘nt->target’ from incompatible pointer type
/usr/src/modules/xtables-addons/compat_xtables.c:235: note: expected ‘const struct xt_target_param *’ but argument is of type ‘const struct xt_target_param *’
/usr/src/modules/xtables-addons/compat_xtables.c: In function ‘xtnu_register_target’:
/usr/src/modules/xtables-addons/compat_xtables.c:327: warning: assignment from incompatible pointer type
make[5]: *** [/usr/src/modules/xtables-addons/compat_xtables.o] Error 1
make[4]: *** [_module_/usr/src/modules/xtables-addons] Error 2
make[3]: *** [sub-make] Error 2
make[2]: *** [all] Error 2
make[2]: Leaving directory `/usr/src/linux-headers-2.6.38-bpo.2-amd64'
make[1]: *** [binary-modules] Error 2
make[1]: Leaving directory `/usr/src/modules/xtables-addons'
make: *** [kdist_build] Error 2
BUILD FAILED!
See /var/cache/modass/xtables-addons-source.buildlog.2.6.38-bpo.2-amd64.1316670424 for details.

подскажите люди добрые что я не так делаю
 

Оффлайн SeHELLioN

  • Сообщений: 910
ну а в логе то что написано?/var/cache/modass/xtables-addons-source.buildlog.2.6.38-bpo.2-amd64.1316670424
Asus m5a97+Amd fx-8350+4x4GB DDR3 1600MGz+asus gtx670 DCII (перешита в top)
Debian stable
 

Оффлайн Lexs

  • Topic Author
  • Сообщений: 4
Установка ips_set под ядро 2.6.39 (Debian 6 squeeze)
« Ответ #8 : 21 Сентябрь 2011, 23:50:20 »
В общем, если кто столкнется с похожей проблемой мой мануальчик

ядро 2.6.39 ставил из backport. Модуль ip_set уже в ядре, поэтому собираем саму утилиту ipset версии >=6

apt-get install autoconf2.13 libtool pkg-config git libmnl-dev libmnl0
git clone git://git.netfilter.org/ipset.git
cd ipset

./autogen.sh
./configure
make && make install

(ставит последнюю версию, если нужна другая git checkout номер версии)

P.S. В последней версии выкосили iptree, вместо нее теперь используется hash:ip
« Последнее редактирование: 23 Сентябрь 2011, 01:01:23 от Lexs »
 

Теги: