debian.org / О Debian Где взять Debian Поддержка Уголок разработчика Новости Wiki

Автор Тема: Не дает читать .txt файлы на сайтах расположеных на сервере  (Прочитано 694 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dizzy

  • Topic Author
  • Сообщений: 3
Всем привет!
Столкнулся с такой проблемой.
Есть впс в такой конфигурации оси debian-8.0-x86_64-ispconfig
При попытке открыть тхт файл на сайте выдает 403 Forbiden You don't have permission to access.
Права на папку в которой файл 777 и на сам файл тоже, овнер тот же что и у остальных папок сайта.
В апаче в конфиге нету никаких записей на счет ограничения доступа к типу файла.
Уже мозг сломал в поисках проблемы.
 

Оффлайн endru

  • Сообщений: 1546
  • Новосибирск
  • Jabber: endru@jabber.ru
Права на папку в которой файл 777 и на сам файл тоже
скиньте адресок сайта, чтобы вам как можно скорее залили shell на сайт! (шутка, скидывать адрес сайта не нужно!!!).
Никогда не используй права 777 если не знаешь как они работают! Примеров "как правильно настроить права да файлы и директории сайта" полно!

В апаче в конфиге нету никаких записей на счет ограничения доступа к типу файла.
если это apache то смотреть нужно не конфиги, а htaccess!

Оффлайн Dizzy

  • Topic Author
  • Сообщений: 3
Не ну єто понятно я 777 ставил временно только проверить доступность файла а получается что на маскимально открытом доступе нет возможности его открыть..
В htaccess только такое:

# 1.To use URL Alias you need to be running apache with mod_rewrite enabled.

# 2. In your opencart directory rename htaccess.txt to .htaccess.

# For any support issues please visit: http://www.opencart.com

Options +FollowSymlinks

# Prevent Directoy listing
Options -Indexes

<FilesMatch "(?i)((\.tpl|\.ini|\.log|(?<!robots)\.txt))">
 Order deny,allow
 Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
RewriteRule ^system/download/(.*) index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]


### Additional Settings that may need to be enabled for some servers
### Uncomment the commands by removing the # sign in front of it.
### If you get an "Internal Server Error 500" after enabling any of the following settings, restore the # as this means your host doesn't allow that.

# 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:
# php_flag register_globals off

# 2. If your cart has magic quotes enabled, This may work to disable it:
# php_flag magic_quotes_gpc Off

# 3. Set max upload file size. Most hosts will limit this and not allow it to be overridden but you can try
# php_value upload_max_filesize 999M

# 4. set max post size. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value post_max_size 999M

# 5. set max time script can take. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_execution_time 200

# 6. set max time for input to be recieved. Uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_input_time 200

# 7. disable open_basedir limitations
# php_admin_value open_basedir none

Вот эту часть и убирал вообще и по разному изменял исходя из инфы по разным источникам в сети

<FilesMatch "(?i)((\.tpl|\.ini|\.log|(?<!robots)\.txt))">
 Order deny,allow
 Deny from all
</FilesMatch>

Но результата нет :)

Барабашка какойто

Cообщение объединено [time]08 Февраля 2017, 13:34:05[/time]
Может как то можно принудительно заставить его читать файл через параметр в htaccess?

Cообщение объединено 09 Февраль 2017, 00:39:49
Кто-то в курсе как в этих параметрах задать еще несколько имен файлов тхт?
не могу найти мануалов по этой команде где описано как несколько файлов прописать  которые разрешено читать...

<FilesMatch "(?i)((\.tpl|\.ini|\.log|(?<!robots)\.txt))">
 Order deny,allow
 Deny from all
</FilesMatch>
« Последнее редактирование: 09 Февраль 2017, 00:39:49 от Dizzy »
 

Оффлайн endru

  • Сообщений: 1546
  • Новосибирск
  • Jabber: endru@jabber.ru
Цитировать
(?<!robots)\.txt)
как раз таки и запрещает доступ к *.txt, кроме robots.txt.
Кто-то в курсе как в этих параметрах задать еще несколько имен файлов тхт?
по аналогии с robots.txt выше.

рекомендую почитать эту ссылку.

Оффлайн Dizzy

  • Topic Author
  • Сообщений: 3
так это понятно, я это убирал сразу же и все равно не давало читать :) я сейчас просто хочу прописать конкретные файлы чтобы закрыть доступ к остальным.
Только я не понял как кокнретно...вот так

<FilesMatch "(?i)((\.tpl|\.ini|\.log|(?<!robots,test)\.txt))">

или вот так?

<FilesMatch "(?i)((\.tpl|\.ini|\.log|(?<!robots)\.txt)(?<!test)\.txt))">
 

Оффлайн endru

  • Сообщений: 1546
  • Новосибирск
  • Jabber: endru@jabber.ru
ну ты видимо не читал ссылку, а там все очень хорошо расписано!
(?i) - включает не чувствительность к регистру.
дальше идут перечисления типов имен в () с разделителем | (оно же логическое ИЛИ).
т.к. . - это любой символ, его экранируют: \.
шаблон:
(?<!robots)\.txt - выборка txt файлов с исключением robots.txt

это исчерпывающая информация. 1 твой вариант полная фигня.
2 вариант будет тебе искать файл *.txt*.txt , т.е. нет логического ИЛИ.

Теги: