debian.org / О Debian Где взять Debian Поддержка Уголок разработчика Новости Wiki

Автор Тема: проблема apt-get update  (Прочитано 670 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Lammer

  • Topic Author
  • Сообщений: 21
  • добрый человек
проблема apt-get update
« : 11 Февраль 2017, 10:57:20 »
Доброго вам времени суток, уважаемые шаманы, маги и волшебники.

я новичок в рядах бесстрашных пользователей ОС linux

столкнулся с проблемой:  :(
решил поменять репозитории в ОС debian 16.04, в принципе всё просто:
открыл файл sources.list и вписал туда новые репозитории, а именно:
    deb http://ftp.ru.debian.org/debian/ squeeze main non-free contrib
    deb-src http://ftp.ru.debian.org/debian/ squeeze main non-free contrib
взятые с сайта http://4debian.info/repository/official

но недуг подкрался незаметно и надавал по первое число.
при команде apt-get update выдаёт следующее

root@Banka:/# apt-get update
Игн http://ftp.ru.debian.org squeeze InRelease
Игн http://ftp.ru.debian.org squeeze Release.gpg
Игн http://ftp.ru.debian.org squeeze Release
Ош  http://ftp.ru.debian.org squeeze/main Sources
  404  Not Found
Ош  http://ftp.ru.debian.org squeeze/non-free Sources
  404  Not Found
Ош  http://ftp.ru.debian.org squeeze/contrib Sources
  404  Not Found
Ош  http://ftp.ru.debian.org squeeze/main amd64 Packages
  404  Not Found
Ош  http://ftp.ru.debian.org squeeze/non-free amd64 Packages
  404  Not Found
Ош  http://ftp.ru.debian.org squeeze/contrib amd64 Packages
  404  Not Found
Игн http://ftp.ru.debian.org squeeze/contrib Translation-ru_RU
Игн http://ftp.ru.debian.org squeeze/contrib Translation-ru
Игн http://ftp.ru.debian.org squeeze/contrib Translation-en
Игн http://ftp.ru.debian.org squeeze/main Translation-ru_RU
Игн http://ftp.ru.debian.org squeeze/main Translation-ru
Игн http://ftp.ru.debian.org squeeze/main Translation-en
Игн http://ftp.ru.debian.org squeeze/non-free Translation-ru_RU
Игн http://ftp.ru.debian.org squeeze/non-free Translation-ru
Игн http://ftp.ru.debian.org squeeze/non-free Translation-en
W: Не удалось получить http://ftp.ru.debian.org/debian/dists/squeeze/main/source/Sources  404  Not Found

W: Не удалось получить http://ftp.ru.debian.org/debian/dists/squeeze/non-free/source/Sources  404  Not Found

W: Не удалось получить http://ftp.ru.debian.org/debian/dists/squeeze/contrib/source/Sources  404  Not Found

W: Не удалось получить http://ftp.ru.debian.org/debian/dists/squeeze/main/binary-amd64/Packages  404  Not Found

W: Не удалось получить http://ftp.ru.debian.org/debian/dists/squeeze/non-free/binary-amd64/Packages  404  Not Found

W: Не удалось получить http://ftp.ru.debian.org/debian/dists/squeeze/contrib/binary-amd64/Packages  404  Not Found

E: Некоторые индексные файлы не скачались. Они были проигнорированы или вместо них были использованы старые версии.


честно перелазил множество форумов, пробовал разное, но к моему сожалению ни чего не помогает.



помогите пожалуйста безграмотному.
« Последнее редактирование: 11 Февраль 2017, 11:00:41 от Lammer »
может я и глуповат, но логика работает.
 

Оффлайн ferum

  • Сообщений: 3090
  • wheezy KDE & jessie LXDE & stretch KDE
Re: проблема apt-get update
« Ответ #1 : 11 Февраль 2017, 11:12:58 »
Ни чего удивительного вы добавили, не понятно зачем, репозитории дистрибутива который уже целый год как не поддерживается (debian 6 "squeeze")
Для того что бы все узнали какой дистрибутив вы используете ( не ubuntu 16.04 случайно ли) дайте вывод команды
lsb_release -aЗ.Ы. лепить к ubuntu репозитории от debian совершенно не нужно.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн Lammer

  • Topic Author
  • Сообщений: 21
  • добрый человек
Re: проблема apt-get update
« Ответ #2 : 11 Февраль 2017, 11:21:43 »
выдаёт следующее:

root@Banka:/# lsb_release -a
No LSB modules are available.
Distributor ID:   Debian
Description:   Debian GNU/Linux 8.7 (jessie)
Release:   8.7
Codename:   jessie

пробовал разные репозитории, но результат тот же.
подскажите пожалуйста актуальные?
может я и глуповат, но логика работает.
 

Оффлайн ferum

  • Сообщений: 3090
  • wheezy KDE & jessie LXDE & stretch KDE
Re: проблема apt-get update
« Ответ #3 : 11 Февраль 2017, 11:29:49 »
deb http://ftp.ru.debian.org/debian/ jessie main non-free contribпервую строку довести до такого состояния что бы были доступны несвободные компоненты, это родные источники, можете добавить источник deb-multimedia
 На этапе ознакомления больше вам ни чего не надо менять в дефолтном sources.list
Русские дебианщики против цифрового слабоумия !
 
Пользователи, которые поблагодарили этот пост: Lammer

Оффлайн Ogis1975

  • OS: Debian 9.4 / WM: Xmonad
  • Сообщений: 276
  • Debian 9.4 Xmonad
Re: проблема apt-get update
« Ответ #4 : 11 Февраль 2017, 11:38:41 »
можете добавить источник deb-multimedia
А вот этого делать точно ненужно. Будут проблемы. Об этом написано в Debian wiki https://wiki.debian.org/MultimediaCodecs
 

Оффлайн Lammer

  • Topic Author
  • Сообщений: 21
  • добрый человек
Re: проблема apt-get update
« Ответ #5 : 11 Февраль 2017, 11:43:20 »
первую строку довести до такого состояния что бы были доступны несвободные компоненты

да, я дерево и скажите мне здравствуй.
как это сделать?и для чего это?


обновление заработало, спасибо вам большое.
может я и глуповат, но логика работает.
 

Оффлайн ferum

  • Сообщений: 3090
  • wheezy KDE & jessie LXDE & stretch KDE
Re: проблема apt-get update
« Ответ #6 : 11 Февраль 2017, 11:46:22 »
Не знаю, пользуюсь этим источником с 2011 года, проблем отродясь не было. Дело в том что не все аудио видео форматы поддерживаются из коробки а этот источник позволяет значительно расширить функционал.
Русские дебианщики против цифрового слабоумия !
 

Теги: