debian.org / О Debian Где взять Debian Поддержка Уголок разработчика Новости Wiki

Автор Тема: Установка Enlightenment v 0.21.6 и новее  (Прочитано 815 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Forum_Liker

  • Topic Author
  • Сообщений: 29
Установка Enlightenment v 0.21.6 и новее
« : 07 Март 2017, 20:40:53 »
Всем привет. Установил из реп е17 версии 0.17.6. Хочет установить более новую версию. Пытался сделать это несколькими способами из инструкции https://www.enlightenment.org/distros/debian-start но ни чего не вышло.
Из репозитория устанавливаться не хочет из-за кучи зависимостей. Из исходников не могу собрать, т.к. как даже файлов configure и make нет в папке.
Поделитесь опытом кто как устанавливал\обновлял enlightenment до более новых версий.

Spoiler: Конфликт при обновлении из репозитория experimental • показать
Пакеты имеющие неудовлетворительные зависимости:
enlightenment: Зависит: libecore-con1 (>= 1.18.4-1) но 1.8.6-2.1+b2 будет установлен
                     Зависит: libecore-evas1 (>= 1.18.4-1) но 1.8.6-2.1+b2 будет установлен
                     Зависит: libecore-file1 (>= 1.18.4-1) но 1.8.6-2.1+b2 будет установлен
                     Зависит: libecore-imf1 (>= 1.18.4-1) но 1.8.6-2.1+b2 будет установлен
                     Зависит: libecore-input1 (>= 1.18.4-1) но 1.8.6-2.1+b2 будет установлен
                     Зависит: libecore-ipc1 (>= 1.18.4-1) но 1.8.6-2.1+b2 будет установлен
                     Зависит: libecore-x1 (>= 1.18.4-1) но 1.8.6-2.1+b2 будет установлен
                     Зависит: libecore1 (>= 1.18.4-1) но 1.8.6-2.1+b2 будет установлен
                     Зависит: libedje1 (>= 1.18.4-1) но 1.8.6-2.1+b2 будет установлен
                     Зависит: libeet1 (>= 1.18.4-1) но 1.8.6-2.1+b2 будет установлен
                     Зависит: libeeze1 (>= 1.18.4-1) но 1.8.6-2.1+b2 будет установлен
                     Зависит: libefreet1a (>= 1.18.4-1) но 1.8.6-2.1+b2 будет установлен
                     Зависит: libeina1a (>= 1.18.4-1) но он не будет установлен
                     Зависит: libeio1 (>= 1.18.4-1) но 1.8.6-2.1+b2 будет установлен
                     Зависит: libelementary1 (>= 1.18.4-1) но он не будет установлен
                     Зависит: libemotion1 (>= 1.18.4-1) но 1.8.6-2.1+b2 будет установлен
                     Зависит: libethumb-client1 (>= 1.18.4-1) но 1.8.6-2.1+b2 будет установлен
                     Зависит: libevas1 (>= 1.18.4-1) но 1.8.6-2.1+b2 будет установлен
« Последнее редактирование: 08 Март 2017, 20:57:35 от Forum_Liker »
 

Оффлайн alsoijw

  • Fedora 25 GNOME 3 amd64
  • Сообщений: 1232
Re: Установка Enlightenment v 0.21.6 и новее
« Ответ #1 : 08 Март 2017, 02:15:28 »
readme есть?
Мало видеть нам начало - надо видеть и конец. Если видишь ты создание - значит где-то есть ТВОРЕЦ
Многие жалуются: геометрия в жизни не пригодилась. Ямб от хорея им приходится отличать ежедневно?
 

Оффлайн ferum

  • Сообщений: 2926
  • wheezy KDE & jessie LXDE & stretch KDE
Re: Установка Enlightenment v 0.21.6 и новее
« Ответ #2 : 08 Март 2017, 11:47:11 »
Поделитесь опытом кто как устанавливал\обновлял enlightenment до более новых версий.
Обновлять ни как, надо собирать или из исходников или по уму в пакеты. Для stretch  можно собрать и последний с официального сайта в пакеты под нужную архитектуру но придётся угробить рабочий день а то и больше, мотивации нет абсолютно.
Для jessie у меня в наличии уже готовые пакеты ( локальный репозиторий ) срезы i386: efl 1.16.0 enlightenment 20.0 amd64 efl 1.17.0 enlightenment 20.6
От установленного среза для i386 остался скрин http://itmages.ru/image/view/3327842/aff5b509
Русские дебианщики против цифрового слабоумия !
 

Оффлайн Forum_Liker

  • Topic Author
  • Сообщений: 29
Re: Установка Enlightenment v 0.21.6 и новее
« Ответ #3 : 08 Март 2017, 12:51:18 »
readme есть?
Да, там описана стандартная процедура сборки.

Cообщение объединено [time]08 Марта 2017, 12:54:04[/time]
ferum

Я установил на старый ноутбук samsung r40 plus сборку netinst i386. Поэтому скорее всего сборку из исходников он не выдержит продолжительностью в сутки) Если можете поделитесь своими пакетами) У меня Debian 8.3 x32
« Последнее редактирование: 08 Март 2017, 12:54:36 от Forum_Liker »
 

Оффлайн ferum

  • Сообщений: 2926
  • wheezy KDE & jessie LXDE & stretch KDE
Re: Установка Enlightenment v 0.21.6 и новее
« Ответ #4 : 08 Март 2017, 13:45:47 »
https://yadi.sk/d/ftHp3DUj3FGcCX например распаковать в домашнюю папку а в /etc/apt/sources.list прописать строку
 deb file:/home/ваш пользователь/erepo /
apt-get update и ставить проще через synaptic может потребоваться deb-multimedia хотя я уже не помню.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн Forum_Liker

  • Topic Author
  • Сообщений: 29
Re: Установка Enlightenment v 0.21.6 и новее
« Ответ #5 : 08 Март 2017, 18:01:53 »
ferum
Обновление нашлось только для трех пакетов: terminology 0.7.0 > 0.9.1; libelementary2 1.8.5 > 1.16.0; libelementary-data 1.8.5 > 1.16.0. А как же остальные?
Я немножко ошибся, у меня Debian 8.7. Если это конечно имеет значение.
« Последнее редактирование: 08 Март 2017, 18:05:33 от Forum_Liker »
 

Оффлайн ferum

  • Сообщений: 2926
  • wheezy KDE & jessie LXDE & stretch KDE
Re: Установка Enlightenment v 0.21.6 и новее
« Ответ #6 : 08 Март 2017, 22:18:49 »
Срез репозитария enlightenment собирался мной на определенную дату. Тогда все работало а debian был чуточку моложе, но это не критично.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн alsoijw

  • Fedora 25 GNOME 3 amd64
  • Сообщений: 1232
Re: Установка Enlightenment v 0.21.6 и новее
« Ответ #7 : 09 Март 2017, 14:24:37 »
Да, там описана стандартная процедура сборки.
и что, при выполнении команд из этого файла сборка не удаётся?
Мало видеть нам начало - надо видеть и конец. Если видишь ты создание - значит где-то есть ТВОРЕЦ
Многие жалуются: геометрия в жизни не пригодилась. Ямб от хорея им приходится отличать ежедневно?
 

Оффлайн Forum_Liker

  • Topic Author
  • Сообщений: 29
Re: Установка Enlightenment v 0.21.6 и новее
« Ответ #8 : 09 Март 2017, 18:56:07 »
ferum
Вы можете его обновить?
 

Оффлайн ferum

  • Сообщений: 2926
  • wheezy KDE & jessie LXDE & stretch KDE
Re: Установка Enlightenment v 0.21.6 и новее
« Ответ #9 : 09 Март 2017, 19:52:35 »
Думаю что могу но репозиторий эксперименталь  не нужен , мне достаточно исходников с официального сайта. Возможно для jessie потребуется дополнительно собрать пару тройку более свежих библиотек, желания заниматься сейчас для jessie, который вышел два года назад этим вопросом у меня нет так как я собирал 18, 19 и 20 версию просветления для этого релиза debian. Ни чего принципиально нового кроме потери некоторых ( плагинов от сторонних программистов) красивых плюшек, которые я юзал еще на 17 версии : кубик, прыгающие пингвины и прочая ересь в свежих версиях я не увидел.
Собрать на свой компьютер это вопрос 2,5 -3 часов а вот вычислить все сборочные и установочные зависимости и сделать полную дебианизацию для сборки пакетов даже используя готовые шаблоны это достаточно долго и нудно. Бывает ведь и проблемы со сборкой и надо крепко подумать  тем более на оф сайте версии исходников свежее чем в экспериментальной ветке.
Возможно по выходу свежего debian я соберу но только для 64 архитектуры.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн Forum_Liker

  • Topic Author
  • Сообщений: 29
Re: Установка Enlightenment v 0.21.6 и новее
« Ответ #10 : 09 Март 2017, 20:36:27 »
stretch выходит в этом году возможно, если вы будете собирать только для x64, то моего древнему ноуту обновления не видать. Я могу на арче собрать пакет для дебиан х32? Или нужно слишком много библиотек иметь в системе? Вы на какой дистрибутиве собираете?
 

Оффлайн ferum

  • Сообщений: 2926
  • wheezy KDE & jessie LXDE & stretch KDE
Re: Установка Enlightenment v 0.21.6 и новее
« Ответ #11 : 09 Март 2017, 21:14:17 »
Я пользуюсь debian но собираю всё это на виртуальной машине в чистой среде, в принципе если собраны deb-src собрать под другую архитектуру не проблема. Люди вообще арендуют мощности на серверах для сборки пакетов при чём не всегда за это надо платить деньги. У ubuntu есть launchpad и есть сервера open suse где можно получить доступ к kwm но я не загонялся их правилами и порядками.  Считаю что linux вообще и разработка в частности должны приносить пользователю удовлетворение от процесса и не надо особо за чем то гоняться через силу. Сам по себе enlightenment с любым индексом не столь уж ценен как продукт, просто экзотика но процесс сборки его не такой уж сложный и весьма полезный для практики изучения.
Ели вы хотите просто покрутить этот рабочий стол на своём ноутбуке можете просто поставить bodhi linux на основе ubuntu или сборку с enlightenment от sparky linux на основе debian testing этого будет достаточно что бы насладиться всем неудобством и глюковатостью этого оконного менеджера, при всей его красоте и экзотике.
P.S. всё со временем приедается.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн Forum_Liker

  • Topic Author
  • Сообщений: 29
Re: Установка Enlightenment v 0.21.6 и новее
« Ответ #12 : 09 Март 2017, 21:37:00 »
Bodhi установил изначально с его переделанным окружением - Moksha. Ноутбук хочу использовать для просмотра iptv и роликов с ютуба, поэтому главным приоритетом в выборе дистрибутива была скорость загрузки. Bodhi запускается слишком долго. После длительных экспериментов, выбор был сделан в пользу Дебиан и е17. Попробую поискать, где можно собрать пакеты из исходников :)
 

Онлайн Ogis1975

  • OS: Debian 9.4 / WM: Xmonadhttps://github.com/Minda1975/xmonad]Мой Github[/url]
  • Сообщений: 193
  • Debian 9.4 Xmonad
    • Мой github
Re: Установка Enlightenment v 0.21.6 и новее
« Ответ #13 : 10 Март 2017, 15:23:28 »
Попробую поискать, где можно собрать пакеты из исходников
Можете глянуть на Sparky linux, основынный на Debian testing. https://sparkylinux.org/
 

Оффлайн Forum_Liker

  • Topic Author
  • Сообщений: 29
Re: Установка Enlightenment v 0.21.6 и новее
« Ответ #14 : 10 Март 2017, 15:44:02 »
Ogis1975, я имел ввиду удаленно собрать на каком нибудь мощном компьютере, а не в какой ос.
 

Теги: