debian.org / О Debian Где взять Debian Поддержка Уголок разработчика Новости Wiki

Автор Тема: -y was used without --force-yes Debian8 Jessie  (Прочитано 632 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн baisar57

  • Topic Author
  • Сообщений: 4
-y was used without --force-yes Debian8 Jessie
« : 04 Апрель 2017, 20:07:06 »
Здравствуйте друзья,

Не могу установить Vesta на Debian Jessie.
При установке возникает ошибка

После команды
sudo bash vst-install.sh --force
это ошибка
"
There are problems and -y was used without --force-yes
Error: apt-get install failed
"
.
Гуглил, ниче не могу найти.

Помогите плис
« Последнее редактирование: 04 Апрель 2017, 20:18:18 от baisar57 »
 

Оффлайн ferum

  • Сообщений: 3090
  • wheezy KDE & jessie LXDE & stretch KDE
Re: -y was used without --force-yes Debian8 Jessie
« Ответ #1 : 04 Апрель 2017, 21:15:31 »
Что там гуглить то? http://jp-minerals.org/vesta/en/download.html написано на какие дистрибутивы оно расчитано. https://www.digitalocean.com/community/tutorials/how-to-install-vesta-control-panel-on-ubuntu-12-04-lts недвусмысленный намёк на то какой софт должен быть уже установлен в системе. Ошибка же по ходу от того что скрипт не может установить какие то пакеты, собственно не сложно же открыть установочный скрипт любым текстовым редактором и посмотреть чего он вообще хочет или пытается сделать.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн baisar57

  • Topic Author
  • Сообщений: 4
Re: -y was used without --force-yes Debian8 Jessie
« Ответ #2 : 04 Апрель 2017, 22:19:13 »
Спс за ответ.
Я не профи в Linux.

Но я установил Vesta на Debian 8 Jessie. Но это был другой сервер(Debian 8 Jessie).
А мне нужен именно этот сервер. И нужно установить.

Но в этот раз че то не идет. Т.е. установка идет - но через 5-6 сек прерывается сообщением.
--
There are problems and -y was used without --force-yes
Error: apt-get install failed

Но как это решить то?


--
В дебиан устанавливается. Мне раньше хостеры устанавливали 1 раз.
 

Оффлайн ogost

  • Сообщений: 2731
  • Linux Registered User #547151
Re: -y was used without --force-yes Debian8 Jessie
« Ответ #3 : 05 Апрель 2017, 03:25:31 »
В дебиан устанавливается. Мне раньше хостеры устанавливали 1 раз.
так и никто не говорит, что нельзя шуруп молотком забить. уважаемый ferum уже вам подсказал, откройте скрипт установки (это vst-install.sh, если что) любым текстовым редактором, посмотрите какие пакеты он ставит. разумеется, раз софтина для убунты - версии пакетов будут отличаться от тех, что в дебиане.

Оффлайн endru

  • Сообщений: 1546
  • Новосибирск
  • Jabber: endru@jabber.ru
Re: -y was used without --force-yes Debian8 Jessie
« Ответ #4 : 05 Апрель 2017, 05:45:26 »
There are problems and -y was used without --force-yes
Error: apt-get install failed
ругается же на ключи в этом скрипте. нужно посмотреть да поправить! делов то.

Оффлайн baisar57

  • Topic Author
  • Сообщений: 4
Re: -y was used without --force-yes Debian8 Jessie
« Ответ #5 : 05 Апрель 2017, 09:02:04 »
Спс за ваши ответы.
Но это не называется забить шуруп молотком.
Vesta официально поддерживается в Debian. Это написано на сайте Vesta https://vestacp.com/.

Все же спс за советы
 

Оффлайн endru

  • Сообщений: 1546
  • Новосибирск
  • Jabber: endru@jabber.ru
Re: -y was used without --force-yes Debian8 Jessie
« Ответ #6 : 05 Апрель 2017, 09:16:04 »
http://vestacp.com/pub/vst-install.sh - выполняет обнаружение поддерживаемой версии и загружает в дальнейшем нужный скприт, который в случае с debian находится по адресу: http://vestacp.com/pub/vst-install-debian.sh

Cообщение объединено 05 Апрель 2017, 09:29:16
Далее, судя по тому что он ругается на ключ -y, находим строки:
# Install apt packages
apt-get -y install $software
check_result $? "apt-get install failed"
меняем -y на --force-yes
и заново запускаем скрипт.
« Последнее редактирование: 05 Апрель 2017, 09:29:16 от endru »
 

Оффлайн baisar57

  • Topic Author
  • Сообщений: 4
Re: -y was used without --force-yes Debian8 Jessie
« Ответ #7 : 05 Апрель 2017, 09:56:00 »
Endru
Спасибо тебе большое.

Я сейчас переустановил Debian8. И собираюсь настраивать сначала.

Скорее всего установлю Vesta без проблем.

Дам знать что будет.

Cообщение объединено 05 Апрель 2017, 10:06:19
Спс за советы ребята.

Я решил. Vesta прекрасно работает теперь.

После переустановки Debian8 - установилось без проблем.
« Последнее редактирование: 05 Апрель 2017, 10:06:19 от baisar57 »
 

Теги: