debian.org / О Debian Где взять Debian Поддержка Уголок разработчика Новости Wiki

Автор Тема: Библиотеки steam  (Прочитано 3428 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ogis1975

  • OS: Debian 9.4 / WM: Xmonad
  • Местный житель
  • ***
  • Сообщений: 433
  • Debian 9.8 xmonad
    • Мой репозиторий на Github
Re: Библиотеки steam
« Ответ #15 : 22 Май 2018, 16:20:01 »
а потом выдала новую ошибку - Fatal Error: Failed to load steamui.so .  шо делать, пока не пойму
Попробуйте переименовать папку  ~/.steam на .steam-old и запустите клиент снова.
 

Оффлайн trey

  • Debian 9.9 Xfce
  • Пользователь
  • *
  • Сообщений: 24
Re: Библиотеки steam
« Ответ #16 : 22 Май 2018, 16:56:19 »
после переименования и запуска появилась копия (изначальная) . установка вроде пошла, предложили ознакомится с правами, а потом таже ошибка выскакивает  ???

Cообщение объединено 22 Май 2018, 18:17:08
хрень какая то все ровно.  Удалил стим который я с сайта стима скачал(деб пакет), и через терминал apt install steam,. установились все пакеты, загрузка продвинулась, Но в итоге под конец выскакивает всё таже ошибка - Fatal Error: Failed to load steamui.so  ???
Вот гемор то с этим стимом, не когда такого не было  :(!

Cообщение объединено 22 Май 2018, 21:28:54

вот тут  https://linuxconfig.org/how-to-install-steam-client-on-debian-9-stretch-linux нашел тоже самое, там вот перечисление библиотек, собственно они у меня все установлены, тока не все i386.
К примеру  libgdk-pixbuf2.0-0:i386  в поиске СИНАПТИКА так не находит !, находит так - libgdk-pixbuf2.0-0, это одно и тоже ?  ???
« Последнее редактирование: 22 Май 2018, 22:14:11 от trey »
 

Оффлайн ihammers

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 1742
  • Debian GNU/Linux Stretch
    • Алтайская Группа Пользователей Linux
  • Jabber: ihammers@jabber.ru
Re: Библиотеки steam
« Ответ #17 : 28 Май 2018, 15:18:23 »
Странно всё это. Показывайте список репозитариев.
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290
 

Оффлайн trey

  • Debian 9.9 Xfce
  • Пользователь
  • *
  • Сообщений: 24
Re: Библиотеки steam
« Ответ #18 : 04 Июнь 2018, 10:01:23 »
deb http://deb.debian.org/debian/ stretch main
deb-src http://deb.debian.org/debian/ stretch main

deb http://deb.debian.org/debian/ stretch/updates main
deb-src http://deb.debian.org/debian/ stretch/updates main

# stretch-updates, previously known as 'volatile'
deb http://deb.debian.org/debian/ stretch contrib non-free
# deb-src http://httpredir.debian.org/debian/ stretch main contrib non-free
# deb http://deb.debian.org/debian/ stretch contrib
# deb-src http://httpredir.debian.org/debian/ stretch main contrib non-free
deb http://security.debian.org/ stretch/updates contrib non-free main
deb http://deb.debian.org/debian/ stretch-updates non-free main contrib
* Используйте теги, для оформления сообщения, ihammers.

Cообщение объединено 05 Июнь 2018, 19:19:51
« Последнее редактирование: 05 Июнь 2018, 19:20:45 от ihammers »
 

Оффлайн ihammers

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 1742
  • Debian GNU/Linux Stretch
    • Алтайская Группа Пользователей Linux
  • Jabber: ihammers@jabber.ru
Re: Библиотеки steam
« Ответ #19 : 05 Июнь 2018, 19:17:31 »
В списках все нормально. Попробуйте сделать ldd на исполнимый файл (steam):
~$ whereis steam
steam: /usr/games/steam /usr/share/man/man6/steam.6.gz
~$ ldd /usr/games/steam

Возможно чего-то не хватает.
« Последнее редактирование: 05 Июнь 2018, 19:20:24 от ihammers »
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290
 

Оффлайн trey

  • Debian 9.9 Xfce
  • Пользователь
  • *
  • Сообщений: 24
Re: Библиотеки steam
« Ответ #20 : 05 Июнь 2018, 21:22:15 »
после этой команды - ldd /usr/games/steam ,
выдало вот это - не является динамическим исполняемым файлом
 

Русскоязычное сообщество Debian GNU/Linux

Re: Библиотеки steam
« Ответ #20 : 05 Июнь 2018, 21:22:15 »


Теги:
 

Что нужно чтоб, работал Minecraft? Какие библиотеки требует игра?

Автор CPU-550

Ответов: 7
Просмотров: 2162
Последний ответ 09 Ноябрь 2015, 04:04:22
от starlayt
Сторонние библиотеки игр.

Автор serke7771

Ответов: 3
Просмотров: 1155
Последний ответ 14 Май 2017, 22:16:49
от ДядяМиша