debian.org / О Debian Где взять Debian Поддержка Уголок разработчика Новости Wiki

Автор Тема: Принтер HP 1132, pyqt4-dbus?  (Прочитано 2345 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн hohlov_jurii

  • Новичок форума
  • Topic Author
  • Сообщений: 1
Принтер HP 1132, pyqt4-dbus?
« : 09 Май 2017, 16:46:07 »
Принтер HP 1132,  pyqt4-dbus?
Друзья с праздником и прошу Вашей помощи! Debian 8.7, рабочее окружение xfce, не могу установить принтер HP 1132. С самого начала я пробовал с синаптика установить hplip, после установки hplip принтер определился, жму чтобы установить драйвер, клавишу некст, все висит, окошко. Пробовал скачать с сайта hplip, версию 3.17.4, в середине установки пишет:
Installer log saved in: hplip-install_Tue-09-May-2017_15:54:10.log
note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.
error: debian-8.8 version is not supported, so all dependencies may not be installed. However trying to install using debian-8.7 version packages.
Press 'y' to continue auto installation. Press 'n' to quit auto instalation(y=yes, n=no*): y
error: Please enter 'y', 'n', 'q' or press <enter> for the default of 'n'.
Press 'y' to continue auto installation. Press 'n' to quit auto instalation(y=yes, n=no*):
В конце установки пишет:
DEPENDENCY AND CONFLICT RESOLUTION
error: A required dependency 'pyqt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)' is still missing.
error: A required dependency 'pyqt4 (PyQt 4- Qt interface for Python (for Qt version 4.x))' is still missing.
Поодскажите куда копать?
 

Оффлайн Jenas

  • Новичок форума
  • Сообщений: 2
Re: Принтер HP 1132, pyqt4-dbus?
« Ответ #1 : 17 Май 2017, 20:22:07 »
У меня та же проблема. И она появилась именно после обновления до 8.8, на 8.6 hplip нормально ставится, и по-моему даже на 8.7 (не на 100% помню). Возможно у вас изначально устанавливался 8.7, а потом вы его обновили до 8.8... В любом случае, подозреваю что придется ждать обновления hplip и наверняка это будет не очень скоро....
« Последнее редактирование: 17 Май 2017, 20:25:22 от Jenas »
 

Оффлайн ihammers

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 1742
  • Debian GNU/Linux Stretch
    • Алтайская Группа Пользователей Linux
  • Jabber: ihammers@jabber.ru
Re: Принтер HP 1132, pyqt4-dbus?
« Ответ #2 : 18 Май 2017, 15:41:14 »
Пробовали ли запускать в терминале hp-check? Все ли пакеты установлены, которые требуются для HP?
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290
 

Оффлайн Jenas

  • Новичок форума
  • Сообщений: 2
Re: Принтер HP 1132, pyqt4-dbus?
« Ответ #3 : 18 Май 2017, 20:21:09 »
Пробовал, проблема  том, что : DEPENDENCY AND CONFLICT RESOLUTION
error: A required dependency 'pyqt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)' is still missing.
error: A required dependency 'pyqt4 (PyQt 4- Qt interface for Python (for Qt version 4.x))' is still missing., и версий этих двух пакетов для D 8.8 как я понимаю, пока нет, по-крайней мере в официальных репозитариях они не находятся. apt-get install -f соотв. тоже ничего не дает. Ну и при начале установки вообще hplip прямо говорит, что версия 8.8 не поддерживается данным установщиком, и он попробует воткнуть пакеты для 8.7
« Последнее редактирование: 18 Май 2017, 20:24:36 от Jenas »
 

Оффлайн ihammers

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 1742
  • Debian GNU/Linux Stretch
    • Алтайская Группа Пользователей Linux
  • Jabber: ihammers@jabber.ru
Re: Принтер HP 1132, pyqt4-dbus?
« Ответ #4 : 30 Май 2017, 05:46:16 »
Пробовал, проблема  том, что : DEPENDENCY AND CONFLICT RESOLUTION
Показывайте вывод следующих команд, если ещё проблема актуальна:
~$ dpkg -l python\* | grep qt | grep ^i
~$ dpkg -l \*hplip\* | grep ^i
~$ dpkg -l \*hp\* | grep ^i
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290
 

Оффлайн kolyacher

  • Новичок форума
  • Сообщений: 3
  • Jabber: kolyacher@jabber.ru
Re: Принтер HP 1132, pyqt4-dbus?
« Ответ #5 : 06 Сентябрь 2018, 08:14:34 »
Проблема та же, помогите пожайлуйста...

admin1@debian9:~/progi/hplip$ dpkg -l python\* | grep qt | grep ^i
ii  python-dbus.mainloop.pyqt5                5.7+dfsg-5             amd64        D-Bus Qt main loop support for Python 2
ii  python-pyqt5                              5.7+dfsg-5             amd64        Python 2 bindings for Qt5
ii  python-pyside.qtcore                      1.2.2-2+b1             amd64        Qt 4 core module - Python bindings
ii  python-pyside.qtdeclarative               1.2.2-2+b1             amd64        Qt 4 Declarative module - Python bindings
ii  python-pyside.qtgui                       1.2.2-2+b1             amd64        Qt 4 GUI module - Python bindings
ii  python-pyside.qthelp                      1.2.2-2+b1             amd64        Qt 4 help module - Python bindings
ii  python-pyside.qtnetwork                   1.2.2-2+b1             amd64        Qt 4 network module - Python bindings
ii  python-pyside.qtopengl                    1.2.2-2+b1             amd64        Qt 4 OpenGL module - Python bindings
ii  python-pyside.qtscript                    1.2.2-2+b1             amd64        Qt 4 script module - Python bindings
ii  python-pyside.qtsql                       1.2.2-2+b1             amd64        Qt 4 SQL module - Python bindings
ii  python-pyside.qtsvg                       1.2.2-2+b1             amd64        Qt 4 SVG module - Python bindings
ii  python-pyside.qttest                      1.2.2-2+b1             amd64        Qt 4 test module - Python bindings
ii  python-pyside.qtuitools                   1.2.2-2+b1             amd64        Qt 4 UI tools module - Python bindings
ii  python-pyside.qtwebkit                    1.2.2-2+b1             amd64        Qt 4 WebKit module - Python bindings
ii  python-pyside.qtxml                       1.2.2-2+b1             amd64        Qt 4 XML module - Python bindings
ii  python-qt4                                4.11.4+dfsg-2+b1       amd64        Python bindings for Qt4
ii  python-qt4-dbus                           4.11.4+dfsg-2+b1       amd64        D-Bus Support for PyQt4
ii  python-qt4-dev                            4.11.4+dfsg-2          all          Development files for PyQt4
ii  python-qt4-gl                             4.11.4+dfsg-2+b1       amd64        Python bindings for Qt4's OpenGL module
ii  python3-dbus.mainloop.pyqt5               5.7+dfsg-5             amd64        D-Bus Qt main loop support for Python 3
ii  python3-dbus.mainloop.qt                  4.11.4+dfsg-2+b1       amd64        D-Bus Support for PyQt4 with Python 3
ii  python3-pyqt4                             4.11.4+dfsg-2+b1       amd64        Python3 bindings for Qt4
ii  python3-pyqt5                             5.7+dfsg-5             amd64        Python 3 bindings for Qt5


Cообщение объединено 06 Сентябрь 2018, 08:15:34
Пробовал, проблема  том, что : DEPENDENCY AND CONFLICT RESOLUTION
Показывайте вывод следующих команд, если ещё проблема актуальна:
~$ dpkg -l python\* | grep qt | grep ^i
~$ dpkg -l \*hplip\* | grep ^i
~$ dpkg -l \*hp\* | grep ^i

admin1@debian9:~/progi/hplip$ dpkg -l \*hplip\* | grep ^i
ii  hplip          3.16.11+repack0-3 amd64        HP Linux Printing and Imaging System (HPLIP)
ii  hplip-data     3.16.11+repack0-3 all          HP Linux Printing and Imaging - data files
ii  hplip-gui      3.16.11+repack0-3 all          HP Linux Printing and Imaging - GUI utilities (Qt-based)


Cообщение объединено 06 Сентябрь 2018, 08:16:41
Пробовал, проблема  том, что : DEPENDENCY AND CONFLICT RESOLUTION
Показывайте вывод следующих команд, если ещё проблема актуальна:
~$ dpkg -l python\* | grep qt | grep ^i
~$ dpkg -l \*hplip\* | grep ^i
~$ dpkg -l \*hp\* | grep ^i
~$ dpkg -l \*hp\* | grep ^i
admin1@debian9:~/progi/hplip$ dpkg -l \*hp\* | grep ^i
ii  hp-ppd                       0.9-0.3                     all          HP Postscript Printer Definition (PPD) files
ii  hplip                        3.16.11+repack0-3           amd64        HP Linux Printing and Imaging System (HPLIP)
ii  hplip-data                   3.16.11+repack0-3           all          HP Linux Printing and Imaging - data files
ii  hplip-gui                    3.16.11+repack0-3           all          HP Linux Printing and Imaging - GUI utilities (Qt-based)
ii  kdevelop-php                 5.0.3-1                     amd64        PHP plugin for KDevelop
ii  kdevelop-php-docs-l10n       5.0.3-1                     all          transitional package for kdevelop-php-l10n
ii  kdevelop-php-l10n            5.0.3-1                     all          localization files for KDevelop PHP plugin
ii  libapache2-mod-php           1:7.0+49                    all          server-side, HTML-embedded scripting language (Apache 2 module) (default)
ii  libapache2-mod-php7.0        7.0.30-0+deb9u1             amd64        server-side, HTML-embedded scripting language (Apache 2 module)
ii  libhpmud0:amd64              3.16.11+repack0-3           amd64        HP Multi-Point Transport Driver (hpmud) run-time libraries
ii  libhpmud0:i386               3.16.11+repack0-3           i386         HP Multi-Point Transport Driver (hpmud) run-time libraries
ii  libpathplan4                 2.38.0-17                   amd64        rich set of graph drawing tools - pathplan library
ii  libsane-hpaio:amd64          3.16.11+repack0-3           amd64        HP SANE backend for multi-function peripherals
ii  libsane-hpaio:i386           3.16.11+repack0-3           i386         HP SANE backend for multi-function peripherals
ii  mathpiper                    0.81f+svn4469+dfsg3-3       all          Java Computer Algebra System
ii  php                          1:7.0+49                    all          server-side, HTML-embedded scripting language (default)
ii  php-bz2                      1:7.0+49                    all          bzip2 module for PHP [default]
ii  php-common                   1:49                        all          Common files for PHP packages
ii  php-curl                     1:7.0+49                    all          CURL module for PHP [default]
ii  php-mbstring                 1:7.0+49                    all          MBSTRING module for PHP [default]
ii  php-mcrypt                   1:7.0+49                    all          libmcrypt module for PHP [default]
ii  php-mysql                    1:7.0+49                    all          MySQL module for PHP [default]
ii  php-pear                     1:1.10.1+submodules+notgz-9 all          PEAR Base System
ii  php-php-gettext              1.0.12-0.1                  all          read gettext MO files directly, without requiring anything other than PHP
ii  php-phpseclib                2.0.4-1                     all          implementations of an arbitrary-precision integer arithmetic library
ii  php-soap                     1:7.0+49                    all          SOAP module for PHP [default]
ii  php-tcpdf                    6.2.12+dfsg2-1              all          PHP class for generating PDF files on-the-fly
ii  php-xml                      1:7.0+49                    all          DOM, SimpleXML, WDDX, XML, and XSL module for PHP [default]
ii  php-xmlrpc                   1:7.0+49                    all          XMLRPC-EPI module for PHP [default]
ii  php7.0                       7.0.30-0+deb9u1             all          server-side, HTML-embedded scripting language (metapackage)
ii  php7.0-bz2                   7.0.30-0+deb9u1             amd64        bzip2 module for PHP
ii  php7.0-cli                   7.0.30-0+deb9u1             amd64        command-line interpreter for the PHP scripting language
ii  php7.0-common                7.0.30-0+deb9u1             amd64        documentation, examples and common module for PHP
ii  php7.0-curl                  7.0.30-0+deb9u1             amd64        CURL module for PHP
ii  php7.0-json                  7.0.30-0+deb9u1             amd64        JSON module for PHP
ii  php7.0-mbstring              7.0.30-0+deb9u1             amd64        MBSTRING module for PHP
ii  php7.0-mcrypt                7.0.30-0+deb9u1             amd64        libmcrypt module for PHP
ii  php7.0-mysql                 7.0.30-0+deb9u1             amd64        MySQL module for PHP
ii  php7.0-opcache               7.0.30-0+deb9u1             amd64        Zend OpCache module for PHP
ii  php7.0-readline              7.0.30-0+deb9u1             amd64        readline module for PHP
ii  php7.0-soap                  7.0.30-0+deb9u1             amd64        SOAP module for PHP
ii  php7.0-xml                   7.0.30-0+deb9u1             amd64        DOM, SimpleXML, WDDX, XML, and XSL module for PHP
ii  php7.0-xmlrpc                7.0.30-0+deb9u1             amd64        XMLRPC-EPI module for PHP
ii  phpmyadmin                   4:4.6.6-4                   all          MySQL web administration tool
ii  printer-driver-hpcups        3.16.11+repack0-3           amd64        HP Linux Printing and Imaging - CUPS Raster driver (hpcups)
ii  printer-driver-hpijs         3.16.11+repack0-3           amd64        HP Linux Printing and Imaging - printer driver (hpijs)
ii  printer-driver-postscript-hp 3.16.11+repack0-3           all          HP Printers PostScript Descriptions
ii  python-launchpadlib          1.10.4-1     
« Последнее редактирование: 06 Сентябрь 2018, 08:17:44 от kolyacher »
 

Оффлайн ihammers

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 1742
  • Debian GNU/Linux Stretch
    • Алтайская Группа Пользователей Linux
  • Jabber: ihammers@jabber.ru
Re: Принтер HP 1132, pyqt4-dbus?
« Ответ #6 : 01 Октябрь 2018, 11:19:01 »
Проблема та же, помогите пожайлуйста...
Показывайте вывод hp-check.
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290
 

Оффлайн PbI6A

  • Старожил
  • ****
  • Сообщений: 809
  • просто я так выгляжу!
Re: Принтер HP 1132, pyqt4-dbus?
« Ответ #7 : 04 Декабрь 2018, 11:53:42 »
Может, чуть не в тему... У меня тут принтеры hp перестали печатать. И 1505, и 1100, на разных компах. Первый - софтовый, второй - аппаратный. Симптомы одинаковые, отправляешь что-то на печать, принтер чпокает и ничего не печатается. Задание откладывается, через некоторое время можно попробовать отправить его заново, снова чпокает - и ничего. Поискал в интернетах разное, нашёл:
hp-check -t
Запустил, оно выругалость что не хватает кучи всего. Поставил кучу всего, что оно хотело, перезапустил cups - чпокает - и ничего. Стал читать дальше, вычитал про запуск из-под иксов:
hp-setup
Потыкал дальше-дальше, написал пароль root-а, чтобы поставились плагины - и стало печататься!
LINUX means: Linux Is Not a UniX
 

Оффлайн Александр

  • Новичок форума
  • Сообщений: 6
  • предпочитаю Linux
Re: Принтер HP 1132, pyqt4-dbus?
« Ответ #8 : 06 Декабрь 2018, 17:56:40 »
Здравствуйте!
У меня Дебиан 9, принтер HP LJ P1005, никаких специальных драйверов не устанавливал. Система показывает , что принтер видит. Но печати нет.
Вот вывод команды hp-check
Saving output in log file: /home/ayi/hp-check.log

HP Linux Imaging and Printing System (ver. 3.16.11)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the
HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
are installed to successfully compile HPLIP.                                   
2. Run-time check mode (-r or --run): Use this mode to determine if a distro   
supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball   
has the proper dependencies installed to successfully run.                     
3. Both compile- and run-time check mode (-b or --both) (Default): This mode   
will check both of the above cases (both compile- and run-time dependencies).   

Check types:                                                                   
a. EXTERNALDEP - External Dependencies                                         
b. GENERALDEP - General Dependencies (required both at compile and run time)   
c. COMPILEDEP - Compile time Dependencies                                       
d. [All are run-time checks]                                                   
PYEXT SCANCONF QUEUES PERMISSION                                               

Status Types:
    OK
    MISSING       - Missing Dependency or Permission or Plug-in
    INCOMPAT      - Incompatible dependency-version or Plugin-version

warning: 2-9.6 version is not supported. Using 2-8.6 versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

 Kernel: 4.9.0-8-amd64 #1 SMP Debian 4.9.130-2 (2018-10-27) GNU/Linux
 Host: S57D
 Proc: 4.9.0-8-amd64 #1 SMP Debian 4.9.130-2 (2018-10-27) GNU/Linux
 Distribution: 2 9.6
 Bitness: 64 bit


-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.16.11
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for 2 distro  9.6 version

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf.  Generated from hplip.conf.in by configure.

[hplip]
version=3.16.11

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/hplip/HP
ppdbase=/usr/share/ppd/hplip
doc=/usr/share/doc/hplip
html=/usr/share/doc/hplip-doc
icon=no
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=yes
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=yes
foomatic-drv-install=yes
foomatic-ppd-install=yes
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.16.11
restricted-build=no
ui-toolkit=qt5
qt3=no
qt4=no
qt5=yes
policy-kit=yes
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=no


Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: No such file or directory

Current contents of '~/.hplip/hplip.conf' file:
warning: Could not access file: No such file or directory
 <Package-name>        <Package-Desc>      <Required/Optional> <Min-Version> <Installed-Version> <Status>   <Comment>

---------------------
| Python Extentions |
---------------------

 hpmudext             IO-Extension                                                 REQUIRED        -               3.16.11         OK         -
 cupsext              CUPS-Extension                                               REQUIRED        -               3.16.11         OK         -

----------------------
| Scan Configuration |
----------------------

 scanext              Scan-SANE-Extension                                          REQUIRED        -               3.16.11         OK         -
'/etc/sane.d/dll.d/hpaio' not found.
 hpaio                HPLIP-SANE-Backend                                           REQUIRED        -               3.16.11         OK         'hpaio found in /etc/sane.d/dll.conf'

--------------
| COMPILEDEP |
--------------

 error: make          make - GNU make utility to maintain groups of programs       REQUIRED        3.0             -               MISSING    'make needs to be installed'
 error: gcc           gcc - GNU Project C and C++ Compiler                         REQUIRED        -               -               MISSING    'gcc needs to be installed'
 error: libtool       libtool - Library building support services                  REQUIRED        -               -               MISSING    'libtool needs to be installed'

------------------------
| General Dependencies |
------------------------

 error: libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED        5.0.9           -               MISSING    'libnetsnmp-devel needs to be installed'
 cups-ddk             CUPS DDK - CUPS driver development kit                       OPTIONAL        -               -               OK         -
 python3-dbus         Python DBus - Python bindings for DBus                       REQUIRED        0.80.0          1.2.4           OK         -
 python3X             Python 2.2 or greater - Python programming language          REQUIRED        2.2             3.5.3           OK         -
 error: sane-devel    SANE - Scanning library development files                    REQUIRED        -               -               MISSING    'sane-devel needs to be installed'
 python3-xml          Python XML libraries                                         REQUIRED        -               2.2.0           OK         -
 error: libpthread    libpthread - POSIX threads library                           REQUIRED        -               b'2.24'         MISSING    'libpthread needs to be installed'
 sane                 SANE - Scanning library                                      REQUIRED        -               -               OK         -
 error: libjpeg       libjpeg - JPEG library                                       REQUIRED        -               -               MISSING    'libjpeg needs to be installed'
 python3-pil          PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL        -               1.1.7           OK         -
 error: python3-devel Python devel - Python development files                      REQUIRED        2.2             3.5.3           MISSING    'python3-devel needs to be installed'
 error: libcrypto     libcrypto - OpenSSL cryptographic library                    REQUIRED        -               1.1.0           MISSING    'libcrypto needs to be installed'
 error: cups-devel    CUPS devel- Common Unix Printing System development files    REQUIRED        -               -               MISSING    'cups-devel needs to be installed'
 error: libusb        libusb - USB library                                         REQUIRED        -               1.0             MISSING    'libusb needs to be installed'
 error: python3-pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4                         OPTIONAL        4.0             -               MISSING    'python3-pyqt4-dbus needs to be installed'
 error: cups-image    CUPS image - CUPS image development files                    REQUIRED        -               -               MISSING    'cups-image needs to be installed'
 python3-reportlab    Reportlab - PDF library for Python                           OPTIONAL        2.0             3.3.0           OK         -
 error: python3-pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x)         REQUIRED        4.0             -               MISSING    'python3-pyqt4 needs to be installed'
 error: python3-notify2 Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL        -               -               MISSING    'python3-notify2 needs to be installed'

-------------------------
| External Dependencies |
-------------------------

 scanimage            scanimage - Shell scanning program                           OPTIONAL        1.0             1.0.25          OK         -
 policykit            PolicyKit - Administrative policy framework                  OPTIONAL        -               0.105           OK         -
 error: xsane         xsane - Graphical scanner frontend for SANE                  OPTIONAL        0.9             -               MISSING    'xsane needs to be installed'
 error: dbus          DBus - Message bus system                                    REQUIRED        -               1.10.26         MISSING    'DBUS may not be installed or not running'
 gs                   GhostScript - PostScript and PDF language interpreter and previewer REQUIRED        7.05            9.26            OK         -
 network              network -wget                                                OPTIONAL        -               1.18            OK         -
 error: avahi-utils   avahi-utils                                                  OPTIONAL        -               -               MISSING    'avahi-utils needs to be installed'
 error: cups          CUPS - Common Unix Printing System                           REQUIRED        1.1             -               INCOMPAT   'CUPS may not be installed or not running'

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

No Scanner found.

--------------------------
| DISCOVERED USB DEVICES |
--------------------------

  Device URI                        Model           
  --------------------------------  -----------------
  hp:/usb/HP_LaserJet_P1005?serial  HP LaserJet P1005
  =BB091L7                                           

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

 
HP-LaserJet-P1005
-----------------
Type: Printer
Device URI: hp:/usb/HP_LaserJet_P1005?serial=BB091L7
PPD: /etc/cups/ppd/HP-LaserJet-P1005.ppd
PPD Description: HP LaserJet P1005 Foomatic/foo2xqx (recommended)
Printer status: принтер HP-LaserJet-P1005 свободен. Включен с момента Чт 06 дек 2018 17:40:41
error: Required plug-in status: Not installed
Communication status: Good


--------------
| PERMISSION |
--------------

USB             HP-LaserJet-P1005              Required        -        -        OK       Node:'/dev/bus/usb/010/003' Perm:'  root  lp rw- rw- rw- rw- rw- r--'
 
-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
error: 'make' package is missing/incompatible
error: 'g++' package is missing/incompatible
error: 'libtool' package is missing/incompatible
error: 'libtool-bin' package is missing/incompatible
error: 'libsnmp-dev' package is missing/incompatible
error: 'snmp' package is missing/incompatible
error: 'libsane-dev' package is missing/incompatible
error: 'libc6' package is missing/incompatible
error: 'libjpeg62-turbo-dev' package is missing/incompatible
error: 'python3-dev' package is missing/incompatible
error: 'libssl-dev' package is missing/incompatible
error: 'libcups2-dev' package is missing/incompatible
error: 'cups-bsd' package is missing/incompatible
error: 'cups-client' package is missing/incompatible
error: 'libusb-1.0.0-dev' package is missing/incompatible
error: 'libcupsimage2' package is missing/incompatible
error: 'libcupsimage2-dev' package is missing/incompatible
error: 'python3-pyqt4' package is missing/incompatible
error: 'gtk2-engines-pixbuf' package is missing/incompatible
error: 'libdbus-1-dev' package is missing/incompatible
error: 'cups' package is missing or 'cups' service is not running.
error: 'libcups2' package is missing/incompatible

Missing Optional Dependencies
-----------------------------
error: 'python3-dbus.mainloop.qt' package is missing/incompatible
error: 'python3-notify2' package is missing/incompatible
error: 'xsane' package is missing/incompatible
error: 'avahi-utils' package is missing/incompatible

Plug-in Status
--------------
error: Plug-ins need to be installed

Total Errors: 20
Total Warnings: 1


Done.
Помогите, пожалуйста, довести до ума принтер. :-\
Debian 64 bit
 

Оффлайн ChubaDuba

  • Местный житель
  • ***
  • Сообщений: 479
  • Debian 9 + Xmonad
  • Jabber: achubakov@jabber.ru
Re: Принтер HP 1132, pyqt4-dbus?
« Ответ #9 : 06 Декабрь 2018, 21:33:51 »
error: 'cups' package is missing or 'cups' service is not running
CUPS - сервер печати установлен в системе?
 

Оффлайн svtv1

  • Местный житель
  • ***
  • Сообщений: 147
  • это я, Debian 9 Mate.
Re: Принтер HP 1132, pyqt4-dbus?
« Ответ #10 : 06 Декабрь 2018, 23:21:34 »
DEPENDENCY AND CONFLICT RESOLUTION-ЗАВИСИМОСТЬ И РАЗРЕШЕНИЕ КОНФЛИКТОВ
sudo apt install -f
Пробовал, а дальше, что скажет?
"Если достаточно долго сидеть возле реки - мимо проплывет труп твоего врага"
 

Оффлайн Александр

  • Новичок форума
  • Сообщений: 6
  • предпочитаю Linux
Re: Принтер HP 1132, pyqt4-dbus?
« Ответ #11 : 07 Декабрь 2018, 20:52:46 »
CUPS - сервер печати установлен в системе?
Да. При поиске в Синаптике выдаёт
Цитировать
Общая система печати в UNIX (английское сокращение CUPS™) — система печати,
заменяющая lpd и другие подобные утилиты. Она поддерживает протокол печати в
Интернет (IPP) и имеет свою собственную модель обрабатывающих драйверов для
работы с различными типами документов.
Пакет предоставляет части CUPS, которые требуются для использования
Debian 64 bit
 

Оффлайн Александр

  • Новичок форума
  • Сообщений: 6
  • предпочитаю Linux
Re: Принтер HP 1132, pyqt4-dbus?
« Ответ #12 : 08 Январь 2019, 15:59:20 »
Всё хорошо, установился!
Честно признаюсь сам не до конца понимаю как это вышло. Включил принтер уже при работающем компьютере (разумеется кабель USB был присоединён к системнику). Выскочило окно с предложением обновить программное обеспечение. Я дал согласие, ввёл пароль администратора и вуаля! Распечатал первую страницу!
[/url]
Debian 64 bit
 

Оффлайн Olej

  • Местный житель
  • ***
  • Сообщений: 405
Re: Принтер HP 1132, pyqt4-dbus?
« Ответ #13 : 15 Январь 2019, 18:15:13 »
Выскочило окно с предложением обновить программное обеспечение.
windows way - наше фсё!  ;D
 

Русскоязычное сообщество Debian GNU/Linux

Re: Принтер HP 1132, pyqt4-dbus?
« Ответ #13 : 15 Январь 2019, 18:15:13 »


Теги:
 

Принтер HP 1020

Автор Fire

Ответов: 4
Просмотров: 4812
Последний ответ 27 Ноябрь 2012, 15:24:30
от robber
Через шару не подключается принтер, после добавленмия в группу(class)

Автор Iflex

Ответов: 1
Просмотров: 1557
Последний ответ 11 Март 2013, 20:06:50
от Iflex
Принтер перестал печатать HP LaserJet 1018

Автор temakonkin

Ответов: 8
Просмотров: 3712
Последний ответ 02 Март 2015, 09:42:34
от gardarea51
[Решено] Принтер HP LaserJet 400 на Debian 8.1

Автор x1Debian

Ответов: 0
Просмотров: 844
Последний ответ 22 Август 2015, 09:01:50
от x1Debian
Возможно принтер НР laserJet 1100 не подключен

Автор san06

Ответов: 2
Просмотров: 610
Последний ответ 08 Сентябрь 2017, 11:57:28
от san06