debian.org / О Debian Где взять Debian Поддержка Уголок разработчика Новости Wiki

Автор Тема: Debian9 и PHP5.6  (Прочитано 886 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн n0m4d

  • Topic Author
  • Сообщений: 20
  • Debian 9 x64 & LMDE 3 x64 Cinnamon
  • Jabber: n0m4dv@jabber.ru
Debian9 и PHP5.6
« : 17 Декабрь 2017, 02:06:46 »
Спасибо, разобрался, тему можно закрывать. В консоли суперпользователя немного команд:
Воизбежание конфликта следует удалить php который стоит в системе
apt purge php*

apt-get install apt-transport-https lsb-release ca-certificates
wget -O /etc/apt/trusted.gpg.d/php.gpg https://packages.sury.org/php/apt.gpg
echo "deb https://packages.sury.org/php/ $(lsb_release -sc) main" > /etc/apt/sources.list.d/php.list

apt update
apt install php5.6
apt install php7.1
apt install php7.2

update-alternatives --config php


sudo a2dismod php7.2  && sudo a2enmod php5.6 && sudo service apache2 restart

sudo a2dismod php5.6  && sudo a2enmod php7.2 && sudo service apache2 restart

Веб-сервер. [Apache2, MySQL, php5, phpmyadmin /etc]
« Последнее редактирование: 06 Май 2018, 01:43:28 от n0m4d »
 

Теги: