debian.org / О Debian Где взять Debian Поддержка Уголок разработчика Новости Wiki

Автор Тема: php5-pgsql  (Прочитано 447 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн tomson131

  • Новичок форума
  • Topic Author
  • Сообщений: 1
php5-pgsql
« : 07 Май 2018, 16:03:29 »
Помогите разобраться

Стоит Debian 8.7
PHP 5.6.30-1~dotdeb и работает php5-fpm
поставил postgresql но не могу установить драйвер для pdo
при установке  sudo apt-get install php5-pgsql
выдает
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 php5-pgsql : Depends: phpapi-20100525
              Depends: php5-common (= 5.4.45-1~dotdeb+7.1) but 5.6.36-1~dotdeb+7.1 is to be installed
E: Unable to correct problems, you have held broken packages.

Попробовал с фиксом: sudo aptitude install php5.6-pgsql
Но предлагает даунгрейд php и удаление php5-fpm


      Remove the following packages:
1)      php5-fpm

      Downgrade the following packages:
2)      php5-cli [5.6.30-1~dotdeb+7.1 (now, wheezy-php56) -> 5.4.45-1~dotdeb+7.1 (wheezy)]
3)      php5-common [5.6.30-1~dotdeb+7.1 (now, wheezy-php56) -> 5.4.45-1~dotdeb+7.1 (wheezy)]
4)      php5-curl [5.6.30-1~dotdeb+7.1 (now, wheezy-php56) -> 5.4.45-1~dotdeb+7.1 (wheezy)]
5)      php5-gd [5.6.30-1~dotdeb+7.1 (now, wheezy-php56) -> 5.4.45-1~dotdeb+7.1 (wheezy)]
6)      php5-geoip [1:1.0.8-2~dotdeb+7.1 (now, wheezy-php56) -> 5.4.45-1~dotdeb+7.1 (wheezy)]
7)      php5-imagick [1:3.1.2-2~dotdeb+7.1 (now, wheezy-php56) -> 5.4.45-1~dotdeb+7.1 (wheezy)]
8)      php5-mcrypt [5.6.30-1~dotdeb+7.1 (now, wheezy-php56) -> 5.4.45-1~dotdeb+7.1 (wheezy)]
9)      php5-memcache [1:3.0.8-2~dotdeb+7.1 (now, wheezy-php56) -> 5.4.45-1~dotdeb+7.1 (wheezy)]
10)     php5-memcached [1:2.2.0-2~dotdeb+7.1 (now, wheezy-php56) -> 5.4.45-1~dotdeb+7.1 (wheezy)]
11)     php5-mysqlnd [5.6.30-1~dotdeb+7.1 (now, wheezy-php56) -> 5.4.45-1~dotdeb+7.1 (wheezy)]
12)     php5-readline [5.6.30-1~dotdeb+7.1 (now, wheezy-php56) -> 5.4.45-1~dotdeb+7.1 (wheezy)]
как бы безболезненно поставить драйвер для pdo?
« Последнее редактирование: 08 Май 2018, 03:23:17 от ogost »
 

Оффлайн ogost

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 2762
  • Linux Registered User #547151
Re: php5-pgsql
« Ответ #1 : 08 Май 2018, 03:26:50 »
По всей видимости использовались сторонние источники. Извиняюсь, но в Дебиане такой подход не рекомендуют.

Русскоязычное сообщество Debian GNU/Linux

Re: php5-pgsql
« Ответ #1 : 08 Май 2018, 03:26:50 »


Теги:
 

Установил PHP. Не появилось php5.conf php5.load

Автор booksmaster

Ответов: 4
Просмотров: 844
Последний ответ 06 Июль 2015, 10:10:24
от booksmaster