debian.org / О Debian Где взять Debian Поддержка Уголок разработчика Новости Wiki

Автор Тема: Проблемы со звуком на виртуальной машине (Debian 9.3+VirtualBox+Xp)  (Прочитано 625 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн LittleTroubleMaker

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 23
Здравствуйте. Есть комп, на котором стоит Debian 9.3. Поставил туда VirtualBox, установил Хр (для старых игр типа BG, HoMM 3, Fallout). И тут меня ждал облом: игры серьезно подтормаживали + звук был какой-то дерганный что-ли( И это не только с играми, с аудиофайлами такая-же проблема. Как я выяснил - это только на Linux-хосте, тк на Win7+VirtualBox+Xp таких проблем не наблюдаеться. Ставить другую систему рядом с Debian не хочу. Помогите решить проблему
« Последнее редактирование: 27 Май 2018, 13:52:32 от LittleTroubleMaker »
 

Оффлайн ChubaDuba

  • Местный житель
  • ***
  • Сообщений: 456
  • Debian 9 + Xmonad
  • Jabber: achubakov@jabber.ru
Игрушки под DOS?
 

Оффлайн LittleTroubleMaker

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 23
@ChubaDuba Для Windows (нетребовательная классика, что без проблем идет на VirtualBox
PS Еще попробую 98se поставить, посмотрю, что будет
 

Оффлайн ChubaDuba

  • Местный житель
  • ***
  • Сообщений: 456
  • Debian 9 + Xmonad
  • Jabber: achubakov@jabber.ru
Скриншот покажите с натройками звука в VirtualBox
 

Оффлайн LittleTroubleMaker

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 23
Вот скрин
PS Поставил драйвер на звуковую карту Realtek 4.06 -звук вообще пропал((( Видео как подтормаживало тогда, подтормаживает и сейчас(((
« Последнее редактирование: 27 Май 2018, 19:30:38 от LittleTroubleMaker »
 

Оффлайн ChubaDuba

  • Местный житель
  • ***
  • Сообщений: 456
  • Debian 9 + Xmonad
  • Jabber: achubakov@jabber.ru
У меня установлен VirtualBox 5.0.40.
Настройки вот такие:

Проблем со звуком нет.

Cообщение объединено 27 Май 2018, 19:45:48
В Windows XP:
« Последнее редактирование: 27 Май 2018, 19:45:48 от ChubaDuba »
 

Оффлайн LittleTroubleMaker

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 23
Вроде настройки такие же( Завтра попробую переустановить Хр, если будут те же проблемы - поставлю 98. Посмотрю что будет. Ужас как не хочеться ставить ради ТОЛЬКО игр другую операционку рядом с Линукс.
@ChubaDuba спасибо за советы
 

Оффлайн ChubaDuba

  • Местный житель
  • ***
  • Сообщений: 456
  • Debian 9 + Xmonad
  • Jabber: achubakov@jabber.ru
Вроде настройки такие же
У вас на хосте PulseAudio...
 

Оффлайн LittleTroubleMaker

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 23
@ChubaDuba Ага, вижу. Поменял на ALSA Audio Driver - ничего не поменялось(
Перепробовал разные комбинации - ничего не помогает :'( Такое ощущение на гостевой системе, когда запускаю игру, будто проц и винчестер там постоянно загружены на 100% Еще раз повторюсь: точно так же все делал на 7 - все было гут. хз что не так(((
 

Оффлайн ChubaDuba

  • Местный житель
  • ***
  • Сообщений: 456
  • Debian 9 + Xmonad
  • Jabber: achubakov@jabber.ru
Если вам уж очень не хочется dual boot, я бы на вашем месте попробовал разные варианты побороться. Если вы ставите виртуалку из репозитория, то там три версии. Можно попробовать перебрать их. Я по своим ощущениям решил, что для XP и 7 мне больше версии 5.0 не требуется. Можно попробовать удалить pulseaudio из системы и попробовать с голой alsa.
Off-Topic: ShowHide

В игрушки я не играю, но бывает делаю слайд шоу из фотографий. Со звуком всё в полном порядке.
« Последнее редактирование: 27 Май 2018, 23:01:10 от ChubaDuba »
 

Оффлайн LittleTroubleMaker

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 23
Все перепробовал: Хр, 98, 7, разные настройки, удалял pulse - ничего не помогает ??? :'( Хз что не так(((((
 

Оффлайн ChubaDuba

  • Местный житель
  • ***
  • Сообщений: 456
  • Debian 9 + Xmonad
  • Jabber: achubakov@jabber.ru
Разные версии VirtualBox пробовали?
С драйвером SoundBlaster 16 тоже стоит попробовать.
« Последнее редактирование: 30 Май 2018, 12:49:43 от ChubaDuba »
 

Русскоязычное сообщество Debian GNU/Linux



Теги:
 

wine - проблемы с удалением пакета

Автор k0matoznik

Ответов: 3
Просмотров: 1065
Последний ответ 13 Август 2016, 09:32:38
от ferum
Проблемы с авторизацией после переноса с контейнера OpenVZ

Автор Osoro

Ответов: 2
Просмотров: 897
Последний ответ 29 Март 2015, 23:52:00
от Osoro
проблемы с Virt-Install(установка KVM)

Автор Alexander_nsk

Ответов: 4
Просмотров: 1800
Последний ответ 24 Апрель 2013, 07:30:11
от PbI6A
Проблемы с LXC

Автор ekso

Ответов: 2
Просмотров: 1565
Последний ответ 16 Август 2016, 15:21:03
от sough
Проблемы со шрифтом. Почему слишком большое расстояние между буквами ?

Автор nepster

Ответов: 2
Просмотров: 1298
Последний ответ 11 Ноябрь 2014, 13:34:35
от nepster