debian.org / О Debian Где взять Debian Поддержка Уголок разработчика Новости Wiki

Автор Тема: Aptitude сошел с ума?  (Прочитано 1232 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн externuz

  • Topic Author
  • Сообщений: 3
  • Suam Decus
Aptitude сошел с ума?
« : 15 Октябрь 2011, 17:56:17 »
Здравствуйте, дорогие форумчане! Это мой первый пост, и надеюсь, вопрос не очень глупый. По крайней мере, для меня он важен, потому что уже доводит до раздражения!  >:(

Решил я поставить на свой Squeeze ALSA для прослушивания звуков разных ))) Значит, по порядку:
1. Установил alsa-utils, alsa-tools, alsa-base, libasound2. Звук не заработал и я начал копать там где копать нельзя, в связи с чем позже удалил все эти три пакета а заодно и несколько конфигов.
2. Заного установил alsa-*
3. Запустил alsactl init (как я понял, это замена старому alsa config)
4. Получил в ответ такое:
ALSA lib conf.c:3617:(snd_config_update_r) Cannot access file /usr/share/alsa/alsa.conf
ALSA lib control.c:882:(snd_ctl_open_noupdate) Invalid CTL hw:0
5. Прочитал где-то что конфиг этот генерируется при установке libasound2, ии решил переустановить этот пакет. В итоге получил следущее:
root@externix:/home/externuz# aptitude remove libasound2
Следующие пакеты будут УДАЛЕНЫ:                 
  libasound2
0 пакетов обновлено, 0 установлено новых, 1 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 0 B архивов. После распаковки освободится 1 384 k байт.
Следующие пакеты имеют неудовлетворённые зависимости:
  bluez-alsa: Зависит: libasound2 (> 1.0.18) но его установка не запланирована.
  alsa-tools: Зависит: libasound2 (> 1.0.18) но его установка не запланирована.
  libflite1: Зависит: libasound2 (> 1.0.18) но его установка не запланирована.
  libfreerdp-plugins-standard: Зависит: libasound2 (> 1.0.18) но его установка не запланирована.
  gstreamer0.10-plugins-bad: Зависит: libasound2 (> 1.0.18) но его установка не запланирована.
  gstreamer0.10-alsa: Зависит: libasound2 (> 1.0.18) но его установка не запланирована.
  chromium-browser: Зависит: libasound2 (> 1.0.18) но его установка не запланирована.
  libcanberra0: Зависит: libasound2 (> 1.0.18) но его установка не запланирована.
  libsdl1.2debian-alsa: Зависит: libasound2 (> 1.0.18) но его установка не запланирована.
  libgcj10: Зависит: libasound2 (> 1.0.18) но его установка не запланирована.
  libportaudio2: Зависит: libasound2 (> 1.0.18) но его установка не запланирована.
  libesd0: Зависит: libasound2 (> 1.0.18) но его установка не запланирована.
  alsa-utils: Зависит: libasound2 (> 1.0.18) но его установка не запланирована.
  libvisual-0.4-plugins: Зависит: libasound2 (> 1.0.14) но его установка не запланирована.
  libpt2.6.7: Зависит: libasound2 (> 1.0.18) но его установка не запланирована.
  openjdk-6-jre: Зависит: libasound2 (> 1.0.18) но его установка не запланирована.
  gnome-alsamixer: Зависит: libasound2 (> 1.0.16) но его установка не запланирована.
  libasound2-plugins: Зависит: libasound2 (> 1.0.18) но его установка не запланирована.
Следующие действия разрешат зависимости:

       Удалить следующие пакеты:                                                                                                                       
1)       alsa-tools                                                                                                                                     
2)       alsa-utils                                                                                                                                     
3)       bluez-alsa                                                                                                                                     
4)       brasero                                                                                                                                       
5)       browser-plugin-gnash                                                                                                                           
6)       bsh-gcj                                                                                                                                       
7)       cheese                                                                                                                                         
8)       chromium-browser                                                                                                                               
9)       compiz                                                                                                                                         
10)      compiz-gnome                                                                                                                                   
11)      compiz-gtk                                                                                                                                     
12)      dasher                                                                                                                                         
13)      default-jre                                                                                                                                   
14)      deskbar-applet                                                                                                                                 
15)      ekiga                                                                                                                                         
16)      empathy                                                                                                                                       
17)      espeak                                                                                                                                         
18)      evolution                                                                                                                                     
19)      evolution-exchange                                                                                                                             
20)      evolution-plugins                                                                                                                             
21)      fusion-icon                                                                                                                                   
22)      gcj-4.4-jre                                                                                                                                   
23)      gcj-4.4-jre-headless                                                                                                                           
24)      gcj-4.4-jre-lib                                                                                                                               
25)      gcj-jre                                                                                                                                       
26)      gcj-jre-headless                                                                                                                               
27)      gdm3                                                                                                                                           
28)      gnash                                                                                                                                         
29)      gnash-common                                                                                                                                   
30)      gnome                                                                                                                                         
31)      gnome-about                                                                                                                                   
32)      gnome-accessibility                                                                                                                           
33)      gnome-alsamixer                                                                                                                               
34)      gnome-applets                                                                                                                                 
35)      gnome-control-center                                                                                                                           
36)      gnome-core                                                                                                                                     
37)      gnome-desktop-environment                                                                                                                     
38)      gnome-dictionary                                                                                                                               
39)      gnome-games                                                                                                                                   
40)      gnome-mag                                                                                                                                     
41)      gnome-media                                                                                                                                   
42)      gnome-netstatus-applet                                                                                                                         
43)      gnome-orca                                                                                                                                     
44)      gnome-panel                                                                                                                                   
45)      gnome-power-manager                                                                                                                           
46)      gnome-screenshot                                                                                                                               
47)      gnome-session                                                                                                                                 
48)      gnome-session-canberra                                                                                                                         
49)      gnome-user-share                                                                                                                               
50)      gok                                                                                                                                           
51)      gstreamer0.10-alsa                                                                                                                             
52)      gstreamer0.10-plugins-bad                                                                                                                     
53)      hamster-applet                                                                                                                                 
54)      libaccess-bridge-java                                                                                                                         
55)      libaccess-bridge-java-jni                                                                                                                     
56)      libasound2-plugins                                                                                                                             
57)      libbonoboui2-0                                                                                                                                 
58)      libbrasero-media0                                                                                                                             
59)      libcanberra-gtk-module                                                                                                                         
60)      libcanberra-gtk0                                                                                                                               
61)      libcanberra0                                                                                                                                   
62)      libcheese-gtk18                                                                                                                               
63)      libdb4.7-java-gcj                                                                                                                             
64)      libesd0                                                                                                                                       
65)      libespeak1                                                                                                                                     
66)      libevolution                                                                                                                                   
67)      libflite1                                                                                                                                     
68)      libfreerdp-plugins-standard                                                                                                                   
69)      libgail-gnome-module                                                                                                                           
70)      libgcj-bc                                                                                                                                     
71)      libgcj10                                                                                                                                       
72)      libgcj10-awt                                                                                                                                   
73)      libgnome-speech7                                                                                                                               
74)      libgnome2-0                                                                                                                                   
75)      libgnome2-perl                                                                                                                                 
76)      libgnome2.24-cil                                                                                                                               
77)      libgnomepanel2.24-cil                                                                                                                         
78)      libgnomeui-0                                                                                                                                   
79)      libgstfarsight0.10-0                                                                                                                           
80)      libhsqldb-java                                                                                                                                 
81)      libhsqldb-java-gcj                                                                                                                             
82)      libmetacity-private0                                                                                                                           
83)      libopal3.6.8                                                                                                                                   
84)      libpanel-applet2-0                                                                                                                             
85)      libportaudio2                                                                                                                                 
86)      libpt2.6.7                                                                                                                                     
87)      libsdl1.2debian                                                                                                                               
88)      libsdl1.2debian-alsa                                                                                                                           
89)      libtelepathy-farsight0                                                                                                                         
90)      libvisual-0.4-plugins                                                                                                                         
91)      metacity                                                                                                                                       
92)      mousetweaks                                                                                                                                   
93)      nautilus-sendto-empathy                                                                                                                       
94)      notification-daemon                                                                                                                           
95)      openjdk-6-jre                                                                                                                                 
96)      openoffice.org                                                                                                                                 
97)      openoffice.org-base                                                                                                                           
98)      openoffice.org-evolution                                                                                                                       
99)      openoffice.org-filter-mobiledev                                                                                                               
100)     openoffice.org-gcj                                                                                                                             
101)     openoffice.org-officebean                                                                                                                     
102)     openoffice.org-report-builder-bin                                                                                                             
103)     python-gnome2                                                                                                                                 
104)     python-gnomeapplet                                                                                                                             
105)     python-pyatspi                                                                                                                                 
106)     remmina-plugin-rdp                                                                                                                             
107)     rhythmbox                                                                                                                                     
108)     rhythmbox-plugin-cdrecorder                                                                                                                   
109)     rhythmbox-plugins                                                                                                                             
110)     seahorse-plugins                                                                                                                               
111)     sound-juicer                                                                                                                                   
112)     system-config-printer                                                                                                                         
113)     tomboy                                                                                                                                         
114)     update-notifier                                                                                                                               

       Оставить следующие зависимости неразрешёнными:                                                                                                   
115)     alacarte рекомендует gnome-panel                                                                                                               
116)     alsa-base рекомендует alsa-utils                                                                                                               
117)     bluetooth рекомендует bluez-alsa                                                                                                               
118)     bsh рекомендует bsh-gcj                                                                                                                       
119)     chromium-browser-inspector рекомендует chromium-browser                                                                                       
120)     capplets-data рекомендует gnome-control-center (>= 1:2.30.1-2)                                                                                 
121)     dasher-data рекомендует dasher                                                                                                                 
122)     libdb4.7-java рекомендует libdb4.7-java-gcj                                                                                                   
123)     espeak-data рекомендует espeak (= 1.43.03-2)      &n


Помогите, Братики!
« Последнее редактирование: 24 Октябрь 2011, 19:42:42 от Brainey »
 

Оффлайн Ghostdmn

  • Ленивы... Ай, лень допеча...
  • Сообщений: 854
  • Jabber: ghostdmn@jabber.cz
Re: Aptitude сошел с ума???
« Ответ #1 : 15 Октябрь 2011, 18:31:16 »
Во-первых, Alsa стоит по умолчанию, причину отсутствия звука рассматривать нужно отдельно (научимся юзать поиск по форуму, да?).
Во-вторых,
cat /etc/apt/sources.listвывод в студию
8Gb/GTX750Ti 2Gb/AMD FX(tm)-4300 Quad-Core Processor/HDD 1Tb Toshiba DT01ACA100
 

Оффлайн externuz

  • Topic Author
  • Сообщений: 3
  • Suam Decus
Re: Aptitude сошел с ума???
« Ответ #2 : 15 Октябрь 2011, 19:22:30 »
Да, пожалуйста!

#deb cdrom:[Debian GNU/Linux 6.0.3 _Squeeze_ - Official amd64 NETINST Binary-1 20111008-19:52]/ squeeze main

deb http://ftp.ru.debian.org/debian/ squeeze main contrib non-free
deb-src http://ftp.ru.debian.org/debian/ squeeze main contrib non-free

deb http://security.debian.org/ squeeze/updates main
deb-src http://security.debian.org/ squeeze/updates main

# squeeze-updates, previously known as 'volatile'
deb http://ftp.ru.debian.org/debian/ squeeze-updates main
deb-src http://ftp.ru.debian.org/debian/ squeeze-updates main
« Последнее редактирование: 15 Октябрь 2011, 19:35:44 от externuz »
 

Оффлайн vladimir_ar

  • Сообщений: 1624
Re: Aptitude сошел с ума???
« Ответ #3 : 15 Октябрь 2011, 19:44:12 »
Что за карта? И вообще что из звукового стоит? Не каждую звуковую алса в сквизе понимает. Я себе собирал из исходников. И порядок звуковых правильный (по умолчанию какая)?
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
 

Оффлайн externuz

  • Topic Author
  • Сообщений: 3
  • Suam Decus
Re: Aptitude сошел с ума???
« Ответ #4 : 15 Октябрь 2011, 19:48:04 »
Вот так как-то! Если еще что-то надо, обязательно отвечу. Слежу за темой не отвлекаясь )))

root@externix:/home/externuz# lspci | grep Audio
00:01.1 Audio device: ATI Technologies Inc Device 1714
00:14.2 Audio device: Advanced Micro Devices [AMD] Hudson Azalia Controller (rev 01)

root@externix:/home/externuz# cat /proc/asound/cards
 0 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xfeb44000 irq 19
 1 [Generic_1      ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xfeb40000 irq 16
« Последнее редактирование: 15 Октябрь 2011, 20:59:31 от externuz »
 

Оффлайн vladimir_ar

  • Сообщений: 1624
Re: Aptitude сошел с ума???
« Ответ #5 : 16 Октябрь 2011, 12:26:54 »
Интел штатная алса без проблем поднимает. Скорее всего где-то накосячили в процессе экспериментов. Мне помогало снести все (ВСЕ) касающееся звука (алса, gstreamer и т.п.) и после перезагрузки установить заново.
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
 

Теги: