debian.org / О Debian Где взять Debian Поддержка Уголок разработчика Новости Wiki

Автор Тема: Greepy  (Прочитано 1315 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sagd

  • Активный пользователь
  • **
  • Topic Author
  • Сообщений: 61
Re: Greepy
« Ответ #15 : 06 Март 2019, 12:20:04 »
Собственно ни чего нового, на эту тему полно багрепортов и все прошли по этим же граблям. В видео приведённом выше показан рабочий способ для kali но скорее всего он подойдёт и вам. Единственное хочу заметить в этом случае подключается git репозиторий за который команда debian похоже не несёт ответственности. Хорошенько подумайте на сколько вам нужна эта программа.
я уже бьюсь с этой программой неделю:) интересно....Читал про неё ещё в 2011году в линукс формате....Осталось только установить webkit.....вот информация: https://packages.debian.org/search?keywords=qtwebkit
Какой из них устанавливать?
 

Онлайн ferum

  • Ветеран
  • *****
  • Сообщений: 3237
  • wheezy KDE & jessie LXDE & stretch KDE
Re: Greepy
« Ответ #16 : 06 Март 2019, 12:37:22 »
я уже бьюсь с этой программой неделю:
Я повторюсь, на сегодняшний день в основном репозитории debian нет этого приложения. Пакет что вы скачивали по моей ссылке собирался в качестве эксперимента в 16 году на временном срезе debian sid. Что то критичное в коде программы перестало соответствовать, вероятно версии используемых в дистрибутиве pyton и qt.
Многие из нас участвуют в рейтинге популярности пакетов, вероятно программа не слишком востребована и не нашлось желающего сопровождать её для stretch. По скольку linux очень гибкая система, возможности пользователя ограничиваются лишь уровнем его квалификации. Потенциально можно поставить в систему практически любое ПО, естественно у всего есть своя цена вопроса. В ролике показан один из таких способов.... минут 10-15 работы. Какие последствия будут для системы я не знаю.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн sagd

  • Активный пользователь
  • **
  • Topic Author
  • Сообщений: 61
Re: Greepy
« Ответ #17 : 06 Март 2019, 12:44:09 »
установил уже кучу webkit)))) не запускается....Запутался в конец....В этом ролике ничего не видно....
 

Оффлайн sagd

  • Активный пользователь
  • **
  • Topic Author
  • Сообщений: 61
Re: Greepy
« Ответ #18 : 06 Март 2019, 12:48:28 »
sagd@sagd:~$ creepy
Traceback (most recent call last):
  File "/usr/bin/creepy", line 19, in <module>
    from PyQt4.QtWebKit import QWebPage, QWebSettings
ImportError: No module named QtWebKit
sagd@sagd:~$ sudo apt-get install QtWebKit
[sudo] пароль для sagd:
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
E: Не удалось найти пакет QtWebKit
 

Оффлайн sagd

  • Активный пользователь
  • **
  • Topic Author
  • Сообщений: 61
Re: Greepy
« Ответ #19 : 06 Март 2019, 12:49:28 »
должен же он быть....Может какой репозиторий не указан?
 

Онлайн ferum

  • Ветеран
  • *****
  • Сообщений: 3237
  • wheezy KDE & jessie LXDE & stretch KDE
Re: Greepy
« Ответ #20 : 06 Март 2019, 13:46:54 »
Как не видно, всё видно.
# удаляет creeppy
apt-get remove --purge creeppy
# удаляет его зависимости
apt-get autoremove
#упущеная деталь
apt install python-pip python-pip-whl
# ставит другую версию python
pip install -U pytz python-qt flickrapi python-instagram yapsy tweeppy google-api-python-client python-dateutil configobj dominate
# скачивает   очевидно бинарную сборку, ежу понятно что пакет git у него в системе уже установлен
git clone https://github.com/jkakavas/creppy.git
#  переходит в каталог с программой
 cd creeppy
  # возможно команду надо выполнить дважды# про ls и pwd вы наверное в курсах...
в итоге он в ~/creeppy/creeppy
# Запускает программу командой
python CreeppyMain.py
# ну и канаёбится с настройками

  Все команда от root. Как то так...
 Ещё один tutorial https://www.youtube.com/watch?v=dQ8GKRfs8ic
« Последнее редактирование: 06 Март 2019, 13:52:40 от ferum »
Русские дебианщики против цифрового слабоумия !
 

Оффлайн sagd

  • Активный пользователь
  • **
  • Topic Author
  • Сообщений: 61
Re: Greepy
« Ответ #21 : 06 Март 2019, 15:14:54 »
про ls и pwd вы наверное в курсах
Не в курсах:) опыта ещё мало....
 

Оффлайн sagd

  • Активный пользователь
  • **
  • Topic Author
  • Сообщений: 61
Re: Greepy
« Ответ #22 : 06 Март 2019, 15:29:42 »
такой выхлоп
sagd@sagd:~$ sudo git clone https://github.com/jkakavas/creppy.git
sudo: git: command not found
 

Оффлайн sagd

  • Активный пользователь
  • **
  • Topic Author
  • Сообщений: 61
Re: Greepy
« Ответ #23 : 06 Март 2019, 15:30:56 »
и такое
sagd@sagd:~$ sudo pip install -U pytz python-qt flickrapi python-instagram yapsy tweeppy google-api-python-client python-dateutil configobj dominate
Collecting pytz
  Downloading https://files.pythonhosted.org/packages/61/28/1d3920e4d1d50b19bc5d24398a7cd85cc7b9a75a490570d5a30c57622d34/pytz-2018.9-py2.py3-none-any.whl (510kB)
    100% |████████████████████████████████| 512kB 270kB/s
Collecting python-qt
  Downloading https://files.pythonhosted.org/packages/51/b0/17af320da0df9608ebde64721bb3a8c0c688c79e1374990930adbf185652/python-qt-0.50.tar.gz
Collecting flickrapi
  Downloading https://files.pythonhosted.org/packages/76/d7/291b7f0f02cf0f59460f7bcc15192905b4c61e13b9fb9263ee86b0a5f647/flickrapi-2.4.0-py2.py3-none-any.whl
Collecting python-instagram
  Downloading https://files.pythonhosted.org/packages/35/a9/c33c2224e4bbc8579940199c98cc980ee5424623f72e142612ba03c567ea/python-instagram-1.3.2.tar.gz
Collecting yapsy
  Downloading https://files.pythonhosted.org/packages/6b/ca/e3d62b38e8b816610c43438a37c43b31d066bf9d298bb7feb2ae4756e6e3/Yapsy-1.12.0.tar.gz (83kB)
    100% |████████████████████████████████| 92kB 481kB/s
Collecting tweeppy
  Could not find a version that satisfies the requirement tweeppy (from versions: )
No matching distribution found for tweeppy
 

Онлайн ferum

  • Ветеран
  • *****
  • Сообщений: 3237
  • wheezy KDE & jessie LXDE & stretch KDE
Re: Greepy
« Ответ #24 : 06 Март 2019, 16:46:49 »
Не в курсах:) опыта ещё мало....
Хочется выругаться, это самые азы....
 не зная команд  ls cd pwd mv cp mkdir rm в linux   делать нечего.
sudo: git: command not found
не установлен пакет git
Collecting tweeppy
  Could not find a version that satisfies the requirement tweeppy (from versions: )
No matching distribution found for tweeppy
Я бы посмотрел сюда https://cirq.readthedocs.io/en/latest/install.html
только логика подсказывает прорядок команд другой
sudo apt-get install python3-tk texlive-latex-base latexmk
python -m pip install --upgrade pip
python -m pip install cirq
(правда если верить тёркам https://github.com/nickoala/telepot/issues/395 python 3.5 что ставится в систему по дефолту имеет проблему и народ собирает сам версии выше.)
потом снова
pip install -U pytz python-qt flickrapi python-instagram yapsy tweeppy google-api-python-client python-dateutil configobj dominate стесняюсь спросить какие дивиденты вообще от этой программы , за чем она нужна?
« Последнее редактирование: 06 Март 2019, 16:54:17 от ferum »
Русские дебианщики против цифрового слабоумия !
 
Пользователи, которые поблагодарили этот пост: sagd

Русскоязычное сообщество Debian GNU/Linux

Re: Greepy
« Ответ #24 : 06 Март 2019, 16:46:49 »


Теги: