Автор Тема: Не мегу устоновить libssh2-php  (Прочитано 248 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн romenskiy2012

  • Новичок форума
  • Topic Author
  • Сообщений: 2
Не мегу устоновить libssh2-php
« : 15 Октябрь 2019, 17:15:53 »
Debian 9, не могу установить libssh2-php
Debian 9 последняя версия

Связка apache2 + nginx
---------------------------------------------------------------------------------------------------------------------------
root@debian-9:/# apt-get install libssh2-1-dev libssh2-php
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Пакет libssh2-php недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list
Однако следующие пакеты могут его заменить:
  php-ssh2

E: Для пакета «libssh2-php» не найден кандидат на установку
---------------------------------------------------------------------------------------------------------------------------

root@debian-9:/# aptitude install libssh2-1-dev libssh2-php
libssh2-1-dev уже установлен в запрошенной версии (1.7.0-1+deb9u1)
Нет подходящей версии для libssh2-php
Не удалось применить некоторые действия, прерываем работу
---------------------------------------------------------------------------------------------------------------------------
Он нужен для RadioCMS 2.6
---------------------------------------------------------------------------------------------------------------------------
Описание                                            Текущее                                 Необходимо
Права на папку music                         недоступен для записи         доступен для записи
Права на файл _config.php                недоступен для записи         доступен для записи
Права на файл _system.php              недоступен для записи         доступен для записи
Параметр open_basedir                    no_value                                 / или no_value
Библиотека libssh2                            не установлена                     установлена
Библиотека curl                                   установлена                         установлена
Библиотека SimpleXML                         установлена                         установлена
Библиотека iconv                                 установлена                         установлена
Библиотека gd2                                   установлена                         установлена
---------------------------------------------------------------------------------------------------------------------------
« Последнее редактирование: 16 Октябрь 2019, 04:07:08 от ogost »
 


Оффлайн endru

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 1820
  • Новосибирск
  • Jabber: endru@jabber.ru
Re: Не мегу устоновить libssh2-php
« Ответ #1 : 16 Октябрь 2019, 03:33:01 »
Пакет libssh2-php недоступен...
Однако следующие пакеты могут его заменить:
  php-ssh2

вы читать то умеете?

Оффлайн romenskiy2012

  • Новичок форума
  • Topic Author
  • Сообщений: 2
Re: Не мегу устоновить libssh2-php
« Ответ #2 : 16 Октябрь 2019, 10:56:22 »
вы читать то умеете?

Я же говорю что мне нужен ИМЕННО libssh2-php никакой другой.
Так требует установщик RadioCMS 2.6.
 

Оффлайн ferum

  • Ветеран
  • *****
  • Сообщений: 3420
  • Buster TDE & Buster LXDE & stretch KDE
Re: Не мегу устоновить libssh2-php
« Ответ #3 : 16 Октябрь 2019, 11:36:46 »
Посмотрел, установщик распространялся аж в 2015 году то бишь почти пять лет назад. Короче говоря его надо ставить на debian 8 jessie.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн endru

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 1820
  • Новосибирск
  • Jabber: endru@jabber.ru
Re: Не мегу устоновить libssh2-php
« Ответ #4 : 16 Октябрь 2019, 11:46:12 »
нужен ИМЕННО libssh2-php
впервые вижу это желание.

судя по тому что эта версия древняя как мамонт - нужно ставить jessie, т.к. скорее всего на php 7.0 это поделие работать не будет, из него выпилили mysql функции, теперь используют только mysqli.
и уж если надо, то это явно вам на их форум http://radiocms.ru/forum/ и долбите их до посинения, если они живые конечно.


Теги: libssh2-php