debian.org / О Debian Где взять Debian Поддержка Уголок разработчика Новости Wiki

Автор Тема: обновление pidgin, но не до sid-версии  (Прочитано 1410 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн elivin

  • Topic Author
  • Сообщений: 39
обновление pidgin, но не до sid-версии
« : 27 Декабрь 2011, 13:51:56 »
Приветствую всех, кто читает эту тему!
Раньше у меня был подключен репозиторий ветки sid. И pidgin был именно оттуда. Но недавно я приобрёл новый жёсткий диск (уточню сразу - работаю с ноутбуком, так что оба жёстких одновременно не поставить) и вновь поставил на него дебиан. Поставил с набора дисков, на которых был stable-репозиторий. До сих пор сидел на stable, но столкнулся с несколькими проблемами в pidgin'е: сообщения доходят не ото всех и ссылки в сообщениях переводятся в текст. С прошлым жёстким решил это обновлением. Попробовал снова подключить sid, но при обновлении мне выводятся страшные условия:

Удалить следующие пакеты:                                           
1)       epiphany-browser                                                   
2)       epiphany-extensions                                               
3)       gdm3                                                               
4)       gir1.0-clutter-1.0                                                 
5)       gir1.0-freedesktop                                                 
6)       gir1.0-gstreamer-0.10                                             
7)       gir1.0-gtk-2.0                                                     
8)       gnome                                                             
9)       gnome-accessibility                                               
10)      gnome-applets                                                     
11)      gnome-bluetooth                                                   
12)      gnome-control-center                                               
13)      gnome-core                                                         
14)      gnome-desktop-environment                                         
15)      gnome-panel                                                       
16)      gnome-panel-data                                                   
17)      gnome-session                                                     
18)      gnome-system-tools                                                 
19)      gnome-user-share                                                   
20)      libpolkit-gtk-1-0                                                 
21)      libseed0

В то же время удаление gnome потянет за собой удаление огромного количества других пакетов. Итак, сам вопрос: можно ли обновить pidgin до более ранней версии, чем сейчас в sid?

P.S. у меня usb-модем, так что всё сносить и ставить заново - вообще не вариант...
 

Оффлайн SeHELLioN

  • Сообщений: 910
Re: обновление pidgin, но не до sid-версии
« Ответ #1 : 27 Декабрь 2011, 15:04:54 »
попробуйте скачать сам пакет через браузер и потом поставить с помощью dpkg или gdebi
И еще, я так понимаю, установить побуете через синаптик? в настройках случайно рассматривать рекомендации как зависимости не включено?
Asus m5a97+Amd fx-8350+4x4GB DDR3 1600MGz+asus gtx670 DCII (перешита в top)
Debian stable
 

Оффлайн elivin

  • Topic Author
  • Сообщений: 39
Re: обновление pidgin, но не до sid-версии
« Ответ #2 : 27 Декабрь 2011, 16:19:06 »
SeHELLioN, что-то не могу найти deb-пакет более ранней версии, чем 2.10.1 (sid) и более поздней чем 2.7.3 (stable). Попробовал установить предварительно скачанный 2.10.1, вот вывод:

# dpkg -i ./Загрузки/pidgin_2.10.1-1_i386.deb
(Чтение базы данных ... на данный момент установлено 189952 файла и каталога.)
Подготовка к замене пакета pidgin 2.10.1-1 (используется файл .../pidgin_2.10.1-1_i386.deb) ...
Распаковывается замена для пакета pidgin ...
dpkg: зависимости пакетов не позволяют настроить пакет pidgin:
 pidgin зависит от pidgin-data (>= 2.10.1), однако:
  Версия pidgin-data в системе 2.7.3-1+squeeze1.
 pidgin зависит от libgdk-pixbuf2.0-0 (>= 2.22.0), однако:
  Пакет libgdk-pixbuf2.0-0 не установлен.
 pidgin зависит от libgtk2.0-0 (>= 2.24.0), однако:
  Версия libgtk2.0-0 в системе 2.20.1-2.

 pidgin зависит от libpurple0 (>= 2.8.0), однако:
  Версия libpurple0 в системе 2.7.3-1+squeeze1.
 pidgin зависит от perl-base (>= 5.14.2-6), однако:
  Версия perl-base в системе 5.10.1-17.
 pidgin зависит от perlapi-5.14.2, однако:
  Пакет perlapi-5.14.2 не установлен.
dpkg: не удалось обработать параметр pidgin (--install):
 проблемы зависимостей -- оставляем не настроенным
Обрабатываются триггеры для desktop-file-utils ...
Обрабатываются триггеры для gnome-menus ...
Обрабатываются триггеры для menu ...
Обрабатываются триггеры для man-db ...
Обрабатываются триггеры для gconf2 ...
При обработке следующих пакетов произошли ошибки:
 pidgin

Судя по всему, проблема в пакете libgtk2.0-0, при обновлении которого и удаляется gnome. В синаптике действительно был включен параметр "рассматривать рекомендации как зависимости", но его отключение ни на что не повлияло.
 

Оффлайн SeHELLioN

  • Сообщений: 910
Re: обновление pidgin, но не до sid-версии
« Ответ #3 : 27 Декабрь 2011, 16:29:00 »
полагаю, что от тестинга пробовать тоже нет смысла, ибо, похоже, версии пакетов там такие же, со всеми вытекающими
Asus m5a97+Amd fx-8350+4x4GB DDR3 1600MGz+asus gtx670 DCII (перешита в top)
Debian stable
 

Оффлайн elivin

  • Topic Author
  • Сообщений: 39
Re: обновление pidgin, но не до sid-версии
« Ответ #4 : 27 Декабрь 2011, 17:11:10 »
Думаю, сейчас уже едва ли возможно найти нужные мне версии. Посмотрел на старом HDD - там не сохранились, видимо очищал кэш.
Цитата: SeHELLioN
полагаю, что от тестинга пробовать тоже нет смысла, ибо, похоже, версии пакетов там такие же, со всеми вытекающими
Абсолютно верно. К сожалению  :-[
 

Оффлайн calambus

  • Почетный пользователь форума
  • Сообщений: 554
  • Ушел из жизни 14.07.2013
Re: обновление pidgin, но не до sid-версии
« Ответ #5 : 27 Декабрь 2011, 22:31:20 »
По поводу удаления  метапакетов-пустышек : gnome, gnome-desktop-environment, gnome-core и gnome-accessibility  есть рекомендация от  Valeron'а

Оффлайн elivin

  • Topic Author
  • Сообщений: 39
Re: обновление pidgin, но не до sid-версии
« Ответ #6 : 28 Декабрь 2011, 07:36:09 »
calambus, мне не нравится, что при этом удаляются многие пакеты.
Выполнил рекомендации Valeron, многие пакеты перевелись из разряда "удаляемых при обновлении pidgin" в "обновляемые". Теперь синаптик выдаёт (покажу только на удаление, иначе сообщение превышает максимальное количество символов):

capplets-data будет удалён
console-terminus будет удалён
deskbar-applet будет удалён
gir1.0-clutter-1.0 будет удалён
gir1.0-freedesktop будет удалён
gir1.0-glib-2.0 будет удалён
gir1.0-gstreamer-0.10 будет удалён
gir1.0-gtk-2.0 будет удалён
gir1.0-json-glib-1.0 будет удалён
libbrasero-media0 будет удалён
libdrm-nouveau1 будет удалён
libepc-1.0-2 будет удалён
libepc-ui-1.0-2 будет удалён
libgtkhtml-editor0 будет удалён
libmetacity-private0 будет удалён
libmtp8 будет удалён
libnautilus-extension1 будет удалён
libntfs-3g75 будет удалён
libperl5.10 будет удалён
libpolkit-gtk-1-0 будет удалён
libqt4-multimedia будет удалён
librpm1 будет удалён
libsdl1.2debian-alsa будет удалён
libseed0 будет удалён
libtextcat-data-utf8 будет удалён
openoffice.org-base-core будет удалён
openoffice.org-core будет удалён
openoffice.org-gcj будет удалён
openoffice.org-report-builder-bin будет удалён
portmap будет удалён
python-gnomeapplet будет удалён
seahorse-plugins будет удалён
tmw-data будет удалён
totem-coherence будет удалён
xserver-xorg-video-nv будет удалён

Тут возникает другая проблема:
Цитата: elivin
P.S. у меня usb-модем, так что всё сносить и ставить заново - вообще не вариант...
Вот, что мне предлагает синаптик. Для меня скачать 2143 Мб - это несколько проблематично.
 

Оффлайн calambus

  • Почетный пользователь форума
  • Сообщений: 554
  • Ушел из жизни 14.07.2013
Re: обновление pidgin, но не до sid-версии
« Ответ #7 : 28 Декабрь 2011, 10:15:22 »
Всё таки здесь присутствует конфликт зависимостей , рекомендация от  Valeron'а мне очень помогла при установке стабильной версии Debian 6.0.3 , когда нужно было безболезненно удалить неиспользуемое ПО .
У вас elivin ситуация , несколько иного характера , наверное легче будет сделать новую чистую установку ...

paulcarroty

  • Гость
Re: обновление pidgin, но не до sid-версии
« Ответ #8 : 28 Декабрь 2011, 14:41:10 »
Цитировать
Вот, что мне предлагает синаптик. Для меня скачать 2143 Мб - это несколько проблематично.
Цитировать
У вас elivin ситуация , несколько иного характера , наверное легче будет сделать новую чистую установку ...
Читать полностью умеешь, нет?
И да, чтобы обновлять з стейбла до сида надо сразу понимать, что придется долго работать над багами. Если вам нужен сид, ставить надо минимальную систему тестинга и потом обновляться и доустанавливать.
Попробуйте так:
# atpitude update && aptitude keep-all && aptitude unmarkauto gnome gnome-desktop-environment gnome-core gnome-accessibility
 

Оффлайн elivin

  • Topic Author
  • Сообщений: 39
Re: обновление pidgin, но не до sid-версии
« Ответ #9 : 28 Декабрь 2011, 15:16:16 »
Попробуйте так:
# atpitude update && aptitude keep-all && aptitude unmarkauto gnome gnome-desktop-environment gnome-core gnome-accessibility
Обновляется нормально, ибо из кэша достаёт. Пакеты gnome, gnome-desktop-environment, gnome-core и gnome-accessibility у меня удалены. В общем, вот вывод:

# aptitude update && aptitude keep-all && aptitude unmarkauto gnome gnome-desktop-environment gnome-core gnome-accessibility
Из кэша: http://ftp.ru.debian.org sid Release.gpg                               
Игн http://ftp.ru.debian.org/debian/ sid/contrib Translation-en                 
Игн http://ftp.ru.debian.org/debian/ sid/contrib Translation-ru                 
Игн http://ftp.ru.debian.org/debian/ sid/main Translation-en                   
Из кэша: http://ftp.ru.debian.org/debian/ sid/main Translation-ru               
Игн http://ftp.ru.debian.org/debian/ sid/non-free Translation-en               
Игн http://ftp.ru.debian.org/debian/ sid/non-free Translation-ru               
Из кэша: http://linux.dropbox.com squeeze Release.gpg                           
Игн http://linux.dropbox.com/debian/ squeeze/main Translation-en
Игн http://linux.dropbox.com/debian/ squeeze/main Translation-ru
Из кэша: http://ftp.ru.debian.org sid Release
Из кэша: http://linux.dropbox.com squeeze Release
Из кэша: http://ftp.ru.debian.org sid/main i386 Packages/DiffIndex
Из кэша: http://linux.dropbox.com squeeze/main i386 Packages
Из кэша: http://ftp.ru.debian.org sid/contrib i386 Packages/DiffIndex
Из кэша: http://ftp.ru.debian.org sid/non-free i386 Packages/DiffIndex
                                           
Ни одного пакета не будет установлено, обновлено или удалено.
0 пакетов обновлено, 0 установлено новых, 0 пакетов отмечено для удаления, и 1323 пакетов не обновлено.
Необходимо получить 0 B архивов. После распаковки 0 B будет занято.
                                                 
Не удалось найти пакет "gnome-accessibility". Однако, следующие
пакеты содержат "gnome-accessibility" в своём имени:
  gnome-accessibility-themes
Не удалось найти пакет "gnome-accessibility". Однако, следующие
пакеты содержат "gnome-accessibility" в своём имени:
  gnome-accessibility-themes
Ни одного пакета не будет установлено, обновлено или удалено.
0 пакетов обновлено, 0 установлено новых, 0 пакетов отмечено для удаления, и 1323 пакетов не обновлено.
Необходимо получить 0 B архивов. После распаковки 0 B будет занято.

А на sid переходить не особо охота - раньше под ним и сидел, но возникали некоторые конфликты. Таким образом, раньше я не мог поставить libgtk2.0-dev, который мне был нужен, и я его поставил сразу же, как поставил новый HDD, и решил сидеть на stable во избежание подобной ситуации. Однако, pidgin мне нужно обновить либо каким-то другим образом устранить неполадки.

P.S. где можно достать iso-образы с wheezy (если такие уже есть)? Желательно торрентом (иначе мне не скачать)
« Последнее редактирование: 28 Декабрь 2011, 15:21:36 от elivin »
 

paulcarroty

  • Гость
Re: обновление pidgin, но не до sid-версии
« Ответ #10 : 28 Декабрь 2011, 16:19:58 »
http://www.debian.org/CD/torrent-cd/
Вообще, с таким инетом только на стейбле и сидеть. В сиде поломаные зависимости обычное дело.
 

Оффлайн SeHELLioN

  • Сообщений: 910
Re: обновление pidgin, но не до sid-версии
« Ответ #11 : 28 Декабрь 2011, 16:44:29 »
Ну а на офф сайте разве нет? И да, если не торрентом, то wget -c  отличный вариант
Asus m5a97+Amd fx-8350+4x4GB DDR3 1600MGz+asus gtx670 DCII (перешита в top)
Debian stable
 

Оффлайн elivin

  • Topic Author
  • Сообщений: 39
Re: обновление pidgin, но не до sid-версии
« Ответ #12 : 28 Декабрь 2011, 19:25:20 »
http://www.debian.org/CD/torrent-cd/
Вообще, с таким инетом только на стейбле и сидеть. В сиде поломаные зависимости обычное дело.
Там по ссылке только squeeze, который у меня и стоит. Да, инет - одна из причин, по которой я остался на stable. По крайней мере если пакет тянет за собой много зависимостей (в плане объёма скачиваемого), то я легко могу переключиться на дисковый репозиторий. Благо все 8 DVD у меня имеются в наличии.

Ну а на офф сайте разве нет? И да, если не торрентом, то wget -c  отличный вариант
Хм... Знал конечно, что wget может докачивать, но всё руки не доходили посмотреть как. Хотя я обычно оставлял до окончания загрузки, т.к.  при разрыве соединения он снова соединяется и продолжает качать как ни в чём не бывало. Насколько понимаю, под гномом нет нормальных загрузчиков с GUI, поэтому у меня установлена tilda, и я использую для таких целей только wget.
 

Оффлайн SeHELLioN

  • Сообщений: 910
Re: обновление pidgin, но не до sid-версии
« Ответ #13 : 28 Декабрь 2011, 22:33:19 »
Цитировать
wget может
и ещё как могёт
ну  по поводу gui качалок - они и не нужны толком
Asus m5a97+Amd fx-8350+4x4GB DDR3 1600MGz+asus gtx670 DCII (перешита в top)
Debian stable
 

Теги: