Автор Тема: [РЕШЕНО] Автоматическое монтирования шары NFS  (Прочитано 2758 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн inop

  • Активноленив
  • Пользователь
  • *
  • Topic Author
  • Сообщений: 38
  • [AMD Phenom ll X4 920] [4 Gb RAM] [geforce 9800gt]
Привет.
Создавал шару по этой статье.
Не могу понять, как включить авто монтирование шары.
У меня в /etc/fstab:
192.168.0.3:/home/inop/nfs /mnt/nfs/home/nfs nfs rw,sync,hard,intr 0 0 - это не  сработало,
запихнул в /etc/rc.local (можно ли это вообще делать?):
mount 192.168.0.3:/home/inop/nfs /mnt/nfs Не помогло. Все это делаю на буке который коннектится через вай-фай. Что я могу делать не так?
Спасибо за внимание  :)

Сообщение объединено: 13 Февраль 2012, 00:14:35
у меня есть предположение, что скрипт срабатывает до того как устанавливается ва-фай соединение, соответственно монтируемый ресурс не доступен. я прав?

Сообщение объединено: 13 Февраль 2012, 00:16:42
если сделать /etc/init.d/rc.local start после полной загрузки системы, шара нормально  монтируется.
« Последнее редактирование: 13 Февраль 2012, 17:40:50 от inop »
 


Оффлайн Sterios

  • Da Funk
  • Активный пользователь
  • **
  • Сообщений: 72
  • Jabber: sterios@nix.uz
Re: Автоматическое монтирования шары NFS
« Ответ #1 : 13 Февраль 2012, 12:14:37 »
Привет.
Создавал шару по этой статье.
Не могу понять, как включить авто монтирование шары.
У меня в /etc/fstab:
192.168.0.3:/home/inop/nfs /mnt/nfs/home/nfs nfs rw,sync,hard,intr 0 0 - это не  сработало,
запихнул в /etc/rc.local (можно ли это вообще делать?):
mount 192.168.0.3:/home/inop/nfs /mnt/nfs Не помогло. Все это делаю на буке который коннектится через вай-фай. Что я могу делать не так?
Спасибо за внимание  :)

Сообщение объединено: 13 Февраль 2012, 00:14:35
у меня есть предположение, что скрипт срабатывает до того как устанавливается ва-фай соединение, соответственно монтируемый ресурс не доступен. я прав?

Сообщение объединено: 13 Февраль 2012, 00:16:42
если сделать /etc/init.d/rc.local start после полной загрузки системы, шара нормально  монтируется.

Проверьте что стартует прежде: соединение или исполнение скрипта. Если соединяется позднее, то, как вариант, в rc.local пропишите:
sleep 30 && mount 192.168.0.3:/home/inop/nfs /mnt/nfs Секунды конечно укажите свои, исходя из времени загрузки ос.
- Harder, Better, Faster, Stronger
 

Оффлайн inop

  • Активноленив
  • Пользователь
  • *
  • Topic Author
  • Сообщений: 38
  • [AMD Phenom ll X4 920] [4 Gb RAM] [geforce 9800gt]
Re: Автоматическое монтирования шары NFS
« Ответ #2 : 13 Февраль 2012, 17:38:07 »
Проверьте что стартует прежде: соединение или исполнение скрипта. Если соединяется позднее, то, как вариант, в rc.local пропишите:
sleep 30 && mount 192.168.0.3:/home/inop/nfs /mnt/nfs Секунды конечно укажите свои, исходя из времени загрузки ос.
Спасибо сработало :)
 

Теги:
 

[Решено] Настройка времени и даты

Автор Vacka

Ответов: 2
Просмотров: 1211
Последний ответ 29 Июль 2013, 16:52:05
от seisros
[Решено] Система не грузится.

Автор doctor@tardis

Ответов: 12
Просмотров: 2121
Последний ответ 10 Декабрь 2013, 11:19:40
от Brainey
[Решено] После обновления не монтируются юсб-накопители и не соединяется NM

Автор warezzzok

Ответов: 8
Просмотров: 1931
Последний ответ 04 Сентябрь 2014, 01:11:03
от warezzzok
[Решено] Энергосбережение , power.sh не запускается

Автор vavun

Ответов: 0
Просмотров: 2161
Последний ответ 15 Октябрь 2011, 18:16:35
от vavun
Как правильно чистить логи [решено]

Автор CoolAller

Ответов: 18
Просмотров: 14773
Последний ответ 15 Сентябрь 2015, 02:46:58
от CoolAller