Автор Тема: Postgresql проблема с установкой  (Прочитано 3934 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн krasnopoyas

  • Новичок форума
  • Topic Author
  • Сообщений: 3
Postgresql проблема с установкой
« : 14 Июнь 2012, 12:07:14 »
Добрый день.
Задался задачей установки на Debian 6.0 связки 1с 8.2 + postgresql
postgreesql взял с сайта Этерсофта...
При установке пишет -
Spoiler: ShowHide
root@new:~/new/etersoft# dpkg -i *.deb
(Чтение базы данных ... на данный момент установлено 126711 файлов и каталогов.)
Подготовка к замене пакета libpq5.2-9.0eter 9.0.4-eter14debian (используется файл libpq5.2-9.0eter_9.0.4-eter14debian_i386.deb) ...
Распаковывается замена для пакета libpq5.2-9.0eter ...
Подготовка к замене пакета postgre-etersoft9.0-contrib 9.0.4-eter14debian (используется файл postgre-etersoft9.0-contrib_9.0.4-eter14debian_i386.deb) ...
Распаковывается замена для пакета postgre-etersoft9.0-contrib ...
Подготовка к замене пакета postgre-etersoft9.0-docs 9.0.4-eter14debian (используется файл postgre-etersoft9.0-docs_9.0.4-eter14debian_i386.deb) ...
Распаковывается замена для пакета postgre-etersoft9.0-docs ...
Подготовка к замене пакета postgre-etersoft9.0-plperl 9.0.4-eter14debian (используется файл postgre-etersoft9.0-plperl_9.0.4-eter14debian_i386.deb) ...
Распаковывается замена для пакета postgre-etersoft9.0-plperl ...
Подготовка к замене пакета postgre-etersoft9.0-plpython 9.0.4-eter14debian (используется файл postgre-etersoft9.0-plpython_9.0.4-eter14debian_i386.deb) ...
Распаковывается замена для пакета postgre-etersoft9.0-plpython ...
Подготовка к замене пакета postgre-etersoft9.0-seltaaddon 9.0.4-eter14debian (используется файл postgre-etersoft9.0-seltaaddon_9.0.4-eter14debian_i386.deb) ...
Распаковывается замена для пакета postgre-etersoft9.0-seltaaddon ...
Подготовка к замене пакета postgre-etersoft9.0-server 9.0.4-eter14debian (используется файл postgre-etersoft9.0-server_9.0.4-eter14debian_i386.deb) ...
Распаковывается замена для пакета postgre-etersoft9.0-server ...
Подготовка к замене пакета postgre-etersoft9.0 9.0.4-eter14debian (используется файл postgre-etersoft9.0_9.0.4-eter14debian_i386.deb) ...
Распаковывается замена для пакета postgre-etersoft9.0 ...
Настраивается пакет libpq5.2-9.0eter (9.0.4-eter14debian) ...
Generating locales (this might take a while)...
  en_US.ISO-8859-1... done
  en_US.UTF-8... done
  ru_RU.CP1251... done
  ru_RU.KOI8-R... done
  ru_RU.UTF-8... done
Generation complete.
Generating locales (this might take a while)...
  en_US.ISO-8859-1... done
  en_US.UTF-8... done
  ru_RU.CP1251... done
  ru_RU.KOI8-R... done
  ru_RU.UTF-8... done
Generation complete.
Настраивается пакет postgre-etersoft9.0-docs (9.0.4-eter14debian) ...
dpkg: зависимости пакетов не позволяют настроить пакет postgre-etersoft9.0-server:
 postgre-etersoft9.0-server зависит от postgresql-common, однако:
  Пакет postgresql-common не установлен.
dpkg: не удалось обработать параметр postgre-etersoft9.0-server (--install):
 проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет postgre-etersoft9.0:
 postgre-etersoft9.0 зависит от postgresql-common, однако:
  Пакет postgresql-common не установлен.
dpkg: не удалось обработать параметр postgre-etersoft9.0 (--install):
 проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет postgre-etersoft9.0-contrib:
 postgre-etersoft9.0-contrib зависит от postgre-etersoft9.0, однако:
  Пакет postgre-etersoft9.0 пока не настроен.
dpkg: не удалось обработать параметр postgre-etersoft9.0-contrib (--install):
 проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет postgre-etersoft9.0-plperl:
 postgre-etersoft9.0-plperl зависит от postgre-etersoft9.0-server, однако:
  Пакет postgre-etersoft9.0-server пока не настроен.
dpkg: не удалось обработать параметр postgre-etersoft9.0-plperl (--install):
 проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет postgre-etersoft9.0-plpython:
 postgre-etersoft9.0-plpython зависит от postgre-etersoft9.0-server, однако:
  Пакет postgre-etersoft9.0-server пока не настроен.
dpkg: не удалось обработать параметр postgre-etersoft9.0-plpython (--install):
 проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет postgre-etersoft9.0-seltaaddon:
 postgre-etersoft9.0-seltaaddon зависит от postgre-etersoft9.0, однако:
  Пакет postgre-etersoft9.0 пока не настроен.
dpkg: не удалось обработать параметр postgre-etersoft9.0-seltaaddon (--install):
 проблемы зависимостей -- оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
 postgre-etersoft9.0-server
 postgre-etersoft9.0
 postgre-etersoft9.0-contrib
 postgre-etersoft9.0-plperl
 postgre-etersoft9.0-plpython
 postgre-etersoft9.0-seltaaddon


Удалял руками искал через dpkg -l | grep -i post   пакеты и удалял постгрескл... Устанавливал снова. Ничего не выходит.

Устанавливал postgresql-common ручками. Все равно не ставится.

Spoiler: ShowHide
root@new:~/new/etersoft# aptitude install postgresql-common
Следующие НОВЫЕ пакеты будут установлены:
  postgresql-client-common{a} postgresql-common
Следующие частично установленные пакеты будут настроены:
  postgre-etersoft9.0 postgre-etersoft9.0-contrib postgre-etersoft9.0-plperl postgre-etersoft9.0-plpython postgre-etersoft9.0-seltaaddon postgre-etersoft9.0-server
0 пакетов обновлено, 2 установлено новых, 0 пакетов отмечено для удаления, и 202 пакетов не обновлено.
Необходимо получить 184 kB архивов. После распаковки 1 413 kB будет занято.
Хотите продолжить? [Y/n/?] y
Получить:1 http://mirror.yandex.ru/debian/ squeeze/main postgresql-client-common all 113 [56,9 kB]
Получить:2 http://mirror.yandex.ru/debian/ squeeze/main postgresql-common all 113 [127 kB]
Получено 184 kБ в 1с (110 kБ/с)
Предварительная настройка пакетов ...
Выбор ранее не выбранного пакета postgresql-client-common.
(Чтение базы данных ... на данный момент установлено 126711 файлов и каталогов.)
Распаковывается пакет postgresql-client-common (из файла .../postgresql-client-common_113_all.deb)...
dpkg: не удалось обработать параметр /var/cache/apt/archives/postgresql-client-common_113_all.deb (--unpack):
 попытка перезаписать «/usr/bin/createdb», который уже имеется в пакете postgre-etersoft9.0 9.0.4-eter14debian
configured to not write apport reports
                                      Выбор ранее не выбранного пакета postgresql-common.
Распаковывается пакет postgresql-common (из файла .../postgresql-common_113_all.deb)...
dpkg: не удалось обработать параметр /var/cache/apt/archives/postgresql-common_113_all.deb (--unpack):
 попытка перезаписать «/etc/init.d/postgresql», который уже имеется в пакете postgre-etersoft9.0-server 9.0.4-eter14debian
configured to not write apport reports
                                      Обрабатываются триггеры для man-db ...
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/postgresql-client-common_113_all.deb
 /var/cache/apt/archives/postgresql-common_113_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Не удалось установить пакет. Попытка восстановить:
dpkg: зависимости пакетов не позволяют настроить пакет postgre-etersoft9.0:
 postgre-etersoft9.0 зависит от postgresql-common, однако:
  Пакет postgresql-common не установлен.
dpkg: не удалось обработать параметр postgre-etersoft9.0 (--configure):
 проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет postgre-etersoft9.0-server:
 postgre-etersoft9.0-server зависит от postgre-etersoft9.0, однако:
  Пакет postgre-etersoft9.0 пока не настроен.
 postgre-etersoft9.0-server зависит от postgresql-common, однако:
  Пакет postgresql-common не установлен.
dpkg: не удалось обработать параметр postgre-etersoft9.0-server (--configure):
 проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет postgre-etersoft9.0-seltaaddon:
 postgre-etersoft9.0-seltaaddon зависит от postgre-etersoft9.0, однако:
  Пакет postgre-etersoft9.0 пока не настроен.
dpkg: не удалось обработать параметр postgre-etersoft9.0-seltaaddon (--configure):
 проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет postgre-etersoft9.0-contrib:
 postgre-etersoft9.0-contrib зависит от postgre-etersoft9.0, однако:
  Пакет postgre-etersoft9.0 пока не настроен.
dpkg: не удалось обработать параметр postgre-etersoft9.0-contrib (--configure):
 проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет postgre-etersoft9.0-plpython:
 postgre-etersoft9.0-plpython зависит от postgre-etersoft9.0-server, однако:
  Пакет postgre-etersoft9.0-server пока не настроен.
dpkg: не удалось обработать параметр postgre-etersoft9.0-plpython (--configure):
 проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет postgre-etersoft9.0-plperl:
 postgre-etersoft9.0-plperl зависит от postgre-etersoft9.0-server, однако:
  Пакет postgre-etersoft9.0-server пока не настроен.
dpkg: не удалось обработать параметр postgre-etersoft9.0-plperl (--configure):
 проблемы зависимостей -- оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
 postgre-etersoft9.0
 postgre-etersoft9.0-server
 postgre-etersoft9.0-seltaaddon
 postgre-etersoft9.0-contrib
 postgre-etersoft9.0-plpython
 postgre-etersoft9.0-plperl
« Последнее редактирование: 14 Июнь 2012, 13:02:00 от Ghostdmn »
 

Онлайн qupl

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 4629
  • memento mori
  • Jabber: qupl@jabber.ru
Re: Postgresql помогите...
« Ответ #1 : 14 Июнь 2012, 12:14:42 »
Я бы сначала удалил (purge) все руками установленные пакеты postgresql, поставил  postgresql-common стандартными средствами, а только потом устанавливал версию от Этерсофта.

Оффлайн krasnopoyas

  • Новичок форума
  • Topic Author
  • Сообщений: 3
Re: Postgresql помогите...
« Ответ #2 : 14 Июнь 2012, 12:30:52 »
сделал так. удалил по поиску пакетов и процессов, файлов и папок все что связано с postgresql и с 1с.
Установил postgresql-common
установил от Этерсофта. Так же. Ничего нового.
Помогите пожалуйста разобраться глубже.
 :'(
 


Онлайн qupl

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 4629
  • memento mori
  • Jabber: qupl@jabber.ru
Re: Postgresql помогите...
« Ответ #3 : 14 Июнь 2012, 12:58:56 »
Ничего нового это как?  "установил от Этерсофта" - НЕ установил? тогда что пишет сейчас?

Оффлайн krasnopoyas

  • Новичок форума
  • Topic Author
  • Сообщений: 3
Re: Postgresql проблема с установкой
« Ответ #4 : 15 Июнь 2012, 08:58:59 »
теперь вот такая петрушка.
при установке коммон
Spoiler: ShowHide
root@new:~# aptitude install postgresql-common
Следующие НОВЫЕ пакеты будут установлены:
  postgresql-client-common{a} postgresql-common
0 пакетов обновлено, 2 установлено новых, 0 пакетов отмечено для удаления, и 202 паке                 тов не обновлено.
Необходимо получить 0 B/184 kB архивов. После распаковки 1 413 kB будет занято.
Хотите продолжить? [Y/n/?] y
Предварительная настройка пакетов ...
Выбор ранее не выбранного пакета postgresql-client-common.
(Чтение базы данных ... на данный момент установлено 121557 файлов и каталогов.)
Распаковывается пакет postgresql-client-common (из файла .../postgresql-client-common                 _113_all.deb)...
Выбор ранее не выбранного пакета postgresql-common.
Распаковывается пакет postgresql-common (из файла .../postgresql-common_113_all.deb).                 ..
Обрабатываются триггеры для man-db ...
Настраивается пакет postgresql-client-common (113) ...
Настраивается пакет postgresql-common (113) ...
Building PostgreSQL dictionaries from installed myspell/hunspell packages...
  en_us
insserv: warning: script 'K01etercifs' missing LSB tags and overrides
insserv: warning: script 'K01etersafe' missing LSB tags and overrides
insserv: warning: script 'K01wine' missing LSB tags and overrides
insserv: warning: script 'etersafe' missing LSB tags and overrides
insserv: warning: script 'etercifs.outformat' missing LSB tags and overrides
insserv: warning: script 'wine' missing LSB tags and overrides
insserv: warning: script 'etersafe.outformat' missing LSB tags and overrides
insserv: warning: script 'etercifs' missing LSB tags and overrides


а потом перехожу в папку Этерсофта и ставлю постгрескл
Spoiler: ShowHide
root@new:~/new/etersoft# dpkg -i *.deb
Выбор ранее не выбранного пакета libpq5.2-9.0eter.
(Чтение базы данных ... на данный момент установлено 121646 файлов и каталогов.)
Распаковывается пакет libpq5.2-9.0eter (из файла libpq5.2-9.0eter_9.0.4-eter14debian_                 i386.deb)...
Выбор ранее не выбранного пакета postgre-etersoft9.0.
Распаковывается пакет postgre-etersoft9.0 (из файла postgre-etersoft9.0_9.0.4-eter14d                 ebian_i386.deb)...
dpkg: не удалось обработать параметр postgre-etersoft9.0_9.0.4-eter14debian_i386.deb                  (--install):
 попытка перезаписать «/usr/bin/pg_dump», который уже имеется в пакете postgresql-cli                 ent-common 113
dpkg-deb: подпроцесс вставка завершён по сигналу (Обрыв канала)
Выбор ранее не выбранного пакета postgre-etersoft9.0-contrib.
Распаковывается пакет postgre-etersoft9.0-contrib (из файла postgre-etersoft9.0-contr                 ib_9.0.4-eter14debian_i386.deb)...
dpkg: не удалось обработать параметр postgre-etersoft9.0-contrib_9.0.4-eter14debian_i                 386.deb (--install):
 попытка перезаписать «/usr/bin/vacuumlo», который уже имеется в пакете postgresql-cl                 ient-common 113
dpkg-deb: подпроцесс вставка завершён по сигналу (Обрыв канала)
Выбор ранее не выбранного пакета postgre-etersoft9.0-docs.
Распаковывается пакет postgre-etersoft9.0-docs (из файла postgre-etersoft9.0-docs_9.0                 .4-eter14debian_i386.deb)...
Выбор ранее не выбранного пакета postgre-etersoft9.0-plperl.
Распаковывается пакет postgre-etersoft9.0-plperl (из файла postgre-etersoft9.0-plperl                 _9.0.4-eter14debian_i386.deb)...
Выбор ранее не выбранного пакета postgre-etersoft9.0-plpython.
Распаковывается пакет postgre-etersoft9.0-plpython (из файла postgre-etersoft9.0-plpy                 thon_9.0.4-eter14debian_i386.deb)...
Выбор ранее не выбранного пакета postgre-etersoft9.0-seltaaddon.
Распаковывается пакет postgre-etersoft9.0-seltaaddon (из файла postgre-etersoft9.0-se                 ltaaddon_9.0.4-eter14debian_i386.deb)...
Выбор ранее не выбранного пакета postgre-etersoft9.0-server.
Распаковывается пакет postgre-etersoft9.0-server (из файла postgre-etersoft9.0-server                 _9.0.4-eter14debian_i386.deb)...
dpkg: не удалось обработать параметр postgre-etersoft9.0-server_9.0.4-eter14debian_i3                 86.deb (--install):
 попытка перезаписать «/etc/init.d/postgresql», который уже имеется в пакете postgres                 ql-common 113
dpkg-deb: подпроцесс вставка завершён по сигналу (Обрыв канала)
Настраивается пакет libpq5.2-9.0eter (9.0.4-eter14debian) ...
Generating locales (this might take a while)...
  en_US.ISO-8859-1... done
  en_US.UTF-8... done
  ru_RU.CP1251... done
  ru_RU.KOI8-R... done
  ru_RU.UTF-8... done
Generation complete.
Generating locales (this might take a while)...
  en_US.ISO-8859-1... done
  en_US.UTF-8... done
  ru_RU.CP1251... done
  ru_RU.KOI8-R... done
  ru_RU.UTF-8... done
Generation complete.
Настраивается пакет postgre-etersoft9.0-docs (9.0.4-eter14debian) ...
dpkg: зависимости пакетов не позволяют настроить пакет postgre-etersoft9.0-plperl:
 postgre-etersoft9.0-plperl зависит от postgre-etersoft9.0-server, однако:
  Пакет postgre-etersoft9.0-server не установлен.
dpkg: не удалось обработать параметр postgre-etersoft9.0-plperl (--install):
 проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет postgre-etersoft9.0-plpython:
 postgre-etersoft9.0-plpython зависит от postgre-etersoft9.0-server, однако:
  Пакет postgre-etersoft9.0-server не установлен.
dpkg: не удалось обработать параметр postgre-etersoft9.0-plpython (--install):
 проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет postgre-etersoft9.0-seltaaddon                 :
 postgre-etersoft9.0-seltaaddon зависит от postgre-etersoft9.0, однако:
  Пакет postgre-etersoft9.0 не установлен.
dpkg: не удалось обработать параметр postgre-etersoft9.0-seltaaddon (--install):
 проблемы зависимостей -- оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
 postgre-etersoft9.0_9.0.4-eter14debian_i386.deb
 postgre-etersoft9.0-contrib_9.0.4-eter14debian_i386.deb
 postgre-etersoft9.0-server_9.0.4-eter14debian_i386.deb
 postgre-etersoft9.0-plperl
 postgre-etersoft9.0-plpython
 postgre-etersoft9.0-seltaaddon


а вот вывод  dpkg -l | grep -i post
Spoiler: ShowHide
ii  evince                               2.30.3-2                          Document (PostScript, PDF) viewer
ii  evince-common                        2.30.3-2                          Document (PostScript, PDF) viewer - common files
ii  ghostscript                          8.71~dfsg2-9                      The GPL Ghostscript PostScript/PDF interpreter
ii  ghostscript-cups                     8.71~dfsg2-9                      The GPL Ghostscript PostScript/PDF interpreter - CUPS filters
ii  hp-ppd                               0.9-0.1                           HP Postscript Printer Definition (PPD) files
ii  libevince2                           2.30.3-2                          Document (PostScript, PDF) rendering library
ii  libgs8                               8.71~dfsg2-9                      The Ghostscript PostScript/PDF interpreter Library
ii  libhtml-format-perl                  2.04-2                            format HTML syntax trees into text, PostScript or RTF
ii  libpostproc51                        4:0.5.2-6                         ffmpeg video postprocessing library
ii  libpq5.2-9.0eter                     9.0.4-eter14debian                The shared libraries required for any PostgreSQL clients
ii  libspectre1                          0.2.6-1                           Library for rendering PostScript documents
ii  postgre-etersoft9.0-docs             9.0.4-eter14debian                Extra documentation for PostgreSQL
iU  postgre-etersoft9.0-plperl           9.0.4-eter14debian                The Perl procedural language for PostgreSQL
iU  postgre-etersoft9.0-plpython         9.0.4-eter14debian                The Python procedural language for PostgreSQL
iU  postgre-etersoft9.0-seltaaddon       9.0.4-eter14debian                Selta addon for postgresql
ii  postgresql-client-common             113                               manager for multiple PostgreSQL client versions
ii  postgresql-common                    113                               PostgreSQL database-cluster manager


« Последнее редактирование: 15 Июнь 2012, 09:01:56 от krasnopoyas »
 

Онлайн qupl

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 4629
  • memento mori
  • Jabber: qupl@jabber.ru
Re: Postgresql проблема с установкой
« Ответ #5 : 15 Июнь 2012, 10:24:22 »
То что в пакете/пакетах, который устанавливается вручную проблемы с зависимостями - очевидно.
Как я понимаю продукт платный, у них инструкции нет нормальной по установке?
Вот что нагуглилось у них.

в порядке бреда: ShowHide

Попробуй еще раз все пакеты , включая postgresql-client-common и postgresql-common удалить.
А при установке сделать так
dpkg -i *.deb --ignore-depends=тут_перечислить_через_запятую_список_всех_пакетов

Оффлайн dduh

  • Пользователь
  • *
  • Сообщений: 38
Re: Postgresql проблема с установкой
« Ответ #6 : 17 Июнь 2012, 10:34:27 »
У них на сайте в вики есть про установку. Неоднократно устанавливал, проблем не возникало. Правда ставил в виртуалке на голый Дебиан.
Какую версию скачиваете с их сайта. Попробуйте не 9.0.4 а 9.0.
9.0.4 сыпала ошибками.
http://updates.etersoft.ru/pub/Etersoft/Postgre@Etersoft/9.0/
« Последнее редактирование: 17 Июнь 2012, 10:45:03 от dduh »
 

Оффлайн ferum

  • Ветеран
  • *****
  • Сообщений: 3419
  • Buster TDE & Buster LXDE & stretch KDE
Re: Postgresql проблема с установкой
« Ответ #7 : 17 Июнь 2012, 15:05:14 »
Давненько уже читал на одном из форумов. и вот теперь уже не получается найти, смысл такой: создаётся папка в домашнем каталоге, в неё складываются сторонние деб пакеты, которые вы хотите установить, можно разных версий. Эта папка прописывается в source.list как источник (знать бы как правильно это делать) и ваши пакеты видит synaptic или aptitude кому как удобнее. Выбираете желаемый пакет для установки и если это возможно aptitude автоматически разрешит зависимости, если не возможно пробуйте другую версию желаемого пакета....как то так. ::)
Кстати http://ubuntologia.ru/forum/viewtopic.php?f=96&t=2272
« Последнее редактирование: 17 Июнь 2012, 15:34:24 от ferum »
Русские дебианщики против цифрового слабоумия !
 

Оффлайн Brainey

  • Ветеран
  • *****
  • Сообщений: 1943
  • Jabber: brainey@jabber.cz
Re: Postgresql проблема с установкой
« Ответ #8 : 17 Июнь 2012, 16:00:45 »
смысл такой: создаётся папка в домашнем каталоге, в неё складываются сторонние деб пакеты, которые вы хотите установить
А не проще использовать # dpkg -i * в том же каталоге, вместо прописки в sources.list?
Конференция форума в jabber: debianforum@conference.jabber.ru | Клуб кедоводов: kde@conference.jabber.ru
 

Оффлайн ferum

  • Ветеран
  • *****
  • Сообщений: 3419
  • Buster TDE & Buster LXDE & stretch KDE
Re: Postgresql проблема с установкой
« Ответ #9 : 17 Июнь 2012, 18:24:55 »
А не проще использовать
проще, но результат как мы видим выше не всегда устраивает, а вариант с локальным репозиторием просто позволит избежать установки пакетов с ошибками, вместо этого методом так сказать научного тыка подбирается вариант для успешной установки программы.....возможно это не существенно , но вроде как автоматическое разрешение зависимостей удобная штука, а утилита dpkg этого делать не умеет, в отличии от aptitude  и apt-get.
Русские дебианщики против цифрового слабоумия !
 

Теги:
 

Кластер для PostgreSQL

Автор vladimirse

Ответов: 0
Просмотров: 1723
Последний ответ 15 Март 2012, 12:49:28
от vladimirse
Postgresql перенос базы данных на другой жесткий диск

Автор admiral62

Ответов: 9
Просмотров: 7689
Последний ответ 01 Сентябрь 2016, 10:39:42
от admiral62
Проблемы с PostgreSQL 9.4

Автор Palamar

Ответов: 12
Просмотров: 6249
Последний ответ 24 Январь 2017, 08:55:58
от Palamar