debian.org / О Debian Где взять Debian Поддержка Уголок разработчика Новости Wiki

Автор Тема: кодировка 1251 в текстовом редакторе Gedit  (Прочитано 2820 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн wolfnight

  • Topic Author
  • Сообщений: 15
    • Сайт хаба Pozitive
Когда открываю текстовый файл редактором гедит в терминале , то при сохранении документа доступна только кодировка UTF-8 , как сделать чтоб гедит сохранял и корректно просматривал кодировку 1251
 

Оффлайн SeHELLioN

  • Сообщений: 910
Re: кодировка 1251 в текстовом редакторе Gedit
« Ответ #1 : 21 Июнь 2012, 18:50:56 »
вот http://archivazhno.blogspot.com/2009/01/gedit-cp1251.html
и вот http://biotex.ibss.org.ua/faq_profile.html?id=72
а по теме: ТС - еретик. язабан сжечь
Asus m5a97+Amd fx-8350+4x4GB DDR3 1600MGz+asus gtx670 DCII (перешита в top)
Debian stable
 

Оффлайн wolfnight

  • Topic Author
  • Сообщений: 15
    • Сайт хаба Pozitive
Re: кодировка 1251 в текстовом редакторе Gedit
« Ответ #2 : 21 Июнь 2012, 19:08:03 »
сделал как написанно в мануале толку ноль , поясню когда открываю файл гедитом кликая по файлу мышью то и сохраняет и показывает нормально текст , НО В ТЕРМИНАЛЕ ГЕДИТ ОТОБРАЖАЕТ И СОХРАНЯЕТ ТОЛЬКО КОДИРОВКУ UTF-8
 

Оффлайн qupl

  • Сообщений: 4277
  • memento mori
  • Jabber: qupl@jabber.ru
Re: кодировка 1251 в текстовом редакторе Gedit
« Ответ #3 : 21 Июнь 2012, 19:44:29 »
Как Вы умудрились запустить gedit В ТЕРМИНАЛЕ ?

Оффлайн wolfnight

  • Topic Author
  • Сообщений: 15
    • Сайт хаба Pozitive
Re: кодировка 1251 в текстовом редакторе Gedit
« Ответ #4 : 21 Июнь 2012, 19:56:04 »
Как Вы умудрились запустить gedit В ТЕРМИНАЛЕ ?



например редактирование файла мотд


wolf@wolf-PC:~$ su
Пароль:
root@wolf-PC:/home/wolf# gedit /etc/verlihub/motd

при открытии файла получаю крякозябры а когда жму сохранить как то там только утф 8 , если открывать файл кликая по нему мышкой то там много вариантов сохранения , но файл мотд (к примеру) можно редактироватьь только через терминал т.к он рутовский
 

Оффлайн qupl

  • Сообщений: 4277
  • memento mori
  • Jabber: qupl@jabber.ru
Re: кодировка 1251 в текстовом редакторе Gedit
« Ответ #5 : 21 Июнь 2012, 20:08:33 »
Из под root-а выполни
locale -a

Оффлайн Ghostdmn

  • Ленивы... Ай, лень допеча...
  • Сообщений: 854
  • Jabber: ghostdmn@jabber.cz
Re: кодировка 1251 в текстовом редакторе Gedit
« Ответ #6 : 21 Июнь 2012, 20:09:06 »
gconf-editor

/apps/gedit-2/preferences/encodings

auto_detected:

WINDOWS-1251
CURRENT
UTF-8

не?


Или юзать medit
« Последнее редактирование: 21 Июнь 2012, 20:12:47 от Ghostdmn »
8Gb/GTX750Ti 2Gb/AMD FX(tm)-4300 Quad-Core Processor/HDD 1Tb Toshiba DT01ACA100
 

Оффлайн wolfnight

  • Topic Author
  • Сообщений: 15
    • Сайт хаба Pozitive
Re: кодировка 1251 в текстовом редакторе Gedit
« Ответ #7 : 21 Июнь 2012, 20:18:07 »
Из под root-а выполни
locale -a


root@wolf-PC:/home/wolf# locale -a
C
POSIX
ru_RU.cp1251
ru_RU.utf8
root@wolf-PC:/home/wolf#


Сообщение объединено: 21 Июнь 2012, 20:22:10
gconf-editor

/apps/gedit-2/preferences/encodings

auto_detected:

WINDOWS-1251
CURRENT
UTF-8

не?


Или юзать medit



поставил кодировки как ты сказал : WINDOWS-1251
CURRENT
UTF-8

все заработало как надо , спасибо


а не так же от рута сохранение только в утф 8 , а если из под пользователя открывать то большой выбор кодировок

Сообщение объединено: 21 Июнь 2012, 20:28:13
я что то не понимаю почему от рута сохранение только в утф 8 а от пользователи в разные кодировки в том числе в 1251 ?


Сообщение объединено: 21 Июнь 2012, 20:43:25
так есть варианты как сделать 1251 ? просмотр и сохранения

Сообщение объединено: 21 Июнь 2012, 21:17:07
вобщем тема закрыта , запуск в терминале su гедит только сохранение в утф-8 от пользователя работают все кодировки

что бы работали другие кодировки от пользователя root надо открывать терминал-root
« Последнее редактирование: 21 Июнь 2012, 21:17:07 от wolfnight »
 

Оффлайн Grey_rnd

  • Сообщений: 109
  • Ростов-на-Дону
  • Jabber: grey_rnd@xmpp.ru
Re: кодировка 1251 в текстовом редакторе Gedit
« Ответ #8 : 23 Сентябрь 2017, 08:32:45 »
Ну все бы хорошо, только у меня не работает..запускаю gconf-editor.....а там пусто...
gsettings set org.gnome.gedit.preferences.encodings auto-detected "['UTF-8', 'WINDOWS-1251', 'CURRENT', 'ISO-8859-15', 'UTF-16']"то ж не помогает..пишет нет параметра auto-detected
Asus X59SL
 

Оффлайн Udachnik

  • Сообщений: 1439
Re: кодировка 1251 в текстовом редакторе Gedit
« Ответ #9 : 26 Сентябрь 2017, 18:09:53 »
Ну все бы хорошо, только у меня не работает..запускаю gconf-editor.....а там пусто...
Потому что сейчас вместо gconf используется dconf
Попробуйте выполнить
gsettings set org.gnome.gedit.preferences.encodings candidate-encodings "['UTF-8', 'WINDOWS-1251', 'KOI8-R', 'CURRENT', 'ISO-8859-15', 'UTF-16']"
 

Теги: