Не запускаются приложения.

Автор vladimir_ar, 24 декабря 2012, 02:07:11

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

vladimir_ar

Ситуация следующая (была и ранее пару раз, но не придал значения):
по какой-то причине не запускаются приложения (любые). Т. е. есть загруженная система (wheezy, XFCE-4.8 ), работающая несколько дней (на ночь в ждущий (suspend)), запущено с десяток различных приложений (iceweasel, nautilus, xfce-terminal, vlc, deadbeef и т. п.). В какойто момент перестают запускаться любые приложения - указатель мышки показывает занятость, потом возвращается к исходному виду и все. Приложения не запускаются (каюсь - из терминала не попробовал, сейчас на работе). Если закрыть одно из открытых на данный момент приложений - то можно запустить одно какое либо еще. Закрыть два - запустить два. И т. д. Все. Воспроизвести не получится - прошлая подобная ситуация была месяц - полтора назад. Нужно ждать. Лечил перезагрузкой (в первый раз после перезагрузки проверял мысль - а может где какой лимит - запускал несколько десятков разных приложений - ситуацию не воспроизвел). Сегодня на исследования без перезагрузки сильно не было времени и нужно было поставить в комп другую wi-fi карточку - выключился.

Вопрос в следующем - может, у кого какие мысли есть по этому поводу и куда стоит посмотреть в случае повторения (искусственно воспроизвести не получается - нужно ждать). Есть мысль, что как-то связано со ждущим режимом, но не оформившаяся. Да и, если честно, даже не представляю пока, куда и что смотреть в случае рецидива.

Памяти предостаточно - 12 GB. Занято на момент события не более 3. И на / места около 4 GB, т. е. и на /temp место есть.
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
  •  

qupl

Только проверять в консоли и смотреть логи.

vladimir_ar

Буду ждать. Логи, придя домой, посмотрю - должны остаться. А какие конкретно? Я так понимаю, в кернел.лог маловероятно такое будет? Это скорее уровень приложений? Может это глупое рассуждение, но моих знаний в этой области сильно недостаточно.
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
  •  

qupl


vladimir_ar

#4
Подозрение, что все же как-то связано или с аптаймом, или с тем, что я в ждущий ложу на ночь систему (именно с целью ее не выключать). Будут предновогодние / новогодние праздники, длительные выходные (буду дома, ночных смен не будет, жена выключать комп не будет) - если причина с этим связана - выплывет.
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
  •  

qupl

Может быть в swap не всё влазит при засыпании?

Udachnik

Цитата: vladimir_ar от 24 декабря 2012, 07:30:07Логи, придя домой, посмотрю - должны остаться. А какие конкретно?
Ошибки приложений пишутся в syslog. Он огромный, поэтому грепать по названию приложения.
  •  

vladimir_ar

#7
Цитата: qupl от 24 декабря 2012, 08:08:57Может быть в swap не всё влазит при засыпании?
А, сори, перепутал по ночи названия - ждущий. Да и своп 10G (надо бы увеличить, но по занятой памяти выше 4 не переступал). И если б в своп не влез - не заснул бы.

PS. Исправил на ждущий / suspend. А то слип да - неправильно.

Сообщение объединено: 24 декабря 2012, 08:34:51

Хотя, по поводу того, что в своп не влезет - если не путаю - то при укладке сжимается? (Или просто читал, что можно включить - не помню)

Сообщение объединено: 24 декабря 2012, 20:52:55

Просмотрел сислог за вчерашний день - не увидел там записей по поводу каких - либо проблем с какими - либо приложениями. И в то время, когда проявилась проблема - тоже никаких записей.
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
  •  

qupl

vladimir_ar, а какая реакция на запуск из консоли?

vladimir_ar

Так тогда не додумался, а теперь жду повторения - спровоцировать не знаю как.
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
  •  

vladimir_ar

#10
Словил!
vladimir-7@GNU-HOME:~$ gedit
Maximum number of clients reached Не удалось открыть дисплей:
Запустите «gedit --help» для получения полного списка поддерживаемых ключей.
vladimir-7@GNU-HOME:~$

Пока гуглю.

Сообщение объединено: 28 декабря 2012, 01:42:53

По моему - решилось. После закрытия в трее и запрета на запуск <Быстрый запуск приложений libreoffice> (как то так - дословно не помню) - приложения начали запускаться. Еще понаблюдаю.
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
  •  

qupl

Вот что консоль животворящая делает. ;)

Malaheenee

Все мы где-то, когда-то и в чем-то были новичками.
  •  

vladimir_ar

Какой-то баг с индикатором быстрого запуска приложений офиса - не освобождает сокеты после использования. Пока гуглил, натыкался на жалобы на аналогичное поведение некоторых расширений под firefoxe.
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
  •  

qupl

vladimir_ar, такое же поиск говорил о каких-то примочках к хрому связанных с треем. Похоже на кривость X-овых приложений.