debian.org / О Debian Где взять Debian Поддержка Уголок разработчика Новости Wiki

Автор Тема: [РЕШЕНО]Нет ждущего режима  (Прочитано 4909 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Deni$

  • Topic Author
  • Сообщений: 12
[РЕШЕНО]Нет ждущего режима
« : 10 Апрель 2011, 16:52:20 »
Ноутбук Acer 5635. Не работает ждущий режим и его нет в настройках "Управление питанием". И где можно тонко настроить параметры (того же питания) типа - Редактор конфигурации

Сообщение дополнено через 4 часа 21 минуту 21 секунду

Не знаю, что повлеяло, но после того как я шаманил с монтированием и установкой hdd-temp, ждущий и спящий режимы появились.
« Последнее редактирование: 10 Май 2011, 13:51:28 от Ghostdmn »
 

Оффлайн prof1983

  • Сообщений: 20
  • Все мы в чем-то новички.
  • Jabber: prof1983@jabber.ru
Re: [РЕШЕНО]Нет ждущего режима
« Ответ #1 : 27 Август 2011, 12:33:01 »
Ноутбук Acer 5635. Не работает ждущий режим и его нет в настройках "Управление питанием". И где можно тонко настроить параметры (того же питания) типа - Редактор конфигурации
У меня похожая проблема. Только кнопки ждущего и спящего режима присутствуют. Спящий режим (с выгрузкой содержимого оперативной памяти на HDD и полным отключением) работает. Восстановление из спящего режима тоже работает. Только эта процедура занимает больше времени, чем загрузка.

А вот ждущий режим не работает. Вернее сказать в ждущий режим уходит, вентилятор и пр. отключаются, лампочка питания медленно мигает, как и положено. А вот восстанавливаться из ждущего режима не хочет. При этом вентилятор включается, а экран нет, не реагирует на кнопки и т.д. Завершение работы по нажатию на кнопку вкл/откл не происходит. В консоль по Ctrl+Alt+F1..F7 тоже не переходит. В общем пока не знаю что делать. Проблема не серьезная, поэтому пока просто не пользуюсь ждущим режимом.

У меня, кстати, ноутбук Asus F5SL

Не знаю, что повлеяло, но после того как я шаманил с монтированием и установкой hdd-temp, ждущий и спящий режимы появились.
Можно узнать подробнее, что за hdd-temp и что можно попробовать сделать в моем случае?

(Пофиксил: "спящий" -> "ждущий")
« Последнее редактирование: 28 Август 2011, 05:29:12 от prof1983 »
Runtu-Lite-10.04-201107 + Debian-6.0.2 @ Asus F5SL
 

Оффлайн prof1983

  • Сообщений: 20
  • Все мы в чем-то новички.
  • Jabber: prof1983@jabber.ru
Re: [РЕШЕНО]Нет ждущего режима
« Ответ #2 : 27 Август 2011, 12:37:32 »
Да. Кстати. У меня установлен Debian-6.0.2.1.
Runtu-Lite-10.04-201107 + Debian-6.0.2 @ Asus F5SL
 

Оффлайн Ghostdmn

  • Ленивы... Ай, лень допеча...
  • Сообщений: 854
  • Jabber: ghostdmn@jabber.cz
Re: [РЕШЕНО]Нет ждущего режима
« Ответ #3 : 27 Август 2011, 13:01:02 »
Какая взаимосвязь между датчиками температуры (hddtemp) и режимами?

prof1983, Своп выделял при установке?

И да, что за видеокарта и дрова?
« Последнее редактирование: 27 Август 2011, 13:04:17 от Ghostdmn »
8Gb/GTX750Ti 2Gb/AMD FX(tm)-4300 Quad-Core Processor/HDD 1Tb Toshiba DT01ACA100
 

Оффлайн prof1983

  • Сообщений: 20
  • Все мы в чем-то новички.
  • Jabber: prof1983@jabber.ru
Re: [РЕШЕНО]Нет ждущего режима
« Ответ #4 : 27 Август 2011, 19:16:02 »
prof1983, Своп выделял при установке?
Swap конечно выделил. Как рекомендовали где-то в документации 2хОЗУ = 2х2 ГБ = 4 ГБ swap.

И да, что за видеокарта и дрова?
Видеокарточка дурацкая. ATI Mobility Radeon HD3470. Она в WinXP зачастую определялась как ATI Radeon HD3500 (или что-то подобное, не Mobility), драйверы устанавливались, но запустится не могли. На сколько я понимаю автоопределение видеокарточки идет по каким-то внутренним кодам (идентификаторам) оборудования. И на сколько я понял для некоторых видеокарт ATI делала аналогичные Mobility варианты (обрезки от полноценных) и у них, вероятно, одинаковые идентификаторы. Так что, возможно, просто соответствующий модуль ядра Linux пытает работать с моим урезанным видеочипом как с полноценным. В общем есть некоторые проблемы.

Вот тут, например, можно посмотреть характеристики остального оборудования на моем ноутбуке.
http://notebookbe.ru/asus-f5sl.html
http://www.elnb.ru/product/asus-f5sl/

Единственное, я установил дополнительно 1 Гб ОЗУ + винт поменял на 640 Гб.

Что касается вопроса про дрова. Это надо лог /var/log/xorg.log выложить или как их посмотреть?
« Последнее редактирование: 27 Август 2011, 19:18:16 от prof1983 »
Runtu-Lite-10.04-201107 + Debian-6.0.2 @ Asus F5SL
 

paulcarroty

  • Гость
Re: [РЕШЕНО]Нет ждущего режима
« Ответ #5 : 27 Август 2011, 22:40:39 »
Swap конечно выделил. Как рекомендовали где-то в документации 2хОЗУ = 2х2 ГБ = 4 ГБ swap.
Ужас. Вы представляете время, за сколько такой обьем просвопится?
 

Оффлайн prof1983

  • Сообщений: 20
  • Все мы в чем-то новички.
  • Jabber: prof1983@jabber.ru
Re: [РЕШЕНО]Нет ждущего режима
« Ответ #6 : 28 Август 2011, 05:27:01 »
Ужас. Вы представляете время, за сколько такой обьем просвопится?
Смотря что вы имеете в виду под словом "просвопится".

Признаться я могу перепутать термины, поэтому стараюсь смотреть википедию. Вот из Википедии про swap:
Цитировать
Своп (англ. swap) — русифицированный термин, означающий один из способов представления виртуальной памяти. При этом подразумевается, что данные из виртуальной памяти частично располагаются на внешних запоминающих устройствах.
Своп (жарг. «подкачивать») — термин означающий «процесс подкачки данных» между внешними запоминающими устройствами вычислительной системы и её оперативной памятью.

На сколько я понимаю подкачка (swap) используется только при заполнении основного ОЗУ. А так же при переходе в спящий режим. Так вот 2 Гб записать на HDD, а потом восстановить - это довольно долго. Дольше, чем загрузить с нуля.
При этом размер swap раздела не должен быть меньше определенной величины. Но максимальный размер не имеет значения. Можно было выделить и 16 Гб, но это бессмысленно, т.к. файл подкачки при ОЗУ размером 2 Гб скорее всего (на домашнем компьютере) использоваться не будет. Если бы это был сервер, то другое дело.

Теперь несколько слов в тему топика. Кроме не работающего ждущего режима есть еще много проблем. В частности такая: Я попробовал установить Debian-testing. Установится он без проблем, но стартовать правильно не хочет. Не правильно определяет разрешение экрана. Возможно причина и не правильного выхода из ждущего режима и не определения разрешения в Debian-testing одна и та же. А именно драйвер modules/drivers/ati_drv.so и/или modules/drivers/radeon_drv.so . Но это отдельная тема.

Кстати. Сейчас прочитал свое первое сообщение. Там допустил ошибку. Вместо ждущего режима, написал спящий в нескольких местах.
Runtu-Lite-10.04-201107 + Debian-6.0.2 @ Asus F5SL
 

Оффлайн prof1983

  • Сообщений: 20
  • Все мы в чем-то новички.
  • Jabber: prof1983@jabber.ru
Re: [РЕШЕНО]Нет ждущего режима
« Ответ #7 : 28 Август 2011, 06:52:23 »
Вот нашел тему в которой обсуждается такая же проблема.
http://linuxforum.ru/viewtopic.php?id=13450 - "Отсутствует ждущий режим"

В нем упоминается о необходимости swap, а так же hal.
hal у меня не был установлен. Установил, но это не помогло. (Вместе с hal устанавливается еще пакет hal-info, но это не важно).

Далее приводятся пару хороших ссылок:
http://wiki.debian.org/Suspend
http://mydebiantricks.blogspot.com/2011/01/debian.html

В первой есть описание проверки проблема с экраном или другим оборудованием. В общем когда при восстановлении из ждущего или спящего режима не включается экран, то проверить работает ли система можно нажав CapsLock. При этом соответствующая лампочка должна загораться. У меня этого не происходит.

Сейчас попробую выполнить описание по второй ссылке. Надеюсь поможет.
Runtu-Lite-10.04-201107 + Debian-6.0.2 @ Asus F5SL
 

Оффлайн prof1983

  • Сообщений: 20
  • Все мы в чем-то новички.
  • Jabber: prof1983@jabber.ru
Re: [РЕШЕНО]Нет ждущего режима
« Ответ #8 : 28 Август 2011, 06:59:59 »
Какая взаимосвязь между датчиками температуры (hddtemp) и режимами?
По видимому, при установке hdd-temp в зависимостях присутствуют пакеты, которые необходимы для работы спящего и ждущего режимов (hal и пр.).
Runtu-Lite-10.04-201107 + Debian-6.0.2 @ Asus F5SL
 

Оффлайн prof1983

  • Сообщений: 20
  • Все мы в чем-то новички.
  • Jabber: prof1983@jabber.ru
Re: [РЕШЕНО]Нет ждущего режима
« Ответ #9 : 09 Сентябрь 2011, 09:10:23 »
Попробовал недавно новую Ubuntu 11.10 (Beta1). В ней все работает. И ждущий и спящий и разрешение экрана определила правильно и даже Web камеру определила.
Пробовал еще свежий Knoppix. Ждущий режим в нем работает, а спящий нет.
В Runtu LITE 10.04 201107 у меня ни ждущий не спящий режим не работают.

При этом выполнял рекомендации, которые приводил выше.

Пока не могу определить в чем причина и как это настраивать. Думаю, что проще всего подобрать тот дистрибутив, в котором все работает и доводить его уже до ума. Например в стандартной Ubuntu можно заменить Unity на любую другую DE/DM. В частности мне больше OpenBox и LXDE нравятся.
Runtu-Lite-10.04-201107 + Debian-6.0.2 @ Asus F5SL
 

Оффлайн Teocally

  • Сообщений: 169
  • Jabber: teocally@jabber.ru
Re: [РЕШЕНО]Нет ждущего режима
« Ответ #10 : 09 Сентябрь 2011, 13:57:25 »
Цитировать
Например в стандартной Ubuntu можно заменить Unity на любую другую DE/DM.
Можно поставить как дополнителььный, это да. А заменить вроде как нет, предупреждали даже одно время на бубнофоруме, не делать так.
Или за последнее время что-то изменилось?
 

Теги: