debian.org / О Debian Где взять Debian Поддержка Уголок разработчика Новости Wiki

Автор Тема: [Решено] Нужна libc6-i386 2.15, а в репозитории 2.11  (Прочитано 9453 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн HoleyHat

  • Topic Author
  • Сообщений: 90
  • CrunchBang 11 "Waldorf" 32-bit non-PAE
Только что установил Debian 6.0.7 amd64. Всё хорошо, за исключением того, что мне позарез нужна библиотека libc6-i386 не ниже 2.15, а доступна для скачивания только 2.11. Что делать?
« Последнее редактирование: 31 Май 2013, 06:38:41 от qupl »
Куда страна катится? Только красота спасет мир! Только красота и массовые расстрелы! - к/ф "Антибумер"
 

cinyflo

  • Гость
Re: Нужна libc6-i386 2.15, а в репозитории 2.11
« Ответ #1 : 25 Апрель 2013, 00:23:30 »
Я бы попробовал подклчить репозиторий тестинга или экспериментал, и обновить библиотеку оттуда.
 

Онлайн ogost

  • Сообщений: 2587
  • Linux Registered User #547151
Re: Нужна libc6-i386 2.15, а в репозитории 2.11
« Ответ #2 : 25 Апрель 2013, 09:42:55 »
требуемая Вами библиотека лежит в репах экспериметнала. сид который. версия 2.17.
тыц.

Оффлайн HoleyHat

  • Topic Author
  • Сообщений: 90
  • CrunchBang 11 "Waldorf" 32-bit non-PAE
Re: Нужна libc6-i386 2.15, а в репозитории 2.11
« Ответ #3 : 25 Апрель 2013, 11:44:20 »
требуемая Вами библиотека лежит в репах экспериметнала.

Спасибо! А можно её поставить как-то так, чтобы она использовалась только одним приложением, тем самым, которому она позарез нужна, а вся остальная система использовала стабильную версию?
Куда страна катится? Только красота спасет мир! Только красота и массовые расстрелы! - к/ф "Антибумер"
 

cinyflo

  • Гость
Re: Нужна libc6-i386 2.15, а в репозитории 2.11
« Ответ #4 : 25 Апрель 2013, 12:01:04 »
Нет, при установке более новой версии старая пойдёт под снос.
 

Оффлайн HoleyHat

  • Topic Author
  • Сообщений: 90
  • CrunchBang 11 "Waldorf" 32-bit non-PAE
Re: Нужна libc6-i386 2.15, а в репозитории 2.11
« Ответ #5 : 25 Апрель 2013, 13:40:31 »
Нет, при установке более новой версии старая пойдёт под снос.

Придумал! А как узнать, каким ещё приложениям нужна эта библиотека? Подозреваю, что больше никаким, потому что она обеспечивает взаимодействие 32-битного бинарного кода с 64-битной ОС. А у меня Дебиан поставлен по дефолту, так что он, надо полагать, весь 64-битный насквозь.
Куда страна катится? Только красота спасет мир! Только красота и массовые расстрелы! - к/ф "Антибумер"
 

cinyflo

  • Гость
Re: Нужна libc6-i386 2.15, а в репозитории 2.11
« Ответ #6 : 25 Апрель 2013, 13:48:04 »
Попробуйте её удалить, но не удаляйте. Посмотрите какие зависимости она за собой в ад потащит.

Сообщение объединено: 25 Апрель 2013, 13:50:04
Лично у меня libc6 версии 2.13-38, от неё зависит наверное полсистемы, но это наверное потому что у меня i686.
« Последнее редактирование: 25 Апрель 2013, 13:50:04 от cinyflo »
 

Онлайн ogost

  • Сообщений: 2587
  • Linux Registered User #547151
Re: Нужна libc6-i386 2.15, а в репозитории 2.11
« Ответ #7 : 25 Апрель 2013, 15:11:21 »
aptitude -s purge package_nameс ключом -s симуляция. покажет что произойдет.

Оффлайн HoleyHat

  • Topic Author
  • Сообщений: 90
  • CrunchBang 11 "Waldorf" 32-bit non-PAE
Re: Нужна libc6-i386 2.15, а в репозитории 2.11
« Ответ #8 : 25 Апрель 2013, 21:42:20 »
Я подключил экспериментальный репозиторий и установил libc6-386 оттуда. Добавил строчку в sources.list и создал файл apt.conf, где прописал APT::Default-Release "testing";

Вроде всё прошло гладко, но дать команду aptitude show libc6-i386 и вот что увидел: Пакет: libc6-i386                               
Состояние: установлен
Автоматически установлен: нет
Версия: 2.17-0experimental2
Приоритет: необязательный
Раздел: libs
Сопровождающий: GNU Libc Maintainers <debian-glibc@lists.debian.org>
Архитектура: amd64
Размер в распакованном виде: 9 743 k
Зависимости: libc6 (= 2.17-0experimental2)
Ломают: fakechroot (< 2.9-1.1), fakeroot (< 1.12.3), fglrx-glx-ia32 (< 1:9-6-1),
              gnu-efi (< 3.0e-3), ia32-libs (< 20090804), ia32-libs-gtk (<
              20090804), lib32asound2 (< 1.0.20-3), lib32asound2-dev (<
              1.0.20-3), lib32bz2-1.0 (< 1.0.5-3), lib32bz2-dev (< 1.0.5-3),
              lib32ffi-dev (< 3.0.9~rc9-1), lib32ffi5 (< 3.0.9~rc9-1), lib32g2c0
              (< 1:3.4.6-10), lib32gcc1 (< 1:4.4.0-7), lib32gfortran3 (<
              4.4.0-7), lib32gmp3 (< 2:4.3.1+dfsg-3), lib32gmp3-dev (<
              2:4.3.1+dfsg-3), lib32gmpxx4 (< 2:4.3.1+dfsg-3), lib32gomp1 (<
              4.4.0-7), lib32icu-dev (< 4.0.1-3), lib32icu40 (< 4.0.1-3),
              lib32mudflap0 (< 4.4.0-7), lib32ncurses5 (< 5.7+20090523-1),
              lib32ncurses5-dev (< 5.7+20090530-1), lib32ncursesw5 (<
              5.7+20090530-1), lib32ncursesw5-dev (< 5.7+20090530-1),
              lib32nss-mdns (< 0.10-3.1), lib32objc2 (< 4.4.0-7), lib32readline5
              (< 5.2-5), lib32readline5-dev (< 5.2-5), lib32stdc++6 (< 4.4.0-7),
              lib32stdc++6-4.4-dbg (< 4.4.0-7), lib32z1 (< 1:1.2.3.3.dfsg-14),
              lib32z1-dev (< 1:1.2.3.3.dfsg-14), libc6-dev-i386 (< 2.9-15),
              nvidia-glx-ia32 (< 185.18.14-2), nvidia-libvdpau1-ia32 (<
              185.18.14-2)
Заменяют: libc6-dev-i386
Описание: Embedded GNU C Library: 32-bit shared libraries for AMD64
 This package includes shared versions of the standard C library and the
 standard math library, as well as many others. This is the 32bit version of the
 library, meant for AMD64 systems.
Сайт: http://www.eglibc.org

Это нормально? А то слово "Ломают" меня насторожило. Да, и ещё, чтоб не создавать топик... Я хочу, чтобы моя система всегда была семёркой. То есть я хочу сидеть на wheezy и сейчас, когда он testing, и после его релиза, когда он будет stable. Я так понимаю, что нужно прописать в apt.conf не testing, а wheezy? Или надо в день его релиза заменить слово testing на stable?
Куда страна катится? Только красота спасет мир! Только красота и массовые расстрелы! - к/ф "Антибумер"
 

cinyflo

  • Гость
Re: Нужна libc6-i386 2.15, а в репозитории 2.11
« Ответ #9 : 25 Апрель 2013, 23:12:00 »
создал файл apt.conf, где прописал APT::Default-Release "testing";
Зачем?
Это нормально? А то слово "Ломают" меня насторожило.
Нормально. Это просто информация о пакете, в графе ломают несовместимые библиотеки и пакеты.
Я так понимаю, что нужно прописать в sources.list не testing, а wheezy?
Правильно понимаете.
Или надо в день его релиза заменить слово testing на stable?
Можно и так.
 

Оффлайн HoleyHat

  • Topic Author
  • Сообщений: 90
  • CrunchBang 11 "Waldorf" 32-bit non-PAE
Re: Нужна libc6-i386 2.15, а в репозитории 2.11
« Ответ #10 : 26 Апрель 2013, 07:19:02 »
создал файл apt.conf, где прописал APT::Default-Release "testing";
Зачем?

Чтобы система не начала обновляться с экспериментальной ветки.
Куда страна катится? Только красота спасет мир! Только красота и массовые расстрелы! - к/ф "Антибумер"
 

cinyflo

  • Гость
Re: Нужна libc6-i386 2.15, а в репозитории 2.11
« Ответ #11 : 26 Апрель 2013, 15:18:53 »
Не будет.
 

Оффлайн agentgoblin

  • Сообщений: 50
Re: Нужна libc6-i386 2.15, а в репозитории 2.11
« Ответ #12 : 16 Май 2013, 17:07:47 »
Придумал! А как узнать, каким ещё приложениям нужна эта библиотека?
apt-cache rdepends <имя_пакета>

У aptitude тоже должен быть аналог ключа rdepends, man aptitude.

Spoiler: Вот что выдаёт apt-cache rdepends libc6-i386 на Wheezy • показать

libc6-i386
Reverse Depends:
  lib32tinfo5
  lib32ncursesw5
  lib32ncurses5
  ocaml-mingw-w64-i686
  gnu-efi:i386
  libc6:i386
  sl-modem-daemon
  libgl1-nvidia-legacy-96xx-glx-ia32
  libgl1-nvidia-legacy-71xx-glx-ia32
  libgl1-nvidia-legacy-173xx-glx-ia32
  nvidia-vdpau-driver-ia32
  nvidia-libopencl1-ia32
  libnvidia-compiler-ia32
  libgl1-nvidia-glx-ia32
  libgl1-nvidia-alternatives-ia32
  libcuda1-ia32
  mbrola
  libfglrx-ia32
  fglrx-glx-ia32
  lib32z1-dev
  lib32z1
  lib32z1
  lib32v4l-0
  smlnj-runtime
  libsb2
  lib32readline6
  lib32readline5
  lib32readline-gplv2-dev
  lib32nss-mdns
  lib32nss-mdns
  lib32tinfo5
  lib32tinfo5
  lib32tinfo-dev
  lib32ncursesw5-dev
  lib32ncursesw5
  lib32ncursesw5
  lib32ncurses5-dev
  lib32ncurses5
  lib32ncurses5
  lib32mpfr4
  mingw-ocaml
  lsb-core
  libnss-extrausers
  libnss-cache
  lib32ffi5
  lib32ffi-dev
  gnu-efi
  lib32gmpxx4
  lib32gmpxx4
  lib32gmp10
  lib32gmp10
  lib32gmp-dev
  lib32stdc++6-4.7-dbg
  lib32stdc++6
  lib32stdc++6
  lib32quadmath0
  lib32quadmath0
  lib32objc4
  lib32objc4
  lib32mudflap0
  lib32mudflap0
  lib32itm1
  lib32itm1
  lib32gomp1
  lib32gomp1
  lib32go0
  lib32go0
  lib32gfortran3
  lib32gfortran3
  lib32gcc1
  lib32gcc1
  lib32stdc++6-4.6-dbg
  lib32objc3
  lib32objc3
  lib32stdc++6-4.4-dbg
  libc6-dev-i386
  libc6-dev-i386
  cpushare
  lib32bz2-1.0
  lib32cr0
  lib32cr0
  lib32asound2-dev
  lib32asound2
  lib32asound2
 

Оффлайн pleshner

  • Сообщений: 15
Re: [Решено] Нужна libc6-i386 2.15, а в репозитории 2.11
« Ответ #13 : 31 Январь 2017, 15:17:29 »
сидел на 32 битной нормально все было, захотелось 64 бита, быстренько переустановил и началось teamviewer не запускается
  root@quazar:/home/quazar# dpkg -i teamviewer_i386.deb
(Чтение базы данных … на данный момент установлено 155485 файлов и каталогов.)
Подготовка к распаковке teamviewer_i386.deb …
Распаковывается teamviewer (10.0.41499) на замену (10.0.41499) …
dpkg: зависимости пакетов не позволяют настроить пакет teamviewer:
 teamviewer зависит от libc6 (>= 2.4).
 teamviewer зависит от libgcc1.
 teamviewer зависит от libasound2.
 teamviewer зависит от libexpat1.
 teamviewer зависит от libfontconfig1.
 teamviewer зависит от libfreetype6.
 teamviewer зависит от libjpeg62.
 teamviewer зависит от libpng12-0.
 teamviewer зависит от libsm6.
 teamviewer зависит от libxdamage1.
 teamviewer зависит от libxext6.
 teamviewer зависит от libxfixes3.
 teamviewer зависит от libxinerama1.
 teamviewer зависит от libxrandr2.
 teamviewer зависит от libxrender1.
 teamviewer зависит от libxtst6.
 teamviewer зависит от zlib1g.

dpkg: ошибка при обработке пакета teamviewer (--install):
 проблемы зависимостей — оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
 teamviewer
 


libc6 2.24-8
подскажите что где зарыто...
 

Оффлайн qupl

  • Сообщений: 4137
  • memento mori
  • Jabber: qupl@jabber.ru
Re: [Решено] Нужна libc6-i386 2.15, а в репозитории 2.11
« Ответ #14 : 31 Январь 2017, 15:19:51 »
pleshner, в названии пакета не смущает i386 ?

Теги: