debian.org / О Debian Где взять Debian Поддержка Уголок разработчика Новости Wiki

Автор Тема: Проблема с установкой apache  (Прочитано 1232 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mihail_1

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 176
Проблема с установкой apache
« : 14 Август 2013, 22:50:38 »
checking whether to enable mod_ssl... checking dependencies
checking for SSL/TLS toolkit base... /usr/lib/x86_64-linux-gnu/
checking for SSL/TLS toolkit version... unknown
checking for SSL/TLS toolkit includes... /usr/include
checking for SSL/TLS toolkit libraries... configure: error: OpenSSL libraries not found


./configure  --enable-ssl --with-ssl=/usr/lib/x86_64-linux-gnu
 

seisros

  • Гость
Re: Проблема с установкой apache
« Ответ #1 : 14 Август 2013, 22:56:26 »
Он же понятным языком тебе говорит. Поставь мне openssl. Ты же ещё сам его в конфигурацию включил.
 

Оффлайн mihail_1

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 176
Re: Проблема с установкой apache
« Ответ #2 : 14 Август 2013, 23:10:29 »
Путь я вооюще-то не с потолка взял.

Что кроме
apt-get install openssl
apt-get install libssl-dev
еще ему не хватает?
 

seisros

  • Гость
Re: Проблема с установкой apache
« Ответ #3 : 14 Август 2013, 23:17:49 »
Не знаю, я xampp пользуюсь.
Зайди ещё для надёжности посмотри что там, вдруг там ещё директории есть.
Может по этому просто не видит.
У меня на i686 есть директория cmov и только потом в ней библиотеки.
 

Оффлайн mihail_1

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 176
Re: Проблема с установкой apache
« Ответ #4 : 14 Август 2013, 23:30:57 »
И дирректорий и библиотек там много. Пути до каких конкретно файлов надо указать?
И что он не находит .so или .h?
 

seisros

  • Гость
Re: Проблема с установкой apache
« Ответ #5 : 14 Август 2013, 23:37:04 »
checking for SSL/TLS toolkit libraries... configure: error:
libraries это библиотеки, а библиотеки у нас "so". Наверное библиотеки.
".h" это headers, тоесть заголовки. Это уже не то.
Ищи что-то похожее на libssl.
« Последнее редактирование: 14 Август 2013, 23:42:43 от seisros »
 

Оффлайн mihail_1

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 176
Re: Проблема с установкой apache
« Ответ #6 : 14 Август 2013, 23:51:21 »
Есть файлы
libssl.a
libssl.so
libssl.so.1.0.0
и дирректория
openssl-1.0.0


Сообщение объединено: 15 Август 2013, 11:42:47
Похоже libssl 1.0.0 кривая. Как ее снести и поставить нормальную 0.9.8 ?
« Последнее редактирование: 15 Август 2013, 11:42:47 от mihail_1 »
 

Русскоязычное сообщество Debian GNU/Linux

Re: Проблема с установкой apache
« Ответ #6 : 14 Август 2013, 23:51:21 »


Теги:
 

Проблема с кодировкой в PHP (php.ini)

Автор lamokk

Ответов: 2
Просмотров: 722
Последний ответ 17 Январь 2016, 12:57:53
от lamokk
Шлюз на debian, проблема с iptables

Автор Romkij

Ответов: 4
Просмотров: 2552
Последний ответ 17 Сентябрь 2011, 11:54:03
от Kuper
Проблема с модулем pam_sss.so

Автор realvava

Ответов: 2
Просмотров: 1172
Последний ответ 13 Июль 2017, 09:42:39
от realvava
Проблема с обновлениями debian

Автор aninim

Ответов: 3
Просмотров: 1692
Последний ответ 15 Май 2012, 07:31:03
от aninim
[Решено] Проблема с кодировкой в mysql 5.5.31-0+wheezy1. Господа помогите!

Автор moskov199

Ответов: 3
Просмотров: 1661
Последний ответ 24 Июль 2013, 21:02:51
от ihammers