debian.org / О Debian Где взять Debian Поддержка Уголок разработчика Новости Wiki

Автор Тема: Пакеты, которые будут оставлены в неизменном виде при apt-get upgrade  (Прочитано 9134 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ffrr

  • Topic Author
  • Сообщений: 253
  • ffrr
при выполнении apt-get upgrade список пакетов, которые будут оставлены в неизменном виде уже больше сотни, новые пакеты удачно ставятся, непонятна только цель такой информативности-что такая информация может дать:

$sudo apt-get upgrade
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Пакеты, которые будут оставлены в неизменном виде:
  akonadiconsole akregator amor apache2 apache2-mpm-prefork apache2.2-bin aptdaemon ark baobab blogilo brasero
  brasero-common cervisia connman cups cups-bsd cups-client cups-filters cups-pk-helper cups-ppdc cvsservice dolphin
...
...
...
winbind wireshark-common xserver-xorg-video-nouveau xul-ext-adblock-plus
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 385 пакетов не обновлено.
ffrr
 

Оффлайн qupl

  • Сообщений: 4257
  • memento mori
  • Jabber: qupl@jabber.ru
Зафиксированные пакеты?

Оффлайн vladimir_ar

  • Сообщений: 1624
По всей видимости, да. Или связанные с зафиксированными по зависимостям.
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
 

Оффлайн endru

  • Сообщений: 1546
  • Новосибирск
  • Jabber: endru@jabber.ru
ffrr, покажи вывод команд
зафиксированные пакеты через aptitude:
aptitude search "~ahold"через apt-get:
dpkg --get-selections | grep hold
снять фиксацию с пакета:
echo имя_пакета install | dpkg --set-selections
 
Пользователи, которые поблагодарили этот пост: Александр Кряжев

Оффлайн ffrr

  • Topic Author
  • Сообщений: 253
  • ffrr
и то, и то - пусто, что странно:
$  aptitude search "~ahold"

dpkg --get-selections | grep hold
ffrr
 

Оффлайн endru

  • Сообщений: 1546
  • Новосибирск
  • Jabber: endru@jabber.ru
Наверное ты обновил систему до wheezy и не выполнили команду:
apt-get dist-upgrade

Оффлайн ffrr

  • Topic Author
  • Сообщений: 253
  • ffrr
и что - получается част пакетов просто не скачалась?
ffrr
 

Оффлайн endru

  • Сообщений: 1546
  • Новосибирск
  • Jabber: endru@jabber.ru
куски из man apt-get
upgrade используется для установки новейших версий всех установленных пакетов системы из источников, указанных в /etc/apt/sources.list. Будут разысканы новейшие версии установленных в настоящий момент пакетов и произведено обновление; ни в коем случае не будет удалено ни одного установленного пакета или установлено нового пакета, не имеющего уже установленной в системе предыдущей версии. Текущие версии установленных в настоящий момент пакетов, если они не могут быть обновлены новыми версиями без изменения статуса других пакетов, будут оставлены в неизменном виде.

dist-upgrade, в дополнение выполняет функцию upgrade, а также разумно управляет изменением зависимостей с новыми версиями пакетов; apt-get имеет "умную" систему разрешения конфликтов и она будет в случае необходимости пытаться произвести обновление наиболее важных пакетов за счет менее важных.


Оффлайн PbI6A

  • Сообщений: 794
  • просто я так выгляжу!
Цитировать
apt-get dist-upgrade
А это вообще надо делать? Разве это не чисто убунтовский рудимент?  ???
LINUX means: Linux Is Not a UniX
 

Оффлайн ogost

  • Сообщений: 2731
  • Linux Registered User #547151
Цитировать
apt-get dist-upgrade
А это вообще надо делать? Разве это не чисто убунтовский рудимент?  ???
хмм, я всегда им пользовался...

Оффлайн Pierse

  • Сообщений: 45
apt-get install [имя_пакета], всё уйдёт )) (можно пачками)

потом еще apt-get -f install для уверенности
 

Оффлайн mexx

  • Сообщений: 204
  • Jabber: mexx400@jabber.ru
Штатный Firefox ESR 45.9.0 отказался обновляться:
Цитировать
Пакеты, которые будут оставлены в неизменном виде:
  firefox-esr firefox-esr-l10n-ru
Запустил обновление с явным указанием пакетов - обновился до 52.2.0
При этом добавился libjsoncpp0, предложены fonts-stix otf-stix fonts-lmodern mozplugger с тучей зависимостей и autoremove удалился gstreamer1.0-libav
Так понимаю:
Текущие версии установленных в настоящий момент пакетов, если они не могут быть обновлены новыми версиями без изменения статуса других пакетов, будут оставлены в неизменном виде.
То есть это штатная ситуация?
Debian 8 MATE
 

Теги: