debian.org / О Debian Где взять Debian Поддержка Уголок разработчика Новости Wiki

Автор Тема: [Решено] Атом 2700+ NM10, проблема с разрешением монитора.  (Прочитано 1184 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dduh

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 38
Столкнулся с такой проблемой в Wheezy. Не правильно устанавливается разрешение монитора. Эти железяки работают у меня в качестве клиентов LTSP. До этого стояла Убунта 10.04, всё было нормально. Решил перевести на Дебиан, получил проблему.
При загрузке клиента без указания разрешения получается разрешение 1250Х(что-то широкое но не 1024). При указании разрешения 1250х1024, разрешение устанавливается 1024х768. Ни у кого xorg.conf рабочего нет для этого чипсета?
« Последнее редактирование: 24 Сентябрь 2013, 21:14:38 от dduh »
 

Оффлайн qupl

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 4604
  • memento mori
  • Jabber: qupl@jabber.ru

Оффлайн dduh

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 38
Re: Атом 2700+ NM10, проблема с разрешением монитора.
« Ответ #2 : 24 Сентябрь 2013, 21:11:19 »
Разобрался. Проблема не xorg.conf. При загрузке система видит два монитора. Один стабильно с разрешением 1024х768 (экран ноутбука, которго нет в помине), второй подключенный. Но на подключенный монитор выдается разрешение ноутбука. Надо при загрузке ядра дать ему параметр "video=LVDS-1:d", что отключает первый монитор. После этого всё работает.
 

Оффлайн qupl

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 4604
  • memento mori
  • Jabber: qupl@jabber.ru
dduh, правильнее все-таки через xorg.conf, но если работает - пожалуйста.

Оффлайн dduh

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 38
На данном железе не получилось через xorg.conf. На изменеия конфига реакции не было совсем. Помогала команда xrand. Но при этом возникал артефакт "картинка в картинке", на экране было одновременно две картинке фонового изображения (1024х780 и 1280х1024). Или опять через xrand надо было отключить LVDS1.
Теперь осталось это перенести в LTSP.

Не понимаю одного, почему на предыдущей убунте 10.04 такого геморроя нет совсем? Получается прогресс не всегда приводит к лучшему!
« Последнее редактирование: 25 Сентябрь 2013, 10:03:59 от dduh »
 

Русскоязычное сообщество Debian GNU/Linux



Теги:
 

Re: не отключает питание ноутбук presario 2100 на debian 7 [РЕШЕНО]

Автор extrafant

Ответов: 17
Просмотров: 2029
Последний ответ 16 Февраль 2014, 09:32:34
от extrafant
проблема с установкой wine32 на amd64, добавление i386 архитектуры

Автор dhk

Ответов: 1
Просмотров: 366
Последний ответ 29 Май 2019, 17:27:55
от G_r_i_g_a
[РЕШЕНО] Циклическая перезагрузка. (fsck died with exit status 3)

Автор bocxod

Ответов: 9
Просмотров: 2374
Последний ответ 21 Январь 2012, 13:39:48
от bocxod
Не отображается uuid раздела hdd [Решено]

Автор sidbar

Ответов: 8
Просмотров: 1945
Последний ответ 04 Февраль 2015, 19:07:21
от sidbar
[Решено] Подскажите программу для мониторинга сети

Автор DruKot

Ответов: 17
Просмотров: 2717
Последний ответ 14 Сентябрь 2012, 23:10:05
от Udachnik