[РЕШЕНО] Включение дополнительной панели клавиатуры при загрузке граф. оболочки

Автор speed_vm, 25 октября 2013, 08:51:05

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

speed_vm

Доброго времени суток всем!
Установлена Debian 7.2.0 + LXDE. Каким образом при загрузке графической оболочки заставить автоматически включаться дополнительную клавиатуру (NumPad)?
Пробовал реализовать с помощью 'xset led', но оказалось, что эта утилита только лампочками управляет (к тому же управление диодами NumLock и CapsLock по умолчанию отключено вовсе).
Гугл практически во всех ссылках рекомендует установить пакет numlockx и запускать его при старте графической оболочки. Мне кажется, что решение этой малюсенькой проблемы не должно сводиться к установке каких-то дополнительный пакетов (тем более, что в некоторых случаях код этого пакета приходиться в ручную исправлять).
Уважаемое сообщество! Помогите, чем можете! Заранее всех благодарю за ответы!
  •  

ferum

Русские дебианщики против цифрового слабоумия !
  •  

speed_vm

Копание в сторону xorg ничего не дало. Имеется информация по '/etc/lxdm/lxdm.conf' (нужно в нем раскомментировать строку 'numlock=0' и поставить вместо нуля единицу). Однако, такой директории у меня не имеется и соответственно файла такого тоже. Поиски продолжаются.
  •  

Sergei_Alekseev

  •  

speed_vm

Я привык пользоваться доп. клавиатурой. Это во-первых. Во-вторых, никогда не помешают дополнительные знания по настройке тех или иных компонентов через конфигурационные файлы.

Сообщение объединено: 25 октября 2013, 21:58:37

Цитата: speed_vm от 25 октября 2013, 19:28:26'/etc/lxdm/lxdm.conf' (нужно в нем раскомментировать строку 'numlock=0' и поставить вместо нуля единицу)
Похоже, что эти файлы существовали в прошлых версиях lxde. Текущая версия хранит настройки в '/etc/lightdm/lightdm.conf', но добавление строки 'numlock=1' должного эффекта не возымело.
  •  

Sergei_Alekseev

Я не понимаю почему нельзя нажать на  Num Lock и привычно пользоваться доп. клавиатурой.
К тому же если установка numlockx и добавление в автозагрузку решает проблему, почему бы это не сделать.
Попробуйте slim поставить и отредактировать /etc/slim.conf
# Activate numlock when slim starts. Valid values: on|off
numlock             on

Попробуйте отредактировать /etc/console-tools/config
# Turn on numlock by default
LEDS=+num
  •  

speed_vm

Цитата: Sergei_Alekseev от 26 октября 2013, 05:14:14Я не понимаю почему нельзя нажать на  Num Lock и привычно пользоваться доп. клавиатурой.
Я не понимаю, почему то, что решалось в предыдущих версиях раскомментированием одной строки, теперь должно решаться установкой доп. пакета.
  •  

ogost

у меня эта фича включается/отключается в биосе. в gdm3 при старте он уже горит. не то?

speed_vm

В биосе у меня этой функции нет. К тому же в терминальном режиме можно включить доп. панель клавиатуры при загрузке (setleds). Вот только после запуска иксов активированное положение доп. клавиатуры сбрасывается и становится неактивным. В xfce (как и в гноме скорее всего), если перезапустить иксы с включенным намлоком, его положение сохраняется и при следующей загрузке устанавливается во включенное положение автоматом. Прискорбно, что такой возможности не предусмотрели разработчики lxde.
  •  

Sergei_Alekseev

В пакете numlockx находятся
бинарник 9 кб
скрипт, определяющий лаптоп или нет
файл конфигурации
документы
Это совершенно нормально - установить какой-то пакет для решения проблемы.
Можете взять отдельно бинарник
http://metafight.ru/files/numlockx.tar.gz
положить в path и прописать в автозагрузку или в какой-нибудь файл, который выполняет что-либо после X.
9 килобайт, ёлы-палы.
Я лично думаю, что это бесполезная функция, поэтому её выпилили.
И для тех, кому это по прежнему нужно, сделали numlockx.
  •  

speed_vm

Благодарю всех за помощь. Действительно, после перекапывания официальных (и неофициальных) форумов решением данной проблемы является установка numlockx и запуск этой утилиты при загрузке иксов. Тема закрыта.
  •