debian.org / О Debian Где взять Debian Поддержка Уголок разработчика Новости Wiki

Автор Тема: Установка Catalyst [РЕШЕНО]  (Прочитано 4099 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Thunder

  • Topic Author
  • Сообщений: 140
  • Jabber: minnigaliev-r@jabber.ru
Установка Catalyst [РЕШЕНО]
« : 07 Май 2011, 08:16:04 »
[РЕШЕНО]
http://wiki.debian.org/ATIProprietary#Squeeze


попробовал скомпилить каталист - не получилось...
root@amd:/mnt/data/Linux/ati/11.4/debian# ./ati-driver-installer-11-4-x86.x86_64.run --buildpkg
Created directory fglrx-install.yBJe7A
Verifying archive integrity... All good.
Uncompressing ATI Catalyst(TM) Proprietary Driver-8.841...
=====================================================================
 ATI Technologies Catalyst(TM) Proprietary Driver Installer/Packager
=====================================================================
Error: Packaging scripts failed to identify current distro/version.  Please provide a distro/version from --listpkg as a parameter
Removing temporary directory: fglrx-install.yBJe7A
root@amd:/mnt/data/Linux/ati/11.4/debian#
что ему надо передать параметром? пробовал писать debian - не оно.
« Последнее редактирование: 24 Июль 2011, 14:44:21 от Thunder »
 

Оффлайн Thunder

  • Topic Author
  • Сообщений: 140
  • Jabber: minnigaliev-r@jabber.ru
Re: Catalyst 11.4
« Ответ #1 : 07 Май 2011, 11:58:34 »
чо ни у кого нормальных видюх нет? одни нвидии? :D
 

Оффлайн SeHELLioN

  • Сообщений: 910
Re: Catalyst 11.4
« Ответ #2 : 07 Май 2011, 12:01:43 »
nvidia норм видюхи, работают без нареканий
Asus m5a97+Amd fx-8350+4x4GB DDR3 1600MGz+asus gtx670 DCII (перешита в top)
Debian stable
 

Оффлайн Udachnik

  • Сообщений: 1438
Re: Catalyst 11.4
« Ответ #3 : 07 Май 2011, 12:16:56 »
Не, у всех только нормальные Нвидии :-)
Но всё же попробуй перед компиляцией выполнить
aptitude install build-essential linux-headers-$(uname -r)
 

Оффлайн Ghostdmn

  • Ленивы... Ай, лень допеча...
  • Сообщений: 854
  • Jabber: ghostdmn@jabber.cz
Re: Catalyst 11.4
« Ответ #4 : 07 Май 2011, 12:22:57 »
./ati-driver-installer-11-4-x86.x86_64.run --help
8Gb/GTX750Ti 2Gb/AMD FX(tm)-4300 Quad-Core Processor/HDD 1Tb Toshiba DT01ACA100
 

Оффлайн Thunder

  • Topic Author
  • Сообщений: 140
  • Jabber: minnigaliev-r@jabber.ru
Re: Catalyst 11.4
« Ответ #5 : 07 Май 2011, 13:07:15 »
щас почитаю хелп.
догнал вот что надо было ввести --listpkg просто для просмотра поддерживаемых

root@amd:/mnt/data/Linux/ati/11.4/debian# ./ati-driver-installer-11-4-x86.x86_64.run --listpkg
Created directory fglrx-install.eNKF6E
Verifying archive integrity... All good.
Uncompressing ATI Catalyst(TM) Proprietary Driver-8.841................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
=====================================================================
 ATI Technologies Catalyst(TM) Proprietary Driver Installer/Packager
=====================================================================
List of generatable packages:

Package Maintainer(s): Aric Cyr <aric.cyr@gmail.com>
                      Mario Limonciello <superm1@gmail.com>
Status: *UNVERIFIED*
Debian Packages:
Debian/sid
Debian/unstable
Debian/etch
Debian/stable
Debian/lenny
Debian/testing
Debian/experimental

Package Maintainer(s): Niko Mirthes <nmirthes@gmail.com>
                      Michael Larabel <michael@phoronix.com>
Status: *UNVERIFIED*
Fedora Packages:
Fedora/FC3
Fedora/FC4
Fedora/FC5
Fedora/FC6
Fedora/F7
Fedora/F8
Fedora/F9
Fedora/F10
Fedora/RHEL3
Fedora/RHEL4

Package Maintainer(s): Anssi Hannula <anssi@mandriva.org>
Status: *UNVERIFIED*
Mandriva Packages:
Mandriva/2007.0
Mandriva/2007.1
Mandriva/2008.0
Mandriva/2008.1
Mandriva/2009.0
Mandriva/2009.1
Mandriva/2010.0
Mandriva/2010.1
Mandriva/2010.2
Mandriva/2011.0

Package Maintainer(s): AMD
Status: Verified
RedHat Packages:
RedHat/RHEL5_64a
RedHat/RHEL6_64a
RedHat/RHEL5
RedHat/RHEL6

Package Maintainer(s): Emanuele Tomasi <tomasi@cli.di.unipi.it>
Status: *UNVERIFIED*
Slackware Packages:
Slackware/Slackware

Package Maintainer(s): Sebastian Siebert <freespacer@gmx.de>
Status: *UNVERIFIED*
SuSE Packages:
SuSE/SLE10-IA32
SuSE/SLE10-AMD64
SuSE/SLE11-IA32
SuSE/SLE11-AMD64
SuSE/SUSE112-IA32
SuSE/SUSE112-AMD64
SuSE/SUSE113-IA32
SuSE/SUSE113-AMD64
SuSE/SUSE114-IA32
SuSE/SUSE114-AMD64
SuSE/SUSE-autodetection

Package Maintainer(s): Alberto Milone <alberto.milone@canonical.com>
Status: *UNVERIFIED*
Ubuntu Packages:
Ubuntu/gutsy
Ubuntu/hardy
Ubuntu/intrepid
Ubuntu/jaunty
Ubuntu/karmic
Ubuntu/lucid
Ubuntu/maverick
Ubuntu/natty
Ubuntu/source

For example, to build a Debian Etch package, run the following:
% ./ati-driver-installer-<version>-<architecture>.run --buildpkg Debian/etch

Removing temporary directory: fglrx-install.eNKF6E

щас получаю вот, что
root@amd:/mnt/data/Linux/ati/11.4/debian# ./ati-driver-installer-11-4-x86.x86_64.run --buildpkg Debian/stable
Created directory fglrx-install.pD778X
Verifying archive integrity... All good.
Uncompressing ATI Catalyst(TM) Proprietary Driver-8.841................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
=====================================================================
 ATI Technologies Catalyst(TM) Proprietary Driver Installer/Packager
=====================================================================
Generating package: Debian/stable
./packages/Debian/ati-packager.sh: 177: dpkg-architecture: not found
Error: unsupported architecture:
Removing temporary directory: fglrx-install.pD778X
root@amd:/mnt/data/Linux/ati/11.4/debian#
 

Оффлайн Thunder

  • Topic Author
  • Сообщений: 140
  • Jabber: minnigaliev-r@jabber.ru
Re: Catalyst 11.4
« Ответ #6 : 07 Май 2011, 13:08:52 »
Цитата: "Udachnik"
Не, у всех только нормальные Нвидии :-)
Но всё же попробуй перед компиляцией выполнить
aptitude install build-essential linux-headers-$(uname -r)

а нафиг, скрипт установки так то сам качает и ставит чо ему не хватает, так в убунту было, также и тут должно быть.
 

Оффлайн Thunder

  • Topic Author
  • Сообщений: 140
  • Jabber: minnigaliev-r@jabber.ru
Re: Catalyst 11.4
« Ответ #7 : 07 Май 2011, 13:12:02 »
нагуглил вот, пробую щас доставить нужные пакеты...
http://wiki.debian.org/ATIProprietary#Squeeze
« Последнее редактирование: 24 Июль 2011, 14:43:43 от Thunder »
 

Оффлайн Ghostdmn

  • Ленивы... Ай, лень допеча...
  • Сообщений: 854
  • Jabber: ghostdmn@jabber.cz
Re: Catalyst 11.4
« Ответ #8 : 07 Май 2011, 13:15:10 »
Скрипт установки, может и качает. Но ты не устанавливаешь, а собираешь, не?
8Gb/GTX750Ti 2Gb/AMD FX(tm)-4300 Quad-Core Processor/HDD 1Tb Toshiba DT01ACA100
 

Оффлайн Thunder

  • Topic Author
  • Сообщений: 140
  • Jabber: minnigaliev-r@jabber.ru
Re: Catalyst 11.4
« Ответ #9 : 07 Май 2011, 13:22:35 »
какая разница, относительно того, что скрипт докачивает сам, что ему нужно для сборки?
===========
но как оказалось видимо не всё, убунту более попсовая, может поэтому там скрипт лучше пашет...

З.Ы.: жопа, что посты подряд не объединяются...
 

Оффлайн Ghostdmn

  • Ленивы... Ай, лень допеча...
  • Сообщений: 854
  • Jabber: ghostdmn@jabber.cz
Re: Catalyst 11.4
« Ответ #10 : 07 Май 2011, 13:25:19 »
Представь ЧТО нужно написать в скрипте, чтобы он с репов ВСЕХ дистров качал зависимости?
Ручками, уважаемый, ручками.
8Gb/GTX750Ti 2Gb/AMD FX(tm)-4300 Quad-Core Processor/HDD 1Tb Toshiba DT01ACA100
 

Оффлайн Thunder

  • Topic Author
  • Сообщений: 140
  • Jabber: minnigaliev-r@jabber.ru
Re: Catalyst 11.4
« Ответ #11 : 07 Май 2011, 14:19:24 »
угу, в общем не помогло... компиляция пошла но там ошибка возникла... в статье по которой делал было про это написано, что возможно и решение - компилить самому ia32-libs. В общем пока забил - поставил из non-free 10.9 - работает. Мож как-нить позже к этой проблеме вернусь.
 

Оффлайн Ghostdmn

  • Ленивы... Ай, лень допеча...
  • Сообщений: 854
  • Jabber: ghostdmn@jabber.cz
Re: Catalyst 11.4
« Ответ #12 : 07 Май 2011, 14:42:24 »
А атишные разве не ставятся
#sh ./ati-driver-installer-11-4-x86.x86_64.runСамо собой с отключенным gdm (kdm)?
8Gb/GTX750Ti 2Gb/AMD FX(tm)-4300 Quad-Core Processor/HDD 1Tb Toshiba DT01ACA100
 

Оффлайн Thunder

  • Topic Author
  • Сообщений: 140
  • Jabber: minnigaliev-r@jabber.ru
Re: Catalyst 11.4
« Ответ #13 : 07 Май 2011, 16:36:53 »
ошибка при --buildpkg
=======================
просто установка прошла, угу.
только glxgears, показал одно и то же до и после.
 

Теги: