debian.org / О Debian Где взять Debian Поддержка Уголок разработчика Новости Wiki

Автор Тема: Есть PDF- обозреватель работающий с оглавлением?  (Прочитано 2608 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн pa_

  • Активный пользователь
  • **
  • Сообщений: 60
  • Jabber: pa_@jabber.ru
В Вашем файле заголовок отсутствует.
заголовок на содержание не влияет ...
специально открыл книгу ебук где отсутствует заголовок и походил по содержанию
--
то ли книга кривая то ли поплер не поддерживает последние стандарты
в общем акробат ридер - прожевывает нормально
 

Оффлайн AlekseyDebian

  • Активный пользователь
  • **
  • Topic Author
  • Сообщений: 73
А по Вашему файлу не ходит. Хотя по листу содержания переходит в нужный раздел.

Не заметил, что если использовать не отдельную панель, а тыкать на сам текст оглавления в книжке, то все отлично переходит (хотя постоянно прыгать на первые страницы не очень удобно).

Сообщение объединено: 14 Декабрь 2013, 07:40:03
#dpkg --add-architecture i386
#aptitude update
#apt-get install libgtk2.0-0:i386  libxml2:i386 libstdc++6:i386
#wget -c ftp://ftp.adobe.com/pub/adobe/reader/unix/9.x/9.5.5/enu/AdbeRdr9.5.5-1_i486linux_enu.bin
#chmod +x ./AdbeRdr9.5.5-1_i486linux_enu.bin
#./AdbeRdr9.5.5-1_i486linux_enu.bin


root@debian:/home/aleksey# apt-get install libgtk2.0-0:i386  libxml2:i386 libstdc++6:i386
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 libgtk2.0-0:i386 : Зависит: libcairo2:i386 (>= 1.6.4-6.1) но он не будет установлен
                    Зависит: libfontconfig1:i386 (>= 2.9.0) но он не будет установлен
                    Зависит: libpango1.0-0:i386 (>= 1.28.3) но он не будет установлен
                    Рекомендует: hicolor-icon-theme:i386 но он не может быть установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
root@debian:/home/aleksey# apt-get -f install
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.

проверил, оглавление есть,работает

поставил еще qpdfview оглавление есть но не переходит

--
ps хотелось бы и 2 том поиметь, вдруг пригодится ;)

Что делать?

ps Второй том на рапидшаре: http://rapidshare.com/share/B4D22C992BAE6D393D1A5635EE64B26E
« Последнее редактирование: 14 Декабрь 2013, 08:05:44 от AlekseyDebian »
 

Оффлайн pa_

  • Активный пользователь
  • **
  • Сообщений: 60
  • Jabber: pa_@jabber.ru
Вы подключили нестабильные ветки реп для обновления поплера ?
заремте в сорс листе и сделайте апдейт
--
у меня чистый визи 64, всё поставилось без проблем

==
как Вы занимаетесь разработкой 1с под дебом ??? в вайне \ виртуалке \ терминальная сессия ?
 

Русскоязычное сообщество Debian GNU/Linux


Оффлайн Brainey

  • Ветеран
  • *****
  • Сообщений: 1943
  • Jabber: brainey@jabber.cz
okular

Поставил Synaptic- ом из стандартного репозитария. Тоже с оглавлением не работает.

Okular 0.14.3, libpoppler19 (0.18.4-6). Всё работает.
ТС: У вас не Squeeze случаем?
Конференция форума в jabber: debianforum@conference.jabber.ru | Клуб кедоводов: kde@conference.jabber.ru
 

Оффлайн AlekseyDebian

  • Активный пользователь
  • **
  • Topic Author
  • Сообщений: 73
Вы подключили нестабильные ветки реп для обновления поплера ?
заремте в сорс листе и сделайте апдейт
--
у меня чистый визи 64, всё поставилось без проблем

==
как Вы занимаетесь разработкой 1с под дебом ??? в вайне \ виртуалке \ терминальная сессия ?

Мой sources.list:
Spoiler: ShowHide
deb http://ftp.ru.debian.org/debian/ wheezy main
deb-src http://ftp.ru.debian.org/debian/ wheezy main

deb http://security.debian.org/ wheezy/updates main
deb-src http://security.debian.org/ wheezy/updates main

# wheezy-updates, previously known as 'volatile'
deb http://ftp.ru.debian.org/debian/ wheezy-updates main
deb-src http://ftp.ru.debian.org/debian/ wheezy-updates main


1с выпустила платформу 8.3, которая может работать под Linux.
« Последнее редактирование: 14 Декабрь 2013, 16:52:59 от AlekseyDebian »
 

Оффлайн Brainey

  • Ветеран
  • *****
  • Сообщений: 1943
  • Jabber: brainey@jabber.cz
Хм. Не понимаю, в чём может быть проблема. У меня как-то так. Что говорит
aptitude show ~ipoppler?
Конференция форума в jabber: debianforum@conference.jabber.ru | Клуб кедоводов: kde@conference.jabber.ru
 

Оффлайн AlekseyDebian

  • Активный пользователь
  • **
  • Topic Author
  • Сообщений: 73
Хм. Не понимаю, в чём может быть проблема. У меня как-то так. Что говорит
aptitude show ~ipoppler?

Spoiler: ShowHide
root@debian:/home/aleksey# aptitude show ~ipoppler
Пакет: poppler-utils                             
Состояние: установлен
Автоматически установлен: да
Мульти-архитектура: сторонняя
Версия: 0.18.4-6
Приоритет: необязательный
Раздел: utils
Сопровождающий: Loic Minier <lool@dooz.org>
Архитектура: amd64
Размер в распакованном виде: 456 k
Зависимости: libc6 (>= 2.4), libcairo2 (>= 1.10.0), libfreetype6 (>= 2.2.1), liblcms1 (>= 1.15-1), libpoppler19 (>= 0.18.4), libstdc++6 (>=
                        4.1.1)
Рекомендуются: ghostscript
Конфликтуют: pdftohtml, pdftohtml, poppler-utils
Ломают: xpdf-utils (< 3.02-2~), xpdf-utils (< 3.02-2~)
Заменяют: pdftohtml, pdftohtml, xpdf-reader, xpdf-reader, xpdf-utils (< 3.02-2~), xpdf-utils (< 3.02-2~)
Предоставляют: pdftohtml, poppler-utils, xpdf-utils
Предоставляется: poppler-utils
Описание: PDF utilities (based on Poppler)
 Poppler is a PDF rendering library based on Xpdf PDF viewer.
 
 This package contains command line utilities (based on Poppler) for getting information of PDF documents, convert them to other formats, or
 manipulate them:
 * pdffonts -- font analyzer
 * pdfimages -- image extractor
 * pdfinfo -- document information
 * pdfseparate -- page extraction tool
 * pdftocairo -- PDF to PNG/JPEG/PDF/PS/EPS/SVG converter using Cairo
 * pdftohtml -- PDF to HTML converter
 * pdftoppm -- PDF to PPM/PNG/JPEG image converter
 * pdftops -- PDF to PostScript (PS) converter
 * pdftotext -- text extraction
 * pdfunite -- document merging tool
Сайт: http://poppler.freedesktop.org/

Пакет: libpoppler-qt4-3
Состояние: установлен
Автоматически установлен: да
Мульти-архитектура: такая же
Версия: 0.18.4-6
Приоритет: необязательный
Раздел: libs
Сопровождающий: Loic Minier <lool@dooz.org>
Архитектура: amd64
Размер в распакованном виде: 423 k
Зависимости: libc6 (>= 2.4), libpoppler19 (>= 0.18.4), libqt4-xml (>= 4:4.5.3), libqtcore4 (>= 4:4.8.1), libqtgui4 (>= 4:4.5.3), libstdc++6
                        (>= 4.1.1)
Предварительные зависимости: multiarch-support
Ломают: libpoppler-qt4-3 (!= 0.18.4-6)
Заменяют: libpoppler-qt4-3 (< 0.18.4-6)
Описание: PDF rendering library (Qt 4 based shared library)
 Poppler is a PDF rendering library based on Xpdf PDF viewer.
 
 This package provides the Qt 4 based shared library for applications using the Qt 4 interface to Poppler.
Сайт: http://poppler.freedesktop.org/

Пакет: poppler-data
Состояние: установлен
Автоматически установлен: да
Версия: 0.4.5-10
Приоритет: необязательный
Раздел: misc
Сопровождающий: Hideki Yamane <henrich@debian.org>
Архитектура: all
Размер в распакованном виде: 12,0 M
Предварительные зависимости: dpkg (>= 1.15.6~)
Предлагаются: poppler-utils, ghostscript, fonts-japanese-mincho | fonts-ipafont-mincho, fonts-japanese-gothic | fonts-ipafont-gothic,
                          fonts-arphic-ukai, fonts-arphic-uming, fonts-unfonts-core
Ломают: cmap-adobe-cns1 (<= 0+20090930-2), cmap-adobe-cns1 (<= 0+20090930-2), cmap-adobe-gb1 (<= 0+20090930-2), cmap-adobe-gb1 (<=
              0+20090930-2), cmap-adobe-japan1 (<= 0+20090930-2), cmap-adobe-japan1 (<= 0+20090930-2), cmap-adobe-japan2 (<= 0+20090930-2),
              cmap-adobe-japan2 (<= 0+20090930-2), cmap-adobe-korea1 (<= 1.20100103-3), cmap-adobe-korea1 (<= 1.20100103-3), gs-aladdin (<=
              6.50-5), gs-aladdin (<= 6.50-5), gs-cjk-resource (<= 1.20100103-3), gs-cjk-resource (<= 1.20100103-3)
Заменяют: cmap-adobe-cns1 (<= 0+20090930-2), cmap-adobe-cns1 (<= 0+20090930-2), cmap-adobe-gb1 (<= 0+20090930-2), cmap-adobe-gb1 (<=
                  0+20090930-2), cmap-adobe-japan1 (<= 0+20090930-2), cmap-adobe-japan1 (<= 0+20090930-2), cmap-adobe-japan2 (<=
                  0+20090930-2), cmap-adobe-japan2 (<= 0+20090930-2), cmap-adobe-korea1 (<= 1.20100103-3), cmap-adobe-korea1 (<=
                  1.20100103-3), gs-cjk-resource (<= 1.20100103-3), gs-cjk-resource (<= 1.20100103-3)
Улучшают: ghostscript
Предоставляют: cmap-adobe-cns1, cmap-adobe-gb1, cmap-adobe-japan1, cmap-adobe-japan2, cmap-adobe-korea1, gs-cjk-resource
Описание: encoding data for the poppler PDF rendering library
 This package provides the CMap tables required to display PDF documents containing CJK characters with libpoppler. They were previously
 provided by the packages cmap-adobe-{cns1,gb1,japan1,japan2,korea1} and gs-cjk-resource.
 
 Users who want to view or create PDF files in Chinese, Japanese, or Korean without embedded fonts will need this package.
Сайт: http://poppler.freedesktop.org/

Пакет: libpoppler-glib8
Состояние: установлен
Автоматически установлен: да
Мульти-архитектура: такая же
Версия: 0.22.5-2
Приоритет: необязательный
Раздел: libs
Сопровождающий: Loic Minier <lool@dooz.org>
Архитектура: amd64
Размер в распакованном виде: 359 k
Зависимости: libc6 (>= 2.14), libcairo2 (>= 1.12.0), libfreetype6 (>= 2.2.1), libglib2.0-0 (>= 2.24.0), libpoppler37 (>= 0.22.5), libstdc++6
                        (>= 4.1.1)
Предварительные зависимости: multiarch-support
Ломают: libpoppler-glib8 (!= 0.22.5-2)
Заменяют: libpoppler-glib8 (< 0.22.5-2)
Описание: PDF rendering library (GLib-based shared library)
 Poppler is a PDF rendering library based on Xpdf PDF viewer.
 
 This package provides the GLib-based shared library for applications using the GLib interface to Poppler.
Сайт: http://poppler.freedesktop.org/

Пакет: libpoppler19
Состояние: установлен
Автоматически установлен: да
Мульти-архитектура: такая же
Версия: 0.18.4-6
Приоритет: необязательный
Раздел: libs
Сопровождающий: Loic Minier <lool@dooz.org>
Архитектура: amd64
Размер в распакованном виде: 2 555 k
Зависимости: libc6 (>= 2.11), libfontconfig1 (>= 2.9.0), libfreetype6 (>= 2.2.1), libjpeg8 (>= 8c), liblcms1 (>= 1.15-1), libopenjpeg2,
                        libpng12-0 (>= 1.2.13-4), libstdc++6 (>= 4.1.1), libtiff4 (> 3.9.5-3~)
Предварительные зависимости: multiarch-support
Рекомендуются: poppler-data
Ломают: libpoppler19 (!= 0.18.4-6)
Заменяют: libpoppler19 (< 0.18.4-6)
Описание: PDF rendering library
 Poppler is a PDF rendering library based on Xpdf PDF viewer.
 
 This package contains the shared core library.
Сайт: http://poppler.freedesktop.org/

Пакет: libpoppler37
Новый: да
Состояние: установлен
Автоматически установлен: нет
Мульти-архитектура: такая же
Версия: 0.22.5-2
Приоритет: необязательный
Раздел: libs
Сопровождающий: Loic Minier <lool@dooz.org>
Архитектура: amd64
Размер в распакованном виде: 2 973 k
Зависимости: libc6 (>= 2.14), libfontconfig1 (>= 2.10.0), libfreetype6 (>= 2.2.1), libjpeg8 (>= 8c), liblcms2-2, libopenjpeg2, libpng12-0
                        (>= 1.2.13-4), libstdc++6 (>= 4.1.1), libtiff4 (> 3.9.5-3~)
Предварительные зависимости: multiarch-support
Рекомендуются: poppler-data
Описание: PDF rendering library
 Poppler is a PDF rendering library based on Xpdf PDF viewer.
 
 This package contains the shared core library.
Сайт: http://poppler.freedesktop.org/

root@debian:/home/aleksey#

 

Оффлайн pa_

  • Активный пользователь
  • **
  • Сообщений: 60
  • Jabber: pa_@jabber.ru
Хм. Не понимаю, в чём может быть проблема. У меня как-то так. Что говорит
речь, как понял, про это http://zalil.ru/34851304 - содержание, которое слева\справа, а не оглавление книги

Сообщение объединено: 14 Декабрь 2013, 19:45:54
2 AlekseyDebian
если у Вас 32 битка попробуйте просто
apt-get install libgtk2.0-0 libxml2 libstdc++6
или через aptitude
или вручную поставьте необходимые пакеты libcairo2 libfontconfig1 libpango1.0-0
« Последнее редактирование: 14 Декабрь 2013, 19:45:54 от pa_ »
 

Оффлайн Brainey

  • Ветеран
  • *****
  • Сообщений: 1943
  • Jabber: brainey@jabber.cz
pa_, Понял. Стормозил, извиняюсь. Содержание отображается, но так же не работает.
Конференция форума в jabber: debianforum@conference.jabber.ru | Клуб кедоводов: kde@conference.jabber.ru
 

Русскоязычное сообщество Debian GNU/Linux



Теги:
 

Только поставил Debian 7, есть кое какие вопросы.

Автор Novice

Ответов: 15
Просмотров: 7606
Последний ответ 21 Май 2013, 14:44:39
от qupl
[Решено!] Целесообразность перехода на Jessie - есть ли смысл?

Автор Sferg

Ответов: 6
Просмотров: 1306
Последний ответ 11 Апрель 2014, 13:48:03
от Sferg
Есть ли аналог apt-btrfs-snapshot в Debian?

Автор anoobis

Ответов: 0
Просмотров: 998
Последний ответ 17 Декабрь 2016, 21:52:52
от anoobis
Есть программа для перевода текста при наведении мыши в doc и pdf файлах?

Автор AlekseyDebian

Ответов: 3
Просмотров: 2171
Последний ответ 30 Август 2013, 20:20:57
от yura_n
Сборка ядра. Есть вопросы.

Автор saifuddin

Ответов: 6
Просмотров: 1103
Последний ответ 11 Август 2016, 14:28:30
от saifuddin