debian.org / О Debian Где взять Debian Поддержка Уголок разработчика Новости Wiki

Автор Тема: [Решено] Зависимости, проблемы в aptitude  (Прочитано 2206 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Vic

  • Активный пользователь
  • **
  • Topic Author
  • Сообщений: 55
  • ASUS EeePC 1215P + Debian (openbox)
Есть некие проблемы с зависимостями. Сразу предупрежу, что некоторое ПО устанавливал из скачанных с официального сайта дебиан пакетов. Что именно я таким образом установил, сказать точно не в силах.
Пока что интересуют два момента:
[spoiler=вывод $ sudo aptitude install shotwell]
Следующие НОВЫЕ пакеты будут установлены:       
  libexiv2-12{a} libgail-3-0{a} libgee2{a} libgexiv2-1{a} libjavascriptcoregtk-3.0-0{a} libraw5{a} librest-0.7-0{a} libunique-3.0-0{a} libwebkitgtk-3.0-0{a}
  libwebkitgtk-3.0-common{a} shotwell shotwell-common{a}
Следующие пакеты будут обновлены:
  libgtk-3-0 libgtk-3-common
2 пакетов обновлено, 12 установлено новых, 0 пакетов отмечено для удаления, и 50 пакетов не обновлено.
Необходимо получить 16,2 MB архивов. После распаковки 47,1 MB будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
 libgtk-3-bin : Зависит: libgtk-3-common (= 3.4.2-6) но устанавливается 3.4.2-7.
Следующие действия разрешат зависимости:

      Удалить следующие пакеты:                           
1)      blueman                                           
2)      gnome-icon-theme                                   
3)      libgtk-3-bin                                       
4)      network-manager-gnome                             
5)      system-config-printer                             

      Оставить следующие зависимости неразрешёнными:       
6)      libgtk-3-0 рекомендует libgtk-3-bin               
7)      lightdm-gtk-greeter рекомендует gnome-icon-theme   
8)      lxde рекомендует network-manager-gnome             
9)      lxlauncher рекомендует gnome-icon-theme           
10)     task-lxde-desktop рекомендует system-config-printer


Принять данное решение? [Y/n/q/?] q
Отмена всех результатов по разрешению данных зависимостей.
Прервать.

Использую blueman для соединения с bluetooth-устройствами. network-manager-gnome - там апплет для установки интернет-соединения. gnome-icon-theme - не знаю, зачем именно он нужен, но удалять страшно. В squeeze спокойно работал в shotwell, все те же программы вроде бы использовал.
[/spoiler]
[spoiler=вывод $ sudo aptitude purge notification-daemon]
[sudo] password for vic:
Следующие пакеты будут УДАЛЕНЫ:                 
  notification-daemon{p}
0 пакетов обновлено, 0 установлено новых, 1 пакетов отмечено для удаления, и 52 пакетов не обновлено.
Необходимо получить 0 B архивов. После распаковки освободится 733 k байт.
Следующие пакеты имеют неудовлетворённые зависимости:
 blueman : Зависит: notification-daemon но его установка не запланирована.
 guake : Зависит: notification-daemon но его установка не запланирована.
Следующие действия разрешат зависимости:

     Удалить следующие пакеты:                             
1)     blueman                                             
2)     guake                                               

     Оставить следующие зависимости неразрешёнными:         
3)     libnotify4 рекомендует notification-daemon           
4)     network-manager-gnome рекомендует notification-daemon


Принять данное решение? [Y/n/q/?] q
Отмена всех результатов по разрешению данных зависимостей.
Прервать.
Guake вечно использую. Blueman - для соединения с bluetooth-устройствами. А вот этот нотификатор мешает в трее, хотел заменить на похожее от xfce[/spoiler]
Удалять указанные программы не хочу, а других вариантов решения проблемы не знаю. Да и не думаю, что установка мимо пакетного менеджера принесёт пользу. По схожей причине не смог работать в графическом интерфсе aptitude для обновления системы. Хочу что-то обновить, а он предлагает другое удалить.
« Последнее редактирование: 14 Февраль 2014, 00:00:54 от Vic »
 

Оффлайн Malaheenee

  • Ветеран
  • *****
  • Сообщений: 2565
  • Учтите, мы можем дать и вредный совет.
Re: Зависимости, проблемы в aptitude
« Ответ #1 : 13 Февраль 2014, 16:11:40 »
1. Попытается обновить все установленное , что имеет в названии libgtk
aptitude install libgtk~i2. Вообще, не стоит, а то он притащит за собой xfconf и прочие либы от xfce.
aptitude install  xfce4-notifyd notification-daemon_ (внимание, этот символ подчеркивания сразу после имени пакета - он дает указание удалить пакет)
Debian Sid: XFCE x 1, openbox x 2.
Все мы где-то, когда-то и в чем-то были новичками.
 

Оффлайн Vic

  • Активный пользователь
  • **
  • Topic Author
  • Сообщений: 55
  • ASUS EeePC 1215P + Debian (openbox)
Re: Зависимости, проблемы в aptitude
« Ответ #2 : 13 Февраль 2014, 17:02:09 »
Malaheenee, Спасибо, по первому пункту помогло. Сейчас посмотрим альтернативу для второго. И гляну, как там с зависимостями для других программ/обновлений.
 

Оффлайн Malaheenee

  • Ветеран
  • *****
  • Сообщений: 2565
  • Учтите, мы можем дать и вредный совет.
Re: Зависимости, проблемы в aptitude
« Ответ #3 : 13 Февраль 2014, 17:10:23 »
xfce4-notifyd предоставляет notification-daemon, поэтому чтобы не несло ничего лишнего есть два выхода: сначала его установить, потом снести notification-daemon или вот так одной командой.
Debian Sid: XFCE x 1, openbox x 2.
Все мы где-то, когда-то и в чем-то были новичками.
 

Оффлайн Vic

  • Активный пользователь
  • **
  • Topic Author
  • Сообщений: 55
  • ASUS EeePC 1215P + Debian (openbox)
Re: Зависимости, проблемы в aptitude
« Ответ #4 : 14 Февраль 2014, 00:00:35 »
Начал сам учиться разрешать зависимости в интерактивном режиме aptitude. Как всё сломаю, отпишусь :) А пока что РЕШЕНО.
 

Русскоязычное сообщество Debian GNU/Linux

Re: Зависимости, проблемы в aptitude
« Ответ #4 : 14 Февраль 2014, 00:00:35 »


Теги:
 

[РЕШЕНО] Как подрезать LVM для установки Windows?

Автор vlas

Ответов: 2
Просмотров: 663
Последний ответ 20 Август 2018, 23:21:17
от vlas
(Решено) Выбор Debian backports linux-image

Автор alastor

Ответов: 23
Просмотров: 3594
Последний ответ 29 Октябрь 2012, 21:40:29
от alastor
[Решено] Ищу программу для черчения

Автор Artuom

Ответов: 20
Просмотров: 3359
Последний ответ 16 Июнь 2013, 20:11:02
от Udachnik
[Решено] Как правильно установить Debian Lenny?

Автор triangel

Ответов: 5
Просмотров: 1096
Последний ответ 09 Октябрь 2013, 14:02:24
от triangel
Не получается установить обновления[Решено]

Автор Школьница

Ответов: 17
Просмотров: 2486
Последний ответ 13 Апрель 2015, 22:58:54
от yura_n