debian.org / О Debian Где взять Debian Поддержка Уголок разработчика Новости Wiki

Автор Тема: Ошибка сегментации, общие вопросы.  (Прочитано 1245 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ua6atg

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 39
    • Мой блог.
Гуглил по теме, но как то не очень.
Собственно наверно не было бы проблем, если бы не дернул меня черт установить libreoffice с деб пакета.  С тех пор и пропала моя спокойная жизнь.  Итак суть проблемы.
Вот мой список репозиториев:
#

## deb cdrom:[Debian GNU/Linux 7.5.0 _Wheezy_ - Official amd64 CD Binary-1 20140426-13:37]/ wheezy main

Цитировать
## deb cdrom:[Debian GNU/Linux 7.5.0 _Wheezy_ - Official amd64 CD Binary-1 20140426-13:37]/ wheezy main
# deb http://ftp.ru.debian.org/debian sid main
# deb http://security.debian.org/ wheezy/updates main
#deb-src http://security.debian.org/ wheezy/updates main
## wheezy-updates, previously known as 'volatile'
## A network mirror was not selected during install.  The following entries
## are provided as examples, but you should amend them as appropriate
## for your mirror of choice.
#
deb http://ftp.debian.org/debian/ wheezy-updates main
 deb-src http://ftp.debian.org/debian/ wheezy-updates main

deb http://ftp.debian.org/debian/ wheezy contrib main non-free
#deb http://ftp.debian.org/debian/ wheezy contrib main non-free
Дело в том, что в если работать с репозиторями отмеченными  красным цветом , то многие программы в  репах не находятся , а те что находятся, имеют массу неудовлетворенных зависимостей (Kaffeini заново не могу поставить к примеру, хотя ранее ставил, тут же, как не странно)
Если взять этот репозиторий: deb http://ftp.ru.debian.org/debian sid main То все находится , начинается установка и.. завершается словами... "Ошибка сегментации"
Вот я теперь в творческом тупике... Хотя до ума осталось довести только одну коффеину, в принципе.  Но хотелось бы понять вопрос принципиально в целях общего развития (c) почтальон Печкин

 
 

Оффлайн qupl

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 4604
  • memento mori
  • Jabber: qupl@jabber.ru
Re: Ошибка сегментации, общие вопросы.
« Ответ #1 : 13 Июнь 2014, 19:31:31 »
ua6atg, а что в итоге хотелось получить? Зачем смешивать stable и sid ?

Какие именно пакеты не находятся в репах stable?

Оффлайн ua6atg

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 39
    • Мой блог.
Re: Ошибка сегментации, общие вопросы.
« Ответ #2 : 13 Июнь 2014, 19:52:29 »
Какие именно пакеты не находятся в репах stable?

Вот рабочий пример установки программы Koffeini
Spoiler: ShowHide
Чтение списков пакетов...
Построение дерева зависимостей...
Чтение информации о состоянии...
Чтение информации о расширенных состояниях...
Инициализация состояний пакетов...
Чтение описаний задач...
Следующие НОВЫЕ пакеты будут установлены:
  kaffeine katepart{a} kde-runtime{ab} kdelibs-bin{a} kdelibs5-plugins{a}
  kdoctools{a} libgcrypt20{a} libgpgme++2{a} libkactivities6{a}
  libkatepartinterfaces4{a} libkcmutils4{a} libkde3support4{a} libkdesu5{a}
  libkdewebkit5{a} libkdnssd4{a} libkemoticons4{a} libkfile4{a}
  libkhtml5{a} libkio5{a} libkmediaplayer4{a} libknewstuff3-4{a}
  libknotifyconfig4{a} libkparts4{a} libktexteditor4{a}
  libkxmlrpcclient4{a} libnepomuk4{a} libnepomukquery4a{a}
  libnepomukutils4{a} libplasma3{a} libsoprano4{ab}
0 пакетов обновлено, 30 установлено новых, 0 пакетов отмечено для удаления, и 386 пакетов не обновлено.
Необходимо получить 0 B/11,2 MB архивов. После распаковки 49,9 MB будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
 kde-runtime : Зависит: plasma-scriptengine-javascript (= 4:4.13.1-1) но его установка не запланирована.
 libsoprano4 : Зависит: soprano-daemon (= 2.9.4+dfsg-1) но установлен 2.7.6+dfsg.1-2wheezy1
Следующие действия разрешат зависимости:

      Сохранить для следующих пакетов их текущие версии:     
1)      kaffeine [Не установлен]                             
2)      katepart [Не установлен]                             
3)      kde-runtime [Не установлен]                         
4)      kdelibs-bin [Не установлен]                         
5)      kdelibs5-plugins [Не установлен]                     
6)      kdoctools [Не установлен]                           
7)      libkatepartinterfaces4 [Не установлен]               
8)      libkde3support4 [Не установлен]                     
9)      libkdewebkit5 [Не установлен]                       
10)     libkemoticons4 [Не установлен]                       
11)     libkfile4 [Не установлен]                           
12)     libkhtml5 [Не установлен]                           
13)     libkio5 [Не установлен]                             
14)     libkmediaplayer4 [Не установлен]                     
15)     libknewstuff3-4 [Не установлен]                     
16)     libknotifyconfig4 [Не установлен]                   
17)     libkparts4 [Не установлен]                           
18)     libktexteditor4 [Не установлен]                     
19)     libkxmlrpcclient4 [Не установлен]                   
20)     libnepomuk4 [Не установлен]                         
21)     libnepomukquery4a [Не установлен]                   
22)     libnepomukutils4 [Не установлен]                     
23)     libplasma3 [Не установлен]                           
24)     libsoprano4 [Не установлен]                         

      Оставить следующие зависимости неразрешёнными:         
25)     libkhtml5 рекомендует kdelibs5-plugins (= 4:4.13.1-1)
26)     kdelibs5-plugins рекомендует kde-runtime             
27)     libkio5 рекомендует kdelibs5-plugins (= 4:4.13.1-1) 


Принять данное решение? [Y/n/q/?]

Я понимаю все,  ;D много чего наворотил по не опытности.  Я так понял , принципиальную вещь: нельзя смещивать пакеты ? Однако некоторые полезные программы были в sid, до сих пор , работают. 
В итоге мне наверно хватит установить эту злосчастную коффеину (у меня карта skystar 2) ну и немного причесать xfce .
p.s Да вот еще, по этой же причине слетел крайне нужный мне файловый менеджер krusader
« Последнее редактирование: 13 Июнь 2014, 19:56:52 от ua6atg »
 

Оффлайн ogost

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 2918
  • Linux Registered User #547151
Re: Ошибка сегментации, общие вопросы.
« Ответ #3 : 13 Июнь 2014, 20:34:48 »
репы, отмеченные красным, содержат только обновления, там нет основных программ (wheezy-updates как бы намекает). кроме того, вы смешиваете репы сида, поэтому и не удовлетворенные зависимости.

Русскоязычное сообщество Debian GNU/Linux

Re: Ошибка сегментации, общие вопросы.
« Ответ #3 : 13 Июнь 2014, 20:34:48 »


Теги:
 

Ошибка при компиляции в Lazarus

Автор flyer

Ответов: 3
Просмотров: 1897
Последний ответ 22 Сентябрь 2014, 13:15:00
от flyer
Ошибка при обновлении Debian 8 до Debian 9

Автор Ferox2017

Ответов: 4
Просмотров: 937
Последний ответ 21 Июнь 2017, 10:54:52
от qupl
При выполнении команды update-grub ошибка not foundrub-mkconfig: 5

Автор Bojokot

Ответов: 1
Просмотров: 889
Последний ответ 24 Сентябрь 2017, 14:47:07
от Juriy
Ошибка с locale

Автор diefair

Ответов: 0
Просмотров: 1066
Последний ответ 28 Октябрь 2014, 15:43:21
от diefair
[РЕШЕНО] Ошибка в kwrite или нет?

Автор Metrix

Ответов: 3
Просмотров: 1825
Последний ответ 08 Март 2011, 00:38:52
от Ghostdmn