debian.org / О Debian Где взять Debian Поддержка Уголок разработчика Новости Wiki

Автор Тема: Как уговорить заработать Debian 7.7 wheezy + Java + Iceweasel ?  (Прочитано 1559 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mcherenkov

  • Активный пользователь
  • **
  • Topic Author
  • Сообщений: 58
Как уговорить заработать Debian 7.7 wheezy + Java + Iceweasel (или какой-нибудь другой браузер, предпочтительнее из stable) ?

Доброго Вам настроения и наступающим Новым Годом!

Контекст следующий:

Все проверки кроме последней проводились с iceweasel 31.2.0esr-3~deb7u1. В конце обновил iceweasel до 31.3.0esr-1~deb7u1 и попробовал с icedtea-7-plugin (1.4-3~deb7u2) и jre1.8.0-25.

Теперь подробности: Iceweasel 31.2.0esr-3~deb7u1, icedtea-7-plugin (1.4-3~deb7u2).

Сгружаю себе jre http://java.com/ru/download/linux_manual.jsp?locale=ru пункт "Linux x64 RPM", файл jre-8u25-linux-x64.rpm.

Конвертирую и ставлю:
# alien -d --scripts jre-8u25-linux-x64.rpm
jre1.8.0-25_1.8.025-1_amd64.deb generated
# dpkg -i jre1.8.0-25_1.8.025-1_amd64.deb
Выбор ранее не выбранного пакета jre1.8.0-25.
(Чтение базы данных … на данный момент установлено 218214 файлов и каталогов.)
Распаковывается пакет jre1.8.0-25 (из файла jre1.8.0-25_1.8.025-1_amd64.deb) …
Настраивается пакет jre1.8.0-25 (1.8.025-1) …
Unpacking JAR files...
        rt.jar...
        jsse.jar...
        charsets.jar...
        localedata.jar...
        jfxrt.jar...
#

Презапускаю Iceweasel, иду на http://java.com/en/download/help/troubleshoot_java.xml#test
"We are unable to verify if Java is currently installed and enabled in your browser."
или
http://java.com/ru/download/installed.jsp
"Невозможно проверить, установлена ли Java и включена ли ее поддержка в браузере."

Аналогично пробовал ставить jre-7u71-linux-x64.rpm, преобразовывая в jre_1.7.071-1_amd64.deb.
Ставил icedtea-7-plugin.


Если делать alien -d без --scripts, то выдаёт:
# alien -d jre-7u71-linux-x64.rpm
Warning: Skipping conversion of scripts in package jre: postinst postrm prerm
Warning: Use the --scripts parameter to include the scripts.
jre_1.7.071-1_amd64.deb generated
# alien -d jre-8u25-linux-x64.rpm
Warning: Skipping conversion of scripts in package jre1.8.0_25: postinst postrm prerm
Warning: Use the --scripts parameter to include the scripts.
jre1.8.0-25_1.8.025-1_amd64.deb generated
#

И тоже не работает (уже не помню подробностей - много разного пробовал).


Пробовал openjdk-6-jre, openjdk-7-jre, gcj-jre.
Не работает.
Масимум, чего удавалось добиться - появления запроса на разрешение Java-апплета, после чего в течение некоторого времени (порядка 15 секунд) показывался белый прямоугольник вместо апплета, а потом - то же самое сообщение - о невозможности проверки Java.
В /var/log/user.log обнаружил запись

Dec 29 17:42:49 host javasettings: No input config file.                                                                                                                             

Мне казалось что она соответствует установке
# dpkg -i jre1.8.0-25_1.8.025-1_amd64.deb
, но при повторении команды эффект не воспроизвёлся.

Посоветуйте, пожалуйста, как установить. Буду благодарен любым доброжелательным советам.
Может быть кто-то укажет работающую конфигурацию...

А тем, кто дочитал - маленький зимний подарок (хотя написал не я):
http://rupoem.ru/samojlov/u-zim-byvayut.aspx
 

Оффлайн qupl

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 4616
  • memento mori
  • Jabber: qupl@jabber.ru
Какой версии java нужна? И почему из оф.репозитория не устраивает?

Онлайн ferum

  • Ветеран
  • *****
  • Сообщений: 3402
  • Buster TDE & Buster LXDE & stretch KDE
 Случайно не http://unixforum.org/index.php?showtopic=119454  ищете?
Русские дебианщики против цифрового слабоумия !
 

Оффлайн ChubaDuba

  • Старожил
  • ****
  • Сообщений: 522
  • Debian 9 + Xmonad
  • Jabber: achubakov@jabber.ru
С официального сайта Java. Особенно пунк "Запуск и конфигурирование"
 

Оффлайн mcherenkov

  • Активный пользователь
  • **
  • Topic Author
  • Сообщений: 58
Всем спасибо за участие, проблема решилась сама собой: оказалось, что упомянутая проверка не проходит, но зато нужный аплет запускается и работает нормально,
Тему можно считать в первом приближении закрытой (относительно меня), но чтобы не обмануть ожидания тех кто придёт сюда из поисковых систем, метку "Решено" не ставлю.
 

Оффлайн Malaheenee

  • Ветеран
  • *****
  • Сообщений: 2565
  • Учтите, мы можем дать и вредный совет.
Скорее всего - перемудрили с безопасностью разработчики. Как, например, с самоподписными сертификатами (вот это были знатные грабли для многих).
Debian Sid: XFCE x 1, openbox x 2.
Все мы где-то, когда-то и в чем-то были новичками.
 

Русскоязычное сообщество Debian GNU/Linux



Теги:
 

Очередная тема про Compiz и wheezy

Автор ambi

Ответов: 0
Просмотров: 1093
Последний ответ 23 Ноябрь 2013, 15:30:36
от ambi
Как озвучить загрузку DebIan?

Автор Иссохшие

Ответов: 9
Просмотров: 820
Последний ответ 19 Январь 2017, 21:04:30
от symon2014
debian testing

Автор ilya-359

Ответов: 2
Просмотров: 833
Последний ответ 14 Июль 2015, 14:07:44
от ferum
Iceweasel проблемы с xorg 1.11

Автор Ben-zin

Ответов: 17
Просмотров: 2490
Последний ответ 06 Ноябрь 2011, 21:36:10
от Ben-zin
[частично решено] Debian 9.3 действие по кнопке power и закрытии ноутбука

Автор Ulysses

Ответов: 2
Просмотров: 1087
Последний ответ 18 Декабрь 2017, 18:17:24
от Ogis1975