debian.org / О Debian Где взять Debian Поддержка Уголок разработчика Новости Wiki

Автор Тема: [Решено]Skype + Debian_8 x64  (Прочитано 7300 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mulder

  • Topic Author
  • Сообщений: 14
[Решено]Skype + Debian_8 x64
« : 01 Май 2015, 20:45:15 »
Добрый день. Ушёл пока с UBUNTU. 14,15 версии показались мне очень падучими и нестабильными.
Вернулся на Дебиан 8. Тут свои грабли. Может кто поможет?

Пытаюсь установить Скайп. Пока без результатно. Пробовал разные сборки skype-debian_4.3.0.37-1_i386.deb, skype-ubuntu-lucid_4.3.0.37-1_i386.deb, skype-ubuntu-precise_4.3.0.37-1_i386.deb

Везде ругается на "linqt4-network".

sudo dpkg -i /home/service/Загрузки/skype-debian_4.3.0.37-1_i386.deb
(Чтение базы данных … на данный момент установлено 158287 файлов и каталогов.)
Подготовка к распаковке …/skype-debian_4.3.0.37-1_i386.deb …
Распаковывается skype (4.3.0.37-1) …
dpkg: зависимости пакетов не позволяют настроить пакет skype:
 skype зависит от libqt4-network (>= 4:4.8.0), однако:
  Пакет libqt4-network не установлен.
 skype зависит от libqtwebkit4 (>= 2.1.0~2011week13), однако:
  Пакет libqtwebkit4 не установлен.




прикол, в том, что  libqtwebkit4 не может быть установлен, по причине того, что у него неразрешённая зависимость с  libqt4-network (>= 4:4.8.1)

Как вообще править зависимости. Разве нельзя иметь несколько подходящих библиотек разных версий в одной системе. Или иметь эти библиотеки внутри программы. Всего- то надо, иметь доступ к камере, микрофону, звуку, интернету.

Есть команды понижения версий, или установки конкретно для определённых программ?

За ранее благодарен.
« Последнее редактирование: 27 Август 2015, 05:03:57 от ogost »
 

Оффлайн delldeb

  • Сообщений: 85
Re: Skype + Debian_8
« Ответ #1 : 01 Май 2015, 21:06:22 »
Я по этому мануалу ставил, работает нормально.
First, you will have to enable Multi-Arch:

# dpkg --add-architecture i386
# apt-get update

Then, download the i386 package as above and install:

# wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
# dpkg -i skype-install.deb

If you then proceed with

# apt-get -f install
Debian Stretch, amd64, Xfce 4.12.
 
Пользователи, которые поблагодарили этот пост: mulder

Оффлайн aslex

  • Сообщений: 8
Re: Skype + Debian_8
« Ответ #2 : 01 Май 2015, 21:53:22 »
skype-debian_4.3.0.37-1_i386.deb
брал отсюда http://www.skype.com/ru/download-skype/skype-for-linux/
ставил через gdebi, все без проблем.
 
Пользователи, которые поблагодарили этот пост: mulder

Оффлайн iAchilles

  • Сообщений: 20
  • Debian Wheezy 7.7 (stable), GNOME 3.4.2
Re: Skype + Debian_8
« Ответ #3 : 02 Май 2015, 00:55:38 »
# dpkg --add-architecture i386
# apt-get update

Скачал с оф. сайта deb пакет для Debian 7, и поставил через gdebi. Никаких ошибок не было - все работает. (Debian 8, Gnome)
 
Пользователи, которые поблагодарили этот пост: mulder, SuperMeatBall

Оффлайн mulder

  • Topic Author
  • Сообщений: 14
Re: Skype + Debian_8
« Ответ #4 : 02 Май 2015, 15:53:31 »
Ёшкин кот!!!  ;D
Жил стаким чудом рука об руку. И не знал, что оно у меня уже есть.
Большая вам благодарность. Установил за три минуты. Работает на ура. Gdebi dсе зависимости удовлетворила.
Как говорится век живи, век учись.
 

Оффлайн SuperMeatBall

  • Сообщений: 7
Re: Skype + Debian_8
« Ответ #5 : 26 Август 2015, 21:15:56 »
mulder, добавь пожалуйста в название темы х64 и [Решено], чтоб было проще найти ответ через поиск. А то таких тем про скайп на 64-битной системе много тут и почти все без решения.


Как итог, общий порядок действий такой:
# dpkg --add-architecture i386
# apt-get update
# gdebi skype-install.deb
« Последнее редактирование: 27 Август 2015, 12:03:25 от SuperMeatBall »
 

Оффлайн almukantarat

  • Сообщений: 13
    • Погода в Карелии
Re: [Решено]Skype + Debian_8 x64
« Ответ #6 : 27 Август 2015, 10:10:02 »
Gdebi (дело рук Canonical) зависимости проверяет посредством apt-get? Так? Вопрос: почему тогда возникла вышеописанная проблема с установкой?
Debian Testing x86-64
 

Оффлайн SuperMeatBall

  • Сообщений: 7
Re: [Решено]Skype + Debian_8 x64
« Ответ #7 : 27 Август 2015, 12:53:42 »
Gdebi (дело рук Canonical) зависимости проверяет посредством apt-get? Так? Вопрос: почему тогда возникла вышеописанная проблема с установкой?

Я тут почитал man-ы apt-get и aptitude и решил проверить еще раз как они себя ведут.
После установки skype через dpkg, # aptitude -f install видит зависимости скайпа, но не хочет их ставить и предлагает только удалить сам скайп. Как результат, можно самому набить список пакетов и установить через aptitude.
А вот # apt-get check skype - покажет зависимости скайпа, а # apt-get -f install - предложит установить все зависимые пакеты, после чего скайп будет нормально работать. (это же решение delldeb описал)

Так что проблема возникла из-за слишком большого доверия к aptitude, его же рекомендуют использовать в большинстве случаев.
Я вот, кстати, посмотрел еще раз на дебиан вики страницу https://wiki.debian.org/ru/skype и там рекомендуется использовать apt-get -f install, но я по привычке пытался запустить "более продвинутый" aptitude :)
« Последнее редактирование: 27 Август 2015, 13:56:50 от SuperMeatBall »
 

Оффлайн viktor6

  • Сообщений: 37
Re: [Решено]Skype + Debian_8 x64
« Ответ #8 : 31 Октябрь 2015, 14:24:39 »
А как решить проблему из иконкой в трее ее там нет
 

Оффлайн userman

  • Сообщений: 79
Re: [Решено]Skype + Debian_8 x64
« Ответ #9 : 03 Декабрь 2015, 16:15:03 »
 Не получилось установить вышеприведенными методами.
Debian 8 64 bit.
 

Оффлайн CoolAller

  • Сообщений: 789
Re: [Решено]Skype + Debian_8 x64
« Ответ #10 : 03 Декабрь 2015, 17:05:48 »
Как итог, общий порядок действий такой
Это сейчас уже не нужно. Просто качаете скайп с оф.сайта и ставите через gdebi или руками через dpkg и apt-get.
« Последнее редактирование: 03 Декабрь 2015, 17:07:57 от CoolAller »
 

Оффлайн ferum

  • Сообщений: 2926
  • wheezy KDE & jessie LXDE & stretch KDE
Re: [Решено]Skype + Debian_8 x64
« Ответ #11 : 03 Декабрь 2015, 19:05:21 »
Не получилось установить вышеприведенными методами.
Последовательность действий качаем skype с официального сайта http://www.skype.com/ru/download-skype/skype-for-linux/downloading/?type=debian32
# dpkg --add-architecture i386 # enable multi-arch
# apt-get update
# apt-get install libc6:i386 # install base 32bit libraries
# apt-get install pulseaudio pavucontrol
cd /путь до/skype-debian4.3.0.37-1_i386.deb
# dpkg -i skype-debian4.3.0.37-1_i386.deb
# apt-get -f install
Вся фишка в том что надо взять за правило перед установкой программ обновлять список пакетов # apt-get update
З.Ы. pavucontrol может потребоваться когда будете плясать  с бубном вокруг звука с микрофоном. :D
Русские дебианщики против цифрового слабоумия !
 
Пользователи, которые поблагодарили этот пост: userman

Оффлайн userman

  • Сообщений: 79
Re: [Решено]Skype + Debian_8 x64
« Ответ #12 : 04 Декабрь 2015, 15:02:20 »
 Спасибо. Теперь вышло. Почему не могут прикрутить Скайп для 64 бит без всяких танцов с бубном?
 

Оффлайн ferum

  • Сообщений: 2926
  • wheezy KDE & jessie LXDE & stretch KDE
Re: [Решено]Skype + Debian_8 x64
« Ответ #13 : 04 Декабрь 2015, 15:10:12 »
Почему не могут прикрутить Скайп для 64 бит без всяких танцов с бубном?
Да всё потому что и skype и wine используют компоненты всецелостно принадлежащие  microsoft... я понимаю у нас даже не принято читать лицензионное соглашение при установке программ  :D
Русские дебианщики против цифрового слабоумия !
 

Оффлайн userman

  • Сообщений: 79
Re: [Решено]Skype + Debian_8 x64
« Ответ #14 : 20 Декабрь 2015, 17:20:37 »
Да всё потому что и skype и wine используют компоненты всецелостно принадлежащие  microsoft... я понимаю у нас даже не принято читать лицензионное соглашение при установке программ  :D

 Да знаю я. С тех пор как мелокосфт выкупили Скайп он стал каким то не соответствующим  требованиям.
« Последнее редактирование: 24 Декабрь 2015, 10:55:44 от userman »
 

Теги: