Падает CUPS

Автор M1chA, 23 октября 2015, 14:51:40

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

M1chA

Здравствуйте!
Поставил Debian 8.2 XFCE. Все настроил под себя. Стал ставить принтер HP LaserJet M125rnw.
Скачал c hpliponlene файл  hplip-3.15.9.run
Запустил установку bp под root'a. Все хорошо, но... при отправке на печать тестовой страницы вышла ошибка c предложением провести диагностику.
Файл с выводом прилагается.
Попробовал зайти на CUPS через браузер через localhost:631 выдает ошибку, что "Попытка соединения не удалась"
Что делать?

[вложение удалено администратором]

ferum

 sudo systemctl status cups.service
вывод
Русские дебианщики против цифрового слабоумия !

M1chA

#2
● cups.service - CUPS Printing Service
   Loaded: loaded (/lib/systemd/system/cups.service; enabled)
   Active: active (running) since Пт 2015-10-23 09:12:20 MSK; 7h ago
     Docs: man:cupsd(8)
           man:cupsd.conf(5)
Main PID: 439 (cupsd)
   CGroup: /system.slice/cups.service
           └─439 /usr/sbin/cupsd -f

окт 23 10:54:30 it hpcups[3245]: prnt/hpcups/Hbpl1.cpp 52: Hbpl1 constructor : m_szLanguage = HBPL1
окт 23 10:54:30 it hpcups[3245]: common/utils.c 69: unable to open /var/lib/hp/hplip.state: No such file or directory
окт 23 10:54:30 it hpcups[3245]: common/utils.c 119: validate_plugin_version() Failed to get Plugin version from [/var/lib/hp/hplip.state]
окт 23 10:54:30 it hpcups[3245]: common/utils.c 157: Plugin version is not matching
окт 23 14:47:44 it hpcups[6953]: prnt/hpcups/Hbpl1.cpp 52: Hbpl1 constructor : m_szLanguage = HBPL1


* Используйте теги для оформления сообщения, ihammers.

ferum

Правильней выло назвать тему не запускается hpcups
https://answers.launchpad.net/hplip/+question/269531 предлагают решение с понижением версии драйвера или применением патча.
Русские дебианщики против цифрового слабоумия !

M1chA

#4
Цитата: ferum от 23 октября 2015, 19:54:36Правильней выло назвать тему не запускается hpcups
https://answers.launchpad.net/hplip/+question/269531 предлагают решение с понижением версии драйвера или применением патча.

Поставил hplip 3.16 - проблема не исчезла

вывод systemctl status cups.service

● cups.service - CUPS Printing Service
   Loaded: loaded (/lib/systemd/system/cups.service; enabled)
   Active: active (running) since Сб 2015-10-24 12:30:24 MSK; 6min ago
     Docs: man:cupsd(8)
           man:cupsd.conf(5)
Main PID: 441 (cupsd)
   CGroup: /system.slice/cups.service
           └─441 /usr/sbin/cupsd -f


* Используйте теги для оформления сообщения, ihammers.

mrgoodvin

M1chA, попробуйте так: http://hplipopensource.com/hplip-web/install/manual/distros/debian.html
И скорее всего 3.16 - это не как не понижение версии драйвера :)

M1chA

#6
А что же имеется ввиду под "понижением драйвера"?

Cообщение объединено 25 октября 2015, 10:12:42

python --version
Python 2.7.9


делаю

su -c "apt-get install --force-yes -y avahi-utils cups libcups2 libcups2-dev cups-bsd cups-client libcupsimage2 libcupsimage2-dev libdbus-1-dev g++ ghostscript ghostscript-cups ghostscript-x libssl-dev libjpeg8-dev libsnmp-dev libc6 libtool libusb-1.0.0-dev make wget python-imaging policykit-1 policykit-1-gnome python-qt4 python-qt4-dbus python-dbus python-gobject python-dev python-notify python python-reportlab sane libsane-dev sane-utils xsane"


получаю

Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Note, selecting 'cups-filters' instead of 'ghostscript-cups'
Note, selecting 'libusb-1.0-0-dev' for regex 'libusb-1.0.0-dev'
Package libjpeg8-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  libjpeg62-turbo-dev:i386 libjpeg62-turbo-dev

E: Package 'libjpeg8-dev' has no installation candidate

ferum

Цитата: M1chA от 25 октября 2015, 10:03:12А что же имеется ввиду под "понижением драйвера"?
Открыть содержимое (спойлер)

This is an issue with hplip 3.15.7 drivers. I have provided the patch for the same in the bug report
https://bugs.launchpad.net/hplip/+bug/1476920.
This issue will be resolved in our next version of hplip.

If you wish to go back to hplip-3.15.6. You can download the drivers from
http://sourceforge.net/projects/hplip/files/hplip/3.15.6/hplip-3.15.6.run/download
[свернуть]
Уже не первый раз сталкиваюсь когда ссылка скопированная с адресной строки связаная с launchpad.net не открывается.
Русские дебианщики против цифрового слабоумия !

ihammers

А пробовали запускать hp-check, что выдаёт?
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290

M1chA

#9
$ hp-check > /home/####/hp.check.txt
warning: debian-8.2 version is not supported. Using debian-8.0 versions dependencies to verify and install...
warning: HPLIP-Installation: Auto installation is not supported for debian distro  8.2 version
error: Failed to find the lsusb command


Это вывел терминал.
А вывод hp-check во вложении

[вложение удалено администратором]

ihammers

Так, начинаем. Для начала вывод следующих команд:
~$ cat /etc/apt/sources.list
~$ cat /etc/apt/sources.list.d/*
~$ dpkg -l | grep cups
~$ dpkg -l | grep hp
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290

ferum

#11
Цитата: M1chA от 26 октября 2015, 09:47:14Auto installation is not supported for debian distro  8.2 versio
Значит надо руками ставить, я бы глянул как у последних ubuntu http://hplipopensource.com/hplip-web/install/manual/distros/ubuntu.html
а вот и объяснение причины http://forums.debian.net/viewtopic.php?f=7&t=124735
Русские дебианщики против цифрового слабоумия !